profile
viewpoint

issue commentMCreator/MCreator

My entity has a issues and I cannot use it in game

:wave: @Epicman44553, we use GitHub issue tracker exclusively for bug reports. However, this issue appears to be a support or a feature request. Please use our Forums on the website for support and feature requests.

Epicman44553

comment created time in 2 months

issue commentMCreator/MCreator

my mod crashes when I run it

:wave: @lovelifeee, we use GitHub issue tracker exclusively for bug reports. However, this issue appears to be a support or a feature request. Please use our Forums on the website for support and feature requests.

lovelifeee

comment created time in 2 months

issue closedMCreator/MCreator

Couldn't compile

Describe the bug

It won't compile java for some reason

Details

  • MCreator version: 2021.1
  • Generator type: forge-1.16.5
  • OS windows 10

Steps To Reproduce

I just made it so when I hit a living entity it damages the living entity by infinity damage

Minimal reproducible example workspace

If the bug is related to the workspace, always provide a minimal reproducible example workspace, export it to a shareable ZIP file, and attach it to the ticket.

Keep in mind your workspace of the project is not minimal reproducible example. Make a workspace only with elements crucial for the bug.

Logs

Executing Gradle task: build Build info: MCreator 2021.2.36710, forge-1.16.5, 64-bit, 14222 MB, Windows 10, JVM 11.0.11, JAVA_HOME: C:\Program Files\Pylo\MCreator\jdk

Task :compileJava FAILED C:\Users\zmumf\MCreatorWorkspaces\insanity_chaotic_edition\src\main\java\net\mcreator\insanitychaoticedition\procedures\SwordofinsanityLivingEntityIsHitWithToolProcedure.java:20: error: cannot find symbol ((LivingEntity) entity).attackEntityFrom(new DamageSource("custom").setDamageBypassesArmor(), (float) Infinity); ^ symbol: variable Infinity location: class net.mcreator.insanitychaoticedition.procedures.SwordofinsanityLivingEntityIsHitWithToolProcedure 1 error FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ':compileJava'.

Compilation failed; see the compiler error output for details.

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
  • Get more help at https://help.gradle.org Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0. You can use '--warning-mode all' to show the individual deprecation warnings and determine if they come from your own scripts or plugins. See https://docs.gradle.org/7.1.1/userguide/command_line_interface.html#sec:command_line_warnings BUILD FAILED in 2s 1 actionable task: 1 executed BUILD FAILED Task completed in 5 seconds

closed time in 2 months

ElectricplaysGaming

issue commentMCreator/MCreator

Couldn't compile

:wave: @ElectricplaysGaming, we use GitHub issue tracker exclusively for bug reports. However, this issue appears to be a support or a feature request. Please use our Forums on the website for support and feature requests.

ElectricplaysGaming

comment created time in 2 months

issue commentNillerMedDild/Enigmatica6

I updated the modpack and it crashes on startup

We use the issue tracker exclusively for bug reports, development and feature requests. However, this issue appears to be a support request. Please use the support channel on our Discord to get help.

Dragon77mathbye

comment created time in 2 months

issue commentNillerMedDild/Enigmatica6

Datapack error loading world

We use the issue tracker exclusively for bug reports, development and feature requests. However, this issue appears to be a support request. Please use the support channel on our Discord to get help.

tuca1234567890

comment created time in 2 months

issue closedMinecraftForge/ForgeGradle

Problems with locations of pom files for Forge Gradle

Hi,

I am new to making minecraft mods and have been having some problems trying to build the workspace for my 1.8.9 mod due to the changes in the maven location. My cmd prompt is telling me that it cannot resolve all artifacts and has looked in: Searched in the following locations: - https://jcenter.bintray.com/com/github/asbyth/ForgeGradle/6f53277/ForgeGradle-6f53277.pom - https://maven.minecraftforge.net/com/github/asbyth/ForgeGradle/6f53277/ForgeGradle-6f53277.pom

The full error code is: `FAILURE: Build failed with an exception.

  • What went wrong: A problem occurred configuring root project.

Could not resolve all artifacts for configuration ':classpath'. Could not find com.github.asbyth:ForgeGradle:6f53277. Searched in the following locations: - https://jcenter.bintray.com/com/github/asbyth/ForgeGradle/6f53277/ForgeGradle-6f53277.pom - https://maven.minecraftforge.net/com/github/asbyth/ForgeGradle/6f53277/ForgeGradle-6f53277.pom Required by: project :

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org`

Hope you can help, Aaryan

closed time in 2 months

Aaryan-N

issue commentMinecraftForge/ForgeGradle

Problems with locations of pom files for Forge Gradle

👋 We use the issue tracker exclusively for final bug reports and feature requests. However, this issue appears to be better suited for the Forge Modder Support Forums. Please create a new topic on the Modder Support forum with this issue, and the conversation can continue there.

Aaryan-N

comment created time in 2 months

issue closedmui-org/material-ui

How to correctly implement RTL?

Hi there, I love this component library and is super easy to use and style my stuff, but I've noticed that when using the RTL mode many components look bad, it can be easily reproduced for your own Sandbox for buttons

Just go to it, add dir='rtl' to the body and see how the buttons look, the margins between text and icons are not properly placed/

In my app I'm using React with plain Sass, would this be "automagically" fixed by using some other preprocessor like styled-components or something else?

I see in the Demo page that there's an rtl-XXXX class added to the components when I enable it, should I have this with the package, or do I have to code this class myself for each element?

Or is there some extra step I can take to make my app work with SASS too?

Or do I have to style all the RTL things myself?

Thanks and regards.

closed time in 2 months

Geddard

issue commentmui-org/material-ui

How to correctly implement RTL?

👋 Thanks for using MUI Core!

We use GitHub issues exclusively as a bug and feature requests tracker, however, this issue appears to be a support request.

For support, please check out https://mui.com/getting-started/support/. Thanks!

If you have a question on StackOverflow, you are welcome to link to it here, it might help others. If your issue is subsequently confirmed as a bug, and the report follows the issue template, it can be reopened.

Geddard

comment created time in 2 months

issue closedMCreator/MCreator

"Invalid RAM allocation detected!" "ERROR CODE: JAVA_XMS INVALID_VALUE [-13]"

Every time I start a workspace for forge mods, an error msg about my ram comes up

When starting or opening up a forge project, the first 2 steps always work but then the 3rd one immediately stops, pulling up this msg: (https://user-images.githubusercontent.com/91724980/135590222-bba5efe8-2f96-47b2-bf4a-fc61b9b851de.png). i have tried changing my min and max and changing version (happens on every version) but nothing works.

Details

  • MCreator version: [2021.2]
  • Generator type: [forge-1.16.5]
  • OS: [Windows]

Steps To Reproduce

Create or Open A Forge Workspace Wait Until Error Msg Pops Up

Logs

Executing Gradle task: eclipse Build info: MCreator 2021.2.36710, forge-1.16.5, 64-bit, 8034 MB, Windows 10, JVM 11.0.11, JAVA_HOME: E:\Games\Game Files\MCreator\MCreator20212\jdk org.gradle.tooling.GradleConnectionException: Could not execute build using connection to Gradle distribution 'https://services.gradle.org/distributions/gradle-7.1.1-bin.zip'. at org.gradle.tooling.internal.consumer.ExceptionTransformer.transform(ExceptionTransformer.java:55) at org.gradle.tooling.internal.consumer.ExceptionTransformer.transform(ExceptionTransformer.java:29) at org.gradle.tooling.internal.consumer.ResultHandlerAdapter.onFailure(ResultHandlerAdapter.java:43) at org.gradle.tooling.internal.consumer.async.DefaultAsyncConsumerActionExecutor$1$1.run(DefaultAsyncConsumerActionExecutor.java:69) at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:64) at org.gradle.internal.concurrent.ManagedExecutorImpl$1.run(ManagedExecutorImpl.java:48) at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) at org.gradle.internal.concurrent.ThreadFactoryImpl$ManagedThreadRunnable.run(ThreadFactoryImpl.java:56) at java.base/java.lang.Thread.run(Thread.java:829) Caused by: org.gradle.api.GradleException: Unable to start the daemon process. This problem might be caused by incorrect configuration of the daemon. For example, an unrecognized jvm option is used. Please refer to the User Manual chapter on the daemon at https://docs.gradle.org/7.1.1/userguide/gradle_daemon.html Process command line: E:\Games\Game Files\MCreator\MCreator20212\jdk\bin\java.exe --add-opens java.base/java.util=ALL-UNNAMED --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.base/java.lang.invoke=ALL-UNNAMED --add-opens java.base/java.util=ALL-UNNAMED --add-opens java.prefs/java.util.prefs=ALL-UNNAMED --add-opens java.prefs/java.util.prefs=ALL-UNNAMED --add-opens java.base/java.nio.charset=ALL-UNNAMED --add-opens java.base/java.net=ALL-UNNAMED --add-opens java.base/java.util.concurrent.atomic=ALL-UNNAMED -Xms4000m -Xmx6000m -Dfile.encoding=windows-1252 -Duser.country=US -Duser.language=en -Duser.variant -cp C:\Users\charl.mcreator\gradle\wrapper\dists\gradle-7.1.1-bin\f29rtwfnc96ub43tt7p47zsru\gradle-7.1.1\lib\gradle-launcher-7.1.1.jar org.gradle.launcher.daemon.bootstrap.GradleDaemon 7.1.1 Please read the following process output to find out more:

Picked up _JAVA_OPTIONS: -Xmx512M Error occurred during initialization of VM Initial heap size set to a larger value than the maximum heap size at org.gradle.launcher.daemon.client.DaemonGreeter.parseDaemonOutput(DaemonGreeter.java:38) at org.gradle.launcher.daemon.client.DefaultDaemonStarter.startProcess(DefaultDaemonStarter.java:181) at org.gradle.launcher.daemon.client.DefaultDaemonStarter.startDaemon(DefaultDaemonStarter.java:137) at org.gradle.launcher.daemon.client.DefaultDaemonConnector.doStartDaemon(DefaultDaemonConnector.java:217) at org.gradle.launcher.daemon.client.DefaultDaemonConnector.startDaemon(DefaultDaemonConnector.java:211) at org.gradle.launcher.daemon.client.DefaultDaemonConnector.connect(DefaultDaemonConnector.java:133) at org.gradle.launcher.daemon.client.DaemonClient.execute(DaemonClient.java:144) at org.gradle.launcher.daemon.client.DaemonClient.execute(DaemonClient.java:98) at org.gradle.tooling.internal.provider.DaemonBuildActionExecuter.execute(DaemonBuildActionExecuter.java:44) at org.gradle.tooling.internal.provider.DaemonBuildActionExecuter.execute(DaemonBuildActionExecuter.java:30) at org.gradle.tooling.internal.provider.LoggingBridgingBuildActionExecuter.execute(LoggingBridgingBuildActionExecuter.java:60) at org.gradle.tooling.internal.provider.LoggingBridgingBuildActionExecuter.execute(LoggingBridgingBuildActionExecuter.java:37) at org.gradle.tooling.internal.provider.ProviderConnection.run(ProviderConnection.java:222) at org.gradle.tooling.internal.provider.ProviderConnection.run(ProviderConnection.java:148) at org.gradle.tooling.internal.provider.DefaultConnection.getModel(DefaultConnection.java:202) at org.gradle.tooling.internal.consumer.connection.CancellableModelBuilderBackedModelProducer.produceModel(CancellableModelBuilderBackedModelProducer.java:54) at org.gradle.tooling.internal.consumer.connection.PluginClasspathInjectionSupportedCheckModelProducer.produceModel(PluginClasspathInjectionSupportedCheckModelProducer.java:38) at org.gradle.tooling.internal.consumer.connection.AbstractConsumerConnection.run(AbstractConsumerConnection.java:64) at org.gradle.tooling.internal.consumer.connection.ParameterValidatingConsumerConnection.run(ParameterValidatingConsumerConnection.java:49) at org.gradle.tooling.internal.consumer.DefaultBuildLauncher$1.run(DefaultBuildLauncher.java:97) at org.gradle.tooling.internal.consumer.DefaultBuildLauncher$1.run(DefaultBuildLauncher.java:89) at org.gradle.tooling.internal.consumer.connection.LazyConsumerActionExecutor.run(LazyConsumerActionExecutor.java:143) at org.gradle.tooling.internal.consumer.connection.CancellableConsumerActionExecutor.run(CancellableConsumerActionExecutor.java:45) at org.gradle.tooling.internal.consumer.connection.ProgressLoggingConsumerActionExecutor.run(ProgressLoggingConsumerActionExecutor.java:61) at org.gradle.tooling.internal.consumer.connection.RethrowingErrorsConsumerActionExecutor.run(RethrowingErrorsConsumerActionExecutor.java:38) at org.gradle.tooling.internal.consumer.async.DefaultAsyncConsumerActionExecutor$1$1.run(DefaultAsyncConsumerActionExecutor.java:67) ... 6 more TASK EXECUTION FAILED Task completed in 60 seconds

closed time in 2 months

BlackStrike0

issue commentMCreator/MCreator

"Invalid RAM allocation detected!" "ERROR CODE: JAVA_XMS INVALID_VALUE [-13]"

:wave: @BlackStrike0, we use GitHub issue tracker exclusively for bug reports. However, this issue appears to be a support or a feature request. Please use our Forums on the website for support and feature requests.

BlackStrike0

comment created time in 2 months

issue closedjupyterhub/binder

doc content outdated: tag seems can be latest

In https://mybinder.readthedocs.io/en/latest/tutorials/dockerfile.html#preparing-your-dockerfile

When sourcing a pre-existing Docker image with FROM, a tag is required. The tag cannot be latest.

But when I use https://mybinder.org/v2/gh/gibiansky/IHaskell/mybinder from https://github.com/gibiansky/IHaskell/blob/mybinder/Dockerfile , its tag is latest.

closed time in 2 months

imba-tjd

issue commentjupyterhub/binder

doc content outdated: tag seems can be latest

Hi there @imba-tjd :wave:!

I closed this issue because it was labelled as a support question.

Please help us organize discussion by posting this on the http://discourse.jupyter.org/ forum.

Our goal is to sustain a positive experience for both users and developers. We use GitHub issues for specific discussions related to changing a repository's content, and let the forum be where we can more generally help and inspire each other.

Thanks you for being an active member of our community! :heart:

imba-tjd

comment created time in 2 months

issue closedmui-org/material-ui

@emotion/styled injection order (v5)

<!-- Provide a general summary of the issue in the Title above -->

Children styles in emotion/styled of MUI Components is being override by MUI Component styles.

<!-- Thank you very much for contributing to MUI by creating an issue! ❤️ To avoid duplicate issues we ask you to check off the following list. -->

<!-- Checked checkbox should look like this: [x] -->

  • [x] The issue is present in the latest release.
  • [x] I have searched the issues of this repository and believe that this is not a duplicate.

Current Behavior 😯

<!-- Describe what happens instead of the expected behavior. -->

My project is using @emotion/styled as the main styling system, along with material-ui. I want to add margin-top to every children in Container, so I wrapped it with @emotion/styled and expected this CSS to override the Typography's margin.

import styled from '@emotion/styled'
import Container from '@mui/material/Container'
import Typography from '@mui/material/Typography'
import * as React from 'react'

const StyledContainer = styled(Container)`
  & > * {
    margin-top: 1rem;
  }
`

export default function Index() {
  return (
    <StyledContainer maxWidth="sm">
      <Typography>Hello World</Typography>
      <Typography>Hello World</Typography>
      <Typography>Hello World</Typography>
    </StyledContainer>
  )
}

However, after upgrading to v5, styling MUI Components with @emotion/styled become overridden by the MUI Component itself.

Screen Shot 2564-10-01 at 12 28 51

As the image above, each Typography does not have margin-top of 1rem because it has been overridden by the MuiTypography-root styles.

Expected Behavior 🤔

<!-- Describe what should happen. -->

Styling MUI Components with @emotion/styled should takes precedence over every styles.

Steps to Reproduce 🕹

<!-- Provide a link to a live example (you can use codesandbox.io) and an unambiguous set of steps to reproduce this bug. Include code to reproduce, if relevant (which it most likely is).

You should use the official codesandbox template as a starting point: https://mui.com/r/issue-template-next

If you have an issue concerning TypeScript please start from this TypeScript playground: https://mui.com/r/ts-issue-template

Issues without some form of live example have a longer response time. -->

Steps:

  1. Clone the setup from https://github.com/mui-org/material-ui/blob/master/examples/nextjs-with-typescript
  2. Wraps MUI Component with @emotion/styled and add child selector css

Context 🔦

<!-- What are you trying to accomplish? How has this issue affected you? Providing context helps us come up with a solution that is most useful in the real world. -->

The css order is a working correctly in v4, but while migrating to v5, the CSS order breaks the UI of my site.

Your Environment 🌎

<!-- Run npx @mui/envinfo and post the results. If you encounter issues with TypeScript please include the used tsconfig. --> <details> <summary>npx @mui/envinfo</summary>

  System:
    OS: macOS 11.5.2
  Binaries:
    Node: 16.7.0 - /opt/homebrew/bin/node
    Yarn: 1.22.11 - /opt/homebrew/bin/yarn
    npm: 7.20.3 - /opt/homebrew/bin/npm
  Browsers:
    Chrome: 94.0.4606.61
    Edge: Not Found
    Firefox: 91.0.1
    Safari: 14.1.2
  npmPackages:
    @emotion/react: latest => 11.4.1
    @emotion/styled: latest => 11.3.0
    @mui/core:  5.0.0-alpha.49
    @mui/material: latest => 5.0.2
    @mui/private-theming:  5.0.1
    @mui/styled-engine:  5.0.1
    @mui/system:  5.0.2
    @mui/types:  7.0.0
    @mui/utils:  5.0.1
    @types/react: latest => 17.0.26
    react: latest => 17.0.2
    react-dom: latest => 17.0.2
    typescript: latest => 4.4.3

</details>

closed time in 2 months

kykungz

issue commentmui-org/material-ui

@emotion/styled injection order (v5)

👋 Thanks for using MUI Core!

We use GitHub issues exclusively as a bug and feature requests tracker, however, this issue appears to be a support request.

For support, please check out https://mui.com/getting-started/support/. Thanks!

If you have a question on StackOverflow, you are welcome to link to it here, it might help others. If your issue is subsequently confirmed as a bug, and the report follows the issue template, it can be reopened.

kykungz

comment created time in 2 months

issue closedmui-org/material-ui

[system] How to correctly merge multiple themes

<!-- Provide a general summary of the issue in the Title above -->

<!-- Thank you very much for contributing to MUI by creating an issue! ❤️ To avoid duplicate issues we ask you to check off the following list. -->

<!-- Checked checkbox should look like this: [x] -->

  • [x] The issue is present in the latest release.
  • [x] I have searched the issues of this repository and believe that this is not a duplicate.
  • May be related to https://github.com/mui-org/material-ui/issues/28633, but that one is not specific to combining themes.

Current Behavior 😯

<!-- Describe what happens instead of the expected behavior. -->

When composing themes (As described under "Theme Composition" https://mui.com/customization/theming/), typography.fontFamily in the second argument of createTheme is not applied.

Expected Behavior 🤔

<!-- Describe what should happen. --> typography.fontFamily is applied to each typography variant whether or not createTheme is called with a previous theme as the first argument.

Steps to Reproduce 🕹

<!-- Provide a link to a live example (you can use codesandbox.io) and an unambiguous set of steps to reproduce this bug. Include code to reproduce, if relevant (which it most likely is).

You should use the official codesandbox template as a starting point: https://mui.com/r/issue-template-next

If you have an issue concerning TypeScript please start from this TypeScript playground: https://mui.com/r/ts-issue-template

Issues without some form of live example have a longer response time. --> https://codesandbox.io/s/mui-5-fontfamily-issue-lwfbf?file=/src/App.js

Steps:

  1. Create a theme in two steps as described under "Theme Composition" (https://mui.com/customization/theming/)
  2. In the second call to createTheme, set typography.fontFamily to anything other than the MUI default
  3. See that the custom fontFamily has not been correctly applied

Context 🔦

<!-- What are you trying to accomplish? How has this issue affected you? Providing context helps us come up with a solution that is most useful in the real world. --> Workaround is to define typography.fontFamily in the top level theme. This is a valid work around for me because fontFamily it self does not depend on anything in the previous theme. However, this took me a while to diagnose and worries me that there may be other subtle issues with composing themes.

Your Environment 🌎

<!-- Run npx @mui/envinfo and post the results. If you encounter issues with TypeScript please include the used tsconfig. --> <details> <summary>npx @mui/envinfo</summary>

  Don't forget to mention which browser you used.
  Output from `npx @mui/envinfo` goes here.

</details>

closed time in 2 months

MikeRawding

issue commentmui-org/material-ui

[system] How to correctly merge multiple themes

👋 Thanks for using MUI Core!

We use GitHub issues exclusively as a bug and feature requests tracker, however, this issue appears to be a support request.

For support, please check out https://mui.com/getting-started/support/. Thanks!

If you have a question on StackOverflow, you are welcome to link to it here, it might help others. If your issue is subsequently confirmed as a bug, and the report follows the issue template, it can be reopened.

MikeRawding

comment created time in 2 months

issue closedjupyterhub/repo2docker

The repository 'https://deb.nodesource.com/node_14.x bionic Release' does not have a Release file.

<!-- Thank you for contributing. These HTML commments will not render in the issue, but you can delete them once you've read them if you prefer! -->

Bug description

<!-- Use this section to clearly and concisely describe the bug. --> I am using repo2docker version 2021.08.0. When I run repo2docker . in my repository, I get the following error: The repository 'https://deb.nodesource.com/node_14.x bionic Release' does not have a Release file.

When I open my repository using mybinder.org, the docker image is made successfully

Expected behaviour

<!-- Tell us what you thought would happen. --> The docker image is made.

Actual behaviour

<!-- Tell us what you actually happens. --> The docker image built process fails with this error: The repository 'https://deb.nodesource.com/node_14.x bionic Release' does not have a Release file.

How to reproduce

<!-- Use this section to describe the steps that a user would take to experience this bug. -->

  1. Install repo2docker on Ubuntu 20.04: pip install jupyter-repo2docker
  2. Clone this repository: git clone https://github.com/eLearningHub/pdf2video.git
  3. Go the main folder: cd pdf2video
  4. Run: repo2docker .

Your personal set up

<!-- Tell us a little about the system you're using. You can see the guidelines for setting up and reporting this information at https://repo2docker.readthedocs.io/en/latest/contributing/contributing.html#setting-up-for-local-development. -->

  • OS: Ubuntu 20.04
  • Docker version: docker version <!-- Run this command to get your version. -->
Client:
 Version:           20.10.7
 API version:       1.41
 Go version:        go1.13.8
 Git commit:        20.10.7-0ubuntu1~20.04.1
 Built:             Wed Aug  4 22:52:25 2021
 OS/Arch:           linux/amd64
 Context:           default
 Experimental:      true

Server:
 Engine:
  Version:          20.10.7
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.13.8
  Git commit:       20.10.7-0ubuntu1~20.04.1
  Built:            Wed Aug  4 19:07:47 2021
  OS/Arch:          linux/amd64
  Experimental:     false
 containerd:
  Version:          1.5.2-0ubuntu1~20.04.2
  GitCommit:        
 runc:
  Version:          1.0.0~rc95-0ubuntu1~20.04.2
  GitCommit:        
 docker-init:
  Version:          0.19.0
  GitCommit:        
  • repo2docker version repo2docker --version <!-- Run this command to get your version. --> 2021.08.0

closed time in 2 months

bsamadi

issue commentjupyterhub/repo2docker

The repository 'https://deb.nodesource.com/node_14.x bionic Release' does not have a Release file.

Hi there @bsamadi :wave:!

I closed this issue because it was labelled as a support question.

Please help us organize discussion by posting this on the http://discourse.jupyter.org/ forum.

Our goal is to sustain a positive experience for both users and developers. We use GitHub issues for specific discussions related to changing a repository's content, and let the forum be where we can more generally help and inspire each other.

Thanks you for being an active member of our community! :heart:

bsamadi

comment created time in 2 months

issue closedjupyterhub/jupyterhub

HTTP 403: Forbidden error when opening courses tab

<!-- Thank you for contributing. These HTML comments will not render in the issue, but you can delete them once you've read them if you prefer! -->

Bug description

When I am logging in and going to instructors tab, I am getting an error. I have already gone through https://github.com/jupyterhub/jupyterhub/issues/1377. But, still no luck.

Expected behaviour

Link to courses

Actual behaviour

Traceback (most recent call last): File "/usr/local/lib/python3.8/dist-packages/nbgrader/server_extensions/course_list/handlers.py", line 173, in get jhub_courses = yield self.check_for_jupyterhub_formgraders(config) File "/usr/lib/python3/dist-packages/tornado/gen.py", line 1148, in run value = future.result() File "/usr/lib/python3/dist-packages/tornado/gen.py", line 1156, in run yielded = self.gen.throw(*exc_info) File "/usr/local/lib/python3.8/dist-packages/nbgrader/server_extensions/course_list/handlers.py", line 143, in check_for_jupyterhub_formgraders response = yield http_client.fetch(url, headers=auth) File "/usr/lib/python3/dist-packages/tornado/gen.py", line 1148, in run value = future.result() tornado.httpclient.HTTPClientError: HTTP 403: Forbidden

How to reproduce

<!-- Use this section to describe the steps that a user would take to experience this bug. -->

  1. Login
  2. Go to courses tab
  3. See error

closed time in 2 months

rajaprerak

issue commentjupyterhub/jupyterhub

HTTP 403: Forbidden error when opening courses tab

Hi there @rajaprerak :wave:!

I closed this issue because it was labelled as a support question.

Please help us organize discussion by posting this on the http://discourse.jupyter.org/ forum.

Our goal is to sustain a positive experience for both users and developers. We use GitHub issues for specific discussions related to changing a repository's content, and let the forum be where we can more generally help and inspire each other.

Thanks you for being an active member of our community! :heart:

rajaprerak

comment created time in 2 months

issue closedjupyterhub/jupyterhub

File Browser unable to open a folder named "checkpoints"

<!-- Thank you for contributing. These HTML comments will not render in the issue, but you can delete them once you've read them if you prefer! -->

Bug description

The library I'm using stores model checkpoints in a folder named "checkpoints". The file browser will not open that folder. If I open a terminal, I can cd checkpoints && ls -l just fine. If I rename the folder to "checkpoint", the file browser will then open it. But, if I rename it back to "checkpoints" the file browser will again refuse to open it.

Expected behaviour

I should be able to open a folder named "checkpoints".

Actual behaviour

Double-clicking the folder does nothing.

When I look in the developer console for any other folder open request, an object is returned describing the contents of that folder. When I try to open the checkpoints folder, the request returns an empty array.

How to reproduce

  1. Create a folder named "checkpoints".
  2. Try to open it via the GUI.

Your personal set up

<!-- Tell us a little about the system you're using. Please include information about how you installed, e.g. are you using a distribution such as zero-to-jupyterhub or the-littlest-jupyterhub. --> I don't know how it was installed, I'm just a user.

  • OS:
$ uname -a
Linux jupyter-rbattle 5.4.0-62-generic #70-Ubuntu SMP Tue Jan 12 12:45:47 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
  • Version(s):
$ jupyterhub --version
1.4.0
$ python --version
Python 3.8.8
  • <details><summary>Full environment</summary> <!-- For reproduction, it's useful to have the full environment. For example, the output of pip freeze or conda list --->
$ conda list
# packages in environment at /opt/conda:
#
# Name                    Version                   Build  Channel
_libgcc_mutex             0.1                 conda_forge    conda-forge
_openmp_mutex             4.5                       1_gnu    conda-forge
abseil-cpp                20210324.0           h9c3ff4c_0    conda-forge
absl-py                   0.12.0             pyhd8ed1ab_0    conda-forge
aiohttp                   3.7.4            py38h497a2fe_0    conda-forge
alembic                   1.4.1                    pypi_0    pypi
anyio                     2.2.0            py38h578d9bd_0    conda-forge
appdirs                   1.4.4              pyh9f0ad1d_0    conda-forge
argon2-cffi               20.1.0           py38h497a2fe_2    conda-forge
astor                     0.8.1              pyh9f0ad1d_0    conda-forge
astunparse                1.6.3              pyhd8ed1ab_0    conda-forge
async-timeout             3.0.1                   py_1000    conda-forge
async_generator           1.10                       py_0    conda-forge
attrs                     20.3.0             pyhd3deb0d_0    conda-forge
babel                     2.9.1              pyh44b312d_0    conda-forge
backcall                  0.2.0              pyh9f0ad1d_0    conda-forge
backports                 1.0                        py_2    conda-forge
backports.functools_lru_cache 1.6.4              pyhd8ed1ab_0    conda-forge
beautifulsoup4            4.9.3              pyhb0f4dca_0    conda-forge
blas                      1.1                    openblas    conda-forge
bleach                    3.3.0              pyh44b312d_0    conda-forge
blinker                   1.4                        py_1    conda-forge
blosc                     1.21.0               h9c3ff4c_0    conda-forge
bokeh                     2.3.1            py38h578d9bd_0    conda-forge
bottleneck                1.3.2            py38h5c078b8_3    conda-forge
brotli                    1.0.9                h9c3ff4c_4    conda-forge
brotlipy                  0.7.0           py38h497a2fe_1001    conda-forge
brunsli                   0.1                  h9c3ff4c_0    conda-forge
bzip2                     1.0.8                h7f98852_4    conda-forge
c-ares                    1.17.1               h7f98852_1    conda-forge
ca-certificates           2020.12.5            ha878542_0    conda-forge
cached-property           1.5.2                hd8ed1ab_1    conda-forge
cached_property           1.5.2              pyha770c72_1    conda-forge
cachetools                4.2.2              pyhd8ed1ab_0    conda-forge
certifi                   2020.12.5        py38h578d9bd_1    conda-forge
certipy                   0.1.3                      py_0    conda-forge
cffi                      1.14.5           py38ha65f79e_0    conda-forge
chardet                   4.0.0            py38h578d9bd_1    conda-forge
charls                    2.2.0                h9c3ff4c_0    conda-forge
click                     7.1.2              pyh9f0ad1d_0    conda-forge
cloudpickle               1.6.0                      py_0    conda-forge
conda                     4.10.0           py38h578d9bd_0    conda-forge
conda-package-handling    1.7.3            py38h497a2fe_0    conda-forge
configurable-http-proxy   4.3.2           node15_he6ea98c_0    conda-forge
cryptography              3.4.7            py38ha5dfef3_0    conda-forge
cycler                    0.10.0                     py_2    conda-forge
cython                    0.29.23          py38h709712a_0    conda-forge
cytoolz                   0.11.0           py38h497a2fe_3    conda-forge
dask                      2021.4.1           pyhd8ed1ab_0    conda-forge
dask-core                 2021.4.1           pyhd8ed1ab_0    conda-forge
databricks-cli            0.15.0                   pypi_0    pypi
decorator                 5.0.7              pyhd8ed1ab_0    conda-forge
defusedxml                0.7.1              pyhd8ed1ab_0    conda-forge
deprecation               2.1.0              pyh9f0ad1d_0    conda-forge
dill                      0.3.3              pyhd8ed1ab_0    conda-forge
distributed               2021.4.1         py38h578d9bd_0    conda-forge
docker                    5.0.2                    pypi_0    pypi
entrypoints               0.3             pyhd8ed1ab_1003    conda-forge
filelock                  3.1.0                    pypi_0    pypi
flask                     2.0.1                    pypi_0    pypi
freetype                  2.10.4               h0708190_1    conda-forge
fsspec                    2021.4.0           pyhd8ed1ab_0    conda-forge
gast                      0.3.3                      py_0    conda-forge
giflib                    5.2.1                h36c2ea0_2    conda-forge
gitdb                     4.0.7                    pypi_0    pypi
gitpython                 3.1.24                   pypi_0    pypi
gmp                       6.2.1                h58526e2_0    conda-forge
gmpy2                     2.1.0b1          py38hd744826_1    conda-forge
google-auth               1.30.0             pyh44b312d_0    conda-forge
google-auth-oauthlib      0.4.1                      py_2    conda-forge
google-pasta              0.2.0              pyh8c360ce_0    conda-forge
greenlet                  1.0.0            py38h709712a_0    conda-forge
grpc-cpp                  1.37.1               h36de60a_0    conda-forge
grpcio                    1.37.1           py38hdd6454d_0    conda-forge
gunicorn                  20.1.0                   pypi_0    pypi
h5py                      2.10.0          nompi_py38h9915d05_106    conda-forge
hdf5                      1.10.6          nompi_h6a2412b_1114    conda-forge
heapdict                  1.0.1                      py_0    conda-forge
huggingface-hub           0.0.17                   pypi_0    pypi
icu                       68.1                 h58526e2_0    conda-forge
idna                      2.10               pyh9f0ad1d_0    conda-forge
imagecodecs               2021.3.31        py38h1455ab2_0    conda-forge
imageio                   2.9.0                      py_0    conda-forge
importlib-metadata        4.0.1            py38h578d9bd_0    conda-forge
ipykernel                 5.5.4            py38hd0cf306_0    conda-forge
ipympl                    0.7.0              pyhd8ed1ab_0    conda-forge
ipython                   7.23.1           py38hd0cf306_0    conda-forge
ipython_genutils          0.2.0                      py_1    conda-forge
ipywidgets                7.6.3              pyhd3deb0d_0    conda-forge
itsdangerous              2.0.1                    pypi_0    pypi
jedi                      0.18.0           py38h578d9bd_2    conda-forge
jinja2                    3.0.1                    pypi_0    pypi
joblib                    1.0.1              pyhd8ed1ab_0    conda-forge
jpeg                      9d                   h36c2ea0_0    conda-forge
json5                     0.9.5              pyh9f0ad1d_0    conda-forge
jsonschema                3.2.0              pyhd8ed1ab_3    conda-forge
jupyter-packaging         0.10.1             pyhd8ed1ab_0    conda-forge
jupyter_client            6.1.12             pyhd8ed1ab_0    conda-forge
jupyter_core              4.7.1            py38h578d9bd_0    conda-forge
jupyter_server            1.6.4            py38h578d9bd_0    conda-forge
jupyter_telemetry         0.1.0              pyhd8ed1ab_1    conda-forge
jupyterhub                1.4.0            py38h578d9bd_0    conda-forge
jupyterhub-base           1.4.0            py38h578d9bd_0    conda-forge
jupyterlab                3.0.14             pyhd8ed1ab_0    conda-forge
jupyterlab_pygments       0.1.2              pyh9f0ad1d_0    conda-forge
jupyterlab_server         2.5.0              pyhd8ed1ab_0    conda-forge
jupyterlab_widgets        1.0.0              pyhd8ed1ab_1    conda-forge
jxrlib                    1.1                  h7f98852_2    conda-forge
keras-preprocessing       1.1.2              pyhd8ed1ab_0    conda-forge
kiwisolver                1.3.1            py38h1fd1430_1    conda-forge
krb5                      1.17.2               h926e7f8_0    conda-forge
lcms2                     2.12                 hddcbb42_0    conda-forge
ld_impl_linux-64          2.35.1               hea4e1c9_2    conda-forge
lerc                      2.2.1                h9c3ff4c_0    conda-forge
libaec                    1.0.4                h9c3ff4c_1    conda-forge
libarchive                3.5.1                h3f442fb_1    conda-forge
libblas                   3.9.0                9_openblas    conda-forge
libcblas                  3.9.0                9_openblas    conda-forge
libcurl                   7.76.1               hc4aaa36_1    conda-forge
libdeflate                1.7                  h7f98852_5    conda-forge
libedit                   3.1.20191231         he28a2e2_2    conda-forge
libev                     4.33                 h516909a_1    conda-forge
libffi                    3.3                  h58526e2_2    conda-forge
libgcc-ng                 9.3.0               h2828fa1_19    conda-forge
libgfortran-ng            9.3.0               hff62375_19    conda-forge
libgfortran5              9.3.0               hff62375_19    conda-forge
libgomp                   9.3.0               h2828fa1_19    conda-forge
libiconv                  1.16                 h516909a_0    conda-forge
liblapack                 3.9.0                9_openblas    conda-forge
libllvm10                 10.0.1               he513fc3_3    conda-forge
libnghttp2                1.43.0               h812cca2_0    conda-forge
libopenblas               0.3.15          pthreads_h8fe5266_0    conda-forge
libpng                    1.6.37               h21135ba_2    conda-forge
libprotobuf               3.15.8               h780b84a_0    conda-forge
libsodium                 1.0.18               h36c2ea0_1    conda-forge
libsolv                   0.7.18               h780b84a_0    conda-forge
libssh2                   1.9.0                ha56f1ee_6    conda-forge
libstdcxx-ng              9.3.0               h6de172a_19    conda-forge
libtiff                   4.2.0                hdc55705_1    conda-forge
libuv                     1.41.0               h7f98852_0    conda-forge
libwebp-base              1.2.0                h7f98852_2    conda-forge
libxml2                   2.9.10               h72842e0_4    conda-forge
libzopfli                 1.0.3                h9c3ff4c_0    conda-forge
llvmlite                  0.36.0           py38h4630a5e_0    conda-forge
locket                    0.2.0                      py_2    conda-forge
lz4-c                     1.9.3                h9c3ff4c_0    conda-forge
lzo                       2.10              h516909a_1000    conda-forge
mako                      1.1.4              pyh44b312d_0    conda-forge
mamba                     0.12.2           py38h2aa5da1_0    conda-forge
markdown                  3.3.4              pyhd8ed1ab_0    conda-forge
markupsafe                2.0.1                    pypi_0    pypi
matplotlib-base           3.4.1            py38hcc49a3a_0    conda-forge
matplotlib-inline         0.1.2              pyhd8ed1ab_2    conda-forge
mistune                   0.8.4           py38h497a2fe_1003    conda-forge
mlflow                    1.20.2                   pypi_0    pypi
mock                      4.0.3            py38h578d9bd_1    conda-forge
mpc                       1.1.0             h04dde30_1009    conda-forge
mpfr                      4.0.2                he80fd80_1    conda-forge
mpmath                    1.2.1              pyhd8ed1ab_0    conda-forge
msgpack-python            1.0.2            py38h1fd1430_1    conda-forge
multidict                 5.1.0            py38h497a2fe_1    conda-forge
nbclassic                 0.2.7              pyhd8ed1ab_0    conda-forge
nbclient                  0.5.3              pyhd8ed1ab_0    conda-forge
nbconvert                 6.0.7            py38h578d9bd_3    conda-forge
nbformat                  5.1.3              pyhd8ed1ab_0    conda-forge
ncurses                   6.2                  h58526e2_4    conda-forge
nest-asyncio              1.5.1              pyhd8ed1ab_0    conda-forge
networkx                  2.3                        py_0    conda-forge
nodejs                    15.14.0              h92b4a50_0    conda-forge
notebook                  6.3.0              pyha770c72_1    conda-forge
numba                     0.53.1           py38h0e12cce_0    conda-forge
numexpr                   2.7.3            py38h51da96c_0    conda-forge
numpy                     1.20.2           py38h9894fe3_0    conda-forge
oauthlib                  3.0.1                      py_0    conda-forge
olefile                   0.46               pyh9f0ad1d_1    conda-forge
openblas                  0.3.15          pthreads_h4748800_0    conda-forge
openjpeg                  2.4.0                hf7af979_0    conda-forge
openssl                   1.1.1k               h7f98852_0    conda-forge
opt_einsum                3.3.0              pyhd8ed1ab_1    conda-forge
packaging                 20.9               pyh44b312d_0    conda-forge
pamela                    1.0.0                      py_0    conda-forge
pandas                    1.2.4            py38h1abd341_0    conda-forge
pandoc                    2.12                 h7f98852_0    conda-forge
pandocfilters             1.4.2                      py_1    conda-forge
parso                     0.8.2              pyhd8ed1ab_0    conda-forge
partd                     1.2.0              pyhd8ed1ab_0    conda-forge
patsy                     0.5.1                      py_0    conda-forge
pexpect                   4.8.0              pyh9f0ad1d_2    conda-forge
pickleshare               0.7.5                   py_1003    conda-forge
pillow                    8.1.2            py38ha0e1e83_1    conda-forge
pip                       21.1.1             pyhd8ed1ab_0    conda-forge
pooch                     1.3.0              pyhd8ed1ab_0    conda-forge
prometheus-flask-exporter 0.18.2                   pypi_0    pypi
prometheus_client         0.10.1             pyhd8ed1ab_0    conda-forge
prompt-toolkit            3.0.18             pyha770c72_0    conda-forge
protobuf                  3.15.8           py38h709712a_0    conda-forge
psutil                    5.8.0            py38h497a2fe_1    conda-forge
ptyprocess                0.7.0              pyhd3deb0d_0    conda-forge
pyasn1                    0.4.8                      py_0    conda-forge
pyasn1-modules            0.2.7                      py_0    conda-forge
pycosat                   0.6.3           py38h497a2fe_1006    conda-forge
pycparser                 2.20               pyh9f0ad1d_2    conda-forge
pycurl                    7.43.0.6         py38h996a351_1    conda-forge
pygments                  2.9.0              pyhd8ed1ab_0    conda-forge
pyjwt                     2.1.0              pyhd8ed1ab_0    conda-forge
pyopenssl                 20.0.1             pyhd8ed1ab_0    conda-forge
pyparsing                 2.4.7              pyh9f0ad1d_0    conda-forge
pyrsistent                0.17.3           py38h497a2fe_2    conda-forge
pysocks                   1.7.1            py38h578d9bd_3    conda-forge
pytables                  3.6.1            py38hc386592_3    conda-forge
python                    3.8.8           hffdb5ce_0_cpython    conda-forge
python-dateutil           2.8.1                      py_0    conda-forge
python-editor             1.0.4                      py_0    conda-forge
python-flatbuffers        1.12               pyhd8ed1ab_1    conda-forge
python-json-logger        2.0.1              pyh9f0ad1d_0    conda-forge
python_abi                3.8                      1_cp38    conda-forge
pytz                      2021.1             pyhd8ed1ab_0    conda-forge
pywavelets                1.1.1            py38h5c078b8_3    conda-forge
pyyaml                    5.4.1            py38h497a2fe_0    conda-forge
pyzmq                     22.0.3           py38h2035c66_1    conda-forge
querystring-parser        1.2.4                    pypi_0    pypi
re2                       2021.04.01           h9c3ff4c_0    conda-forge
readline                  8.1                  h46c0cb4_0    conda-forge
regex                     2021.9.24                pypi_0    pypi
reproc                    14.2.1               h36c2ea0_0    conda-forge
reproc-cpp                14.2.1               h58526e2_0    conda-forge
requests                  2.25.1             pyhd3deb0d_0    conda-forge
requests-oauthlib         1.3.0              pyh9f0ad1d_0    conda-forge
rsa                       4.7.2              pyh44b312d_0    conda-forge
ruamel.yaml               0.16.12          py38h497a2fe_2    conda-forge
ruamel.yaml.clib          0.2.2            py38h497a2fe_2    conda-forge
ruamel_yaml               0.15.80         py38h497a2fe_1004    conda-forge
sacremoses                0.0.46                   pypi_0    pypi
scikit-image              0.18.1           py38h51da96c_0    conda-forge
scikit-learn              0.24.2           py38hdc147b9_0    conda-forge
scipy                     1.6.3            py38h7b17777_0    conda-forge
seaborn                   0.11.1               hd8ed1ab_1    conda-forge
seaborn-base              0.11.1             pyhd8ed1ab_1    conda-forge
send2trash                1.5.0                      py_0    conda-forge
setuptools                49.6.0           py38h578d9bd_3    conda-forge
six                       1.16.0             pyh6c4a22f_0    conda-forge
smmap                     4.0.0                    pypi_0    pypi
snappy                    1.1.8                he1b5a44_3    conda-forge
sniffio                   1.2.0            py38h578d9bd_1    conda-forge
sortedcontainers          2.3.0              pyhd8ed1ab_0    conda-forge
soupsieve                 2.0.1                      py_1    conda-forge
sqlalchemy                1.4.13           py38h497a2fe_0    conda-forge
sqlite                    3.35.5               h74cdb3f_0    conda-forge
sqlparse                  0.4.2                    pypi_0    pypi
statsmodels               0.12.2           py38h5c078b8_0    conda-forge
sympy                     1.8              py38h578d9bd_0    conda-forge
tabulate                  0.8.9                    pypi_0    pypi
tblib                     1.7.0              pyhd8ed1ab_0    conda-forge
tensorboard               2.4.1              pyhd8ed1ab_0    conda-forge
tensorboard-plugin-wit    1.8.0              pyh44b312d_0    conda-forge
tensorflow                2.4.1            py38h578d9bd_0    conda-forge
tensorflow-base           2.4.1            py38h83f5f1d_0    conda-forge
tensorflow-estimator      2.4.0              pyh9656e83_0    conda-forge
termcolor                 1.1.0                      py_2    conda-forge
terminado                 0.9.4            py38h578d9bd_0    conda-forge
testpath                  0.4.4                      py_0    conda-forge
threadpoolctl             2.1.0              pyh5ca1d4c_0    conda-forge
tifffile                  2021.4.8           pyhd8ed1ab_0    conda-forge
tini                      0.18.0            h14c3975_1001    conda-forge
tk                        8.6.10               h21135ba_1    conda-forge
tokenizers                0.10.3                   pypi_0    pypi
tomlkit                   0.7.0            py38h578d9bd_3    conda-forge
toolz                     0.11.1                     py_0    conda-forge
torch                     1.8.1+cu111              pypi_0    pypi
torchaudio                0.8.1                    pypi_0    pypi
torchvision               0.9.1+cu111              pypi_0    pypi
tornado                   6.1              py38h497a2fe_1    conda-forge
tqdm                      4.60.0             pyhd8ed1ab_0    conda-forge
traitlets                 5.0.5                      py_0    conda-forge
transformers              4.11.0                   pypi_0    pypi
typing-extensions         3.7.4.3                       0    conda-forge
typing_extensions         3.7.4.3                    py_0    conda-forge
ujson                     4.2.0                    pypi_0    pypi
urllib3                   1.26.4             pyhd8ed1ab_0    conda-forge
vincent                   0.4.4                      py_1    conda-forge
wcwidth                   0.2.5              pyh9f0ad1d_2    conda-forge
webencodings              0.5.1                      py_1    conda-forge
websocket-client          1.2.1                    pypi_0    pypi
werkzeug                  2.0.1                    pypi_0    pypi
wheel                     0.36.2             pyhd3deb0d_0    conda-forge
widgetsnbextension        3.5.1            py38h578d9bd_4    conda-forge
wrapt                     1.12.1           py38h497a2fe_3    conda-forge
xlrd                      2.0.1              pyhd8ed1ab_3    conda-forge
xz                        5.2.5                h516909a_1    conda-forge
yaml                      0.2.5                h516909a_0    conda-forge
yarl                      1.6.3            py38h497a2fe_1    conda-forge
zeromq                    4.3.4                h9c3ff4c_0    conda-forge
zfp                       0.5.5                h9c3ff4c_5    conda-forge
zict                      2.0.0                      py_0    conda-forge
zipp                      3.4.1              pyhd8ed1ab_0    conda-forge
zlib                      1.2.11            h516909a_1010    conda-forge
zstd                      1.4.9                ha95c52a_0    conda-forge

</details>

  • <details><summary>Configuration</summary> <!-- For JupyterHub, especially include information such as what Spawner and Authenticator are being used. Be careful not to share any sensitive information. You can paste jupyterhub_config.py below. To exclude lots of comments and empty lines from auto-generated jupyterhub_config.py, you can do: grep -v '(^#|^[[:space:]]*$)' jupyterhub_config.py -->

... don't know where to get this from ...

jovyan@jupyter-rbattle:~$ grep -v '\(^#\|^[[:space:]]*$\)' jupyterhub_config.py
grep: jupyterhub_config.py: No such file or directory

</details>

  • <details><summary>Logs</summary> <!-- Errors are often logged by jupytehub. How you get logs depends on your deployment. With kubernetes it might be:

    kubectl get pod # hub pod name starts with hub... kubectl logs hub-...

    or for a single-user server

    kubectl logs jupyter-username

Or the-littlest-jupyterhub:

journalctl -u jupyterhub
# or for a single-user server
journalctl -u jupyter-username

-->

No errors are thrown. The network request returns code 200.

Request URL: https://jupyter.eng.vmware.com/user/rbattle/api/contents/checkpoints?content=1&1633020422849
Request Method: GET
Status Code: 200 OK
Response: []

</details>

closed time in 2 months

detaos

issue commentjupyterhub/jupyterhub

File Browser unable to open a folder named "checkpoints"

Hi there @detaos :wave:!

I closed this issue because it was labelled as a support question.

Please help us organize discussion by posting this on the http://discourse.jupyter.org/ forum.

Our goal is to sustain a positive experience for both users and developers. We use GitHub issues for specific discussions related to changing a repository's content, and let the forum be where we can more generally help and inspire each other.

Thanks you for being an active member of our community! :heart:

detaos

comment created time in 2 months

issue closedgetredash/redash

Create a less permissive [view_only] data source group Modality

It will be great to have a lesser permissive [View Only] Group than could integrate less privileges.

For exemple, in our institution, we have read_only users that would not be able to download data from Dashboards neither view queries, even if they are behing part of a [View Only] Group

image

Would it be possible to add this datasource group modality @arikfr ?

closed time in 2 months

armandleopold

issue commentgetredash/redash

Create a less permissive [view_only] data source group Modality

:wave: @armandleopold, we use the issue tracker exclusively for bug reports and planned work. However, this issue appears to be a support request. Please use our forum to get help.

armandleopold

comment created time in 2 months

issue closedmui-org/material-ui

Button doesn't respect theme colors

Current Behavior 😯

When rendering a button with a custom theme using ThemeProvider, the button does not respect the color in the theme, instead it uses the default color.

Expected Behavior 🤔

Respect the color in the theme palette. You'll also see the background in not the color specified.

Code Example (tried to use codesandbox but not working)

import React from "react";
import CssBaseline from "@mui/material/CssBaseline";
import { createTheme, StyledEngineProvider } from "@mui/material/styles";
import { ThemeProvider } from "@mui/styles";
import Button from "@mui/material/Button";

const theme = createTheme({
  palette: {
    background: {
      default: "#F7F9FC",
    },
    primary: {
      main: "#ff0000",
    },
  },
});

function App() {
  return (
    <div>
      <StyledEngineProvider injectFirst>
        <CssBaseline />
        <ThemeProvider theme={theme}>
          <div>
            <Button color="primary" variant="contained">
              Test
            </Button>
          </div>
        </ThemeProvider>
      </StyledEngineProvider>
    </div>
  );
}

export default App;

closed time in 2 months

tomcooksey

issue commentmui-org/material-ui

Button doesn't respect theme colors

👋 Thanks for using MUI Core!

We use GitHub issues exclusively as a bug and feature requests tracker, however, this issue appears to be a support request.

For support, please check out https://mui.com/getting-started/support/. Thanks!

If you have a question on StackOverflow, you are welcome to link to it here, it might help others. If your issue is subsequently confirmed as a bug, and the report follows the issue template, it can be reopened.

tomcooksey

comment created time in 2 months

issue closedmui-org/material-ui

makeStyle being overridden by root

<!-- Provide a general summary of the issue in the Title above --> I'm trying to set a style using makeStyle hook, but there is another -root style applied after it overriding my style with some sort of root style. This occurs on all components I have tried.

https://codesandbox.io/embed/jovial-booth-gfvec?fontsize=14&hidenavigation=1&theme=dark

<!-- Thank you very much for contributing to MUI by creating an issue! ❤️ To avoid duplicate issues we ask you to check off the following list. -->

<!-- Checked checkbox should look like this: [x] -->

  • [X] The issue is present in the latest release.
  • [ ] I have searched the issues of this repository and believe that this is not a duplicate.

Current Behavior 😯

My style to be applied is being overridden by some other styling <!-- Describe what happens instead of the expected behavior. -->

Expected Behavior 🤔

My style should be applied <!-- Describe what should happen. -->

Steps to Reproduce 🕹

https://codesandbox.io/embed/jovial-booth-gfvec?fontsize=14&hidenavigation=1&theme=dark

<!-- Provide a link to a live example (you can use codesandbox.io) and an unambiguous set of steps to reproduce this bug. Include code to reproduce, if relevant (which it most likely is).

You should use the official codesandbox template as a starting point: https://mui.com/r/issue-template-next

If you have an issue concerning TypeScript please start from this TypeScript playground: https://mui.com/r/ts-issue-template

Issues without some form of live example have a longer response time. -->

Context 🔦

<!-- What are you trying to accomplish? How has this issue affected you? Providing context helps us come up with a solution that is most useful in the real world. --> This is stopping my styling my website

Your Environment 🌎

System: OS: macOS 11.3 Binaries: Node: 16.5.0 - /usr/local/bin/node Yarn: 1.22.11 - ~/Projects/airplacer_frontend-application/admin/node_modules/.bin/yarn npm: 7.20.0 - /usr/local/bin/npm Browsers: Chrome: 94.0.4606.61 Edge: Not Found Firefox: 92.0.1 Safari: 14.1 npmPackages: @emotion/react: ^11.4.1 => 11.4.1 @emotion/styled: ^11.3.0 => 11.3.0 @mui/core: 5.0.0-alpha.48 @mui/icons-material: ^5.0.1 => 5.0.1 @mui/material: ^5.0.1 => 5.0.1 @mui/private-theming: 5.0.1 @mui/styled-engine: 5.0.1 @mui/styles: ^5.0.1 => 5.0.1 @mui/system: 5.0.1 @mui/types: 7.0.0 @mui/utils: 5.0.1 @types/react: 17.0.24 react: ^17.0.2 => 17.0.2 react-dom: ^17.0.2 => 17.0.2 <!-- Run npx @mui/envinfo and post the results. If you encounter issues with TypeScript please include the used tsconfig. --> <details> <summary>npx @mui/envinfo</summary>

  Don't forget to mention which browser you used.
  Output from `npx @mui/envinfo` goes here.

</details>

closed time in 2 months

supagu

issue commentmui-org/material-ui

makeStyle being overridden by root

👋 Thanks for using MUI Core!

We use GitHub issues exclusively as a bug and feature requests tracker, however, this issue appears to be a support request.

For support, please check out https://mui.com/getting-started/support/. Thanks!

If you have a question on StackOverflow, you are welcome to link to it here, it might help others. If your issue is subsequently confirmed as a bug, and the report follows the issue template, it can be reopened.

supagu

comment created time in 2 months

more