profile
viewpoint
Stephen Prater stephenprater 8th Light Portland, OR stephenprater.com

CypherpunkArmory/UserLAnd 1728

Main UserLAnd Repository

CypherpunkArmory/holepunch 37

Holepunch API

CypherpunkArmory/UserLAnd-Assets-Support 29

Repository for building and holding the core assets of UserLAnd

CypherpunkArmory/UserLAnd-Assets-Debian 21

A repository for holding Debian specific assets for UserLAnd

CypherpunkArmory/proot 11

An chroot-like implementation using ptrace.

goldstar/newrelic-elasticsearch 7

NewRelic Instrumentation for Elasticsearch

CypherpunkArmory/momblish 4

What nonsense! Lango!

CypherpunkArmory/punch 3

Holepunch CLI Tool

CypherpunkArmory/UserLAnd-Assets-Kali 3

A repository for holding Kali specific assets for UserLAnd

stephenprater/cocoa.vim 3

mirror of cocoa.vim

issue commentCypherpunkArmory/UserLAnd

Ajuda com download de recursos da kali linux

Hello @jhubu13!

This message has been autogenerated.

It looks like you've posted an issue, but in order for us to best assist you, we need some additional information. We have created some issue templates to make this process easier. You can find them here.

These templates contain lines that begin with the '#' character. These lines are headers. In your issue, please leave these headers as is, and fill out information relevant to the header in the space below it.

If you don't think that you have any information relevant to the header, fill the space below it with something like 'N/A', or consider using a different template.

These headers are essential in allowing us to recreate and resolve your issue. The more detailed your issue, the more quickly we can begin working on it.

This bot could not detect which template you were trying to use. Please follow the link above to find a template to use.

If your issue is not updated to follow a template, it may be removed. If you edit your issue to follow a template, the bot will remove its comment.

Thanks for your help in improving UserLAnd!

jhubu13

comment created time in 10 hours

issue openedCypherpunkArmory/UserLAnd

Ajuda com download de recursos da kali linux

Fica. No download infinito fica 1/2 pra sempre l ajuda porfavor

created time in 10 hours

issue commentCypherpunkArmory/UserLAnd

Syanptic Don't Work

Removing Docker Related files will fix the problem if synaptic won't work on Userland

Type: rm -rf /etc/apt/apt.conf.d/docker-*

MaffSi

comment created time in 11 hours

issue commentCypherpunkArmory/UserLAnd

Please offer Kubuntu

I just tried to install the KDE Plasma on top of Ubuntu but the window manager does not start. There's a white screen only.

Dirk-LG

comment created time in a day

issue openedCypherpunkArmory/UserLAnd

Please offer Kubuntu

Describe the problem your feature request solves.

I like the nice KDE Plasma desktop and its applications. Unfortunately, it is not recommended to upgrade Ubuntu to Kubuntu.

Describe the solution you'd like

Can you please add Kunutu to the list of distributions.

Describe alternatives you've considered

How can I add this myself?

created time in a day

issue commentCypherpunkArmory/UserLAnd

Very slow app starting when using imported file systems

Still persists on Android 10 with UserLAnd 2.7.2. Also on the LG G8s device.

Dirk-LG

comment created time in a day

issue commentCypherpunkArmory/UserLAnd

Feature Request - CUPS / I like to print on a HP printer

I found a solution by myself, there is a issue with libcrypto.so.1.1:

  • Install CUPS
  • do a "cp /usr/lib/aarch64-linux-gnu/libcrypto.so.1.1 /data/user/0/tech.ula/files/support"
  • start CUPS with "sudo /etc/init.d/cups start"
Dirk-LG

comment created time in a day

issue commentCypherpunkArmory/UserLAnd

VNC sessions crash or do not start at all

This issue persists on Android 10. Even when being able to connect, this error may happen after 10-20 minutes. As a result, the user will loose any unsaved work.

Dirk-LG

comment created time in a day

startedSynerise/cleora

started time in 4 days

issue closedCypherpunkArmory/UserLAnd

When proxying userland app through orbot, if I try to launch userland it crashes suddenly after showing "checking to see if updates are required"

How to use this template: Any line that begins with '#' is a header. Please leave the headers in as is, and fill in the information they suggest below them. These templates are here to help us resolve your issue as quickly as possible. Leaving requested information out of your issue will cause our issue template bot to request that your post be reformatted. If a header doesn't seem relevant to your issue, either write 'N/A' or something similar below the header or consider using a different template.

Describe the bug

A clear and concise description of what the bug is, and what expected behavior is. Include whether the bug occurs before or after entering a terminal or vnc client session.

Steps to reproduce the behavior:

A list of exact steps to reproduce the behavior. If we cannot follow the steps to recreate the issue, we won't be able to help you.

For example:

  1. Go to '...'

  2. Click on '....'

  3. Scroll down to '....'

Screenshot_20200924-212135

If applicable, add screenshots to help explain your problem.

Device Information

Device: [umidigi A7 pro].
Android Version: [10].
UserLAnd Version [latest].
nonrooted.
No lineage os

Please add any other context you think might help us resolve your issue.

closed time in 4 days

raheemmuizz

issue closedCypherpunkArmory/UserLAnd

Netdiscover and some features of nmap not working

How to use this template: Any line that begins with '#' is a header. Please leave the headers in as is, and fill in the information they suggest below them. These templates are here to help us resolve your issue as quickly as possible. Leaving requested information out of your issue will cause our issue template bot to request that your post be reformatted. If a header doesn't seem relevant to your issue, either write 'N/A' or something similar below the header or consider using a different template.

Describe the bug

 When I try os fingerprinting on nmap with an ip address regardless if I use SU or sudo command for root it throws up an error.
 Also if I use netdiscover for range or network discovery for any ip address it doesn't work also

Steps to reproduce the behavior:

A list of exact steps to reproduce the behavior. If we cannot follow the steps to recreate the issue, we won't be able to help you.

For example:

  1. 'Su' command for login as root

  2. For nmap: root@localhost:~# nmap -O 127.0.0.1 (changed the original ip for security reasons) Starting Nmap 7.80 ( https://nmap.org ) at 2020-09-24 12:04 UTC route_dst_netlink: can't find interface "tun0" For netdiscover: root@localhost:~# netdiscover -r 127.0.0.1 Couldn't find default device: ccmni0: SIOCETHTOOL(ETHTOOL_GLINK) ioctl failed: Permission denied (I changed the original ip address for security purposes)

  3. Scroll down to '....'

Screenshots

Nmap error: route_dst_netlink: can't find interface "tun0" Netdiscover error: Couldn't find default device: ccmni0: SIOCETHTOOL(ETHTOOL_GLINK) ioctl failed: Permission denied

If applicable, add screenshots to help explain your problem.

Device Information

Device: [e.g. umidigi A7 pro].
Android Version: [ Android 10].
UserLAnd Version [2.7.3].
Not rooted.
No lineage os

I know most network tools will need root to function but if there are any workaround this as it works on metasploit I will be very happy, I need those tools badly :)

closed time in 4 days

raheemmuizz

issue openedCypherpunkArmory/UserLAnd

Bug report After apt full-upgrade, many kali tools that requires port binding tcp connection port opening throws up permission errors

Describe the bug

After apt full-upgrade, many kali tools that requires port binding tcp connection port opening throws up permission errors

Steps to reproduce the behavior:

Sudo apt update && sudo apt upgrade && sudo apt full-upgrade which updated kali to rolling-2020.4 After all upgrade: kali should show tons of no longer needed tools: in my case :-) sudo apt autoremove and apt autoclean

  • Open beef-XSS framework (this should show an error like Operation not permitted - fstat(2) (Errno::EPERM))
  • Open metasploit use any exploit that needs a tcp connection or ip binding. Same error (Operation not permitted - fstat(2) (Errno::EPERM)) *sudo service apache2 start (no luck) etc

Screenshots

Device Information

Device: [umidigi A7 pro].
Android Version: [android 10].
UserLAnd Version [2.7.3].
Non-rooted.
Not running lineage os

Pls cheak this issue as it is actually a bug, All this started after the full upgrade and autoclean I have opened issues on some of the tools listed above including metasploit and it was said to be some sort of permission errors on the local machine not a bug in the tool

created time in 4 days

startedstephenprater/fbterm

started time in 6 days

issue commentCypherpunkArmory/UserLAnd

Bug repo:- why can't i use my samsung keyboard to give command.

Hello @lonetouseef!

This message has been autogenerated.

It looks like you've posted an issue, but in order for us to best assist you, we need some additional information. We have created some issue templates to make this process easier. You can find them here.

These templates contain lines that begin with the '#' character. These lines are headers. In your issue, please leave these headers as is, and fill out information relevant to the header in the space below it.

If you don't think that you have any information relevant to the header, fill the space below it with something like 'N/A', or consider using a different template.

These headers are essential in allowing us to recreate and resolve your issue. The more detailed your issue, the more quickly we can begin working on it.

This bot could not detect which template you were trying to use. Please follow the link above to find a template to use.

If your issue is not updated to follow a template, it may be removed. If you edit your issue to follow a template, the bot will remove its comment.

Thanks for your help in improving UserLAnd!

lonetouseef

comment created time in 6 days

issue openedCypherpunkArmory/UserLAnd

Bug repo:- why can't i use my samsung keyboard to give command.

I m not able to use my #samsung keybaord to give #command in kali lunix. Fix this issue as soon as possible. #Device #samsung:- SM-A205F #Android version:- 10

created time in 6 days

issue openedCypherpunkArmory/UserLAnd-Assets-Debian

Usesets Devisn

Gracias ,!

created time in 8 days

issue commentCypherpunkArmory/UserLAnd

Archlinux tigervnc vncserver cannot launch

I found what appears to be the root of the issue with TigerVNC. It now depends on a systemd session scope. I assume this is something that just hasn't hit Debian yet.

I would close this, but I suspect this is also why it's not possible to launch an Arch/VNC session from the UI. If so, a solution or an advisory might be in order.

headbank

comment created time in 8 days

issue commentCypherpunkArmory/UserLAnd

Archlinux tigervnc vncserver cannot launch

Hello @headbank!

This message has been autogenerated.

It looks like you've posted an issue, but in order for us to best assist you, we need some additional information. We have created some issue templates to make this process easier. You can find them here.

These templates contain lines that begin with the '#' character. These lines are headers. In your issue, please leave these headers as is, and fill out information relevant to the header in the space below it.

If you don't think that you have any information relevant to the header, fill the space below it with something like 'N/A', or consider using a different template.

These headers are essential in allowing us to recreate and resolve your issue. The more detailed your issue, the more quickly we can begin working on it.

It looks like you were attempting to use the bug_report.md template. Copy and paste the headers, including the '#' character, remove the single quotes, and use it to edit your issue. That template requires the following headers:

'# Describe the bug' '# Steps to reproduce the behavior:' '# Screenshots' '# Device Information'

If your issue is not updated to follow a template, it may be removed. If you edit your issue to follow a template, the bot will remove its comment.

Thanks for your help in improving UserLAnd!

headbank

comment created time in 9 days

issue openedCypherpunkArmory/UserLAnd

Archlinux tigervnc vncserver cannot launch

Describe the bug

I wanted to launch tigervnc vncserver from within an Arch/SSH session (I've been able to do this in UserLAnd Debian) but something is amiss with the vncserver perl script I think, as any attempted command, for example

vncserver -geometry 1920x1080 -securitytypes none

(which is sufficient to launch Xtigervnc in Debian) returns only

Usage: vncserver <display>

In addition I was unable to launch the Arch install as a VNC session from the UserLAnd UI either - the process hung on "starting session..."

This is with a new-installed Arch filesystem and session, which I have only added pacman -Syu and pacman -S fluxbox

Device Information

Device: Samsung Galaxy S10 5G.
Android Version: 10/Q.
UserLAnd Version: Latest from Play Store (sorry, no idea how to find version number).
Whether the device is rooted. NO Whether the device is running LineageOS (NO)

created time in 9 days

pull request commentCypherpunkArmory/UserLAnd

German translation

No, I did not manually test this (I have never coded an Android app before). And maybe @MoriPastaPizza would try to check this? I do not know anyone personally though.

RudiAusBuddeln

comment created time in 10 days

issue openedCypherpunkArmory/UserLAnd

Help - [YOUR ISSUE HERE]kali@localhost:~$ wifite . . .´ · . . · `. wifite2 2.5.2 : : : (¯) : : : a wireless auditor by @derv82 `. · ` /¯\ ´ · .´ maintained by kimocoder ` /¯¯¯\ ´ https://github.com/kimocoder/wifite2 [!] error: wifite must be run as root [!] re-run with sudo

How to use this template: Any line that begins with '#' is a header. Please leave the headers in as is, and fill in the information they suggest below them. These templates are here to help us resolve your issue as quickly as possible. Leaving requested information out of your issue will cause our issue template bot to request that your post be reformatted. If a header doesn't seem relevant to your issue, either write 'N/A' or something similar below the header or consider using a different template.

Describe the issue you are having.

This should include things like:

  • What you are trying to accomplish
  • What you have tried so far

Describe how your task behaves in a regular Linux environment

Describe how the task you are trying to accomplish behaves in a regular Linux environment.

created time in 10 days

issue commentCypherpunkArmory/UserLAnd

Android 10 & UserLand v2.7.3 - PostgreSQL shared memory segment when creating cluster

@jancelin @hamody114 @yeasin6152 Since you raised interest in PostgreSQL in the issue #256, could you please help me here by testing the previous working PostgreSQL in a Android 10 environment ? I would like to know if someone else can reproduce the bug.

IMHO I would be a shame if we loose PostgreSQL support in Userland.

Thanks in advance

mdouchin

comment created time in 10 days

issue commentCypherpunkArmory/UserLAnd

Create a new filesystem on a SD card

Can't UserLand just store files in <SD Card>/Android/data/files/tech.ula/files like in Termux? Or am I being ignorant that I can't change permissions the same as in Termux?

glebone

comment created time in 13 days

issue commentCypherpunkArmory/UserLAnd

Translations Needed

Hey there,

I'd be willing to contribute Macedonian translations!

Will start translating soon.

corbinlc

comment created time in 14 days

issue commentCypherpunkArmory/UserLAnd

Help - [No graphic interface]

Hello @parsa1811!

This message has been autogenerated.

It looks like you've posted an issue, but in order for us to best assist you, we need some additional information. We have created some issue templates to make this process easier. You can find them here.

These templates contain lines that begin with the '#' character. These lines are headers. In your issue, please leave these headers as is, and fill out information relevant to the header in the space below it.

If you don't think that you have any information relevant to the header, fill the space below it with something like 'N/A', or consider using a different template.

These headers are essential in allowing us to recreate and resolve your issue. The more detailed your issue, the more quickly we can begin working on it.

This bot could not detect which template you were trying to use. Please follow the link above to find a template to use.

If your issue is not updated to follow a template, it may be removed. If you edit your issue to follow a template, the bot will remove its comment.

Thanks for your help in improving UserLAnd!

parsa1811

comment created time in 16 days

issue openedCypherpunkArmory/UserLAnd

Help - [No graphic interface]

I have no idea what to do the userland said use /sdcard i don't what it means it said it's a issue with android 10. I can't send photo here.

created time in 16 days

startedleerob/nextjs-aws-dynamodb

started time in 16 days

startedyairEO/knobs

started time in 16 days

issue commentCypherpunkArmory/UserLAnd

Android 10 & UserLand v2.7.3 - PostgreSQL shared memory segment when creating cluster

Here is a simple debian image with PostgreSQL 11 installed. https://we.tl/t-4oHhJURU2w

mdouchin

comment created time in 18 days

startedgao-sun/eul

started time in 19 days

more