profile
viewpoint
Sean Linsley seanlinsley Dallas, Texas https://mastodon.social/@seanlinsley (/¯◡ ‿ ◡)/¯ ~ ┻━┻

drapergem/draper 4845

Decorators/View-Models for Rails Applications

seanlinsley/5-gallon-bucket 1

The place where you put things!

seanlinsley/active-record-query-trace 0

Rails 3 plugin to log sources of SQL queries to Rails log

seanlinsley/activerecord-import 0

Extraction of the ActiveRecord::Base#import functionality from ar-extensions for Rails 3 and beyon

seanlinsley/activerecord-safer_migrations 0

Safer ActiveRecord migrations for Postgres

seanlinsley/ActiveRecordExtended 0

Adds additional postgres functionality to an ActiveRecord / Rails application

seanlinsley/ahoy 0

Analytics for Rails

seanlinsley/amp 0

A complete text editor for your terminal.

seanlinsley/arbre 0

An Object Oriented DOM Tree in Ruby

seanlinsley/attachinary 0

Attachments handler for Rails that uses Cloudinary for storage.

issue commentpouchdb/pouchdb

Tried pouchDB 7.2.1 but can't get adapter to be 'indexeddb'

I was able to hack together a solution using Browserify:

npm install -g browserify
npm install pouchdb-adapter-indexeddb

browserify node_modules/pouchdb-adapter-indexeddb/lib/index.js \
  -o pouchdb.indexeddb.js -s PouchDB.IndexedDB
rm -rf node_modules
<script src="lib/pouchdb.js"></script>
<script src="lib/pouchdb.indexeddb.js"></script>
PouchDB.plugin(PouchDB.IndexedDB)
db = new PouchDB('example', {adapter: 'indexeddb', auto_compaction: true})
lochehong

comment created time in 2 months

issue commentpouchdb/pouchdb

Tried pouchDB 7.2.1 but can't get adapter to be 'indexeddb'

As another person who doesn't use a JS package manager, I'd really appreciate if this could get its own .js file.

lochehong

comment created time in 2 months

startedsoapdog/patchfox

started time in 3 months

more