profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/sadarshannaiynar/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
Adarsh sadarshannaiynar Coder, Loves learning and implementing

FedML-AI/FedML 654

A Research-oriented Federated Learning Library. Supporting distributed computing, mobile/IoT on-device training, and standalone simulation. Best Paper Award at NeurIPS 2020 Federated Learning workshop. Join our Slack Community:(https://join.slack.com/t/fedml/shared_invite/zt-havwx1ee-a1xfOUrATNfc9DFqU~r34w)

FedML-AI/FedCV 8

FedCV: A Federated Learning Framework for Diverse Computer Vision Tasks

aru-jo/corona-dash 1

COVID - 19 Dashboard (Total Cases, Cases, Twitter Trends, Top Headlines & API Support)

ravikiran0606/energy-disaggregation 0

Energy Disaggregation and Energy Consumption Forecasting

ravikiran0606/kaggle-dashboard 0

This web application is used for visualizing the data in the form of dashboard.

sadarshannaiynar/carbon 0

🎨 Create and share beautiful images of your source code

sadarshannaiynar/catalystJs 0

Your one stop for setting Git aliases!

delete branch sadarshannaiynar/electron-typescript-react-redux-boilerplate

delete branch : dependabot/npm_and_yarn/postcss-8.2.10

delete time in 2 hours

PR closed sadarshannaiynar/electron-typescript-react-redux-boilerplate

Bump postcss from 7.0.2 to 8.2.10 dependencies

Bumps postcss from 7.0.2 to 8.2.10. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/postcss/postcss/releases">postcss's releases</a>.</em></p> <blockquote> <h2>8.2.10</h2> <ul> <li>Fixed ReDoS vulnerabilities in source map parsing.</li> <li>Fixed webpack 5 support (by <a href="https://github.com/barak007"><code>@​barak007</code></a>).</li> <li>Fixed docs (by <a href="https://github.com/roelandmoors"><code>@​roelandmoors</code></a>).</li> </ul> <h2>8.2.9</h2> <ul> <li>Exported <code>NodeErrorOptions</code> type (by <a href="https://github.com/realityking"><code>@​realityking</code></a>)</li> </ul> <h2>8.2.8</h2> <ul> <li>Fixed browser builds in webpack 5 (by <a href="https://github.com/mattcompiles"><code>@​mattcompiles</code></a>).</li> </ul> <h2>8.2.7</h2> <ul> <li>Fixed browser builds in webpack 5 (by <a href="https://github.com/mattcompiles"><code>@​mattcompiles</code></a>).</li> </ul> <h2>8.2.6</h2> <ul> <li>Fixed <code>Maximum call stack size exceeded</code> in <code>Node#toJSON</code>.</li> <li>Fixed docs (by <a href="https://github.com/inokawa"><code>@​inokawa</code></a>).</li> </ul> <h2>8.2.5</h2> <ul> <li>Fixed escaped characters handling in <code>list.split</code> (by <a href="https://github.com/nex3"><code>@​nex3</code></a>).</li> </ul> <h2>8.2.4</h2> <ul> <li>Added plugin name to <code>postcss.plugin()</code> warning (by <a href="https://github.com/Alphy11"><code>@​Alphy11</code></a>).</li> <li>Fixed docs (by <a href="https://github.com/billcolumbia"><code>@​billcolumbia</code></a>).</li> </ul> <h2>8.2.3</h2> <ul> <li>Fixed <code>JSON.stringify(Node[])</code> support (by <a href="https://github.com/mischnic"><code>@​mischnic</code></a>).</li> </ul> <h2>8.2.2</h2> <ul> <li>Fixed CSS-in-JS support (by <a href="https://github.com/43081j"><code>@​43081j</code></a>).</li> <li>Fixed plugin types (by <a href="https://github.com/ludofischer"><code>@​ludofischer</code></a>).</li> <li>Fixed <code>Result#warn()</code> types.</li> </ul> <h2>8.2.1</h2> <ul> <li>Fixed <code>Node#toJSON()</code> and <code>postcss.fromJSON()</code> (by <a href="https://github.com/mischnic"><code>@​mischnic</code></a>).</li> </ul> <h2>8.2 “Prince Orobas”</h2> <!-- raw HTML omitted --> <p>PostCSS 8.2 added a new API to serialize and deserialize CSS AST to JSON.</p> <pre lang="js"><code>import { parse, fromJSON } from 'postcss' <p>let root = parse('a{}', { from: 'input.css' }) let json = root.toJSON() // save to file, send by network, etc let root2 = fromJSON(json) </code></pre></p> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/postcss/postcss/blob/main/CHANGELOG.md">postcss's changelog</a>.</em></p> <blockquote> <h2>8.2.10</h2> <ul> <li>Fixed ReDoS vulnerabilities in source map parsing.</li> <li>Fixed webpack 5 support (by Barak Igal).</li> <li>Fixed docs (by Roeland Moors).</li> </ul> <h2>8.2.9</h2> <ul> <li>Exported <code>NodeErrorOptions</code> type (by Rouven Weßling).</li> </ul> <h2>8.2.8</h2> <ul> <li>Fixed browser builds in webpack 4 (by Matt Jones).</li> </ul> <h2>8.2.7</h2> <ul> <li>Fixed browser builds in webpack 5 (by Matt Jones).</li> </ul> <h2>8.2.6</h2> <ul> <li>Fixed <code>Maximum call stack size exceeded</code> in <code>Node#toJSON</code>.</li> <li>Fixed docs (by inokawa).</li> </ul> <h2>8.2.5</h2> <ul> <li>Fixed escaped characters handling in <code>list.split</code> (by Natalie Weizenbaum).</li> </ul> <h2>8.2.4</h2> <ul> <li>Added plugin name to <code>postcss.plugin()</code> warning (by Tom Williams).</li> <li>Fixed docs (by Bill Columbia).</li> </ul> <h2>8.2.3</h2> <ul> <li>Fixed <code>JSON.stringify(Node[])</code> support (by Niklas Mischkulnig).</li> </ul> <h2>8.2.2</h2> <ul> <li>Fixed CSS-in-JS support (by James Garbutt).</li> <li>Fixed plugin types (by Ludovico Fischer).</li> <li>Fixed <code>Result#warn()</code> types.</li> </ul> <h2>8.2.1</h2> <ul> <li>Fixed <code>Node#toJSON()</code> and <code>postcss.fromJSON()</code> (by Niklas Mischkulnig).</li> </ul> <h2>8.2 “Prince Orobas”</h2> <ul> <li>Added <code>Node#toJSON()</code> and <code>postcss.fromJSON()</code> (by Niklas Mischkulnig).</li> </ul> <h2>8.1.14</h2> <ul> <li>Fixed parser performance regression.</li> </ul> <h2>8.1.13</h2> <ul> <li>Fixed broken AST after moving nodes in visitor API.</li> </ul> <h2>8.1.12</h2> <ul> <li>Fixed Autoprefixer regression.</li> </ul> <h2>8.1.11</h2> <ul> <li>Added PostCSS update suggestion on unknown event in plugin.</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/postcss/postcss/commit/8395d9f53efbaae5f3372b6b662a9e9b5b02360b"><code>8395d9f</code></a> Release 8.2.10 version</li> <li><a href="https://github.com/postcss/postcss/commit/f2baaa7e3780bad669814df498e301a47b5307c3"><code>f2baaa7</code></a> Update ESLint config</li> <li><a href="https://github.com/postcss/postcss/commit/b6f3e4d5a8d7504d553267f80384373af3a3dec5"><code>b6f3e4d</code></a> Fix unsafe regexp in getAnnotationURL() too</li> <li><a href="https://github.com/postcss/postcss/commit/4bcd7276d19511ec9ae01d6471c6417533240668"><code>4bcd727</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/postcss/postcss/issues/1553">#1553</a> from barak007/patch-2</li> <li><a href="https://github.com/postcss/postcss/commit/7c2e97aeaaae1faa65f655c09798101b4bc00a44"><code>7c2e97a</code></a> Add covrage ignore on error paths</li> <li><a href="https://github.com/postcss/postcss/commit/8c5843463041a9e76b9af2b76eb54db5faddde64"><code>8c58434</code></a> Apply suggestions from code review</li> <li><a href="https://github.com/postcss/postcss/commit/ff2fd57f6632436426156be63e696529f5ba0504"><code>ff2fd57</code></a> add error for sourcePath</li> <li><a href="https://github.com/postcss/postcss/commit/8f02bdcf62b820c8927a822fad02ffb6fec779d9"><code>8f02bdc</code></a> disable url based features</li> <li><a href="https://github.com/postcss/postcss/commit/a54d0205ef4c4bb127ccd1eaa807498f0534cdcf"><code>a54d020</code></a> Fix browser bundling with webpack 5</li> <li><a href="https://github.com/postcss/postcss/commit/8682b1e4e328432ba692bed52326e84439cec9e4"><code>8682b1e</code></a> Fix unsafe regexp</li> <li>Additional commits viewable in <a href="https://github.com/postcss/postcss/compare/7.0.2...8.2.10">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+73 -7

1 comment

3 changed files

dependabot[bot]

pr closed time in 2 hours

PR opened sadarshannaiynar/electron-typescript-react-redux-boilerplate

Bump postcss from 7.0.2 to 7.0.36

Bumps postcss from 7.0.2 to 7.0.36. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/postcss/postcss/releases">postcss's releases</a>.</em></p> <blockquote> <h2>7.0.36</h2> <ul> <li>Backport ReDoS vulnerabilities from PostCSS 8.</li> </ul> <h2>7.0.35</h2> <ul> <li>Add <a href="https://github.com/postcss/postcss/wiki/PostCSS-8-for-end-users">migration guide link</a> to PostCSS 8 error text.</li> </ul> <h2>7.0.34</h2> <ul> <li>Fix compatibility with <code>postcss-scss</code> 2.</li> </ul> <h2>7.0.33</h2> <ul> <li>Add error message for PostCSS 8 plugins.</li> </ul> <h2>7.0.32</h2> <ul> <li>Fix error message (by <a href="https://github.com/admosity"><code>@​admosity</code></a>).</li> </ul> <h2>7.0.31</h2> <ul> <li>Use only the latest source map annotation (by <a href="https://github.com/emzoumpo"><code>@​emzoumpo</code></a>).</li> </ul> <h2>7.0.30</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/nex3"><code>@​nex3</code></a>)</li> </ul> <h2>7.0.29</h2> <ul> <li>Update <code>Processor#version</code>.</li> </ul> <h2>7.0.28</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/nex3"><code>@​nex3</code></a>).</li> </ul> <h2>7.0.27</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/nex3"><code>@​nex3</code></a>).</li> </ul> <h2>7.0.26</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/nex3"><code>@​nex3</code></a>)</li> </ul> <h2>7.0.25</h2> <ul> <li>Fix absolute path support for Windows (by <a href="https://github.com/tomrav"><code>@​tomrav</code></a>)</li> </ul> <h2>7.0.24</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/keithamus"><code>@​keithamus</code></a>).</li> </ul> <h2>7.0.23</h2> <ul> <li>Update <code>Processor#version</code>.</li> </ul> <h2>7.0.22</h2> <ul> <li>Add funding link for <code>npm fund</code>.</li> </ul> <h2>7.0.21</h2> <ul> <li>Revert passing <code>nodes</code> property to node constructor.</li> </ul> <h2>7.0.20</h2> <ul> <li>Allow to pass PostCSS’s nodes in <code>nodes</code> property to node constructor.</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/postcss/postcss/blob/main/CHANGELOG.md">postcss's changelog</a>.</em></p> <blockquote> <h2>7.0.36</h2> <ul> <li>Backport ReDoS vulnerabilities from PostCSS 8.</li> </ul> <h2>7.0.35</h2> <ul> <li>Add migration guide link to PostCSS 8 error text.</li> </ul> <h2>7.0.34</h2> <ul> <li>Fix compatibility with <code>postcss-scss</code> 2.</li> </ul> <h2>7.0.33</h2> <ul> <li>Add error message for PostCSS 8 plugins.</li> </ul> <h2>7.0.36</h2> <ul> <li>Backport ReDoS vulnerabilities from PostCSS 8.</li> </ul> <h2>7.0.35</h2> <ul> <li>Add migration guide link to PostCSS 8 error text.</li> </ul> <h2>7.0.34</h2> <ul> <li>Fix compatibility with <code>postcss-scss</code> 2.</li> </ul> <h2>7.0.33</h2> <ul> <li>Add error message for PostCSS 8 plugins.</li> </ul> <h2>7.0.32</h2> <ul> <li>Fix error message (by <a href="https://github.com/admosity"><code>@​admosity</code></a>).</li> </ul> <h2>7.0.31</h2> <ul> <li>Use only the latest source map annotation (by Emmanouil Zoumpoulakis).</li> </ul> <h2>7.0.30</h2> <ul> <li>Fix TypeScript definition (by Natalie Weizenbaum).</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/postcss/postcss/commit/67e3d7b3402c5d3d036ab7c1e781f86910d6ca72"><code>67e3d7b</code></a> Release 7.0.36 version</li> <li><a href="https://github.com/postcss/postcss/commit/54cbf3c4847eb0fb1501b9d2337465439e849734"><code>54cbf3c</code></a> Backport ReDoS vulnerabilities from PostCSS 8</li> <li><a href="https://github.com/postcss/postcss/commit/12832f3d203474bd273bd06bd3b2407567bfe09e"><code>12832f3</code></a> Release 7.0.35 version</li> <li><a href="https://github.com/postcss/postcss/commit/4455ef6baf84ceea87cb662131f95d798063896c"><code>4455ef6</code></a> Use OpenCollective in funding</li> <li><a href="https://github.com/postcss/postcss/commit/e867c794b5d646839350dd4b76f3cc81423413e6"><code>e867c79</code></a> Add migration guide to PostCSS 8 error</li> <li><a href="https://github.com/postcss/postcss/commit/32a22a98bc4de9c7a2489041ceae24eedc62144f"><code>32a22a9</code></a> Release 7.0.34 version</li> <li><a href="https://github.com/postcss/postcss/commit/22939829688574b9acdbd29106ca2ec9470b2b17"><code>2293982</code></a> Lock build targets</li> <li><a href="https://github.com/postcss/postcss/commit/2c3a111a940b373a60fae196e63931b3b6e9d8ca"><code>2c3a111</code></a> Release 7.0.33 version</li> <li><a href="https://github.com/postcss/postcss/commit/4105f21b48d75847e822e89746633792c478922b"><code>4105f21</code></a> Use yaspeller instead of yaspeller-ci</li> <li><a href="https://github.com/postcss/postcss/commit/c8d02a0da503f9fa5d96a854a2c9244710c18c72"><code>c8d02a0</code></a> Revert yaspeller-ci removal</li> <li>Additional commits viewable in <a href="https://github.com/postcss/postcss/compare/7.0.2...7.0.36">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+50 -14

0 comment

3 changed files

pr created time in 2 hours

issue commentFedML-AI/FedML

Question about FedGKT

I got the same problem using GPUs. Anything wrong? image

Agent2H

comment created time in 6 days

release golang/tools

gopls/v0.7.0

released time in 6 days

startedlampepfl/dotty

started time in 6 days

startedsadarshannaiynar/js-blockchain

started time in 8 days

startedslidevjs/slidev

started time in 8 days

issue commentFedML-AI/FedML

fedml_experiments/distributed/fedavg run_fedavg_distributed_pytorch.sh stuck

anybody encountered this problems?

wangzhenzhou2020

comment created time in 8 days

issue commentFedML-AI/FedML

standalone: main_fedavg.py: error: argument --comm_round: invalid int value: 'hetero'

这个问题我也没碰到。我的服务器是这样的:在CI-install里的九个数据集,有2、3个需要从google下载,我的服务器不能下载这2、3个。但服务器可以使用wandb。 我是这样使用 wandb 的: 1 安装 wandb 2 wandb login (运行它会生成链接,取得api_keys,然后复制粘贴,回车,就登陆了。前提是你有wandb的账户) 3 wandb init(...) 4 wandb log(...) 第3、4 步 看官网教程,或者百度、知乎学习吧。

liyang-good

comment created time in 8 days

issue commentFedML-AI/FedML

standalone: main_fedavg.py: error: argument --comm_round: invalid int value: 'hetero'

你好, 1,上次有位朋友,看他的文件,我修改了参数,可以跑。

  1. 运行这个命令,我现在会遇到这种问题,wandb这个不知怎么设置了,需要连接外网吗?谢谢。

发件人: wangzhenzhou2020 发送时间: 2021年6月7日 10:17 收件人: FedML-AI/FedML 抄送: liyang-good; Author 主题: Re: [FedML-AI/FedML] standalone: main_fedavg.py: error: argument--comm_round: invalid int value: 'hetero' (#124)

我没遇到这个问题耶。命令和你一样。 — You are receiving this because you authored the thread. Reply to this email directly, view it on GitHub, or unsubscribe.

liyang-good

comment created time in 8 days

issue openedFedML-AI/FedML

fedml_experiments/distributed/fedavg run_fedavg_distributed_pytorch.sh stuck

find the problem, for every worker(process): image

eventually, it stucks at: image

created time in 9 days

issue commentFedML-AI/FedML

standalone: main_fedavg.py: error: argument --comm_round: invalid int value: 'hetero'

我没遇到这个问题耶。命令和你一样。

liyang-good

comment created time in 9 days

PR opened FedML-AI/FedML

Bump urllib3 from 1.25.9 to 1.26.5

Bumps urllib3 from 1.25.9 to 1.26.5. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/releases">urllib3's releases</a>.</em></p> <blockquote> <h2>1.26.5</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed deprecation warnings emitted in Python 3.10.</li> <li>Updated vendored <code>six</code> library to 1.16.0.</li> <li>Improved performance of URL parser when splitting the authority component.</li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.4</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Changed behavior of the default <code>SSLContext</code> when connecting to HTTPS proxy during HTTPS requests. The default <code>SSLContext</code> now sets <code>check_hostname=True</code>.</li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.3</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li> <p>Fixed bytes and string comparison issue with headers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2141">#2141</a>)</p> </li> <li> <p>Changed <code>ProxySchemeUnknown</code> error message to be more actionable if the user supplies a proxy URL without a scheme (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2107">#2107</a>)</p> </li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.2</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed an issue where <code>wrap_socket</code> and <code>CERT_REQUIRED</code> wouldn't be imported properly on Python 2.7.8 and earlier (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2052">#2052</a>)</li> </ul> <h2>1.26.1</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed an issue where two <code>User-Agent</code> headers would be sent if a <code>User-Agent</code> header key is passed as <code>bytes</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2047">#2047</a>)</li> </ul> <h2>1.26.0</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li> <p>Added support for HTTPS proxies contacting HTTPS servers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1923">#1923</a>, Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1806">#1806</a>)</p> </li> <li> <p>Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning should opt-in explicitly by setting <code>ssl_version=ssl.PROTOCOL_TLSv1_1</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2002">#2002</a>) <strong>Starting in urllib3 v2.0: Connections that receive a <code>DeprecationWarning</code> will fail</strong></p> </li> <li> <p>Deprecated <code>Retry</code> options <code>Retry.DEFAULT_METHOD_WHITELIST</code>, <code>Retry.DEFAULT_REDIRECT_HEADERS_BLACKLIST</code> and <code>Retry(method_whitelist=...)</code> in favor of <code>Retry.DEFAULT_ALLOWED_METHODS</code>, <code>Retry.DEFAULT_REMOVE_HEADERS_ON_REDIRECT</code>, and <code>Retry(allowed_methods=...)</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2000">#2000</a>) <strong>Starting in urllib3 v2.0: Deprecated options will be removed</strong></p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/blob/main/CHANGES.rst">urllib3's changelog</a>.</em></p> <blockquote> <h2>1.26.5 (2021-05-26)</h2> <ul> <li>Fixed deprecation warnings emitted in Python 3.10.</li> <li>Updated vendored <code>six</code> library to 1.16.0.</li> <li>Improved performance of URL parser when splitting the authority component.</li> </ul> <h2>1.26.4 (2021-03-15)</h2> <ul> <li>Changed behavior of the default <code>SSLContext</code> when connecting to HTTPS proxy during HTTPS requests. The default <code>SSLContext</code> now sets <code>check_hostname=True</code>.</li> </ul> <h2>1.26.3 (2021-01-26)</h2> <ul> <li> <p>Fixed bytes and string comparison issue with headers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2141">#2141</a>)</p> </li> <li> <p>Changed <code>ProxySchemeUnknown</code> error message to be more actionable if the user supplies a proxy URL without a scheme. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2107">#2107</a>)</p> </li> </ul> <h2>1.26.2 (2020-11-12)</h2> <ul> <li>Fixed an issue where <code>wrap_socket</code> and <code>CERT_REQUIRED</code> wouldn't be imported properly on Python 2.7.8 and earlier (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2052">#2052</a>)</li> </ul> <h2>1.26.1 (2020-11-11)</h2> <ul> <li>Fixed an issue where two <code>User-Agent</code> headers would be sent if a <code>User-Agent</code> header key is passed as <code>bytes</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2047">#2047</a>)</li> </ul> <h2>1.26.0 (2020-11-10)</h2> <ul> <li> <p><strong>NOTE: urllib3 v2.0 will drop support for Python 2</strong>. <code>Read more in the v2.0 Roadmap <https://urllib3.readthedocs.io/en/latest/v2-roadmap.html></code>_.</p> </li> <li> <p>Added support for HTTPS proxies contacting HTTPS servers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1923">#1923</a>, Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1806">#1806</a>)</p> </li> <li> <p>Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning</p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/urllib3/urllib3/commit/d1616473df94b94f0f5ad19d2a6608cfe93b7cdf"><code>d161647</code></a> Release 1.26.5</li> <li><a href="https://github.com/urllib3/urllib3/commit/2d4a3fee6de2fa45eb82169361918f759269b4ec"><code>2d4a3fe</code></a> Improve performance of sub-authority splitting in URL</li> <li><a href="https://github.com/urllib3/urllib3/commit/2698537d52f8ff1f0bbb1d45cf018b118e91f637"><code>2698537</code></a> Update vendored six to 1.16.0</li> <li><a href="https://github.com/urllib3/urllib3/commit/07bed791e9c391d8bf12950f76537dc3c6f90550"><code>07bed79</code></a> Fix deprecation warnings for Python 3.10 ssl module</li> <li><a href="https://github.com/urllib3/urllib3/commit/d725a9b56bb8baf87c9e6eee0e9edf010034b63b"><code>d725a9b</code></a> Add Python 3.10 to GitHub Actions</li> <li><a href="https://github.com/urllib3/urllib3/commit/339ad34c677c98fd9ad008de1d8bbeb9dbf34381"><code>339ad34</code></a> Use pytest==6.2.4 on Python 3.10+</li> <li><a href="https://github.com/urllib3/urllib3/commit/f271c9c3149e20d7feffb6429b135bbb6c09ddf4"><code>f271c9c</code></a> Apply latest Black formatting</li> <li><a href="https://github.com/urllib3/urllib3/commit/1884878aac87ef0494b282e940c32c24ee917d52"><code>1884878</code></a> [1.26] Properly proxy EOF on the SSLTransport test suite</li> <li><a href="https://github.com/urllib3/urllib3/commit/a8913042b676c510e94fc2b097f6b514ae11a537"><code>a891304</code></a> Release 1.26.4</li> <li><a href="https://github.com/urllib3/urllib3/commit/8d65ea1ecf6e2cdc27d42124e587c1b83a3118b0"><code>8d65ea1</code></a> Merge pull request from GHSA-5phf-pp7p-vc2r</li> <li>Additional commits viewable in <a href="https://github.com/urllib3/urllib3/compare/1.25.9...1.26.5">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

pr created time in 14 days

create barnchFedML-AI/FedML

branch : dependabot/pip/urllib3-1.26.5

created branch time in 14 days

PR opened aru-jo/corona-dash

Bump urllib3 from 1.25.8 to 1.26.5

Bumps urllib3 from 1.25.8 to 1.26.5. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/releases">urllib3's releases</a>.</em></p> <blockquote> <h2>1.26.5</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed deprecation warnings emitted in Python 3.10.</li> <li>Updated vendored <code>six</code> library to 1.16.0.</li> <li>Improved performance of URL parser when splitting the authority component.</li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.4</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Changed behavior of the default <code>SSLContext</code> when connecting to HTTPS proxy during HTTPS requests. The default <code>SSLContext</code> now sets <code>check_hostname=True</code>.</li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.3</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li> <p>Fixed bytes and string comparison issue with headers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2141">#2141</a>)</p> </li> <li> <p>Changed <code>ProxySchemeUnknown</code> error message to be more actionable if the user supplies a proxy URL without a scheme (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2107">#2107</a>)</p> </li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.2</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed an issue where <code>wrap_socket</code> and <code>CERT_REQUIRED</code> wouldn't be imported properly on Python 2.7.8 and earlier (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2052">#2052</a>)</li> </ul> <h2>1.26.1</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed an issue where two <code>User-Agent</code> headers would be sent if a <code>User-Agent</code> header key is passed as <code>bytes</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2047">#2047</a>)</li> </ul> <h2>1.26.0</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li> <p>Added support for HTTPS proxies contacting HTTPS servers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1923">#1923</a>, Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1806">#1806</a>)</p> </li> <li> <p>Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning should opt-in explicitly by setting <code>ssl_version=ssl.PROTOCOL_TLSv1_1</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2002">#2002</a>) <strong>Starting in urllib3 v2.0: Connections that receive a <code>DeprecationWarning</code> will fail</strong></p> </li> <li> <p>Deprecated <code>Retry</code> options <code>Retry.DEFAULT_METHOD_WHITELIST</code>, <code>Retry.DEFAULT_REDIRECT_HEADERS_BLACKLIST</code> and <code>Retry(method_whitelist=...)</code> in favor of <code>Retry.DEFAULT_ALLOWED_METHODS</code>, <code>Retry.DEFAULT_REMOVE_HEADERS_ON_REDIRECT</code>, and <code>Retry(allowed_methods=...)</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2000">#2000</a>) <strong>Starting in urllib3 v2.0: Deprecated options will be removed</strong></p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/blob/main/CHANGES.rst">urllib3's changelog</a>.</em></p> <blockquote> <h2>1.26.5 (2021-05-26)</h2> <ul> <li>Fixed deprecation warnings emitted in Python 3.10.</li> <li>Updated vendored <code>six</code> library to 1.16.0.</li> <li>Improved performance of URL parser when splitting the authority component.</li> </ul> <h2>1.26.4 (2021-03-15)</h2> <ul> <li>Changed behavior of the default <code>SSLContext</code> when connecting to HTTPS proxy during HTTPS requests. The default <code>SSLContext</code> now sets <code>check_hostname=True</code>.</li> </ul> <h2>1.26.3 (2021-01-26)</h2> <ul> <li> <p>Fixed bytes and string comparison issue with headers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2141">#2141</a>)</p> </li> <li> <p>Changed <code>ProxySchemeUnknown</code> error message to be more actionable if the user supplies a proxy URL without a scheme. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2107">#2107</a>)</p> </li> </ul> <h2>1.26.2 (2020-11-12)</h2> <ul> <li>Fixed an issue where <code>wrap_socket</code> and <code>CERT_REQUIRED</code> wouldn't be imported properly on Python 2.7.8 and earlier (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2052">#2052</a>)</li> </ul> <h2>1.26.1 (2020-11-11)</h2> <ul> <li>Fixed an issue where two <code>User-Agent</code> headers would be sent if a <code>User-Agent</code> header key is passed as <code>bytes</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2047">#2047</a>)</li> </ul> <h2>1.26.0 (2020-11-10)</h2> <ul> <li> <p><strong>NOTE: urllib3 v2.0 will drop support for Python 2</strong>. <code>Read more in the v2.0 Roadmap <https://urllib3.readthedocs.io/en/latest/v2-roadmap.html></code>_.</p> </li> <li> <p>Added support for HTTPS proxies contacting HTTPS servers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1923">#1923</a>, Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1806">#1806</a>)</p> </li> <li> <p>Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning</p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/urllib3/urllib3/commit/d1616473df94b94f0f5ad19d2a6608cfe93b7cdf"><code>d161647</code></a> Release 1.26.5</li> <li><a href="https://github.com/urllib3/urllib3/commit/2d4a3fee6de2fa45eb82169361918f759269b4ec"><code>2d4a3fe</code></a> Improve performance of sub-authority splitting in URL</li> <li><a href="https://github.com/urllib3/urllib3/commit/2698537d52f8ff1f0bbb1d45cf018b118e91f637"><code>2698537</code></a> Update vendored six to 1.16.0</li> <li><a href="https://github.com/urllib3/urllib3/commit/07bed791e9c391d8bf12950f76537dc3c6f90550"><code>07bed79</code></a> Fix deprecation warnings for Python 3.10 ssl module</li> <li><a href="https://github.com/urllib3/urllib3/commit/d725a9b56bb8baf87c9e6eee0e9edf010034b63b"><code>d725a9b</code></a> Add Python 3.10 to GitHub Actions</li> <li><a href="https://github.com/urllib3/urllib3/commit/339ad34c677c98fd9ad008de1d8bbeb9dbf34381"><code>339ad34</code></a> Use pytest==6.2.4 on Python 3.10+</li> <li><a href="https://github.com/urllib3/urllib3/commit/f271c9c3149e20d7feffb6429b135bbb6c09ddf4"><code>f271c9c</code></a> Apply latest Black formatting</li> <li><a href="https://github.com/urllib3/urllib3/commit/1884878aac87ef0494b282e940c32c24ee917d52"><code>1884878</code></a> [1.26] Properly proxy EOF on the SSLTransport test suite</li> <li><a href="https://github.com/urllib3/urllib3/commit/a8913042b676c510e94fc2b097f6b514ae11a537"><code>a891304</code></a> Release 1.26.4</li> <li><a href="https://github.com/urllib3/urllib3/commit/8d65ea1ecf6e2cdc27d42124e587c1b83a3118b0"><code>8d65ea1</code></a> Merge pull request from GHSA-5phf-pp7p-vc2r</li> <li>Additional commits viewable in <a href="https://github.com/urllib3/urllib3/compare/1.25.8...1.26.5">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

pr created time in 14 days

create barncharu-jo/corona-dash

branch : dependabot/pip/urllib3-1.26.5

created branch time in 14 days

PR opened sadarshannaiynar/electron-typescript-react-redux-boilerplate

Bump dns-packet from 1.3.1 to 1.3.4

Bumps dns-packet from 1.3.1 to 1.3.4. <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/mafintosh/dns-packet/commit/ebdf849da5dc0d96836e87628349776c623c5be7"><code>ebdf849</code></a> 1.3.4</li> <li><a href="https://github.com/mafintosh/dns-packet/commit/ac578722f2707310b841b65aae61d6332f8882a1"><code>ac57872</code></a> move all allocUnsafes to allocs for easier maintenance</li> <li><a href="https://github.com/mafintosh/dns-packet/commit/c64c9507e51532c9e9a3cbefa146a134ecc025fd"><code>c64c950</code></a> 1.3.3</li> <li><a href="https://github.com/mafintosh/dns-packet/commit/0598ba19d18da4568b32415e60a9629061b3c45c"><code>0598ba1</code></a> fix .. in encodingLength</li> <li><a href="https://github.com/mafintosh/dns-packet/commit/010aedb33c1ee8c3f558db5249c1d46e2bd7a101"><code>010aedb</code></a> 1.3.2</li> <li><a href="https://github.com/mafintosh/dns-packet/commit/0d0d593f8df4e2712c43957a6c62e95047f12b2d"><code>0d0d593</code></a> backport encodingLength fix to v1</li> <li>See full diff in <a href="https://github.com/mafintosh/dns-packet/compare/v1.3.1...v1.3.4">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+10 -6

0 comment

2 changed files

pr created time in 20 days

issue openedFedML-AI/FedML

standalone: main_fedavg.py: error: argument --comm_round: invalid int value: 'hetero'

I want to test run_fedavg_standalone_pytorch.sh, however, print : invalid int value: 'hetero'

hetero 代表什么,我可以去哪个文件夹查看这个参数的含义? thanks

![image](https://user-images.githubusercontent.com/71406269/119598820-3dc7e300-be16-11eb-959c-7ee8158caee9.png

created time in 21 days

created repositoryjrsam/practice

created time in 23 days

issue commentFedML-AI/FedML

FedAvg accuracy stucks under 50

Hello everyone!

I have also encountered similar issues with FedAvg (distributed). I conducted some experiments with ResNet56 on CIFAR100 non-IID and found the following. I checked-out the branch from the benchmark wandb run here. On 8 RTX2080ti GPUs, I was able to reproduce the results almost exactly (I got 64.56% and the benchmark reports 64.7%) (see here for all my results I will mention in this post). In the current FedML master (as of May 15th, 2021 when I cloned it), I was getting much lower accuracy. I looked for differences between these branches and noticed 3 things:

  1. There is a grad clip in the current version (as others have previously mentioned) [code], but not in the old version.
  2. model.zero_grad() [code] is used versus optimizer.zero_grad() in the old version.
  3. Weight decay is 0.001 [code, and here] in the new version by default but is hard-coded in the old version to 0.0001 for Adam.

Notice that although (1) and (2) are from the standalone API files, the standalone classification trainer is used in the current version for the distributed code also [import seen here]. It appears they were merged sometime a while back. Making these changes I was able to get decent results on both 4 and 8 GPUs (about 1% lower than the old code in both cases). I’m not sure if (2) actually made much difference but I didn't test it fully in isolation. (1) and (3) definitely make a difference though. . I also looked into reproducing the FedAvg results reported in the FedGKT paper (this was my primary interest to begin with). These use 16 clients rather than 10 and 200 rounds rather than 100. With the original benchmark FedAvg code, I reproduced the results closely (reported 63.78% and I got 64.23%). However, in the current code with my modifications, I was still 2% lower (~62%). There still must be some differences, but since the time of the original benchmark code, it appears many changes in the underlying code have been made. I have not been able to determine the exact cause of the last 1-2% discrepancy. Has anyone found other potential causes for this 1-2% difference?

AbdulMoqeet

comment created time in 25 days

startedqoomon/docker-host

started time in a month

issue openedFedML-AI/FedML

Arguments and environment variables are not mapped correctly

As mapping is not done correctly i have to either hard code args or supply differently. https://github.com/FedML-AI/FedML/blob/400072ef5daa9a9ca0f205ff3a90ccf13f975729/fedml_experiments/centralized/run_single.sh#L1

created time in a month

issue openedFedML-AI/FedML

shell script has some issue at line 13 during installation

https://github.com/FedML-AI/FedML/blob/400072ef5daa9a9ca0f205ff3a90ccf13f975729/CI-install.sh#L13

created time in a month