profile
viewpoint

postmodern/chruby 2382

Changes the current Ruby

postmodern/chgems 90

DEPRECATED: use gem_home instead!

postmodern/digest-crc 72

A Cyclic Redundancy Check (CRC) library for Ruby.

postmodern/deployml 58

DeploYML is a simple deployment solution that uses a single YAML file.

postmodern/combinatorics 37

Bringing (more) Combinatorics to Ruby.

postmodern/cparser 21

A pure Ruby ANSI C Parser.

postmodern/dm-chunked_query 12

Allows performing chunked queries with DataMapper.

postmodern/dm-is-authenticatable 12

A DataMapper plugin for adding authentication and encrypted passwords to your DataMapper models.

postmodern/chars 6

A Ruby library for working with various character sets, recognizing text and generating random text from specific character sets.

postmodern/dm-is-counter_cacheable 5

A DataMapper plugin for adding counter-cache properties to related models.

fork cooperq/pe-static

Static file analysis for PE files

fork in an hour

fork kdcloverkid/ruby-install

Installs Ruby, JRuby, Rubinius, TruffleRuby or MRuby

fork in 7 hours

startedpostmodern/ruby-install

started time in 8 hours

startedpostmodern/chruby

started time in 18 hours

startedpostmodern/chruby

started time in a day

issue closedrubysec/ruby-advisory-db

Recent Ruby CVEs are missing severity - is that intentional?

Hey, I noticed that many of the recent Ruby related CVEs are missing severity. Is that intentional or can I fix this?

closed time in a day

mensfeld

startedchangkun/modern-cpp-tutorial

started time in a day

startedpostmodern/digest-crc

started time in a day

issue openedpostmodern/digest-crc

Why there is a strict `rake '~>13.0'` requirement in gemspec?

Hello,

I would like to ask why there is a strict version requirement in gemspec of 0.6.1 version.

It currently breaks existing systems where the original Gemfile does not have a specific rake dependency defined.

Default rake that exists in ruby installations has version 12 for ruby versions 2.6 and a few earlier ones. With digest-crc gemspec change, calling rake directly has started to fail saying we should run with bundle exec rake.

In short, is it possible to have a wider range of supported rake versions there?

Thanks

created time in a day

startedpostmodern/chruby

started time in 2 days

startedr0t0tiller/Exploits

started time in 2 days

startedlibbpf/libbpf-bootstrap

started time in 2 days

pull request commentrubysec/bundler-audit

#218 Add the ability to use dot config file to control the ignore list

Any chance we could add some documentation to this feature for the format of the file?

jebentier

comment created time in 2 days

pull request commentrubysec/bundler-audit

Adds the '--lockfile' option to 'bundle-audit check' command

👋 @reedloden

mariozaizar

comment created time in 2 days

startedpostmodern/spidr

started time in 2 days

fork tduehr/OctoPrint-PrintJobHistory

OctoPrint Plugin stores all print-job informations of a print in a database

fork in 4 days

issue commentpostmodern/ffi-hunspell

ffi-hunspell on Windows

Thank you for your help.

Le sam. 28 nov. 2020 à 17:51, Postmodern notifications@github.com a écrit :

I don't have much experience running Ruby on Windows. You might consider trying Windows Linux SubSystem (WLS) or running in a Linux VM with VMWare Player.

— You are receiving this because you authored the thread. Reply to this email directly, view it on GitHub https://github.com/postmodern/ffi-hunspell/issues/28#issuecomment-735255187, or unsubscribe https://github.com/notifications/unsubscribe-auth/ACN2DT24U5UYE633TTWLQMLSSETCZANCNFSM4UFH5X4A .

jfaset

comment created time in 4 days

issue commentpostmodern/ffi-hunspell

ffi-hunspell on Windows

Thank you very much for your answer.

I tried to add hunspellx64 from https://www.trichview.com/help-actions/hunspell.htm to C:\Ruby27-x64\lib\ruby\gems\2.7.0\gems\ffi-hunspell-0.5.0 and C:\Windows\SysWOW64. With the same error C:/Ruby27-x64/lib/ruby/gems/2.7.0/gems/ffi-1.13.1-x64-mingw32/lib/ffi/library.rb:145:in `block in ffi_lib'

I give up. Perhaps I shall try again, one day, with Python. Thanks again.

Le sam. 28 nov. 2020 à 08:40, Postmodern notifications@github.com a écrit :

Did you also install the hunspell DLL?

— You are receiving this because you authored the thread. Reply to this email directly, view it on GitHub https://github.com/postmodern/ffi-hunspell/issues/28#issuecomment-735051745, or unsubscribe https://github.com/notifications/unsubscribe-auth/ACN2DT6YXG4ZK3R7ECCAVILSSCSQBANCNFSM4UFH5X4A .

jfaset

comment created time in 4 days

issue openedpostmodern/ffi-hunspell

ffi-hunspell on Windows

Hello,

On Windows,

gem install ffi-hunspell ... gem install ffi --platform=ruby ... gem install ffi-hunspell

Successfully installed ffi-1.13.1-x64-mingw32

Successfully installed ffi-hunspell-0.5.0

require 'ffi/hunspell'

--> C:/Ruby27-x64/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require': cannot load such file -- ffi/hunspell (LoadError)

...

i_lib': Could not open library 'hunspell-1.7': Le module sp�cifi� est introuvable.\r (LoadError) . Could not open library 'hunspell-1.7.dll': Le module sp�cifi� est introuvable.\r . Could not open library 'libhunspell-1.7.so.0': Le module sp�cifi� est introuvable.\r . Could not open library 'libhunspell-1.7.so.0.dll': Le module sp�cifi� est introuvable.\r . Could not open library 'hunspell-1.6': Le module sp�cifi� est introuvable.\r

....

Could not open library 'libhunspell-1.2.so.0.dll': Le module sp�cifi� est introuvable.\r

===============

Shall I Give up ?

created time in 5 days

startedpostmodern/chruby

started time in 5 days

fork struct/mimalloc-bench

Suite for benchmarking malloc implementations.

fork in 5 days

fork manuyavuz-pointr/digest-crc

A Cyclic Redundancy Check (CRC) library for Ruby.

fork in 5 days

fork pointrlabs/digest-crc

A Cyclic Redundancy Check (CRC) library for Ruby.

fork in 5 days

startedad-m/github-push-action

started time in 6 days

startedCr0n1c/crowdstrike-rtr

started time in 7 days

startedgeohot/qira

started time in 7 days

startedRumbleDiscovery/jarm-go

started time in 8 days

startedpostmodern/hexdump

started time in 10 days

startedpostmodern/chruby

started time in 10 days

fork etiennebarrie/chruby

Changes the current Ruby

fork in 10 days

more