profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/ovhemert/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
Osmond van Hemert ovhemert @NearForm The Netherlands https://ovhemert.dev Software Architect / Engineer / Open Source Geek - #nodejs, #kubernetes, etc

gatsbyjs/gatsby 50990

Build blazing fast, modern apps and websites with React

ovhemert/gatsby-plugin-brotli 23

Gatsby plugin for preparing brotli-compressed versions of assets

ovhemert/gatsby-plugin-zopfli 11

Gatsby plugin for preparing zopfli-compressed versions of assets

ovhemert/gatsby-plugin-sri 10

Gatsby plugin for enabling Sub Resource Integrity

ovhemert/elasticsearch-batch-stream 5

A write stream that creates batches of elasticsearch bulk operations

ovhemert/aedes-persistence-nedb 4

NeDB persistence for Aedes

ovhemert/batch2 3

A transform stream that collects chunks and passes them on as batches.

ovhemert/gatsby-plugin-iltorb 2

Gatsby plugin for preparing brotli-compressed versions of assets using iltorb native bindings

ovhemert/ci-status 1

Displays the build status of projects on a continuous integration server.

delete branch ovhemert/ci-status

delete branch : snyk-upgrade-4124dcced6d18385f650f7b923326fef

delete time in 8 hours

PR merged ovhemert/ci-status

[Snyk] Upgrade aws-sdk from 2.951.0 to 2.959.0

<h3>Snyk has created this PR to upgrade aws-sdk from 2.951.0 to 2.959.0.</h3>

merge advice :information_source: Keep your dependencies up-to-date. This makes it easier to fix existing vulnerabilities and to more quickly identify and fix newly disclosed vulnerabilities when they affect your project. <hr/>

  • The recommended version is 8 versions ahead of your current version.
  • The recommended version was released 2 days ago, on 2021-08-02.

<details> <summary><b>Release notes</b></summary> <br/> <details> <summary>Package name: <b>aws-sdk</b></summary> <ul> <li> <b>2.959.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.959.0">2021-08-02</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.958.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.958.0">2021-07-30</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.957.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.957.0">2021-07-29</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.956.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.956.0">2021-07-28</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.955.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.955.0">2021-07-27</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.954.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.954.0">2021-07-26</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.953.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.953.0">2021-07-23</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.952.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.952.0">2021-07-22</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.951.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.951.0">2021-07-21</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> </ul> from <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases">aws-sdk GitHub release notes</a> </details> </details>

<details> <summary><b>Commit messages</b></summary> </br> <details> <summary>Package name: <b>aws-sdk</b></summary> <ul> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/f0d9e0325210beb3a45b87345db975a8eafa304c">f0d9e03</a> Updates SDK to v2.959.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/abdb1d1419e1cd8e60129f648b6095ce88b5c9ea">abdb1d1</a> Updates SDK to v2.958.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/e9371bb4ea0671b8034cef08fcdd69bf434d7a03">e9371bb</a> Updates SDK to v2.957.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/002f0fb06bdf68f769fa022fa6e4044208aa0333">002f0fb</a> Updates SDK to v2.956.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/f9061deee197685971c72017ff9e82b0112da13a">f9061de</a> Updates SDK to v2.955.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/d91ac91125702036d5ad671c538f365abd7c4e10">d91ac91</a> Updates SDK to v2.954.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/4f98fe58659aa77e78765d68264ca536fb273dd7">4f98fe5</a> Updates SDK to v2.953.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/719dd1a3835027dd41bf9209d7bfe42dda05a371">719dd1a</a> Updates SDK to v2.952.0</li> </ul>

<a href="https://snyk.io/redirect/github/aws/aws-sdk-js/compare/d511c633ad4d727bc49f27a57d0a21b435227c67...f0d9e0325210beb3a45b87345db975a8eafa304c">Compare</a> </details> </details> <hr/>

Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open upgrade PRs.

For more information: <img src="https://api.segment.io/v1/pixel/track?data=eyJ3cml0ZUtleSI6InJyWmxZcEdHY2RyTHZsb0lYd0dUcVg4WkFRTnNCOUEwIiwiYW5vbnltb3VzSWQiOiI3NWM5ZTU2MC1jZjZiLTQxOGUtOTc0Ni04Y2UyMDhjY2JiYTIiLCJldmVudCI6IlBSIHZpZXdlZCIsInByb3BlcnRpZXMiOnsicHJJZCI6Ijc1YzllNTYwLWNmNmItNDE4ZS05NzQ2LThjZTIwOGNjYmJhMiJ9fQ==" width="0" height="0"/>

🧐 View latest project report

🛠 Adjust upgrade PR settings

🔕 Ignore this dependency or unsubscribe from future upgrade PRs

<!--- (snyk:metadata:{"prId":"75c9e560-cf6b-418e-9746-8ce208ccbba2","prPublicId":"75c9e560-cf6b-418e-9746-8ce208ccbba2","dependencies":[{"name":"aws-sdk","from":"2.951.0","to":"2.959.0"}],"packageManager":"npm","type":"auto","projectUrl":"https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr","projectPublicId":"bffe9710-d95c-4887-a784-74285d2dfc83","env":"prod","prType":"upgrade","vulns":[],"issuesToFix":[],"upgrade":[],"upgradeInfo":{"versionsDiff":8,"publishedDate":"2021-08-02T18:23:02.730Z"},"templateVariants":["merge-advice-badge-shown"],"hasFixes":false,"isMajorUpgrade":false,"isBreakingChange":false,"priorityScoreList":[]}) --->

+4 -4

1 comment

2 changed files

snyk-bot

pr closed time in 8 hours

push eventovhemert/ci-status

snyk-bot

commit sha 28e12b3a0e846ac346efd4f21c9d0b098abc1d4b

fix: upgrade aws-sdk from 2.951.0 to 2.959.0 Snyk has created this PR to upgrade aws-sdk from 2.951.0 to 2.959.0. See this package in npm: https://www.npmjs.com/package/aws-sdk See this project in Snyk: https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr

view details

Osmond van Hemert

commit sha 6a187e005ed03c6def042793764f43cc20d54c69

Merge pull request #77 from ovhemert/snyk-upgrade-4124dcced6d18385f650f7b923326fef [Snyk] Upgrade aws-sdk from 2.951.0 to 2.959.0

view details

push time in 8 hours

push eventovhemert/ci-status

snyk-bot

commit sha 28e12b3a0e846ac346efd4f21c9d0b098abc1d4b

fix: upgrade aws-sdk from 2.951.0 to 2.959.0 Snyk has created this PR to upgrade aws-sdk from 2.951.0 to 2.959.0. See this package in npm: https://www.npmjs.com/package/aws-sdk See this project in Snyk: https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr

view details

push time in 2 days

delete branch ovhemert/ci-status

delete branch : snyk-upgrade-00bcb2c0d6c013cef5d6245b4e63c96a

delete time in 3 days

push eventovhemert/ci-status

snyk-bot

commit sha f5960ad6b36f0be2f0fb99d4dd6cf75b4ce94715

fix: upgrade aws-sdk from 2.950.0 to 2.951.0 Snyk has created this PR to upgrade aws-sdk from 2.950.0 to 2.951.0. See this package in npm: https://www.npmjs.com/package/aws-sdk See this project in Snyk: https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr

view details

Osmond van Hemert

commit sha f66770573fca3c945708240e261109463b1ffc96

Merge pull request #75 from ovhemert/snyk-upgrade-00bcb2c0d6c013cef5d6245b4e63c96a [Snyk] Upgrade aws-sdk from 2.950.0 to 2.951.0

view details

push time in 3 days

PR merged ovhemert/ci-status

[Snyk] Upgrade aws-sdk from 2.950.0 to 2.951.0

<h3>Snyk has created this PR to upgrade aws-sdk from 2.950.0 to 2.951.0.</h3>

merge advice :information_source: Keep your dependencies up-to-date. This makes it easier to fix existing vulnerabilities and to more quickly identify and fix newly disclosed vulnerabilities when they affect your project. <hr/>

  • The recommended version is 1 version ahead of your current version.
  • The recommended version was released a day ago, on 2021-07-21.

<details> <summary><b>Release notes</b></summary> <br/> <details> <summary>Package name: <b>aws-sdk</b></summary> <ul> <li> <b>2.951.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.951.0">2021-07-21</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.950.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.950.0">2021-07-20</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> </ul> from <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases">aws-sdk GitHub release notes</a> </details> </details>

<details> <summary><b>Commit messages</b></summary> </br> <details> <summary>Package name: <b>aws-sdk</b></summary> <ul> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/d511c633ad4d727bc49f27a57d0a21b435227c67">d511c63</a> Updates SDK to v2.951.0</li> </ul>

<a href="https://snyk.io/redirect/github/aws/aws-sdk-js/compare/7f49c821196d5aa6e69a94cfd2d965adbe2025a7...d511c633ad4d727bc49f27a57d0a21b435227c67">Compare</a> </details> </details> <hr/>

Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open upgrade PRs.

For more information: <img src="https://api.segment.io/v1/pixel/track?data=eyJ3cml0ZUtleSI6InJyWmxZcEdHY2RyTHZsb0lYd0dUcVg4WkFRTnNCOUEwIiwiYW5vbnltb3VzSWQiOiJhYzZjNWU2Yi1mMzJkLTQ4MDQtYmEwNS0yM2ZiODUyNzRjYTMiLCJldmVudCI6IlBSIHZpZXdlZCIsInByb3BlcnRpZXMiOnsicHJJZCI6ImFjNmM1ZTZiLWYzMmQtNDgwNC1iYTA1LTIzZmI4NTI3NGNhMyJ9fQ==" width="0" height="0"/>

🧐 View latest project report

🛠 Adjust upgrade PR settings

🔕 Ignore this dependency or unsubscribe from future upgrade PRs

<!--- (snyk:metadata:{"prId":"ac6c5e6b-f32d-4804-ba05-23fb85274ca3","prPublicId":"ac6c5e6b-f32d-4804-ba05-23fb85274ca3","dependencies":[{"name":"aws-sdk","from":"2.950.0","to":"2.951.0"}],"packageManager":"npm","type":"auto","projectUrl":"https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr","projectPublicId":"bffe9710-d95c-4887-a784-74285d2dfc83","env":"prod","prType":"upgrade","vulns":[],"issuesToFix":[],"upgrade":[],"upgradeInfo":{"versionsDiff":1,"publishedDate":"2021-07-21T18:23:43.250Z"},"templateVariants":["merge-advice-badge-shown"],"hasFixes":false,"isMajorUpgrade":false,"isBreakingChange":false,"priorityScoreList":[]}) --->

+4 -4

1 comment

2 changed files

snyk-bot

pr closed time in 3 days

push eventovhemert/pino-stackdriver

Snyk bot

commit sha 335474d8af8c8348ce0e22941a97a0e15df8f8bc

fix: upgrade commander from 8.0.0 to 8.1.0 (#105) Snyk has created this PR to upgrade commander from 8.0.0 to 8.1.0. See this package in npm: https://www.npmjs.com/package/commander See this project in Snyk: https://app.snyk.io/org/ovhemert/project/9d2d2e62-16f0-494d-92ca-0a46d8e428d4?utm_source=github&utm_medium=upgrade-pr

view details

push time in 3 days

PR merged ovhemert/pino-stackdriver

[Snyk] Upgrade commander from 8.0.0 to 8.1.0

<h3>Snyk has created this PR to upgrade commander from 8.0.0 to 8.1.0.</h3>

merge advice :information_source: Keep your dependencies up-to-date. This makes it easier to fix existing vulnerabilities and to more quickly identify and fix newly disclosed vulnerabilities when they affect your project. <hr/>

  • The recommended version is 1 version ahead of your current version.
  • The recommended version was released a day ago, on 2021-07-27.

<details> <summary><b>Release notes</b></summary> <br/> <details> <summary>Package name: <b>commander</b></summary> <ul> <li> <b>8.1.0</b> - <a href="https://snyk.io/redirect/github/tj/commander.js/releases/tag/v8.1.0">2021-07-27</a></br><h3>Added</h3> <ul> <li><code>.copyInheritedSettings()</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="936173206" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1557" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1557/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1557">#1557</a>)</li> <li>update Chinese translations for Commander v8 (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="946780119" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1570" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1570/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1570">#1570</a>)</li> <li><code>Argument</code> methods for <code>.argRequired()</code> and <code>.argOptional()</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="941412397" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1567" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1567/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1567">#1567</a>)</li> </ul> </li> <li> <b>8.0.0</b> - <a href="https://snyk.io/redirect/github/tj/commander.js/releases/tag/v8.0.0">2021-06-25</a></br><h3>Added</h3> <ul> <li><code>.argument(name, description)</code> for adding command-arguments (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="842430318" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1490" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1490/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1490">#1490</a>) <ul> <li>supports default value for optional command-arguments (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="863545723" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1508" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1508/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1508">#1508</a>)</li> <li>supports custom processing function (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="863545723" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1508" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1508/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1508">#1508</a>)</li> </ul> </li> <li><code>.createArgument()</code> factory method (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="852086846" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1497" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1497/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1497">#1497</a>)</li> <li><code>.addArgument()</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="842430318" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1490" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1490/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1490">#1490</a>)</li> <li><code>Argument</code> supports <code>.choices()</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="898597490" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1525" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1525/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1525">#1525</a>)</li> <li><code>.showHelpAfterError()</code> to display full help or a custom message after an error (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="906295321" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1534" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1534/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1534">#1534</a>)</li> <li><code>.hook()</code> with support for <code>'preAction'</code> and <code>'postAction'</code> callbacks (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="878602030" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1514" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1514/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1514">#1514</a>)</li> <li>client typing of <code>.opts()</code> return type using TypeScript generics (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="906628226" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1539" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1539/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1539">#1539</a>)</li> <li>the number of command-arguments is checked for programs without an action handler (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="855173074" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1502" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1502/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1502">#1502</a>)</li> <li><code>.getOptionValue()</code> and <code>.setOptionValue()</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="892607631" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1521" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1521/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1521">#1521</a>)</li> </ul> <h3>Changed</h3> <ul> <li>refactor and simplify TypeScript declarations (with no default export) (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="892364739" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1520" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1520/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1520">#1520</a>)</li> <li><code>.parseAsync()</code> is now declared as <code>async</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="876319942" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1513" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1513/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1513">#1513</a>)</li> <li><em>Breaking:</em> <code>Help</code> method <code>.visibleArguments()</code> returns array of <code>Argument</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="842430318" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1490" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1490/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1490">#1490</a>)</li> <li><em>Breaking:</em> Commander 8 requires Node.js 12 or higher (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="854969905" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1500" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1500/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1500">#1500</a>)</li> <li><em>Breaking:</em> <code>CommanderError</code> code <code>commander.invalidOptionArgument</code> renamed <code>commander.invalidArgument</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="863545723" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1508" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1508/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1508">#1508</a>)</li> <li><em>Breaking:</em> TypeScript declaration for <code>.addTextHelp()</code> callback no longer allows result of <code>undefined</code>, now just <code>string</code> (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="881415466" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1516" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1516/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1516">#1516</a>)</li> <li>refactor <code>index.tab</code> into a file per class (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="894168942" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1522" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1522/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1522">#1522</a>)</li> <li>remove help suggestion from "unknown command" error message (see <code>.showHelpAfteError()</code>) (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="906295321" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1534" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1534/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1534">#1534</a>)</li> <li><code>Command</code> property <code>.arg</code> initialised to empty array (was previously undefined) (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="900362310" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1529" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1529/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1529">#1529</a>)</li> <li>update dependencies</li> </ul> <h3>Deprecated</h3> <ul> <li>second parameter of <code>cmd.description(desc, argDescriptions)</code> for adding argument descriptions (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="842430318" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1490" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1490/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1490">#1490</a>) <ul> <li>(use new <code>.argument(name, description)</code> instead)</li> </ul> </li> <li><code>InvalidOptionArgumentError</code> (replaced by <code>InvalidArgumentError</code>) (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="863545723" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1508" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1508/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1508">#1508</a>)</li> </ul> <h3>Removed</h3> <ul> <li><em>Breaking:</em> TypeScript declaration for default export of global <code>Command</code> object (<a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="892364739" data-permission-text="Title is private" data-url="https://github.com/tj/commander.js/issues/1520" data-hovercard-type="pull_request" data-hovercard-url="/tj/commander.js/pull/1520/hovercard" href="https://snyk.io/redirect/github/tj/commander.js/pull/1520">#1520</a>) <ul> <li>(still available as named <code>program</code> export)</li> </ul> </li> </ul> <h3>Migration Tips</h3> <p>If you have a simple program without an action handler, you will now get an error if<br> there are missing command-arguments.</p> <div class="highlight highlight-source-js position-relative" data-snippet-clipboard-copy-content="program .option('-d, --debug') .arguments('<file>'); program.parse(); "><pre><span class="pl-s1">program</span> <span class="pl-kos">.</span><span class="pl-en">option</span><span class="pl-kos">(</span><span class="pl-s">'-d, --debug'</span><span class="pl-kos">)</span> <span class="pl-kos">.</span><span class="pl-en">arguments</span><span class="pl-kos">(</span><span class="pl-s">'<file>'</span><span class="pl-kos">)</span><span class="pl-kos">;</span> <span class="pl-s1">program</span><span class="pl-kos">.</span><span class="pl-en">parse</span><span class="pl-kos">(</span><span class="pl-kos">)</span><span class="pl-kos">;</span></pre></div> <div class="highlight highlight-source-shell position-relative" data-snippet-clipboard-copy-content="$ node trivial.js error: missing required argument 'file' "><pre>$ node trivial.js error: missing required argument <span class="pl-s"><span class="pl-pds">'</span>file<span class="pl-pds">'</span></span></pre></div> <p>If you want to show the help in this situation, you could check the arguments before parsing:</p> <div class="highlight highlight-source-js position-relative" data-snippet-clipboard-copy-content="if (process.argv.length === 2) program.help(); program.parse(); "><pre><span class="pl-k">if</span> <span class="pl-kos">(</span><span class="pl-s1">process</span><span class="pl-kos">.</span><span class="pl-c1">argv</span><span class="pl-kos">.</span><span class="pl-c1">length</span> <span class="pl-c1">===</span> <span class="pl-c1">2</span><span class="pl-kos">)</span> <span class="pl-s1">program</span><span class="pl-kos">.</span><span class="pl-en">help</span><span class="pl-kos">(</span><span class="pl-kos">)</span><span class="pl-kos">;</span> <span class="pl-s1">program</span><span class="pl-kos">.</span><span class="pl-en">parse</span><span class="pl-kos">(</span><span class="pl-kos">)</span><span class="pl-kos">;</span></pre></div> <p>Or, you might choose to show the help after any user error:</p> <div class="highlight highlight-source-js position-relative" data-snippet-clipboard-copy-content="program.showHelpAfterError(); "><pre><span class="pl-s1">program</span><span class="pl-kos">.</span><span class="pl-en">showHelpAfterError</span><span class="pl-kos">(</span><span class="pl-kos">)</span><span class="pl-kos">;</span></pre></div> </li> </ul> from <a href="https://snyk.io/redirect/github/tj/commander.js/releases">commander GitHub release notes</a> </details> </details>

<details> <summary><b>Commit messages</b></summary> </br> <details> <summary>Package name: <b>commander</b></summary> <ul> <li><a href="https://snyk.io/redirect/github/tj/commander.js/commit/a9c9f17c7eff96b8da8c2b9d01751d41f1eb0ae3">a9c9f17</a> Add link for version diff</li> <li><a href="https://snyk.io/redirect/github/tj/commander.js/commit/411ca9575266037358df95e7c6158de63d0b5600">411ca95</a> Clarify that more than just README</li> <li><a href="https://snyk.io/redirect/github/tj/commander.js/commit/a036bde5ccc403f741f30161ed8e789f0f51a73c">a036bde</a> Prepare for 8.1</li> <li><a href="https://snyk.io/redirect/github/tj/commander.js/commit/e6943c4ee19e9ad6b3529311ac893166d4d45b03">e6943c4</a> Update Chinese docs</li> <li><a href="https://snyk.io/redirect/github/tj/commander.js/commit/6f51e4a10912f6ac65d1f1335dd3e16f454b5e09">6f51e4a</a> Feature/argument arg explicit (#1567)</li> <li><a href="https://snyk.io/redirect/github/tj/commander.js/commit/4be69f17e021eb081634526bfe54888b00318fec">4be69f1</a> Use getCommandAndParents for array of parents (#1566)</li> <li><a href="https://snyk.io/redirect/github/tj/commander.js/commit/56c410831f5cfc3bf3a898d5da7379488848ec45">56c4108</a> Follow jsdoc and tsdoc more closely, especially @ example (#1562)</li> <li><a href="https://snyk.io/redirect/github/tj/commander.js/commit/5517d250a6547d70befce50518d1fc0891ed6d00">5517d25</a> Add copyInheritedSettings (#1557)</li> </ul>

<a href="https://snyk.io/redirect/github/tj/commander.js/compare/80054ba3756853c1acf80e168ee7d44b63ad826b...a9c9f17c7eff96b8da8c2b9d01751d41f1eb0ae3">Compare</a> </details> </details> <hr/>

Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open upgrade PRs.

For more information: <img src="https://api.segment.io/v1/pixel/track?data=eyJ3cml0ZUtleSI6InJyWmxZcEdHY2RyTHZsb0lYd0dUcVg4WkFRTnNCOUEwIiwiYW5vbnltb3VzSWQiOiJlNTI1N2QyYi1hMTczLTQ5NDAtYTY4Zi0wMGVjMDAyOTc0MzYiLCJldmVudCI6IlBSIHZpZXdlZCIsInByb3BlcnRpZXMiOnsicHJJZCI6ImU1MjU3ZDJiLWExNzMtNDk0MC1hNjhmLTAwZWMwMDI5NzQzNiJ9fQ==" width="0" height="0"/>

🧐 View latest project report

🛠 Adjust upgrade PR settings

🔕 Ignore this dependency or unsubscribe from future upgrade PRs

<!--- (snyk:metadata:{"prId":"e5257d2b-a173-4940-a68f-00ec00297436","prPublicId":"e5257d2b-a173-4940-a68f-00ec00297436","dependencies":[{"name":"commander","from":"8.0.0","to":"8.1.0"}],"packageManager":"npm","type":"auto","projectUrl":"https://app.snyk.io/org/ovhemert/project/9d2d2e62-16f0-494d-92ca-0a46d8e428d4?utm_source=github&utm_medium=upgrade-pr","projectPublicId":"9d2d2e62-16f0-494d-92ca-0a46d8e428d4","env":"prod","prType":"upgrade","vulns":[],"issuesToFix":[],"upgrade":[],"upgradeInfo":{"versionsDiff":1,"publishedDate":"2021-07-27T03:56:22.861Z"},"templateVariants":["merge-advice-badge-shown"],"hasFixes":false,"isMajorUpgrade":false,"isBreakingChange":false,"priorityScoreList":[]}) --->

+4 -4

1 comment

2 changed files

snyk-bot

pr closed time in 3 days

issue commentovhemert/pino-stackdriver

Errors in remote API are not shown

Closing the issue,.. will not change this atm since it breaks existing functionality. Need to keep the process running regardless of any errors that occur.

slhck

comment created time in 3 days

issue closedovhemert/pino-stackdriver

Errors in remote API are not shown

🐛 Bug Report

When the CLI program hits a 404 response from the Google Cloud API, it does not show any error, just says "logging".

To Reproduce

Try to log with the CLI program to a non-existing project ID.

$ ./my-program | pino-stackdriver --project bar --credentials foo.json
logging

In the Google Cloud Console I see the corresponding errors in the logging API:

image

However, pino-stackdriver does not tell me about those.

Expected behavior

The CLI program should inform me about the remote API errors so that they can be fixed.

Your Environment

  • os: Ubuntu 20.04

closed time in 3 days

slhck

push eventovhemert/ci-status

snyk-bot

commit sha b4583b168cb339bc8920919b6968fea395e3e486

fix: upgrade chalk from 4.1.1 to 4.1.2 Snyk has created this PR to upgrade chalk from 4.1.1 to 4.1.2. See this package in npm: https://www.npmjs.com/package/chalk See this project in Snyk: https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr

view details

push time in 5 days

push eventovhemert/pino-stackdriver

snyk-bot

commit sha 5b22b86fc0fdfbe98cdf364198983539884b4de6

fix: upgrade commander from 8.0.0 to 8.1.0 Snyk has created this PR to upgrade commander from 8.0.0 to 8.1.0. See this package in npm: https://www.npmjs.com/package/commander See this project in Snyk: https://app.snyk.io/org/ovhemert/project/9d2d2e62-16f0-494d-92ca-0a46d8e428d4?utm_source=github&utm_medium=upgrade-pr

view details

push time in 9 days

push eventovhemert/ci-status

snyk-bot

commit sha f5960ad6b36f0be2f0fb99d4dd6cf75b4ce94715

fix: upgrade aws-sdk from 2.950.0 to 2.951.0 Snyk has created this PR to upgrade aws-sdk from 2.950.0 to 2.951.0. See this package in npm: https://www.npmjs.com/package/aws-sdk See this project in Snyk: https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr

view details

push time in 14 days

delete branch ovhemert/ci-status

delete branch : snyk-upgrade-3d23a35409403dfa77b01ac716b43715

delete time in 15 days

push eventovhemert/ci-status

snyk-bot

commit sha 3af9ea6adbffbe9bb2caf3991789e9bedeeff4bd

fix: upgrade aws-sdk from 2.814.0 to 2.950.0 Snyk has created this PR to upgrade aws-sdk from 2.814.0 to 2.950.0. See this package in npm: https://www.npmjs.com/package/aws-sdk See this project in Snyk: https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr

view details

Osmond van Hemert

commit sha 887baeaf6e43e8f2b186a1aa4c8f0d1fedc3f698

Merge pull request #74 from ovhemert/snyk-upgrade-3d23a35409403dfa77b01ac716b43715 [Snyk] Upgrade aws-sdk from 2.814.0 to 2.950.0

view details

push time in 15 days

PR merged ovhemert/ci-status

[Snyk] Upgrade aws-sdk from 2.814.0 to 2.950.0

<h3>Snyk has created this PR to upgrade aws-sdk from 2.814.0 to 2.950.0.</h3>

:information_source: Keep your dependencies up-to-date. This makes it easier to fix existing vulnerabilities and to more quickly identify and fix newly disclosed vulnerabilities when they affect your project. <hr/>

  • The recommended version is 136 versions ahead of your current version.
  • The recommended version was released a day ago, on 2021-07-20.

<details> <summary><b>Release notes</b></summary> <br/> <details> <summary>Package name: <b>aws-sdk</b></summary> <ul> <li> <b>2.950.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.950.0">2021-07-20</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.949.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.949.0">2021-07-19</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.948.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.948.0">2021-07-16</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.947.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.947.0">2021-07-15</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.946.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.946.0">2021-07-14</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.945.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.945.0">2021-07-13</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.944.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.944.0">2021-07-12</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.943.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.943.0">2021-07-09</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.942.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.942.0">2021-07-08</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.941.0</b> - <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases/tag/v2.941.0">2021-07-07</a></br><p>See <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/blob/master/CHANGELOG.md">changelog</a> for more information.</p> </li> <li> <b>2.940.0</b> - 2021-07-06 </li> <li> <b>2.939.0</b> - 2021-07-02 </li> <li> <b>2.938.0</b> - 2021-07-01 </li> <li> <b>2.937.0</b> - 2021-06-30 </li> <li> <b>2.936.0</b> - 2021-06-28 </li> <li> <b>2.935.0</b> - 2021-06-25 </li> <li> <b>2.934.0</b> - 2021-06-24 </li> <li> <b>2.933.0</b> - 2021-06-23 </li> <li> <b>2.932.0</b> - 2021-06-21 </li> <li> <b>2.931.0</b> - 2021-06-17 </li> <li> <b>2.930.0</b> - 2021-06-16 </li> <li> <b>2.929.0</b> - 2021-06-15 </li> <li> <b>2.928.0</b> - 2021-06-14 </li> <li> <b>2.927.0</b> - 2021-06-11 </li> <li> <b>2.926.0</b> - 2021-06-10 </li> <li> <b>2.925.0</b> - 2021-06-09 </li> <li> <b>2.924.0</b> - 2021-06-08 </li> <li> <b>2.923.0</b> - 2021-06-07 </li> <li> <b>2.922.0</b> - 2021-06-04 </li> <li> <b>2.921.0</b> - 2021-06-03 </li> <li> <b>2.920.0</b> - 2021-06-02 </li> <li> <b>2.919.0</b> - 2021-06-01 </li> <li> <b>2.918.0</b> - 2021-05-28 </li> <li> <b>2.917.0</b> - 2021-05-27 </li> <li> <b>2.916.0</b> - 2021-05-27 </li> <li> <b>2.915.0</b> - 2021-05-26 </li> <li> <b>2.914.0</b> - 2021-05-25 </li> <li> <b>2.913.0</b> - 2021-05-24 </li> <li> <b>2.912.0</b> - 2021-05-21 </li> <li> <b>2.911.0</b> - 2021-05-20 </li> <li> <b>2.910.0</b> - 2021-05-19 </li> <li> <b>2.909.0</b> - 2021-05-18 </li> <li> <b>2.908.0</b> - 2021-05-17 </li> <li> <b>2.907.0</b> - 2021-05-14 </li> <li> <b>2.906.0</b> - 2021-05-12 </li> <li> <b>2.905.0</b> - 2021-05-11 </li> <li> <b>2.904.0</b> - 2021-05-10 </li> <li> <b>2.903.0</b> - 2021-05-07 </li> <li> <b>2.902.0</b> - 2021-05-06 </li> <li> <b>2.901.0</b> - 2021-05-05 </li> <li> <b>2.900.0</b> - 2021-05-04 </li> <li> <b>2.899.0</b> - 2021-05-03 </li> <li> <b>2.898.0</b> - 2021-05-03 </li> <li> <b>2.897.0</b> - 2021-04-30 </li> <li> <b>2.896.0</b> - 2021-04-29 </li> <li> <b>2.895.0</b> - 2021-04-28 </li> <li> <b>2.894.0</b> - 2021-04-27 </li> <li> <b>2.893.0</b> - 2021-04-26 </li> <li> <b>2.892.0</b> - 2021-04-23 </li> <li> <b>2.891.0</b> - 2021-04-22 </li> <li> <b>2.890.0</b> - 2021-04-21 </li> <li> <b>2.889.0</b> - 2021-04-19 </li> <li> <b>2.888.0</b> - 2021-04-15 </li> <li> <b>2.887.0</b> - 2021-04-14 </li> <li> <b>2.886.0</b> - 2021-04-13 </li> <li> <b>2.885.0</b> - 2021-04-12 </li> <li> <b>2.884.0</b> - 2021-04-09 </li> <li> <b>2.883.0</b> - 2021-04-08 </li> <li> <b>2.882.0</b> - 2021-04-07 </li> <li> <b>2.881.0</b> - 2021-04-06 </li> <li> <b>2.880.0</b> - 2021-04-05 </li> <li> <b>2.879.0</b> - 2021-04-02 </li> <li> <b>2.878.0</b> - 2021-04-01 </li> <li> <b>2.877.0</b> - 2021-03-31 </li> <li> <b>2.876.0</b> - 2021-03-30 </li> <li> <b>2.875.0</b> - 2021-03-29 </li> <li> <b>2.874.0</b> - 2021-03-26 </li> <li> <b>2.873.0</b> - 2021-03-26 </li> <li> <b>2.872.0</b> - 2021-03-25 </li> <li> <b>2.871.0</b> - 2021-03-24 </li> <li> <b>2.870.0</b> - 2021-03-23 </li> <li> <b>2.869.0</b> - 2021-03-22 </li> <li> <b>2.868.0</b> - 2021-03-19 </li> <li> <b>2.867.0</b> - 2021-03-18 </li> <li> <b>2.866.0</b> - 2021-03-17 </li> <li> <b>2.865.0</b> - 2021-03-16 </li> <li> <b>2.864.0</b> - 2021-03-15 </li> <li> <b>2.863.0</b> - 2021-03-12 </li> <li> <b>2.862.0</b> - 2021-03-11 </li> <li> <b>2.861.0</b> - 2021-03-10 </li> <li> <b>2.860.0</b> - 2021-03-09 </li> <li> <b>2.859.0</b> - 2021-03-08 </li> <li> <b>2.858.0</b> - 2021-03-05 </li> <li> <b>2.857.0</b> - 2021-03-04 </li> <li> <b>2.856.0</b> - 2021-03-03 </li> <li> <b>2.855.0</b> - 2021-03-02 </li> <li> <b>2.854.0</b> - 2021-03-01 </li> <li> <b>2.853.0</b> - 2021-02-26 </li> <li> <b>2.852.0</b> - 2021-02-25 </li> <li> <b>2.851.0</b> - 2021-02-24 </li> <li> <b>2.850.0</b> - 2021-02-23 </li> <li> <b>2.849.0</b> - 2021-02-22 </li> <li> <b>2.848.0</b> - 2021-02-19 </li> <li> <b>2.847.0</b> - 2021-02-18 </li> <li> <b>2.846.0</b> - 2021-02-17 </li> <li> <b>2.845.0</b> - 2021-02-16 </li> <li> <b>2.844.0</b> - 2021-02-15 </li> <li> <b>2.843.0</b> - 2021-02-12 </li> <li> <b>2.842.0</b> - 2021-02-11 </li> <li> <b>2.841.0</b> - 2021-02-09 </li> <li> <b>2.840.0</b> - 2021-02-08 </li> <li> <b>2.839.0</b> - 2021-02-05 </li> <li> <b>2.838.0</b> - 2021-02-04 </li> <li> <b>2.837.0</b> - 2021-02-04 </li> <li> <b>2.836.0</b> - 2021-02-03 </li> <li> <b>2.835.0</b> - 2021-02-03 </li> <li> <b>2.834.0</b> - 2021-01-29 </li> <li> <b>2.833.0</b> - 2021-01-28 </li> <li> <b>2.832.0</b> - 2021-01-27 </li> <li> <b>2.831.0</b> - 2021-01-22 </li> <li> <b>2.830.0</b> - 2021-01-21 </li> <li> <b>2.829.0</b> - 2021-01-19 </li> <li> <b>2.828.0</b> - 2021-01-14 </li> <li> <b>2.827.0</b> - 2021-01-13 </li> <li> <b>2.826.0</b> - 2021-01-12 </li> <li> <b>2.825.0</b> - 2021-01-11 </li> <li> <b>2.824.0</b> - 2021-01-07 </li> <li> <b>2.823.0</b> - 2021-01-06 </li> <li> <b>2.822.0</b> - 2021-01-05 </li> <li> <b>2.821.0</b> - 2021-01-04 </li> <li> <b>2.820.0</b> - 2020-12-31 </li> <li> <b>2.819.0</b> - 2020-12-29 </li> <li> <b>2.818.0</b> - 2020-12-28 </li> <li> <b>2.817.0</b> - 2020-12-23 </li> <li> <b>2.816.0</b> - 2020-12-22 </li> <li> <b>2.815.0</b> - 2020-12-21 </li> <li> <b>2.814.0</b> - 2020-12-18 </li> </ul> from <a href="https://snyk.io/redirect/github/aws/aws-sdk-js/releases">aws-sdk GitHub release notes</a> </details> </details>

<details> <summary><b>Commit messages</b></summary> </br> <details> <summary>Package name: <b>aws-sdk</b></summary> <ul> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/7f49c821196d5aa6e69a94cfd2d965adbe2025a7">7f49c82</a> Updates SDK to v2.950.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/ebac2a5ec042592866aeded3b42d94e66bba4244">ebac2a5</a> fix: intermittent test failures with OpsWorks (#3839)</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/2e61ed8772e4793ad896300aad2fcaeee105557e">2e61ed8</a> Updates SDK to v2.949.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/8533bd2d2336c00f95efb63702ebc10af2ddc12b">8533bd2</a> support document type trait (#3808)</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/3bf6c628c5c9219018ebbee381ea61afcfc32a83">3bf6c62</a> revert removing integration tests (#3835)</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/85fe35347ad839e8e26c5e3c82b8fc84062be504">85fe353</a> Updates SDK to v2.948.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/50e46727e58bcaebd61876e669d60d528b300f62">50e4672</a> Updates SDK to v2.947.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/a7db325c7af6ffb5ae6040336ac80a0a764514ac">a7db325</a> Updates SDK to v2.946.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/371ca9d6256f561f7bb43df6cc33fd4c1d02468e">371ca9d</a> Updates SDK to v2.945.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/fefd1868774157f74b82321f32787caa83d71591">fefd186</a> remove device farm integ test (#3830)</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/e101fa50a16546042f3cde034bfef603a315ba85">e101fa5</a> fix: remove AWS OpsWorks integration test step (#3828)</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/daf1c843d2e7cffe32c9cf15cfdf1807011b9171">daf1c84</a> Updates SDK to v2.944.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/821e9a11f3917551e26d5cbc794bf319979ceb00">821e9a1</a> Updates SDK to v2.943.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/7d75b8c96d0ebe598e65c00ff1aa8840e520bad3">7d75b8c</a> Updates SDK to v2.942.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/69494c39c0d340d374697a3e1fc6f6446f484e2e">69494c3</a> Updates SDK to v2.941.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/bea1c42a526856ac681b2b90756a476642d752f4">bea1c42</a> Updates SDK to v2.940.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/a2f8e4ff6c6672657b9ee0ceaf134bee81c7d8e6">a2f8e4f</a> Updates SDK to v2.939.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/bcb3a270e00ececa28ed7e6e12c87ac903021b55">bcb3a27</a> Enable CORS for cloudhsmv2 (#3779)</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/d15a479e3499ae74a534380464bca10c1228ca4d">d15a479</a> Updates SDK to v2.938.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/194b13ea36333a06e3ce815a22ebca460f83182e">194b13e</a> Updates SDK to v2.937.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/b264dde175d132fbafc111ff929dfd8207c63490">b264dde</a> Updates SDK to v2.936.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/47d49492e6bdd9ffb9f9d89be96228fb4477bb42">47d4949</a> Updates SDK to v2.935.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/7661e6db2edd1f301b379c8d0d869ea84a109a8a">7661e6d</a> Updates SDK to v2.934.0</li> <li><a href="https://snyk.io/redirect/github/aws/aws-sdk-js/commit/d420427503fcfe7854d191c055e4a034fcfa9fdd">d420427</a> Updates SDK to v2.933.0</li> </ul>

<a href="https://snyk.io/redirect/github/aws/aws-sdk-js/compare/8875a35871b738388398ed5667ffc7d6eb1aa36f...7f49c821196d5aa6e69a94cfd2d965adbe2025a7">Compare</a> </details> </details> <hr/>

Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open upgrade PRs.

For more information: <img src="https://api.segment.io/v1/pixel/track?data=eyJ3cml0ZUtleSI6InJyWmxZcEdHY2RyTHZsb0lYd0dUcVg4WkFRTnNCOUEwIiwiYW5vbnltb3VzSWQiOiJhZDY0ODdiYi1hMzg0LTQwMDktYjZkMC1jOTA0ODQyMWVkZjIiLCJldmVudCI6IlBSIHZpZXdlZCIsInByb3BlcnRpZXMiOnsicHJJZCI6ImFkNjQ4N2JiLWEzODQtNDAwOS1iNmQwLWM5MDQ4NDIxZWRmMiJ9fQ==" width="0" height="0"/><img src="https://app.snyk.io/badges/merge-advice/?package_manager=npm&package_name=aws-sdk&from_version=2.814.0&to_version=2.950.0&pr_id=ad6487bb-a384-4009-b6d0-c9048421edf2&visibility=false&has_feature_flag=false" width="0" height="0"/>

🧐 View latest project report

🛠 Adjust upgrade PR settings

🔕 Ignore this dependency or unsubscribe from future upgrade PRs

<!--- (snyk:metadata:{"prId":"ad6487bb-a384-4009-b6d0-c9048421edf2","prPublicId":"ad6487bb-a384-4009-b6d0-c9048421edf2","dependencies":[{"name":"aws-sdk","from":"2.814.0","to":"2.950.0"}],"packageManager":"npm","type":"auto","projectUrl":"https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr","projectPublicId":"bffe9710-d95c-4887-a784-74285d2dfc83","env":"prod","prType":"upgrade","vulns":[],"issuesToFix":[],"upgrade":[],"upgradeInfo":{"versionsDiff":136,"publishedDate":"2021-07-20T18:24:22.702Z"},"templateVariants":["merge-advice-badge-shown"],"hasFixes":false,"isMajorUpgrade":false,"isBreakingChange":false,"priorityScoreList":[]}) --->

+4 -4

1 comment

2 changed files

snyk-bot

pr closed time in 15 days

push eventovhemert/pino-applicationinsights

snyk-bot

commit sha 55f45bacee63f66c4a05967b7bc049d4766f8289

fix: upgrade applicationinsights from 2.1.0 to 2.1.4 Snyk has created this PR to upgrade applicationinsights from 2.1.0 to 2.1.4. See this package in npm: https://www.npmjs.com/package/applicationinsights See this project in Snyk: https://app.snyk.io/org/ovhemert/project/54ef59ba-d945-46da-a39d-bde06f93c92d?utm_source=github&utm_medium=upgrade-pr

view details

push time in 15 days

push eventovhemert/ci-status

snyk-bot

commit sha 3af9ea6adbffbe9bb2caf3991789e9bedeeff4bd

fix: upgrade aws-sdk from 2.814.0 to 2.950.0 Snyk has created this PR to upgrade aws-sdk from 2.814.0 to 2.950.0. See this package in npm: https://www.npmjs.com/package/aws-sdk See this project in Snyk: https://app.snyk.io/org/ovhemert/project/bffe9710-d95c-4887-a784-74285d2dfc83?utm_source=github&utm_medium=upgrade-pr

view details

push time in 15 days

delete branch ovhemert/pino-applicationinsights

delete branch : snyk-upgrade-f63104f1fc5fec56f096e736643349aa

delete time in 15 days

push eventovhemert/pino-applicationinsights

snyk-bot

commit sha c83255ad4c5b73589f24d5b01da13436d152f2fd

feat: upgrade applicationinsights from 1.8.8 to 2.1.0 Snyk has created this PR to upgrade applicationinsights from 1.8.8 to 2.1.0. See this package in npm: https://www.npmjs.com/package/applicationinsights See this project in Snyk: https://app.snyk.io/org/ovhemert/project/54ef59ba-d945-46da-a39d-bde06f93c92d?utm_source=github&utm_medium=upgrade-pr

view details

push time in 15 days

PR merged ovhemert/pino-applicationinsights

[Snyk] Upgrade applicationinsights from 1.8.8 to 2.1.0

<h3>Snyk has created this PR to upgrade applicationinsights from 1.8.8 to 2.1.0.</h3>

merge advice :information_source: Keep your dependencies up-to-date. This makes it easier to fix existing vulnerabilities and to more quickly identify and fix newly disclosed vulnerabilities when they affect your project. <hr/>

Warning: This is a major version upgrade, and may be a breaking change.

  • The recommended version is 14 versions ahead of your current version.
  • The recommended version was released 7 days ago, on 2021-06-02.

<details> <summary><b>Release notes</b></summary> <br/> <details> <summary>Package name: <b>applicationinsights</b></summary> <ul> <li> <b>2.1.0</b> - <a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/releases/tag/2.1.0">2021-06-02</a></br><p><a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="908868478" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/762" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/762/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/762">#762</a> Add retry when redirect is triggered<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="897488895" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/759" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/759/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/759">#759</a> Use x-forwarded-proto header if available<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="832142371" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/739" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/739/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/739">#739</a> Adding extra options in default Https agent</p> </li> <li> <b>2.1.0-beta.1</b> - <a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/releases/tag/2.1.0-beta.1">2021-06-09</a></br><p><a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="916575944" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/772" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/772/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/772">#772</a> Adding support for temporary redirect</p> </li> <li> <b>2.1.0-beta.0</b> - <a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/releases/tag/2.1.0-beta.0">2021-06-02</a></br><p><a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="844887504" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/746" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/746/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/746">#746</a> Add AAD support<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="908868478" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/762" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/762/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/762">#762</a> Add retry when redirect is triggered<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="897488895" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/759" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/759/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/759">#759</a> Use x-forwarded-proto header if available<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="832142371" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/739" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/739/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/739">#739</a> Adding extra options in default Https agent</p> </li> <li> <b>2.0.0</b> - <a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/releases/tag/2.0.0">2021-05-10</a></br><p>Breaking changes:<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="832238129" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/740" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/740/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/740">#740</a> Adding node.js > 8 requirement</p> <p>Other changes:<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="858334041" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/752" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/752/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/752">#752</a> Adding 206 response handling from Breeze<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="840413213" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/745" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/745/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/745">#745</a> Make native metrics handle creation singleton<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="820522429" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/737" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/737/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/737">#737</a> Roles support, Endpoint redirects and ping interval hints for Live Metrics<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="817749759" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/736" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/736/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/736">#736</a> Add support for pre aggregated metrics<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="806765526" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/732" data-hovercard-type="issue" data-hovercard-url="/microsoft/ApplicationInsights-node.js/issues/732/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/issues/732">#732</a> Validate envelope after telemetry processors</p> </li> <li> <b>2.0.0-beta.201103.0</b> - 2020-11-03 </li> <li> <b>2.0.0-beta.201004.0</b> - 2020-10-05 </li> <li> <b>2.0.0-beta.200831.2</b> - 2020-09-01 </li> <li> <b>2.0.0-beta.200831.1</b> - 2020-09-01 </li> <li> <b>2.0.0-beta.200828.1</b> - 2020-08-28 </li> <li> <b>2.0.0-beta.200714.1</b> - 2020-07-14 </li> <li> <b>2.0.0-beta.200713.1</b> - 2020-07-13 </li> <li> <b>2.0.0-beta.200707.1</b> - 2020-07-07 </li> <li> <b>1.8.10</b> - <a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/releases/tag/1.8.10">2021-02-11</a></br><p><a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="805843982" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/728" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/728/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/728">#728</a> Add cloud role name automatic population<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="804848760" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/727" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/727/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/727">#727</a> Bootstrap check for AppInsights SDK to be present updated<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="798701456" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/723" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/723/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/723">#723</a> Automatic dependency tracking of Azure SDKs not working correctly</p> </li> <li> <b>1.8.9</b> - <a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/releases/tag/1.8.9">2021-01-20</a></br><p><a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="786305694" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/720" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/720/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/720">#720</a> Use request.protocol when available in automatic dependency collection<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="770458884" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/718" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/718/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/718">#718</a> Update diagnostic-channel-publishers to 0.4.3<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="766824765" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/717" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/717/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/717">#717</a> Adding envelope interface<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="759898938" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/711" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/711/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/711">#711</a> Fixing issue with packageJsonPath ignored for App version context<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="744169907" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/701" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/701/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/701">#701</a> Fix Max call stack size exceeded when used with Azure blob storage<br> <a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="613120175" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/629" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/629/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/629">#629</a> Http.createServer is missing the options variable</p> </li> <li> <b>1.8.8</b> - <a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/releases/tag/1.8.8">2020-11-03</a></br><ul> <li><a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="730722677" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/690" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/690/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/690">#690</a> Update diagnostic-channel-publishers to 0.4.2</li> <li><a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="734768620" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/692" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/692/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/692">#692</a> Correctly parse RDD URLs missing network protocols</li> <li><a class="issue-link js-issue-link" data-error-text="Failed to load title" data-id="734958743" data-permission-text="Title is private" data-url="https://github.com/microsoft/ApplicationInsights-node.js/issues/696" data-hovercard-type="pull_request" data-hovercard-url="/microsoft/ApplicationInsights-node.js/pull/696/hovercard" href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/pull/696">#696</a> Fix ExceptionTelemetry stackframe regex parser to handle scoped npm packages</li> </ul> </li> </ul> from <a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/releases">applicationinsights GitHub release notes</a> </details> </details>

<details> <summary><b>Commit messages</b></summary> </br> <details> <summary>Package name: <b>applicationinsights</b></summary> <ul> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/9ff235d25448ec5dbf20d989fb64a15627187509">9ff235d</a> 2.1.0 release (#766)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/3064bea0d9dea76b34cb6cf4babbe13db50375fa">3064bea</a> Readme updates for beta (#764)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/547b0a32326bfbe12789eaeb2e4c8a71a890e5a5">547b0a3</a> Fix type issue with pre aggregated metrics for Traces and Exceptions (#763)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/1de38705508b9223240717a81d0eb852c77c6250">1de3870</a> Add retry when redirect is triggered (#762)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/4f60072f52015e046af299db2a938a460a5b652d">4f60072</a> Add AAD support (#746)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/297f023e8066eee9a49ae713007be8fc245d5729">297f023</a> Use x-forwarded-proto header if available (#759)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/75372a92a7025439b355ce7fffdef88acd4f2b4d">75372a9</a> Adding extra options in default Https agent (#739)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/5843fdf623fc6357cbd7d2cd6419822c00e7c9aa">5843fdf</a> Adding supported node.js versions in readme (#757)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/eded93dd0d0b5b2ace017c7701b15db0bdd2c855">eded93d</a> 2.0.0 release (#756)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/38f684019f4a577477f48ab3052d190bf593fe30">38f6840</a> Update license (#753)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/acf85eee7e0111983bb07f7fdc983d02726a1367">acf85ee</a> Adding 206 response handling from Breeze (#752)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/c13a78d900be17f000992c2a2fbfb162062c5271">c13a78d</a> Adding Breeze endpoint redirect support (#747)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/8b5306840d2566078fd334786ee476b9ed047c2e">8b53068</a> Make native metrics handle creation singleton (#745)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/a735789f5ed1e0614b7a4ba4e70a15d39a5fdaed">a735789</a> Adding node.js > 8 requirement (#740)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/fb2318861f246c7f460bd61fc5aac26fee15e0b9">fb23188</a> Roles support, Endpoint redirects and ping interval hints for Live Metrics (#737)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/d0525dc4ff5fb7bd6fec705bdfc52a20c604a2a1">d0525dc</a> Add support for pre aggregated metrics (#736)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/246807a21827523b0e89ad16a0da6475d1b51d3c">246807a</a> #732: Fix: Validate envelope after telemetry processors (#734)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/7b46d2175428834d528230e169d79784a055cf66">7b46d21</a> 1.8.10 release (#730)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/c3f9d86e6149098348181077934b008766237ba2">c3f9d86</a> Add cloud role name automatic population (#728)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/c401cf0d9afd03a40d17f33740f885282cd8369e">c401cf0</a> WIP (#727)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/932519cfd5509d41d97154eea8e4446842d8f6bf">932519c</a> Automatic dependency tracking of Azure SDKs not working correctly (#723)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/42cfda06b451c4fc8ec2d3487b47d245b5fa9e09">42cfda0</a> 1.8.9 release (#718)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/9c4c97fbc20e72ebc0232f45f77297f556889cbb">9c4c97f</a> Use request.protocol when available in automatic dependency collection (#720)</li> <li><a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/commit/2605117f3485487c510a46aa5679f12176ab6490">2605117</a> Http.createServer is missing the options variable (#629)</li> </ul>

<a href="https://snyk.io/redirect/github/microsoft/ApplicationInsights-node.js/compare/7f3a5cafca0648c34f8dd3c65e6484c811bd78ef...9ff235d25448ec5dbf20d989fb64a15627187509">Compare</a> </details> </details> <hr/>

Note: You are seeing this because you or someone else with access to this repository has authorized Snyk to open upgrade PRs.

For more information: <img src="https://api.segment.io/v1/pixel/track?data=eyJ3cml0ZUtleSI6InJyWmxZcEdHY2RyTHZsb0lYd0dUcVg4WkFRTnNCOUEwIiwiYW5vbnltb3VzSWQiOiI2N2IyOGJkYS0xZTBjLTQ2NjQtYTY5NC1lZjcxNDU0ZGJlOGEiLCJldmVudCI6IlBSIHZpZXdlZCIsInByb3BlcnRpZXMiOnsicHJJZCI6IjY3YjI4YmRhLTFlMGMtNDY2NC1hNjk0LWVmNzE0NTRkYmU4YSJ9fQ==" width="0" height="0"/>

🧐 View latest project report

🛠 Adjust upgrade PR settings

🔕 Ignore this dependency or unsubscribe from future upgrade PRs

<!--- (snyk:metadata:{"prId":"67b28bda-1e0c-4664-a694-ef71454dbe8a","prPublicId":"67b28bda-1e0c-4664-a694-ef71454dbe8a","dependencies":[{"name":"applicationinsights","from":"1.8.8","to":"2.1.0"}],"packageManager":"npm","type":"auto","projectUrl":"https://app.snyk.io/org/ovhemert/project/54ef59ba-d945-46da-a39d-bde06f93c92d?utm_source=github&utm_medium=upgrade-pr","projectPublicId":"54ef59ba-d945-46da-a39d-bde06f93c92d","env":"prod","prType":"upgrade","vulns":[],"issuesToFix":[],"upgrade":[],"upgradeInfo":{"versionsDiff":14,"publishedDate":"2021-06-02T22:42:48.750Z"},"templateVariants":["merge-advice-badge-shown"],"hasFixes":false,"isMajorUpgrade":true,"isBreakingChange":true,"priorityScoreList":[]}) --->

+290 -24

0 comment

2 changed files

snyk-bot

pr closed time in 15 days

push eventovhemert/pino-applicationinsights

Osmond van Hemert

commit sha 705f55db921ee415bb807032d153d8de3238ce97

fix ci

view details

push time in 15 days

delete branch ovhemert/ci-status

delete branch : snyk-fix-0974ca0c625a7c01eb0cf2458f877456

delete time in 15 days