profile
viewpoint

navoshta/KITTI-Dataset 206

Visualising LIDAR data from KITTI dataset.

navoshta/MetalRenderCamera 179

A simple app that grabs raw camera data, converts to textures and renders on screen with Metal.

navoshta/traffic-signs 112

Building a CNN based traffic signs classifier.

navoshta/behavioral-cloning 73

Behavioral cloning: end-to-end learning for self-driving cars.

navoshta/detecting-road-features 68

Detecting Road Features: identifying lane and vehicles boundaries in a video.

navoshta/kaggle-facial-keypoints-detection 26

Kaggle "Facial Keypoints Detection" competition.

navoshta/cloudlog 21

A simple logger that duplicates console logs to a file, Dropbox and Telegram.

navoshta/Jupyter-Notebook-Theme 6

Personal theme that I use for Jupyter notebooks

navoshta/MotionSensorData 6

A simple app that uses CoreMotion framework to obtain and display data from various motion sensors available on iOS devices.

navoshta/RevealImageDemo 6

A demo for a blog post at oldyellowbricks.com: Transitions with CoreAnimation: revealing an image.

issue openedrationalmatter/Juno-Issue-Tracker

Scikit-surprise

Scikit-surprise

created time in 14 hours

issue openedrationalmatter/Juno-Issue-Tracker

Unable to connect to remote Jupyter Lab server

I just purchased Juno Connect and trying to connect to the remote server in my university. I am connecting to my school’s VPN and am able to ssh into the server via Terminus. However, when I try to connect to the Jupyter Lab server, I get the below message: PNG image This is my setting: PNG image 2

Could you help take a look and see why? Thanks a lot!

created time in 2 days

issue openedrationalmatter/Juno-Issue-Tracker

Ipynb files are grayed out. I tried everything on your forums but it does not work

Describe the bug A clear and concise description of what the bug is.

To Reproduce Steps to reproduce the behavior:

  1. Go to '...'
  2. Tap on '....'
  3. Scroll down to '....'
  4. See error

Expected behavior A clear and concise description of what you expected to happen.

Screenshots If applicable, add screenshots or a screen recording to help explain your problem.

Environment (please complete the following information):

  • Device: [e.g. iPad Pro 11"]
  • iOS version: [e.g. iOS 12.2]
  • App version [e.g. 1.0.0]

created time in 7 days

delete branch nwhitehead/pineapple

delete branch : dependabot/pip/notebook-5.7.8

delete time in 10 days

PR closed nwhitehead/pineapple

Bump notebook from 4.0.5 to 5.7.8 dependencies

Bumps notebook from 4.0.5 to 5.7.8. <details> <summary>Commits</summary>

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot ignore this [patch|minor|major] version will close this PR and stop Dependabot creating any more for this minor/major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+2 -2

1 comment

2 changed files

dependabot[bot]

pr closed time in 10 days

pull request commentnwhitehead/pineapple

Bump notebook from 4.0.5 to 5.7.8

Superseded by #81.

dependabot[bot]

comment created time in 10 days

PR opened nwhitehead/pineapple

Bump notebook from 4.0.4 to 6.1.5

Bumps notebook from 4.0.4 to 6.1.5. <details> <summary>Commits</summary> <ul> <li>See full diff in <a href="https://github.com/jupyter/jupyterhub/commits">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+2 -2

0 comment

2 changed files

pr created time in 10 days

create barnchnwhitehead/pineapple

branch : dependabot/pip/notebook-6.1.5

created branch time in 10 days

issue commentrationalmatter/Juno-Issue-Tracker

Add google-cloud-bigquery

Started from a clean slate and used your environment.yml. Looks like six was the only package with a version conflict (1.12 → 1.15, but 1.13 should suffice).

%pip install --upgrade 'google-cloud-bigquery[pandas]' --no-cache

Collecting google-cloud-bigquery[pandas]
...
Installing collected packages: pycparser, cffi, google-crc32c, six, google-resumable-media, protobuf, proto-plus, pyasn1, pyasn1-modules, cachetools, rsa, google-auth, urllib3, idna, chardet, requests, googleapis-common-protos, grpcio, google-api-core, google-cloud-core, pyarrow, google-cloud-bigquery
  Found existing installation: six 1.12.0
    Uninstalling six-1.12.0:
      Successfully uninstalled six-1.12.0
Successfully installed cachetools-4.1.1 cffi-1.14.3 chardet-3.0.4 google-api-core-1.23.0 google-auth-1.23.0 google-cloud-bigquery-2.4.0 google-cloud-core-1.4.3 google-crc32c-1.0.0 google-resumable-media-1.1.0 googleapis-common-protos-1.52.0 grpcio-1.33.2 idna-2.10 proto-plus-1.11.0 protobuf-3.14.0 pyarrow-2.0.0 pyasn1-0.4.8 pyasn1-modules-0.2.8 pycparser-2.20 requests-2.25.0 rsa-4.6 six-1.15.0 urllib3-1.26.2
christopherseaman

comment created time in 11 days

startednavoshta/traffic-signs

started time in 12 days

startednavoshta/traffic-signs

started time in 12 days

issue commentrationalmatter/Juno-Issue-Tracker

Help functions not working

Thanks for reporting @method-marco — I'm assuming this is for Juno, not Juno Connect? Could be something with how we embed those modules then.

Yes, it’s with Juno and not with Juno Connect. I can reproduce it with builtins and other imports.

method-marco

comment created time in 22 days

issue openedrationalmatter/Juno-Issue-Tracker

Help functions not working

Describe the bug The help() function is not working correctly. Sometimes the output is not shown.

To Reproduce Execute: help(abs)

Expected behavior Prints the help for the abs function

Environment (please complete the following information):

  • Device: iPad Pro 12" 2020
  • iOS version: iOS 14

created time in 24 days

startednavoshta/MetalRenderCamera

started time in 25 days

startednavoshta/KITTI-Dataset

started time in a month

issue openedrationalmatter/Juno-Issue-Tracker

Juno connect moves blocks in and out of screen as I type

Describe the bug Blocks in notbook move on and off screen for each character typed.

To Reproduce Steps to reproduce the behavior:

  1. Go to any jupyter notebook
  2. Tap on a block
  3. Try to type
  4. See error

Expected behavior I expect the block to remain onscreen as I type.

Screenshots

https://imgur.com/a/X5EP20T

Environment (please complete the following information):

  • Device: iPad Pro 11 (2018)
  • iOS version: iOS 14
  • App version 1.5.11

created time in a month

startednavoshta/behavioral-cloning

started time in a month

issue commentrationalmatter/Juno-Issue-Tracker

Add google-cloud-bigquery

Thanks for the quick response.

I'll admit that I haven't run down the list of deps to see what else may need to be upgraded. Obviously, if you can get either of those load statements running without error, that'd be a great start. I installed a working set of site-packages on Ubuntu 18.04 (closest match to Juno versions I could find) and put it in the cloud to make it easier to get onto the iPad; if it helps to work through dependencies, you can find it here: https://www.dropbox.com/s/vo6lgmks05s65ux/site-packages.tar.xz?dl=0

Happy to help test if that would be helpful.

christopherseaman

comment created time in a month

startednavoshta/KITTI-Dataset

started time in a month

issue openedrationalmatter/Juno-Issue-Tracker

Add **pymongo**

pymongo Humbly requesting that pymongo be installed. https://pypi.org/project/pymongo/. It would make it possible to interact with mongodb databases from my phone. Allowing my phone to be an extension of my computer when it comes to running script.s

created time in a month

issue commentrationalmatter/Juno-Issue-Tracker

Working directory

Hi @navoshta I'm a new user to Juno, I'm working on an iPad Pro 12.9 Inch 2020. Just to be clear -- Juno should be able to run from other directories like Dropbox, ICloud, etc?

Because if that is so then I can't get it to work. When I type os.getcwd() in a notebook running on Dropbox or anywhere else, it always give /private/var/mobile/Containers/Data/Application/FB.../Caches

What is the meaning of your last sentence "Or perhaps you are opening a notebook in another app's directory?" -- Isn't that the point, to open notebooks in other directories like Dropbox, iCloud, etc.?

TomdeGraaf

comment created time in a month

issue openedrationalmatter/Juno-Issue-Tracker

Add google-cloud-bigquery

Requesting support or inclusion of google-cloud-bigquery[pandas]

The google-cloud-bigquery package does not successfully load using %load_ext google.cloud.bigquery or from google.cloud import bigquery even when all dependencies are present in site-packages bc it depends on a newer version of six than included in Juno. There may be a workaround for this using require, but I couldn't convince pkg_resources to load the newer one from site-packages instead of built-in.

created time in a month

issue closedrationalmatter/Juno-Issue-Tracker

How to delete Jupyter servers?

I’m not sure if this is a bug because just starting with Juno connect.

But I created a bunch of Jupyter servers to try to get it to connect and now I can’t figure out how to delete the ones that were bad.

Your help is appreciated.

closed time in a month

craldaz

issue commentrationalmatter/Juno-Issue-Tracker

How to delete Jupyter servers?

Thank you! It works :)

craldaz

comment created time in a month

issue openedrationalmatter/Juno-Issue-Tracker

Package installer is not present for use

Describe the bug A clear and concise description of what the bug is.

To Reproduce Steps to reproduce the behavior:

  1. Go to '...'
  2. Tap on '....'
  3. Scroll down to '....'
  4. See error

Expected behavior A clear and concise description of what you expected to happen.

Screenshots If applicable, add screenshots or a screen recording to help explain your problem.

Environment (please complete the following information):

  • Device: [e.g. iPad Pro 11"]
  • iOS version: [e.g. iOS 12.2]
  • App version [e.g. 1.0.0]

created time in a month

issue openedrationalmatter/Juno-Issue-Tracker

CoolProp - Fluid Properties

Describe the bug The installation of the Coolprop module is successful but then Juno does not recognise the module when trying to load it.

To Reproduce Steps to reproduce the behavior:

  1. install CoolProp module
  2. load module using "from CoolProp.CoolProp import *"
  3. See error

Expected behavior Recognise the module

Screenshots If applicable, add screenshots or a screen recording to help explain your problem. Fig1 Fig2 Fig3 Fig4

Environment (please complete the following information):

  • Device: iPad Pro 10.5"
  • iOS version: 14.2
  • App version 1.2.8

created time in a month

more