profile
viewpoint
Giel van Schijndel muggenhor @tomtom-international https://blog.mortis.eu

erezsh/plyplus 259

a friendly yet powerful LR-parser written in Python

muggenhor/focus-blur 2

GIMP Focus Blur plugin

dascandy/rapscallion 1

C++ RPC using C++17 futures

muggenhor/dockerfiles 1

docker container definitions

muggenhor/gimp-depthmap 1

GIMP Depthmap plug-in

muggenhor/awesome-assert 0

Simple C++ assertion library with expression decomposition

muggenhor/basync 0

Basic Async library for modern C++

muggenhor/BetterPawnControl 0

A RimWorld mod that allows bulk assignment of animals to zones and colonists to outfits (or drugs) in one single action

muggenhor/boost-filesystem 0

Boost.org filesystem module

startedsatya-das/cib

started time in 9 days

startedboost-ext/sml

started time in 21 days

startedsupercmmetry/rainman

started time in 22 days

issue closedcucumber/cucumber-cpp

New release tag?

Hi,

As I see it, master has fixes thar tag v.05 does not. Can you create a new release tag ?

closed time in 23 days

vladhategancs

startedmicrosoft/wil

started time in 25 days

issue openedcucumber/cucumber-cpp

New release tag?

Hi,

As I see it, master has fixes thar tag v.05 does not. Can you create a new release tag ?

created time in a month

PR closed cucumber/cucumber-cpp

Fix boost 1.7x compatibility (fix #238)

<!-- These sections are meant as guidance for you. If something doesn't fit, you can just skip it. -->

Summary

Boost 1.7x introduced changes to log_build_info method in the reporter class, which broke Cucumber-cpp.

Details

Add the missing bool parameter to the log_build_info method

Motivation and Context

To keep track with Boost releases.

How Has This Been Tested?

This problem caused Cucumber-cpp to fail to build when configured with CUKE_ENABLE_BOOST_TEST=on.

  • [x] make --build build --target install
  • [x] Tested with local project

Tested with make --build against Boost 1.74

Types of changes

<!--- What types of changes does your code introduce? Put an x in all the boxes that apply: -->

  • [x] Bug fix (non-breaking change which fixes an issue).
  • [ ] New feature (non-breaking change which adds functionality).
  • [ ] Breaking change (fix or feature that would cause existing functionality to not work as expected).

Checklist:

<!--- Go over all the following points, and put an x in all the boxes that apply. --> <!--- If you're unsure about any of these, don't hesitate to ask. We're here to help! -->

  • [x] It is my own work, its copyright is implicitly assigned to the project and no substantial part of it has been copied from other sources (including Stack Overflow). In rare occasions this is acceptable, like in CMake modules where the original copyright information should be kept.
  • [x] I'm using the same code standards as the existing code (indentation, spacing, variable naming, ...).
  • [ ] I've added tests for my code.
  • [X] I have verified whether my change requires changes to the documentation *NB: The README could be updated to say which is the latest Boost version that is tested as compatible
  • [x] My change either requires no documentation change or I've updated the documentation accordingly.
  • [x] My branch has been rebased to master, keeping only relevant commits.
+4 -1

2 comments

1 changed file

dmeehan1968

pr closed time in a month

pull request commentcucumber/cucumber-cpp

Fix boost 1.7x compatibility (fix #238)

Duplicate of #225

dmeehan1968

comment created time in a month

pull request commentcucumber/cucumber-cpp

Switch to Boost from GTest, add Sensor (fix #238)

Coverage Status

Coverage remained the same at 62.47% when pulling 28a224565781dc8c46337a7f82e83cbe8d83d9cd on dmeehan1968:fix-238-boost-1.7x-compat into dd424c1a900cb41c5db9d481714eb3471ce195e3 on cucumber:master.

dmeehan1968

comment created time in a month

issue commentcucumber/cucumber-cpp

Boost 1.7x build incompatibility due to invalid method signature

Pull Request: https://github.com/cucumber/cucumber-cpp/pull/239

dmeehan1968

comment created time in a month

PR opened cucumber/cucumber-cpp

Switch to Boost from GTest, add Sensor (fix #238)

<!-- These sections are meant as guidance for you. If something doesn't fit, you can just skip it. -->

Summary

Boost 1.7x introduced changes to log_build_info method in the reporter class, which broke Cucumber-cpp.

Details

Add the missing bool parameter to the log_build_info method

Motivation and Context

To keep track with Boost releases.

How Has This Been Tested?

This problem caused Cucumber-cpp to fail to build when configured with CUKE_ENABLE_BOOST_TEST=on.

  • [x] make --build build --target install
  • [x] Tested with local project

Tested with make --build against Boost 1.74

Types of changes

<!--- What types of changes does your code introduce? Put an x in all the boxes that apply: -->

  • [x] Bug fix (non-breaking change which fixes an issue).
  • [ ] New feature (non-breaking change which adds functionality).
  • [ ] Breaking change (fix or feature that would cause existing functionality to not work as expected).

Checklist:

<!--- Go over all the following points, and put an x in all the boxes that apply. --> <!--- If you're unsure about any of these, don't hesitate to ask. We're here to help! -->

  • [x] It is my own work, its copyright is implicitly assigned to the project and no substantial part of it has been copied from other sources (including Stack Overflow). In rare occasions this is acceptable, like in CMake modules where the original copyright information should be kept.
  • [x] I'm using the same code standards as the existing code (indentation, spacing, variable naming, ...).
  • [ ] I've added tests for my code.
  • [X] I have verified whether my change requires changes to the documentation *NB: The README could be updated to say which is the latest Boost version that is tested as compatible
  • [x] My change either requires no documentation change or I've updated the documentation accordingly.
  • [x] My branch has been rebased to master, keeping only relevant commits.
+1 -1

0 comment

1 changed file

pr created time in a month

issue openedcucumber/cucumber-cpp

Boost 1.7x build incompatibility due to invalid method signature

Failing Code:

  • https://github.com/cucumber/cucumber-cpp/blob/dd424c1a900cb41c5db9d481714eb3471ce195e3/src/drivers/BoostDriver.cpp#L53

Boost commit that breaks Cucumber-cpp:

  • https://github.com/boostorg/test/commit/7e20f966dca4e4b49585bbe7654334f31b35b3db

Compiler Error:

.../cucumber-cpp/src/drivers/BoostDriver.cpp:53:10: error: 'cucumber::internal::CukeBoostLogInterceptor::log_build_info' hides overloaded virtual function [-Werror,-Woverloaded-virtual]
    void log_build_info( std::ostream&) {};
         ^
/usr/local/include/boost/test/unit_test_log_formatter.hpp:144:25: note: hidden overloaded virtual function 'boost::unit_test::unit_test_log_formatter::log_build_info' declared here: different number of parameters (2 vs 1)
    virtual void        log_build_info( std::ostream& os, bool log_build_info = true ) = 0;
                        ^
.../cucumber-cpp/src/drivers/BoostDriver.cpp:122:26: error: allocating an object of abstract class type 'cucumber::internal::CukeBoostLogInterceptor'
    logInterceptor = new CukeBoostLogInterceptor;
                         ^
/usr/local/include/boost/test/unit_test_log_formatter.hpp:144:25: note: unimplemented pure virtual method 'log_build_info' in 'CukeBoostLogInterceptor'
    virtual void        log_build_info( std::ostream& os, bool log_build_info = true ) = 0;
                        ^
2 errors generated.

created time in a month

startedsimdjson/simdjson

started time in a month

startedtrailofbits/constexpr-everything

started time in a month

startedhanickadot/compile-time-regular-expressions

started time in a month

PR closed cucumber/cucumber-cpp

Resolves compile error with Boost 1.71.0

<!-- These sections are meant as guidance for you. If something doesn't fit, you can just skip it. -->

Summary

<!--- Provide a general summary description of your changes -->

Details

<!--- Describe your changes in detail -->

Motivation and Context

<!--- Why is this change required? What problem does it solve? --> <!--- If it fixes an open issue, please link to the issue here. -->

How Has This Been Tested?

<!--- Please add tests for changes to the code, otherwise we probably won't merge it -->

<!--- Please describe in detail how you tested your changes. --> <!--- Include details of your testing environment, tests ran to see how --> <!--- your change affects other areas of the code, etc. -->

Types of changes

<!--- What types of changes does your code introduce? Put an x in all the boxes that apply: -->

  • [x] Bug fix (non-breaking change which fixes an issue).
  • [x] New feature (non-breaking change which adds functionality).
  • [x] Breaking change (fix or feature that would cause existing functionality to not work as expected).

Checklist:

<!--- Go over all the following points, and put an x in all the boxes that apply. --> <!--- If you're unsure about any of these, don't hesitate to ask. We're here to help! -->

  • [x] It is my own work, its copyright is implicitly assigned to the project and no substantial part of it has been copied from other sources (including Stack Overflow). In rare occasions this is acceptable, like in CMake modules where the original copyright information should be kept.
  • [x] I'm using the same code standards as the existing code (indentation, spacing, variable naming, ...).
  • [x] I've added tests for my code.
  • [x] I have verified whether my change requires changes to the documentation
  • [x] My change either requires no documentation change or I've updated the documentation accordingly.
  • [x] My branch has been rebased to master, keeping only relevant commits.
+5 -0

3 comments

1 changed file

dionisioedu

pr closed time in a month

push eventcucumber/cucumber-eclipse-update-site-snapshot

Deployment Bot (from Travis CI)

commit sha 016a6d8cab6376869cb1141c2edc806fa4175d60

Deploy cucumber/cucumber-eclipse-update-site-snapshot to github.com/cucumber/cucumber-eclipse-update-site-snapshot.git:gh-pages

view details

push time in 2 months

issue openedcucumber/cucumber-eclipse-update-site-snapshot

Cucumber Eclipes Plugin Snapshot updates site returns 404

Hello,

The Cucumber Plugin Snapshot update site has been giving a 404 lately https://cucumber.github.io/cucumber-eclipse-update-site-snapshot.

I am aware that the plugin can still be installed from a local copy of the update site (which can be downloaded directly from this repo), so my intent with this ticket is to learn if it is intentional that the link above does not work anymore.

Thank you so much!

created time in 2 months

PR opened cucumber/commitbit

Bump extend from 3.0.1 to 3.0.2

Bumps extend from 3.0.1 to 3.0.2. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/justmoon/node-extend/blob/main/CHANGELOG.md">extend's changelog</a>.</em></p> <blockquote> <h1>3.0.2 / 2018-07-19</h1> <ul> <li>[Fix] Prevent merging <code>proto</code> property (<a href="https://github-redirect.dependabot.com/justmoon/node-extend/issues/48">#48</a>)</li> <li>[Dev Deps] update <code>eslint</code>, <code>@ljharb/eslint-config</code>, <code>tape</code></li> <li>[Tests] up to <code>node</code> <code>v10.7</code>, <code>v9.11</code>, <code>v8.11</code>, <code>v7.10</code>, <code>v6.14</code>, <code>v4.9</code>; use <code>nvm install-latest-npm</code></li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/justmoon/node-extend/commit/8d106d23931c0802e8b88188b0aac433e13358d9"><code>8d106d2</code></a> v3.0.2</li> <li><a href="https://github.com/justmoon/node-extend/commit/e97091fa7557e106042e475ef59e654fa9d2c7ab"><code>e97091f</code></a> [Dev Deps] update <code>tape</code></li> <li><a href="https://github.com/justmoon/node-extend/commit/e841aac7ce7119606345b440b0a9e7668e848985"><code>e841aac</code></a> [Tests] up to <code>node</code> <code>v10.7</code></li> <li><a href="https://github.com/justmoon/node-extend/commit/0e68e71d93507fcc391e398bc84abd0666b28190"><code>0e68e71</code></a> [Fix] Prevent merging <strong>proto</strong> property</li> <li><a href="https://github.com/justmoon/node-extend/commit/a689700740b44846e76f8f1dc4bdf230a2cb5c0d"><code>a689700</code></a> Only apps should have lockfiles</li> <li><a href="https://github.com/justmoon/node-extend/commit/f13c1c4e51c47b90604eb2dc56cc60561e497d36"><code>f13c1c4</code></a> [Dev Deps] update <code>eslint</code>, <code>@ljharb/eslint-config</code>, <code>tape</code></li> <li><a href="https://github.com/justmoon/node-extend/commit/f3570fe5582dbfba47e60c0cd75b4fb6f01cd3fe"><code>f3570fe</code></a> [Tests] up to <code>node</code> <code>v10.0</code>, <code>v9.11</code>, <code>v8.11</code>, <code>v7.10</code>, <code>v6.14</code>, <code>v4.9</code>; use...</li> <li>See full diff in <a href="https://github.com/justmoon/node-extend/compare/v3.0.1...v3.0.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+2 -2

0 comment

1 changed file

pr created time in 2 months

create barnchcucumber/commitbit

branch : dependabot/npm_and_yarn/extend-3.0.2

created branch time in 2 months

PR opened cucumber/commitbit

Bump debug from 2.6.8 to 2.6.9

Bumps debug from 2.6.8 to 2.6.9. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/visionmedia/debug/releases">debug's releases</a>.</em></p> <blockquote> <h2>2.6.9</h2> <h3>Patches</h3> <ul> <li>Remove ReDoS regexp in <code>%o</code> formatter: <a href="https://github-redirect.dependabot.com/visionmedia/debug/issues/504">#504</a></li> </ul> <h3>Credits</h3> <p>Huge thanks to <a href="https://github.com/zhuangya">@zhuangya</a> for their help!</p> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/visionmedia/debug/blob/2.6.9/CHANGELOG.md">debug's changelog</a>.</em></p> <blockquote> <h1>2.6.9 / 2017-09-22</h1> <ul> <li>remove ReDoS regexp in %o formatter (<a href="https://github-redirect.dependabot.com/visionmedia/debug/issues/504">#504</a>)</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/visionmedia/debug/commit/13abeae468fea297d0dccc50bc55590809241083"><code>13abeae</code></a> Release 2.6.9</li> <li><a href="https://github.com/visionmedia/debug/commit/f53962e944a87e6ca9bb622a2a12dffc22a9bb5a"><code>f53962e</code></a> remove ReDoS regexp in %o formatter (<a href="https://github-redirect.dependabot.com/visionmedia/debug/issues/504">#504</a>)</li> <li>See full diff in <a href="https://github.com/visionmedia/debug/compare/2.6.8...2.6.9">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+2 -2

0 comment

1 changed file

pr created time in 2 months

create barnchcucumber/commitbit

branch : dependabot/npm_and_yarn/debug-2.6.9

created branch time in 2 months

PR opened cucumber/commitbit

Bump mime from 1.3.6 to 1.6.0

Bumps mime from 1.3.6 to 1.6.0. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/broofa/mime/releases">mime's releases</a>.</em></p> <blockquote> <h2>v1.4.1</h2> <ul> <li>Fix RegEx DoS issue</li> </ul> <h2>v1.4.0</h2> <ul> <li>[<strong>closed</strong>] support for ac3 voc files <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/159">#159</a></li> <li>[<strong>closed</strong>] Help understanding change from application/xml to text/xml <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/158">#158</a></li> <li>[<strong>closed</strong>] no longer able to override mimetype <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/157">#157</a></li> <li>[<strong>closed</strong>] application/vnd.adobe.photoshop <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/147">#147</a></li> <li>[<strong>closed</strong>] Directories should appear as something other than application/octet-stream <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/135">#135</a></li> <li>[<strong>closed</strong>] requested features <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/131">#131</a></li> <li>[<strong>closed</strong>] Make types.json loading optional? <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/129">#129</a></li> <li>[<strong>closed</strong>] Cannot find module './types.json' <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/120">#120</a></li> <li>[<strong>V2</strong>] .wav files show up as "audio/x-wav" instead of "audio/x-wave" <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/118">#118</a></li> <li>[<strong>closed</strong>] Don't be a pain in the ass for node community <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/108">#108</a></li> <li>[<strong>closed</strong>] don't make default_type global <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/78">#78</a></li> <li>[<strong>closed</strong>] mime.extension() fails if the content-type is parameterized <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/74">#74</a></li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/broofa/mime/blob/v1.6.0/CHANGELOG.md">mime's changelog</a>.</em></p> <blockquote> <h2>v1.6.0 (24/11/2017)</h2> <p><em>No changelog for this release.</em></p> <hr /> <h2>v2.0.4 (24/11/2017)</h2> <ul> <li>[<strong>closed</strong>] Switch to mime-score module for resolving extension contention issues. <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/182">#182</a></li> <li>[<strong>closed</strong>] Update mime-db to 1.31.0 in v1.x branch <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/181">#181</a></li> </ul> <hr /> <h2>v1.5.0 (22/11/2017)</h2> <ul> <li>[<strong>closed</strong>] need ES5 version ready in npm package <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/179">#179</a></li> <li>[<strong>closed</strong>] mime-db no trace of iWork - pages / numbers / etc. <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/178">#178</a></li> <li>[<strong>closed</strong>] How it works in brownser ? <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/176">#176</a></li> <li>[<strong>closed</strong>] Missing <code>./Mime</code> <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/175">#175</a></li> <li>[<strong>closed</strong>] Vulnerable Regular Expression <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/167">#167</a></li> </ul> <hr /> <h2>v2.0.3 (25/09/2017)</h2> <p><em>No changelog for this release.</em></p> <hr /> <h2>v1.4.1 (25/09/2017)</h2> <ul> <li>[<strong>closed</strong>] Issue when bundling with webpack <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/172">#172</a></li> </ul> <hr /> <h2>v2.0.2 (15/09/2017)</h2> <ul> <li>[<strong>V2</strong>] fs.readFileSync is not a function <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/165">#165</a></li> <li>[<strong>closed</strong>] The extension for video/quicktime should map to .mov, not .qt <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/164">#164</a></li> <li>[<strong>V2</strong>] [v2 Feedback request] Mime class API <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/163">#163</a></li> <li>[<strong>V2</strong>] [v2 Feedback request] Resolving conflicts over extensions <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/162">#162</a></li> <li>[<strong>V2</strong>] Allow callers to load module with official, full, or no defined types. <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/161">#161</a></li> <li>[<strong>V2</strong>] Use "facets" to resolve extension conflicts <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/160">#160</a></li> <li>[<strong>V2</strong>] Remove fs and path dependencies <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/152">#152</a></li> <li>[<strong>V2</strong>] Default content-type should not be application/octet-stream <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/139">#139</a></li> <li>[<strong>V2</strong>] reset mime-types <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/124">#124</a></li> <li>[<strong>V2</strong>] Extensionless paths should return null or false <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/113">#113</a></li> </ul> <hr /> <h2>v2.0.1 (14/09/2017)</h2> <ul> <li>[<strong>closed</strong>] Changelog for v2.0 does not mention breaking changes <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/171">#171</a></li> <li>[<strong>closed</strong>] MIME breaking with 'class' declaration as it is without 'use strict mode' <a href="https://github-redirect.dependabot.com/broofa/node-mime/issues/170">#170</a></li> </ul> <hr /> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/broofa/mime/commit/87b396e859aad0cea0845e706613d333c2b0bfdc"><code>87b396e</code></a> 1.6.0</li> <li><a href="https://github.com/broofa/mime/commit/4db512596ec929bf588162ead9e38a98d130aa63"><code>4db5125</code></a> changelog</li> <li><a href="https://github.com/broofa/mime/commit/3668c6b3ef98e9a08cd6ab2f3b56c2f6e6a9bde9"><code>3668c6b</code></a> Use mime-score module to resolve extension conflicts. Fixes <a href="https://github-redirect.dependabot.com/broofa/mime/issues/183">#183</a></li> <li><a href="https://github.com/broofa/mime/commit/949b4519c5a89484d532108f8eaa46c08772d06b"><code>949b451</code></a> 1.5.0</li> <li><a href="https://github.com/broofa/mime/commit/85672d33c1d5cc6b4fefc6867b2f4c5e1b784816"><code>85672d3</code></a> application/font-woff -> font/woff</li> <li><a href="https://github.com/broofa/mime/commit/1f6281d344a357e4f06ef57627e3aa7219fb6eb5"><code>1f6281d</code></a> chmod cli.js</li> <li><a href="https://github.com/broofa/mime/commit/c0853d2f600235c6019b57ce68f1d0845c9319b7"><code>c0853d2</code></a> update to mime-db@v1.31.0</li> <li><a href="https://github.com/broofa/mime/commit/3004636f096a513559e61e95629ea7b30eb88950"><code>3004636</code></a> Generate CHANGELOG.md via github-release-notes</li> <li><a href="https://github.com/broofa/mime/commit/eb24bae372a76acd2c95fd05f8837814c33a9e3d"><code>eb24bae</code></a> 1.4.1</li> <li><a href="https://github.com/broofa/mime/commit/855d0c4b8b22e4a80b9401a81f2872058eae274d"><code>855d0c4</code></a> Fix <a href="https://github-redirect.dependabot.com/broofa/mime/issues/167">#167</a></li> <li>Additional commits viewable in <a href="https://github.com/broofa/mime/compare/v1.3.6...v1.6.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+2 -2

0 comment

1 changed file

pr created time in 2 months

create barnchcucumber/commitbit

branch : dependabot/npm_and_yarn/mime-1.6.0

created branch time in 2 months

startedmanagarm/managarm

started time in 2 months

pull request commentcucumber/cucumber-cpp

Add support for pkg-config

Coverage Status

Coverage remained the same at 62.47% when pulling 1212a2af0fda497754db7dfe36ffd3e176411d4a on watersofoblivion:add-pkg-config into dd424c1a900cb41c5db9d481714eb3471ce195e3 on cucumber:master.

watersofoblivion

comment created time in 2 months

PR opened cucumber/cucumber-cpp

Add support for pkg-config

Summary

Adds support for pkg-config.

Details

Generates and installs cucumber-cpp.pc and cucumber-cpp-nomain.pc files. The version number is hard-coded at 0.6 (one minor past the last tagged version) in the .pc files since there doesn't appear to be a version variable to use.

The implementation was largely lifted from Googletest.

Motivation and Context

This was added to ease integration with other build systems (specifically, to be usable by flatpak + meson.)

How Has This Been Tested?

As part of the build there are no unit tests, but the change was tested manually. ("Works on my machine!")

Types of changes

  • [ ] Bug fix (non-breaking change which fixes an issue).
  • [x] New feature (non-breaking change which adds functionality).
  • [ ] Breaking change (fix or feature that would cause existing functionality to not work as expected).

Checklist:

  • [x] It is my own work, its copyright is implicitly assigned to the project and no substantial part of it has been copied from other sources (including Stack Overflow). In rare occasions this is acceptable, like in CMake modules where the original copyright information should be kept.
  • [x] I'm using the same code standards as the existing code (indentation, spacing, variable naming, ...).
  • [ ] I've added tests for my code.
  • [x] I have verified whether my change requires changes to the documentation
  • [x] My change either requires no documentation change or I've updated the documentation accordingly.
  • [x] My branch has been rebased to master, keeping only relevant commits.
+35 -0

0 comment

3 changed files

pr created time in 2 months

created repositoryKazDragon/conan-suburb

created time in 2 months

created repositorydascandy/toolsets

Nice default toolsets (that I use)

created time in 3 months

more