profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/kiapanahi/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
Kia Panahi Rad kiapanahi @clay-one Tehran, Iran https://kiapanahi.github.io Software enthusiast. Problem solving freak - not always successful though. Passionate about distributed systems, data streams and everything in between.

kiapanahi/famous-design-patterns 2

This repository contains well-known design patterns and their implementations in C#

kiapanahi/Mirza 1

A simple toolset (CLI and web) to easily log daily works

clay-one/composer-core 0

Composer is an extensible Compositional Architecture framework, providing a set of functionality such as Inversion of Control container (IoC), Dependency Injection (DI), Plug-in framework, Aspect Oriented Programming (AOP), Configurability and Composability for components.

kiapanahi/arcade 0

Tools that provide common build infrastructure for multiple .NET Foundation projects.

kiapanahi/code-settings-sync 0

🌴💪 Synchronize your Visual Studio Code Settings Across Multiple Machines using GitHub GIST 💪🌴

push eventkiapanahi/grpc-dotnet

James Newton-King

commit sha f54a118569c70ec3058a0a195879b4ce9c828882

Fix not using invariant culture with duration text (#1327)

view details

push time in a month

startedrezataroosheh/Cheatsheets

started time in 2 months

push eventkiapanahi/grpc-dotnet

John Luo

commit sha 31009f6de1fe35d724f4d25b4ffa5689f38d5363

Fix refresh argument arity (#1313)

view details

Kia Panahi Rad

commit sha 5bb5f48fc472f09da2c264b62f0e6cdb630f0a63

Improvements in Ticketer example (#1315)

view details

push time in 2 months

delete branch Anti-graviton/polland

delete branch : dependabot/pip/django-2.2.24

delete time in 2 months

push eventAnti-graviton/polland

dependabot[bot]

commit sha fcc8e29025550249821178b8c7189af7e290cd48

Bump django from 2.2.22 to 2.2.24 Bumps [django](https://github.com/django/django) from 2.2.22 to 2.2.24. - [Release notes](https://github.com/django/django/releases) - [Commits](https://github.com/django/django/compare/2.2.22...2.2.24) --- updated-dependencies: - dependency-name: django dependency-type: direct:production ... Signed-off-by: dependabot[bot] <support@github.com>

view details

Kia Panahi Rad

commit sha 19f68798dbc57c5707870480cb59cd3c5d38ca75

Merge pull request #13 from Anti-graviton/dependabot/pip/django-2.2.24 Bump django from 2.2.22 to 2.2.24

view details

push time in 2 months

PR merged Anti-graviton/polland

Bump django from 2.2.22 to 2.2.24 dependencies

Bumps django from 2.2.22 to 2.2.24. <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/django/django/commit/2da029d8540ab0b2e9edcba25c4d46c52853197f"><code>2da029d</code></a> [2.2.x] Bumped version for 2.2.24 release.</li> <li><a href="https://github.com/django/django/commit/f27c38ab5d90f68c9dd60cabef248a570c0be8fc"><code>f27c38a</code></a> [2.2.x] Fixed CVE-2021-33571 -- Prevented leading zeros in IPv4 addresses.</li> <li><a href="https://github.com/django/django/commit/053cc9534d174dc89daba36724ed2dcb36755b90"><code>053cc95</code></a> [2.2.x] Fixed CVE-2021-33203 -- Fixed potential path-traversal via admindocs'...</li> <li><a href="https://github.com/django/django/commit/6229d8794ff7d3f471e29811857d72e67f24b608"><code>6229d87</code></a> [2.2.x] Confirmed release date for Django 2.2.24.</li> <li><a href="https://github.com/django/django/commit/f163ad5c638f79d3fd0e76bed0e15e6928fae1f5"><code>f163ad5</code></a> [2.2.x] Added stub release notes and date for Django 2.2.24.</li> <li><a href="https://github.com/django/django/commit/bed1755bc596b8c83351471e4276386b2e6643c0"><code>bed1755</code></a> [2.2.x] Changed IRC references to Libera.Chat.</li> <li><a href="https://github.com/django/django/commit/63f0d7a0f6b6d762b8c15894c531b687ac843c66"><code>63f0d7a</code></a> [2.2.x] Refs <a href="https://github-redirect.dependabot.com/django/django/issues/32718">#32718</a> -- Fixed file_storage.test_generate_filename and model_fi...</li> <li><a href="https://github.com/django/django/commit/5fe4970bd0b64a24ed6f9f18db3d4a80b5ac0a78"><code>5fe4970</code></a> [2.2.x] Post-release version bump.</li> <li><a href="https://github.com/django/django/commit/61f814f9fab554d10f1e2c193bcf3a5c56c4e9ef"><code>61f814f</code></a> [2.2.x] Bumped version for 2.2.23 release.</li> <li><a href="https://github.com/django/django/commit/b8ecb0643619a0650a4447b282478ce5257856e2"><code>b8ecb06</code></a> [2.2.x] Fixed <a href="https://github-redirect.dependabot.com/django/django/issues/32718">#32718</a> -- Relaxed file name validation in FileField.</li> <li>Additional commits viewable in <a href="https://github.com/django/django/compare/2.2.22...2.2.24">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 2 months

delete branch Anti-graviton/polland

delete branch : dependabot/pip/django-2.2.22

delete time in 2 months

push eventAnti-graviton/polland

dependabot[bot]

commit sha df1a41a46f89451b46e3b204777db3587c7117fe

Bump django from 2.2.21 to 2.2.22 Bumps [django](https://github.com/django/django) from 2.2.21 to 2.2.22. - [Release notes](https://github.com/django/django/releases) - [Commits](https://github.com/django/django/compare/2.2.21...2.2.22) --- updated-dependencies: - dependency-name: django dependency-type: direct:production ... Signed-off-by: dependabot[bot] <support@github.com>

view details

Kia Panahi Rad

commit sha 06110675e5a0642746042d88231770bf15b18fa6

Merge pull request #12 from Anti-graviton/dependabot/pip/django-2.2.22 Bump django from 2.2.21 to 2.2.22

view details

push time in 2 months

PR merged Anti-graviton/polland

Bump django from 2.2.21 to 2.2.22 dependencies

Bumps django from 2.2.21 to 2.2.22. <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/django/django/commit/df9fd4661e203d41c189054d8b23d256815e14fc"><code>df9fd46</code></a> [2.2.x] Bumped version for 2.2.22 release.</li> <li><a href="https://github.com/django/django/commit/d9594c4ea57b6309d93879805302cec9ae9f23ff"><code>d9594c4</code></a> [2.2.x] Fixed <a href="https://github-redirect.dependabot.com/django/django/issues/32713">#32713</a>, Fixed CVE-2021-32052 -- Prevented newlines and tabs fro...</li> <li><a href="https://github.com/django/django/commit/163700388cda2305c8dbcdb3ac1542a442f3e955"><code>1637003</code></a> [2.2.x] Refs CVE-2021-31542 -- Skipped mock AWS storage test on Windows.</li> <li><a href="https://github.com/django/django/commit/bcafd9ba848d736769870b4fc940b2ebbf87a70a"><code>bcafd9b</code></a> [2.2.x] Added CVE-2021-31542 to security archive.</li> <li><a href="https://github.com/django/django/commit/3931dc765177b2793fe806b4a02122b1a718b1c3"><code>3931dc7</code></a> [2.2.x] Post-release version bump.</li> <li>See full diff in <a href="https://github.com/django/django/compare/2.2.21...2.2.22">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 2 months

PR opened dotnet/arcade

Update TierOneRepos.md to reflect coreclr -> runtime migration

Since the coreclr is not maintained as the runtime repo has taken its place, it seems logical to update the file accordingly.

+1 -1

0 comment

1 changed file

pr created time in 2 months

delete branch kiapanahi/arcade

delete branch : kiapanahi-update-tierOneRepos

delete time in 2 months

push eventkiapanahi/arcade

Kia Panahi Rad

commit sha 3e0be28ecb6920abd6f8d5e8b60330aba823c065

Update TierOneRepos.md

view details

Kia Panahi Rad

commit sha e2d006d0f775a8e58230ab7a69a5da14e45cb074

Merge pull request #1 from kiapanahi/kiapanahi-update-tierOneRepos Update TierOneRepos.md to reflect coreclr -> runtime migration

view details

push time in 2 months

PR merged kiapanahi/arcade

Update TierOneRepos.md to reflect coreclr -> runtime migration

Since the coreclr is not maintained as the runtime repo has taken its place, it seems logical to update the file accordingly.

+1 -1

0 comment

1 changed file

kiapanahi

pr closed time in 2 months

PR opened kiapanahi/arcade

Update TierOneRepos.md to reflect coreclr -> runtime migration

Since the coreclr is not maintained as the runtime repo has taken its place, it seems logical to update the file accordingly.

+1 -1

0 comment

1 changed file

pr created time in 2 months

create barnchkiapanahi/arcade

branch : kiapanahi-update-tierOneRepos

created branch time in 2 months

fork kiapanahi/arcade

Tools that provide common build infrastructure for multiple .NET Foundation projects.

fork in 2 months

delete branch Anti-graviton/polland

delete branch : dependabot/pip/django-2.2.21

delete time in 2 months

push eventAnti-graviton/polland

dependabot[bot]

commit sha 1954df1b5588c9c55c072d1072cca5a5c1e9a79a

Bump django from 2.2.20 to 2.2.21 Bumps [django](https://github.com/django/django) from 2.2.20 to 2.2.21. - [Release notes](https://github.com/django/django/releases) - [Commits](https://github.com/django/django/compare/2.2.20...2.2.21) --- updated-dependencies: - dependency-name: django dependency-type: direct:production ... Signed-off-by: dependabot[bot] <support@github.com>

view details

Kia Panahi Rad

commit sha e40b34273c6311324eda80127f2119324f58d053

Merge pull request #11 from Anti-graviton/dependabot/pip/django-2.2.21 Bump django from 2.2.20 to 2.2.21

view details

push time in 2 months

PR merged Anti-graviton/polland

Bump django from 2.2.20 to 2.2.21 dependencies

Bumps django from 2.2.20 to 2.2.21. <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/django/django/commit/ff1385ae45d267f455b1744fb39a9ab5de688d05"><code>ff1385a</code></a> [2.2.x] Bumped version for 2.2.21 release.</li> <li><a href="https://github.com/django/django/commit/04ac1624bdc2fa737188401757cf95ced122d26d"><code>04ac162</code></a> [2.2.x] Fixed CVE-2021-31542 -- Tightened path & file name sanitation in file...</li> <li><a href="https://github.com/django/django/commit/7f1b088ab4a4342a87a11496096471703994a006"><code>7f1b088</code></a> [2.2.x] Added CVE-2021-28658 to security archive.</li> <li><a href="https://github.com/django/django/commit/e95fbb6a7653a5f199d5d8c90a282cdf9e58fc22"><code>e95fbb6</code></a> [2.2.x] Post-release version bump.</li> <li>See full diff in <a href="https://github.com/django/django/compare/2.2.20...2.2.21">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 2 months

delete branch kiapanahi/grpc-dotnet

delete branch : examples-mailer-improvements

delete time in 2 months

push eventkiapanahi/grpc-dotnet

Kia Panahi Rad

commit sha 5d223d540e8663739da1333600ac8f46305a087b

Minor improvements in examples codebase: Mailer (#1312) Co-authored-by: James Newton-King <james@newtonking.com>

view details

push time in 2 months

delete branch Anti-graviton/polland

delete branch : dependabot/pip/urllib3-1.26.5

delete time in 2 months

push eventAnti-graviton/polland

dependabot[bot]

commit sha a6c944e59f8bcc86060960cf2fc8ff66d5005800

Bump urllib3 from 1.25.8 to 1.26.5 Bumps [urllib3](https://github.com/urllib3/urllib3) from 1.25.8 to 1.26.5. - [Release notes](https://github.com/urllib3/urllib3/releases) - [Changelog](https://github.com/urllib3/urllib3/blob/main/CHANGES.rst) - [Commits](https://github.com/urllib3/urllib3/compare/1.25.8...1.26.5) --- updated-dependencies: - dependency-name: urllib3 dependency-type: direct:production ... Signed-off-by: dependabot[bot] <support@github.com>

view details

Kia Panahi Rad

commit sha 27bf18ef0f87c45ab4ba64bbea60ffa250711220

Merge pull request #10 from Anti-graviton/dependabot/pip/urllib3-1.26.5 Bump urllib3 from 1.25.8 to 1.26.5

view details

push time in 2 months

PR merged Anti-graviton/polland

Bump urllib3 from 1.25.8 to 1.26.5 dependencies

Bumps urllib3 from 1.25.8 to 1.26.5. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/releases">urllib3's releases</a>.</em></p> <blockquote> <h2>1.26.5</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed deprecation warnings emitted in Python 3.10.</li> <li>Updated vendored <code>six</code> library to 1.16.0.</li> <li>Improved performance of URL parser when splitting the authority component.</li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.4</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Changed behavior of the default <code>SSLContext</code> when connecting to HTTPS proxy during HTTPS requests. The default <code>SSLContext</code> now sets <code>check_hostname=True</code>.</li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.3</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li> <p>Fixed bytes and string comparison issue with headers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2141">#2141</a>)</p> </li> <li> <p>Changed <code>ProxySchemeUnknown</code> error message to be more actionable if the user supplies a proxy URL without a scheme (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2107">#2107</a>)</p> </li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.2</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed an issue where <code>wrap_socket</code> and <code>CERT_REQUIRED</code> wouldn't be imported properly on Python 2.7.8 and earlier (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2052">#2052</a>)</li> </ul> <h2>1.26.1</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed an issue where two <code>User-Agent</code> headers would be sent if a <code>User-Agent</code> header key is passed as <code>bytes</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2047">#2047</a>)</li> </ul> <h2>1.26.0</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li> <p>Added support for HTTPS proxies contacting HTTPS servers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1923">#1923</a>, Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1806">#1806</a>)</p> </li> <li> <p>Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning should opt-in explicitly by setting <code>ssl_version=ssl.PROTOCOL_TLSv1_1</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2002">#2002</a>) <strong>Starting in urllib3 v2.0: Connections that receive a <code>DeprecationWarning</code> will fail</strong></p> </li> <li> <p>Deprecated <code>Retry</code> options <code>Retry.DEFAULT_METHOD_WHITELIST</code>, <code>Retry.DEFAULT_REDIRECT_HEADERS_BLACKLIST</code> and <code>Retry(method_whitelist=...)</code> in favor of <code>Retry.DEFAULT_ALLOWED_METHODS</code>, <code>Retry.DEFAULT_REMOVE_HEADERS_ON_REDIRECT</code>, and <code>Retry(allowed_methods=...)</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2000">#2000</a>) <strong>Starting in urllib3 v2.0: Deprecated options will be removed</strong></p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/blob/main/CHANGES.rst">urllib3's changelog</a>.</em></p> <blockquote> <h2>1.26.5 (2021-05-26)</h2> <ul> <li>Fixed deprecation warnings emitted in Python 3.10.</li> <li>Updated vendored <code>six</code> library to 1.16.0.</li> <li>Improved performance of URL parser when splitting the authority component.</li> </ul> <h2>1.26.4 (2021-03-15)</h2> <ul> <li>Changed behavior of the default <code>SSLContext</code> when connecting to HTTPS proxy during HTTPS requests. The default <code>SSLContext</code> now sets <code>check_hostname=True</code>.</li> </ul> <h2>1.26.3 (2021-01-26)</h2> <ul> <li> <p>Fixed bytes and string comparison issue with headers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2141">#2141</a>)</p> </li> <li> <p>Changed <code>ProxySchemeUnknown</code> error message to be more actionable if the user supplies a proxy URL without a scheme. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2107">#2107</a>)</p> </li> </ul> <h2>1.26.2 (2020-11-12)</h2> <ul> <li>Fixed an issue where <code>wrap_socket</code> and <code>CERT_REQUIRED</code> wouldn't be imported properly on Python 2.7.8 and earlier (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2052">#2052</a>)</li> </ul> <h2>1.26.1 (2020-11-11)</h2> <ul> <li>Fixed an issue where two <code>User-Agent</code> headers would be sent if a <code>User-Agent</code> header key is passed as <code>bytes</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2047">#2047</a>)</li> </ul> <h2>1.26.0 (2020-11-10)</h2> <ul> <li> <p><strong>NOTE: urllib3 v2.0 will drop support for Python 2</strong>. <code>Read more in the v2.0 Roadmap <https://urllib3.readthedocs.io/en/latest/v2-roadmap.html></code>_.</p> </li> <li> <p>Added support for HTTPS proxies contacting HTTPS servers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1923">#1923</a>, Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1806">#1806</a>)</p> </li> <li> <p>Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning</p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/urllib3/urllib3/commit/d1616473df94b94f0f5ad19d2a6608cfe93b7cdf"><code>d161647</code></a> Release 1.26.5</li> <li><a href="https://github.com/urllib3/urllib3/commit/2d4a3fee6de2fa45eb82169361918f759269b4ec"><code>2d4a3fe</code></a> Improve performance of sub-authority splitting in URL</li> <li><a href="https://github.com/urllib3/urllib3/commit/2698537d52f8ff1f0bbb1d45cf018b118e91f637"><code>2698537</code></a> Update vendored six to 1.16.0</li> <li><a href="https://github.com/urllib3/urllib3/commit/07bed791e9c391d8bf12950f76537dc3c6f90550"><code>07bed79</code></a> Fix deprecation warnings for Python 3.10 ssl module</li> <li><a href="https://github.com/urllib3/urllib3/commit/d725a9b56bb8baf87c9e6eee0e9edf010034b63b"><code>d725a9b</code></a> Add Python 3.10 to GitHub Actions</li> <li><a href="https://github.com/urllib3/urllib3/commit/339ad34c677c98fd9ad008de1d8bbeb9dbf34381"><code>339ad34</code></a> Use pytest==6.2.4 on Python 3.10+</li> <li><a href="https://github.com/urllib3/urllib3/commit/f271c9c3149e20d7feffb6429b135bbb6c09ddf4"><code>f271c9c</code></a> Apply latest Black formatting</li> <li><a href="https://github.com/urllib3/urllib3/commit/1884878aac87ef0494b282e940c32c24ee917d52"><code>1884878</code></a> [1.26] Properly proxy EOF on the SSLTransport test suite</li> <li><a href="https://github.com/urllib3/urllib3/commit/a8913042b676c510e94fc2b097f6b514ae11a537"><code>a891304</code></a> Release 1.26.4</li> <li><a href="https://github.com/urllib3/urllib3/commit/8d65ea1ecf6e2cdc27d42124e587c1b83a3118b0"><code>8d65ea1</code></a> Merge pull request from GHSA-5phf-pp7p-vc2r</li> <li>Additional commits viewable in <a href="https://github.com/urllib3/urllib3/compare/1.25.8...1.26.5">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 2 months

PR opened grpc/grpc-dotnet

Improvements in Ticketer example

Adds using statement in client project for disposable objects. specifically HttpClient, HttpRequestMessage and HttpResponseMessage in Authenticate method.

+3 -3

0 comment

1 changed file

pr created time in 2 months

create barnchkiapanahi/grpc-dotnet

branch : examples-improvements-ticketer

created branch time in 2 months

PR opened grpc/grpc-dotnet

Minor improvements in examples codebase: Mailer

Small improvements in the Mailer example codebase including:

  • argument length checks
  • adding readonly modifier
  • replacing class and ValueTuple types with records
+12 -19

0 comment

4 changed files

pr created time in 2 months

PR closed grpc/grpc-dotnet

Minor improvements in examples codebase: Mailer

Small improvements in the Mailer example codebase including:

  • argument length checks
  • adding readonly modifier
  • replacing class and ValueTuple types with records
+12 -19

1 comment

4 changed files

kiapanahi

pr closed time in 2 months

startedgrpc/grpc-dotnet

started time in 2 months