profile
viewpoint

Ask questionsIn setup branch, app comes up blank, console reports a javascript error

Describe the bug I tried running this app locally but it came up with a blank web page and an error in the console.

To Reproduce Steps to reproduce the behavior:

  1. git clone -b setup git@github.com:kimobrian/TwilioReact.git
  2. cd TwilioReact
  3. Put secrets into .env
  4. npm start
  5. Load localhost:3000 in a browser

Expected behavior The app should appear.

Screenshots Instead, it comes up blank with an error in the console: Screen Shot 2020-04-19 at 12 46 49 PM

Environment (please complete the following information):

  • OS: Mac OS X Mojave
  • Browser: Chrome
  • App Version: 1d478b6d89f8fa8a7b9a733596ab77aced880b31
  • SDK Version: I didn't find it.
  • Node.js version: 13.11.0

A quick fix was to pin react and react-dom to version 16.2.0, based on what I found at https://stackoverflow.com/questions/52251687/uncaught-typeerror-cannot-read-property-injection-of-undefined:

[ ~/src/speakeasy/speakeasy-twilio ] git diff
diff --git a/package.json b/package.json
index ff70e9a..00c77c7 100644
--- a/package.json
+++ b/package.json
@@ -11,8 +11,8 @@
     "express": "^4.16.2",
     "faker": "^4.1.0",
     "material-ui": "^0.20.0",
-    "react": "^16.2.0",
-    "react-dom": "^16.2.0",
+    "react": "16.2.0",
+    "react-dom": "16.2.0",
     "react-tap-event-plugin": "^3.0.2"
   },
   "scripts": {
twilio/twilio-video-app-react

Answer questions ijt

Got it, thanks @timmydoza .

useful!

Related questions

No questions were found.
Github User Rank List