profile
viewpoint

Ask questionstype-fest peer dependency warning

NPM warns that v0.4.3 requires a peer of type-fest@^0.13.1 when type-fest@^0.17.0 is installed. Would it be possible to use "type-fest": ">=0.13.1" instead of "type-fest": "^0.13.1"?

pmmmwh/react-refresh-webpack-plugin

Answer questions yyynnn

this is s also breaking regular install on npm 7.0.4

npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! Found: type-fest@0.18.0 npm ERR! node_modules/type-fest npm ERR! dev type-fest@"0.18.0" from the root project npm ERR! npm ERR! Could not resolve dependency: npm ERR! peerOptional type-fest@"^0.13.1" from @pmmmwh/react-refresh-webpack-plugin@0.4.3 npm ERR! node_modules/@pmmmwh/react-refresh-webpack-plugin npm ERR! dev @pmmmwh/react-refresh-webpack-plugin@"0.4.3" from the root project npm ERR! npm ERR! Fix the upstream dependency conflict, or retry npm ERR! this command with --force, or --legacy-peer-deps npm ERR! to accept an incorrect (and potentially broken) dependency resolution. npm ERR!

useful!
source:https://uonfu.com/
answerer
Sergio Nikolaev yyynnn BI.ZONE Moscow, RU https://innotechnum.com/ Frontend teamlead at Иннотех (VTB) @yyynnncompute - telegram
Github User Rank List