profile
viewpoint

Ask questionsError while executing command 'react-native run-ios --simulator --no-packager'

Actual Behavior

  1. When I run the Debug iOS, the console outputs the following 'Could not debug. Error while executing command react-native run-ios --simulator --no-packager: Error while executing command react-native run- Ios --simulator --no-packager

Expected Behavior

  1. Running Debug iOS successfully

Software versions

  • React-Native VS Code extension version: 0.6.18
  • VSCode version: 1.28.2
  • OS platform and version: macOS High Sierra 10.13.2 (17C88)
  • NodeJS version: v11.0.0
  • React Native version: 0.56.0
  • Expo SDK version (include if relevant): iOS 11.2

Outputs (Include if relevant)

  • Output of the Debug Console (View -> Toggle Debug Console):
OS: darwin x64
Adapter node: v8.9.3 x64
vscode-chrome-debug-core: 3.17.3
Could not debug. Error while executing command 'react-native run-ios --simulator --no-packager': Error while executing command 'react-native run-ios --simulator --no-packager'
  • Output of the React-Native output channel (View -> Toggle Output -> Select React-Native in ListBox):
[Error] Error: Error while executing command 'react-native run-ios --simulator --no-packager': Error while executing command 'react-native run-ios --simulator --no-packager'
  • Output of the Developer Tools console (Help -> Toggle Developer Tools -> Select Console tab):
microsoft/vscode-react-native

Answer questions codingplayboy

Hi, please Help, I had this error too. 屏幕快照 2019-06-08 下午10 16 51

How can I change the adapter node version ? It's ok when run this command in terminal with node v10.9.0.

useful!

Related questions

Error while executing command 'react-native.cmd run-android --no-packager' (error code 101) hot 4
Cannot read property 'getCurrentUserAsync' of undefined hot 1
Expo app doesn't connect to packager hot 1
Current workspace does not contain React Native projects hot 1
Could not debug - error code 604 hot 1
Current workspace does not contain React Native projects hot 1
Version 0.13 breaks running packager from VS Code from different folder hot 1
Error while executing command 'react-native.cmd run-android --no-packager': Error while executing command 'react-native.cmd run-android --no-packager' (error code 101) hot 1
Starting React packager from VSCode fails hot 1
Can't attach packager for debugging hot 1
Cannot bind listener: operation not permitted hot 1
Not all success patterns were matched. (error code 712) hot 1
Current workspace does not contain React Native projects hot 1
Cannot bind listener: operation not permitted hot 1
Could not debug - error code 604 hot 1
Github User Rank List