Ask questionsOut-of-date requirements file


You have an out-of-date requirements file.

psycopg-2.7.4 is not compatible with python 3.8.*

If you leave it unchanged and try to run a remote docker folder, you will get this issue (because of old version of psycopg2 which is not compatible with python 3.8.*).


It also was discussed in this thread:

You can simply fix it by replacing the version of psycopg2 in requirements file with the last stable version of psycopg from (2.8.5 for instance)

Replace this

psycopg2==2.7.4 --no-binary psycopg2

with this

psycopg2==2.8.5 --no-binary psycopg2

djangorestframework-3.9.1 is not compatible with django 3.*

It won't let you to migrate your models, if you don't update. Because of deprecated django.utils.six module.

Solution: pip install djangorestframework --upgrade

whitenoise-4.1 is not compatible with django 3.*

Same as above. Now it won't let you run server. Again this six import!!

Solution: pip install whitenoise --upgrade


Answer questions luabud

Thanks @mishagin-tim for bringing it up! I updated the packages, it's working for me but it'd be great if others could confirm 😊


Related questions

No questions were found.
Github User Rank List