Ask questionsOut-of-date requirements file
You have an out-of-date requirements file.
If you leave it unchanged and try to run a remote docker folder, you will get this issue (because of old version of psycopg2 which is not compatible with python 3.8.*).
It also was discussed in this thread: https://github.com/psycopg/psycopg2/issues/854#issuecomment-636526605
You can simply fix it by replacing the version of psycopg2 in requirements file with the last stable version of psycopg from psycopg.com (2.8.5 for instance)
psycopg2==2.7.4 --no-binary psycopg2
psycopg2==2.8.5 --no-binary psycopg2
It won't let you to migrate your models, if you don't update. Because of deprecated django.utils.six module.
pip install djangorestframework --upgrade
Same as above. Now it won't let you run server. Again this six import!!
pip install whitenoise --upgrade
Answer questions luabud
Thanks @mishagin-tim for bringing it up! I updated the packages, it's working for me but it'd be great if others could confirm 😊
Related questionsNo questions were found.