profile
viewpoint

Ask questions[2.3 beta 3] Packages incompatibles with beta 3

After update to beta 3, I got this error:

/usr/local/bin/meteor --settings ./settings/settings-development.json
[[[[[ ~/Documents/versus-api-player ]]]]]

=> Started proxy.
=> [HMR] Dev server listening on port 3003.
Browserslist: caniuse-lite is outdated. Please run next command `npm update`
W20210528-16:59:27.405(-5)? (STDERR) The package alanning:roles at 1.2.10 is incompatible with Meteor 0.9.0 or later. 
W20210528-16:59:27.475(-5)? (STDERR) If a new, compatible version of this package exists, running 'meteor update' should cause you to update. 
W20210528-16:59:28.320(-5)? (STDERR) /Users/diavrank/.meteor/packages/meteor-tool/.2.3.0-beta.3.1s1vdmj.vphk++os.osx.x86_64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:280
W20210528-16:59:28.320(-5)? (STDERR) 						throw(ex);
W20210528-16:59:28.320(-5)? (STDERR) 						^
W20210528-16:59:28.320(-5)? (STDERR) 
W20210528-16:59:28.321(-5)? (STDERR) TypeError: Cannot read property '_handleConnect' of undefined
W20210528-16:59:28.321(-5)? (STDERR)     at exposeLivedata (packages/lamhieu_meteorx.js:26:25)
W20210528-16:59:28.321(-5)? (STDERR)     at packages/lamhieu_meteorx.js:200:1
W20210528-16:59:28.321(-5)? (STDERR)     at packages/lamhieu_meteorx.js:225:4
W20210528-16:59:28.321(-5)? (STDERR)     at packages/lamhieu_meteorx.js:233:3
W20210528-16:59:28.321(-5)? (STDERR)     at /Users/diavrank/Documents/versus-api-player/.meteor/local/build/programs/server/boot.js:401:38
W20210528-16:59:28.321(-5)? (STDERR)     at Array.forEach (<anonymous>)
W20210528-16:59:28.321(-5)? (STDERR)     at /Users/diavrank/Documents/versus-api-player/.meteor/local/build/programs/server/boot.js:226:21
W20210528-16:59:28.322(-5)? (STDERR)     at /Users/diavrank/Documents/versus-api-player/.meteor/local/build/programs/server/boot.js:464:7
W20210528-16:59:28.322(-5)? (STDERR)     at Function.run (/Users/diavrank/Documents/versus-api-player/.meteor/local/build/programs/server/profile.js:280:14)
W20210528-16:59:28.322(-5)? (STDERR)     at /Users/diavrank/Documents/versus-api-player/.meteor/local/build/programs/server/boot.js:463:13
=> Exited with code: 1
=> Your application is crashing. Waiting for file change.

I don't know why meteor downgrade some packages that I have:

  • alanning:roles* downgraded from 3.2.3 to 1.2.10
  • socialize:server-presence* downgraded from 1.0.3 to 0.1.3
  • socialize:user-presence* downgraded from 1.0.3 to 0.4.0
(base) ➜  versus-api-player git:(meteor-latest) meteor update --release 2.3-beta.3
                                                                                   
Changes to your project's package version selections from updating the release:
                                              
accounts-base*               upgraded from 1.9.0 to 2.0.0-beta230.3
accounts-password*           upgraded from 1.7.1 to 2.0.0-beta230.3
alanning:roles*              downgraded from 3.2.3 to 1.2.10
aldeed:collection2           removed from your project
aldeed:schema-deny           removed from your project
aldeed:schema-index          removed from your project
babel-compiler               upgraded from 7.6.2-beta230.1 to 7.6.2-beta230.3
ddp-client                   upgraded from 2.4.1 to 2.5.0-beta230.3
ddp-rate-limiter             upgraded from 1.0.9 to 1.1.0-beta230.3
ddp-server                   upgraded from 2.4.0-beta230.0 to 2.4.0-beta230.3
dynamic-import               upgraded from 0.7.0-beta230.1 to 0.7.0-beta230.3
ecmascript                   upgraded from 0.15.1 to 0.15.2-beta230.3
email                        upgraded from 2.1.0-beta230.1 to 2.1.0-beta230.3
launch-screen                upgraded from 1.3.0-beta230.1 to 1.3.0-beta230.3
matb33:collection-hooks      removed from your project
meteor-base                  upgraded from 1.4.0 to 1.5.0-beta230.3
minimongo                    upgraded from 1.6.2 to 1.7.0-beta230.3
mongo                        upgraded from 1.11.1 to 1.12.0-beta230.3
promise                      upgraded from 0.12.0-beta230.1 to 0.12.0-beta230.3
raix:eventemitter            removed from your project
service-configuration        upgraded from 1.0.11 to 1.1.0-beta230.3
socialize:base-model         removed from your project
socialize:linkable-model     removed from your project
socialize:server-presence*   downgraded from 1.0.3 to 0.1.3
socialize:server-time        removed from your project
socialize:user-model         removed from your project
socialize:user-presence*     downgraded from 1.0.3 to 0.4.0
socket-stream-client         upgraded from 0.3.3 to 0.4.0-beta230.3
srp                          removed from your project
tmeasday:check-npm-versions  removed from your project
typescript                   upgraded from 4.2.4-beta230.1 to 4.3.2-beta230.3
webapp                       upgraded from 1.11.0-beta230.1 to 1.11.0-beta230.3

                                              
* These packages have been updated to new versions that are not backwards
compatible.
versus-api-player: updated to Meteor 2.3-beta.3.

I tried to update them but It doesn't work:

(base) ➜  versus-api-player git:(meteor-latest) ✗ meteor update accounts-password alanning:roles meteor-base socialize:user-presence
The specified packages are at their latest compatible versions.

I also tried with this command:

(base) ➜  versus-api-player git:(meteor-latest) ✗ meteor update
Not updating the release, because this app is at a newer release (METEOR@2.3-beta.3) than the latest recommended release (METEOR@2.2).
                                              
Changes to your project's package version selections from updating package versions:
                                              
http                         upgraded from 1.4.3 to 1.4.4
static-html                  upgraded from 1.3.0 to 1.3.1
tunguska:reactive-aggregate  upgraded from 1.3.3 to 1.3.6

                                              
The following top-level dependencies were not updated to the very latest version available:
 * accounts-password 2.0.0-beta230.3 (2.2.0-beta.3 is available)
 * alanning:roles 1.2.10 (3.2.3 is available) 
 * meteor-base 1.5.0-beta230.3 (2.0.0-beta230.2 is available)
 * socialize:user-presence 0.4.0 (1.0.3 is available)
                                              
Newer versions of the following indirect dependencies are available:
 * meteortesting:mocha-core 8.0.1 (8.1.2 is available)
 * socialize:server-presence 0.1.3 (1.0.3 is available)
 * spacebars 1.0.15 (1.1.0 is available)      
These versions may not be compatible with your project.
To update one or more of these packages to their latest
compatible versions, pass their names to `meteor update`,
or just run `meteor update --all-packages`.

but only update other packages.

Notes:

  • Meteor beta 1 to beta 3
  • Node 14.17
  • Mac 11.3.1
meteor/meteor

Answer questions dokithonon

Hello, I am not sure but the package mizzao:timesync may need also a patch

While selecting package versions:
   error: Conflict: Constraint mizzao:timesync@0.5.1 is not satisfied by mizzao:timesync 0.1.3.
   Constraints on package "mizzao:timesync":
   * mizzao:timesync@0.5.1 <- mizzao:user-status 1.0.1
useful!
source:https://uonfu.com/
answerer
Thomas Doki-Thonon dokithonon Rationalk Estavayer-le-Lac, Switzerland https://rationalk.ch Director at Rationalk
Github User Rank List