profile
viewpoint

Ask questionsgo install throws this error: cannot find package

Can you guide me what i am missing :

I get the following error message:

cannot find package "github.com/gohugoio/hugo/commands" in any of: /usr/local/Cellar/go/1.10.3/libexec/src/github.com/gohugoio/hugo/commands (from $GOROOT) /Users/user1/go/src/github.com/gohugoio/hugo/commands (from $GOPATH)

gohugoio/hugo

Answer questions stuartcw

Hugo uses the Go Modules support built into Go 1.11 to build.

This is the important part of the process that people have missed if you get this problem. It would be kinder if the documentation said "run go version and don't proceed any further until your version is at least 1.11". I almost gave up when I found that I was going to have to join the discord to get a simple answer to this problem.

useful!
source:https://uonfu.com/
answerer
Stuart Woodward stuartcw Hanamaru K.K. Yokosuka, Japan Englishman in Tokyo since 1988.
Github User Rank List