profile
viewpoint

Ask questionsUpdate the API usage to fetch interpreter path

@formulahendry Apologies, It turns out we are updating the API again (https://github.com/microsoft/vscode-python/issues/12596). You'll have to change the usage accordingly,

  • Introduce a flag in your package.json file so we can ask users to upgrade code runner (https://github.com/microsoft/vscode-python/pull/12765#issuecomment-654320227)
  • Add yet another condition which introspect what APIs we expose and choose which one to use. IOW do a hasattr check.

The PR is in review at the moment https://github.com/microsoft/vscode-python/issues/12596

I'll let you know when it's finalized after which you need to publish the code runner extension.

formulahendry/vscode-code-runner

Answer questions karrtikr

Looks good to me👍 please proceed.

useful!

Related questions

The token '&&' is not a valid statement separator in this version. hot 2
command 'code-runner.run' not found hot 1
command 'code-runner.run' not found hot 1
What is tempCodeRunnerFile? - vscode-code-runner hot 1
atob and btoa are not defined hot 1
code-runner.executorMap support for env variables ${env:CONDA_DEFAULT_ENV} hot 1
Previous output not being cleared. hot 1
Проблемы с code-runner помогите пожалуйста hot 1
The token '&&' is not a valid statement separator in this version. hot 1
Github User Rank List