profile
viewpoint

Ask questionsTask 'assembleAarRelease' not found in root project 'android_generated'. Some candidates are: 'assembleRelease'.

<!-- Thank you for using Flutter!

 If you are looking for support, please check out our documentation
 or consider asking a question on Stack Overflow:
  * https://flutter.dev/
  * https://api.flutter.dev/
  * https://stackoverflow.com/questions/tagged/flutter?sort=frequent

 If you have found a bug or if our documentation doesn't have an answer
 to what you're looking for, then fill our the template below. Please read
 our guide to filing a bug first: https://flutter.dev/docs/resources/bug-reports

-->

Steps to Reproduce

<!-- Please tell us exactly how to reproduce the problem you are running into.

 Please attach a small application (ideally just one main.dart file) that
 reproduces the problem. You could use https://gist.github.com/ for this.

 If the problem is with your application's rendering, then please attach
 a screenshot and explain what the problem is.

-->

By following instructions here, I created a flutter module with flutter create -t module, and run

$ cd some/path/my_flutter
$ flutter build aar

The output is:

Initializing gradle...                                              0.4s
Resolving dependencies...                                           2.2s
Running Gradle task 'assembleAarRelease'...                             
Running Gradle task 'assembleAarRelease'... Done                    0.6s
Configuration on demand is an incubating feature.


FAILURE: Build failed with an exception.

* What went wrong:
Task 'assembleAarRelease' not found in root project 'android_generated'. Some candidates are: 'assembleRelease'.

* Try:
Run gradlew tasks to get a list of available tasks. Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 473ms


Gradle task assembleAarRelease failed with exit code 0.

<!-- Please tell us which target platform(s) the problem occurs (Android / iOS / Web / macOS / Linux / Windows) Which target OS version, for Web, browser, is the test system running? Does the problem occur on emulator/simulator as well as on physical devices? -->

Target Platform: Target OS version/browser: Devices:

flutter doctor information:

Doctor summary (to see all details, run flutter doctor -v):
[✓] Flutter (Channel master, v1.10.15-pre.137, on Mac OS X 10.14.4 18E2034, locale en-CN)
flutter/flutter

Answer questions jianzhongli

I'm unable to repro this issue. Are you still able to repro this problem if you flutter upgrade?

Yes, the problem still exists.

Reproduce steps:

flutter create -t module my_flutter
cd my_flutter
flutter build aar

Flutter version:

Flutter 1.10.17-pre.70 • channel master • https://github.com/flutter/flutter
Framework • revision 01f4f1ac55 (10 hours ago) • 2019-11-12 18:25:53 -0800
Engine • revision 31cd2dfca2
Tools • Dart 2.7.0
useful!
source:https://uonfu.com/
Github User Rank List