profile
viewpoint

Ask questionshintfull setting is not respected

I've configured hintfull in fontconfig:

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="font">
  <edit mode="assign" name="hintstyle">
   <const>hintfull</const>
  </edit>
 </match>
</fontconfig>

This is recognized by alacritty. I've not disabled antialiasing for any font. Therefore alacritty uses the following code path:

https://github.com/alacritty/alacritty/blob/fde2424b398dadd2310686b365041189decd1d63/font/src/ft/mod.rs#L491

hintfull is not applied in this case.

Disabling antialiasing via fontconfig makes the font ragged in alacritty and other programs and is therefore not an option.

This problem is specific to alacritty. Hinting works as expected in all other programs I'm using.

The following patch fixes the problem:

diff --git a/font/src/ft/mod.rs b/font/src/ft/mod.rs
index d393b63..76b0dc7 100644
--- a/font/src/ft/mod.rs
+++ b/font/src/ft/mod.rs
@@ -453,7 +453,7 @@ impl FreeTypeRasterizer {
     }
 
     fn ft_load_flags(pattern: &PatternRef) -> freetype::face::LoadFlag {
-        let antialias = pattern.antialias().next().unwrap_or(true);
+        let antialias = pattern.antialias().next().unwrap_or(false);
         let hinting = pattern.hintstyle().next().unwrap_or(fc::HintStyle::Slight);
         let rgba = pattern.rgba().next().unwrap_or(fc::Rgba::Unknown);
         let embedded_bitmaps = pattern.embeddedbitmap().next().unwrap_or(true);

Current master with antialiasing enabled: 2020-03-30-094447_412x159_scrot Current master with the patch applied and antialiasing enabled: 2020-03-30-094529_371x156_scrot Current master with antialiasing disabled: 2020-03-30-094617_345x151_scrot

alacritty/alacritty

Answer questions mahkoh

As for the sharpened variant seen in the images posted in #3534 (comment), the only way I get something like that anywhere is if I do export FREETYPE_PROPERTIES="truetype:interpreter-version=35"

That's in fact what I'm using.

I.e. use the legacy freetype interpreter (the default up to FreeType 2.6).

"legacy" seems a bit ambiguous. interpreter-version=35 is a fully supported setting of freetype.

useful!

Related questions

No questions were found.
source:https://uonfu.com/
Github User Rank List