profile
viewpoint
Francis francisschmaltz HealthJoy Chicago I design things.

francisschmaltz/bound 10

Rails app for Bind – fork of @adamcooke/bound@fd4a04e

francisschmaltz/nest-remote-sensor 9

NodeJS app to expose an endpoint for Nest Remote Temperature Sensors

francisschmaltz/pge-status 2

Check PG&E for outages – even if their site is down

francisschmaltz/AOC2020 0

My shitty solutions for Advent of Code 2020 in (Node) JS

francisschmaltz/artnet 0

Send ArtDMX to an Art-Net node (DMX512, Stage Lighting) 💡🎬

francisschmaltz/CASino 0

CASino is a Ruby-based Single Sign-On solution supporting the CAS standard

francisschmaltz/conductor-ui 0

Netflix's Conductor UI Docker container

francisschmaltz/dcosprep 0

Scripts to setup DCOS on Ubuntu and CentOS for Zeta

francisschmaltz/francis-vyos-lts 0

VyOS LTS ISO Build

issue commentKraigM/homebridge-nest

Problem Handling Multiple Homes

Has this been solved yet?

AntonStewart

comment created time in 21 days

created repositoryacviana/advent-of-code-2020

Solutions to 2020 Advent of Code Challenge in Python

created time in 2 months

startedChrisRG/AOC2020

started time in 2 months

MemberEvent

created repositoryacviana/picture-perfect

A Streamlit dashboard to help you hang pictures neatly.

created time in 2 months

created repositoryacviana/picture-perfect

A Streamlit dashboard to help you hang pictures neatly.

created time in 2 months

issue closedKraigM/homebridge-nest

Homebridge on synology for Nest Problems throw new Error("The requested platform '" + name + "' was not registered by any plugin.");

capture d ecran 2017-05-07 a 14 39 58 Hi i am sorry french for the translation. I have a problem installing the Nest plugins on my Synology with the Docker application. When I run the program I have this answer:

Logged in as: stdout 12:29:28 root stdout 12:29:28 /root/.homebridge/.env not found. stdout 12:29:28 Default env variables will be used. stdout 12:29:28 Installing plugins from /root/.homebridge/package.json. stdout 12:29:31 [?25l[..................] / normalizeTree: sill install loadCurrentTree [..................] / normalizeTree: sill install loadCurrentTree [..................] / normalizeTree: sill install loadCurrentTree [..................] / normalizeTree: sill install loadCurrentTree [..................] / normalizeTree: sill install loadCurrentTree [..................] / normalizeTree: sill install loadCurrentTree [..................] / normalizeTree: sill install loadCurrentTree [ ...............] - cloneCurrentTree: sill cloneCurrentTree Finishing [ ...........] / loadDeps: sill install loadAllDepsIntoIdealTree [ ........] \ diffTrees: sill install generateActionsToTake [ .....] \ fetch: sill doParallel fetch 0 [ ..] - build:homebridge-nest: sill lifecycle homebridge-nest@1.

[?25h/root/.homebridge/install.sh not found. stdout 12:29:31 *** WARNING *** The program 'nodejs' uses the Apple Bonjour compatibility layer of Avahi. stdout 12:29:31 *** WARNING *** Please fix your application to use the native API of Avahi! stdout 12:29:31 *** WARNING *** For more information see http://0pointer.de/avahi-compat?s=libdns_sd&e=nodejs stdout 12:29:31 *** WARNING *** The program 'nodejs' called 'DNSServiceRegister()' which is not supported (or only supported partially) in the Apple Bonjour compatibility layer of Avahi. stdout 12:29:31 *** WARNING *** Please fix your application to use the native API of Avahi! stdout 12:29:31 *** WARNING *** For more information see http://0pointer.de/avahi-compat?s=libdns_sd&e=nodejs&f=DNSServiceRegister stdout 12:29:33 [5/7/2017, 12:29:33 PM] No plugins found. See the README for information on installing plugins. stdout 12:29:33 [5/7/2017, 12:29:33 PM] Loaded config.json with 1 accessories and 1 platforms. stdout 12:29:33 [5/7/2017, 12:29:33 PM] --- stdout 12:29:33 [5/7/2017, 12:29:33 PM] Loading 1 platforms... stdout 12:29:33 /usr/lib/node_modules/homebridge/lib/api.js:122 stdout 12:29:33 throw new Error("The requested platform '" + name + "' was not registered by any plugin."); stdout 12:29:33 ^ stdout 12:29:33 stdout 12:29:33 Error: The requested platform 'Nest' was not registered by any plugin. stdout 12:29:33 at API.platform (/usr/lib/node_modules/homebridge/lib/api.js:122:13) stdout 12:29:33 at Server._loadPlatforms (/usr/lib/node_modules/homebridge/lib/server.js:284:45) stdout 12:29:33 at Server.run (/usr/lib/node_modules/homebridge/lib/server.js:80:36) stdout 12:29:33 at module.exports (/usr/lib/node_modules/homebridge/lib/cli.js:40:10) stdout 12:29:33 at Object.<anonymous> (/usr/lib/node_modules/homebridge/bin/homebridge:17:22) stdout 12:29:33 at Module._compile (module.js:556:32) stdout 12:29:33 at Object.Module._extensions..js (module.js:565:10) stdout 12:29:33 at Module.load (module.js:473:32) stdout 12:29:33 at tryModuleLoad (module.js:432:12) stdout 12:29:33 at Function.Module._load (module.js:424:3)

could you help me please? I can not seem to get it working. You must also know that my config.json file works on the homebridge that I have configured on my MAC. I have only one problem when I enter it on the synology (Docker). Thank you very much for your help I do not think to be very far.

Here is my Config.json file

{ "bridge": { "name": "Homebridge", "username": "CC:22:3D:E3:CE:51", "port": 51826, "pin": "031-45-154" }, "description": "This is an example configuration file for homebridge synology plugin", "hint": "Always paste into jsonlint.com validation page before starting your homebridge, saves a lot of frustration", "accessories": [ { "accessory": "Synology", "name": "Diskstation", "ip": "192.168.1.58", "mac": "00-11-32-64-EC-F9", "port": "5000", "secure": false, "account": "admin", "password": "Satine20", "version": 6 }], "platforms": [{ "platform": "Nest", "token": "c.DKCoPqxfnSkmDnWsawzwdmeUd0nTD8b6SVDwiwJ0vYbe7vPoYjqBQjUuVwCG7YB4kGw4jFFwZzswE7SbksSYm9Bcap4gYzzqb7LQinnhWy13kooUTv8yTPCe9Q8fWeYahcPqjoQg6Bk2TO", "clientId": "9a7f05a1-d5f2-4ae0-923c-d5230c09a1e9", "clientSecret": "mOdZ3szKE1QW16FIDmNG8dkbj", "code": "E84X27X2", "username": "laurent.gui***10@icloud.com", "password": "Sati***"

		}]

}

closed time in 3 months

djrams10

issue closedKraigM/homebridge-nest

No token in log

I have set it up according to the instructions, and I get it working on the first run, but I can't find the token in the log. The only nest entries I can find are these:

[2018-4-24 22:30:47] Loaded plugin: homebridge-nest
[2018-4-24 22:30:47] Registering platform 'homebridge-nest.Nest'
[2018-4-24 22:30:47] [Nest] Initializing Nest platform...
[2018-4-24 22:30:47] [Nest] Fetching Nest devices.
[2018-4-24 22:30:51] [Nest] initing protect "Kitchen Nest Protect": deviceId: ### structureId: ###
[2018-4-24 22:30:51] [Nest] Initializing platform accessory 'Kitchen Nest Protect'...

My config looks like this:

{
   "platform": "Nest",
   "clientId": "##",
   "clientSecret": "##",
   "code": "##"
}

closed time in 3 months

jobha
more