profile
viewpoint
Wojciech duxet Gdańsk, Poland https://strm.pl https://telegram.me/duxet

duxet/awesome-hubot 39

A list of must have Hubot scripts.

duxet/builds-tab 24

Web extension that adds builds tab to Github

duxet/adium-facebook 13

Facebook plugin for Adium

duxet/dingo-api 1

A RESTful API package for the Laravel and Lumen frameworks.

duxet/docker-php 1

Docker Official Image packaging for PHP

duxet/aasdk 0

Library to build AndroidAuto headunit

duxet/abao 0

REST API automated testing tool based on RAML

duxet/adium-tox-im 0

Adium plugin for Tox IM protocol

duxet/akka 0

Build highly concurrent, distributed, and resilient message-driven applications on the JVM

duxet/anbu 0

Anbu profiler for the Laravel PHP Framework.

push eventStrimoid/Strimoid

duxet

commit sha 62cc34e13308d404b772e5d780dd77d6b011cf12

Update dependencies

view details

push time in a day

push eventStrimoid/Strimoid

duxet

commit sha be67ad23ad612ca8daf1bdf1d5c37b6c0c252e9e

Update dependencies

view details

push time in a day

startedsmacke/ffsubsync

started time in 2 days

push eventStrimoid/Strimoid

Wojciech

commit sha 023620c2a5370d99c9532a1eff52ada7055db343

Update README.md

view details

push time in 14 days

startedjlesage/docker-handbrake

started time in 16 days

startednushell/nushell

started time in a month

startedbirdayz/kaf

started time in a month

startedrs/curlie

started time in a month

push eventStrimoid/Strimoid

duxet

commit sha c849e818950718e888c2a45389080c6a5d020da8

Fix some Lighthouse reported issues

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha af5e3b88895a880d33722615745d73b6cdc4078e

Fix some Lighthouse reported issues

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 90b8c44987e4bd976131ee090182e618bcc997a7

Fix some Lighthouse reported issues

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 7ab1d739bdacb9177bc42fcbc7f99e955af605c7

Fix some Lighthouse reported issues

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 08b14d5f1d6f7724e5de94b59c59d32e813fa67b

Optimize OEmbed code fetching

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 7a3d36ee07268ac55752a52f9f6e5ae1b7561aec

Optimize OEmbed code fetching

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 45262a23ad38c204b71d612cbbc144cb3532f12d

Bump nginx to 1.19

view details

push time in 2 months

created tagStrimoid/docker-php

tag7.4

created time in 2 months

delete tag Strimoid/docker-php

delete tag : 7.4

delete time in 2 months

push eventStrimoid/docker-php

duxet

commit sha 4381b89e64831e1c4cc0fa47687017b3b1f72b19

Add opcache extension

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 5c4051bd7be2747f1a579616ef4f78616bf83aa4

Update dependencies

view details

push time in 2 months

created tagStrimoid/docker-iframely

tag1.4.5

created time in 2 months

release Strimoid/docker-iframely

1.4.5

released time in 2 months

push eventStrimoid/docker-iframely

Wojciech

commit sha 354e88f4f8c3ab3ada905129927d7fd88ea35f7d

Bump to 1.4.5

view details

push time in 2 months

startedalpinejs/alpine

started time in 2 months

starteddavidB/kubectl-view-allocations

started time in 2 months

startedhwayne/awesome-cold-showers

started time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 955d0c77a54c1f49446c734c3f3becdeb909983e

Fix light buttons in dark mode

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha a386556f34c56c75310e542a52f047c81fa67c20

Fix table font color in dark mode

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha b369326ec4a5acd7c91c5605f4ce2cc82d30554e

Fix content filtering and sorting

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha e4bd3c9c674872e1f681a33f155419dbd9b2253a

Fix create group form

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 4cb1aafae168c4565efbb2180bf35d8eabb63a34

Fix commands and UI bugs

view details

push time in 2 months

startedpestphp/pest

started time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 3748aafdc33f20a6d4a60be87517fc96eff306ae

Fix content form

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha f14555aa468920bc2530860c9dbfe9fe7fe1e411

Fix build and entry form

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 8ef00fb1f3e8add039887f945eaeec6415474074

Fix notifications dropdown position

view details

push time in 2 months

PR closed Strimoid/Strimoid

[Security] Bump jquery from 3.4.1 to 3.5.1 dependencies javascript security

Bumps jquery from 3.4.1 to 3.5.1. This update includes security fixes. <details> <summary>Vulnerabilities fixed</summary> <p><em>Sourced from <a href="https://github.com/advisories/GHSA-gxr4-xjj5-5px2">The GitHub Security Advisory Database</a>.</em></p> <blockquote> <p><strong>Potential XSS vulnerability in jQuery</strong></p> <h3>Impact</h3> <p>Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. <code>.html()</code>, <code>.append()</code>, and others) may execute untrusted code.</p> <h3>Patches</h3> <p>This problem is patched in jQuery 3.5.0.</p> <h3>Workarounds</h3> <p>To workaround the issue without upgrading, adding the following to your code:</p> <pre lang="js"><code>jQuery.htmlPrefilter = function( html ) { return html; }; </code></pre> <p>You need to use at least jQuery 1.12/2.2 or newer to be able to apply this workaround.</p> <h3>References</h3> <p><a href="https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/">https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/</a> <a href="https://jquery.com/upgrade-guide/3.5/">https://jquery.com/upgrade-guide/3.5/</a></p> </tr></table> ... (truncated) <p>Affected versions: >= 1.2 < 3.5.0</p> </blockquote> <p><em>Sourced from <a href="https://github.com/advisories/GHSA-jpcq-cgw6-v4j6">The GitHub Security Advisory Database</a>.</em></p> <blockquote> <p><strong>Potential XSS vulnerability in jQuery</strong> In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code.</p> <p>This problem is patched in jQuery 3.5.0.</p> <p>Affected versions: >= 1.0.3 < 3.5.0</p> </blockquote> </details> <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/jquery/jquery/releases">jquery's releases</a>.</em></p> <blockquote> <h2>jQuery 3.5.0 Released!</h2> <p>See the blog post: <a href="https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/">https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/</a> and the upgrade guide: <a href="https://jquery.com/upgrade-guide/3.5/">https://jquery.com/upgrade-guide/3.5/</a></p> <p><strong>NOTE:</strong> Despite being a minor release, this update includes a breaking change that we had to make to fix <a href="https://github.com/advisories/GHSA-gxr4-xjj5-5px2">a security issue</a> ( <a href="https://nvd.nist.gov/vuln/detail/CVE-2020-11022"><code>CVE-2020-11022</code></a>). Please follow the blog post & the upgrade guide for more details.</p> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/jquery/jquery/commit/e1cffdef277fcf543833a20d28cbadcd000ebece"><code>e1cffde</code></a> 3.5.1</li> <li><a href="https://github.com/jquery/jquery/commit/7d2ce691cdbd53956f5eeab2048a13efd372277c"><code>7d2ce69</code></a> Release: update AUTHORS.txt</li> <li><a href="https://github.com/jquery/jquery/commit/ea2d0d50c06e8d77ea3fdfa32fa0bfe6f91418d2"><code>ea2d0d5</code></a> Tests: Workaround failures in recent XSS tests in iOS 8 - 12</li> <li><a href="https://github.com/jquery/jquery/commit/ea3766c08156541617ca3d15755a9ade8fdedcc0"><code>ea3766c</code></a> Docs: Fix typos</li> <li><a href="https://github.com/jquery/jquery/commit/58a8e87979d68f001de9e52c00601b805bab303d"><code>58a8e87</code></a> Tests: Add tests for recently fixed manipulation XSS issues</li> <li><a href="https://github.com/jquery/jquery/commit/c1c0598d8fde1bb66a257d7e993dd940aa4f4ce7"><code>c1c0598</code></a> Tests: Cleanup <code>window</code> & <code>document</code> handlers in a new event test</li> <li><a href="https://github.com/jquery/jquery/commit/46ba70c5e82cf55965ffe8825ec9247066a01ddd"><code>46ba70c</code></a> Tests: Fix flakiness in the "jQuery.ajax() - JSONP - Same Domain" test</li> <li><a href="https://github.com/jquery/jquery/commit/f7fed7eec235fe6e1f55c5ad9c7193a507bf5713"><code>f7fed7e</code></a> Docs: Update the link to the jsdom repository</li> <li><a href="https://github.com/jquery/jquery/commit/205dd134b93c42d53e19078846a972f33fc9d8eb"><code>205dd13</code></a> Build: Test on Node.js 14, stop testing on Node.js 8 & 13</li> <li><a href="https://github.com/jquery/jquery/commit/b21d6710cf2d9e227396fe8d78b262dfeb8b3c28"><code>b21d671</code></a> Build: Enable reportUnusedDisableDirectives in ESLint</li> <li>Additional commits viewable in <a href="https://github.com/jquery/jquery/compare/3.4.1...3.5.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+3 -3

0 comment

1 changed file

dependabot-preview[bot]

pr closed time in 2 months

PR closed Strimoid/Strimoid

[Security] Bump websocket-extensions from 0.1.3 to 0.1.4 dependencies javascript security

Bumps websocket-extensions from 0.1.3 to 0.1.4. This update includes a security fix. <details> <summary>Vulnerabilities fixed</summary> <p><em>Sourced from <a href="https://github.com/advisories/GHSA-g78m-2chm-r7qv">The GitHub Security Advisory Database</a>.</em></p> <blockquote> <p><strong>Regular Expression Denial of Service in websocket-extensions (NPM package)</strong></p> <h3>Impact</h3> <p>The ReDoS flaw allows an attacker to exhaust the server's capacity to process incoming requests by sending a WebSocket handshake request containing a header of the following form:</p> <pre><code>Sec-WebSocket-Extensions: a; b="\c\c\c\c\c\c\c\c\c\c ... </code></pre> <p>That is, a header containing an unclosed string parameter value whose content is a repeating two-byte sequence of a backslash and some other character. The parser takes exponential time to reject this header as invalid, and this will block the processing of any other work on the same thread. Thus if you are running a single-threaded server, such a request can render your service completely unavailable.</p> <h3>Patches</h3> <p>Users should upgrade to version 0.1.4.</p> <h3>Workarounds</h3> </tr></table> ... (truncated) <p>Affected versions: < 0.1.4</p> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/faye/websocket-extensions-node/blob/master/CHANGELOG.md">websocket-extensions's changelog</a>.</em></p> <blockquote> <h3>0.1.4 / 2020-06-02</h3> <ul> <li>Remove a ReDoS vulnerability in the header parser (CVE-2020-7662, reported by Robert McLaughlin)</li> <li>Change license from MIT to Apache 2.0</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/faye/websocket-extensions-node/commit/8efd0cd6e35faf9bb9cb08759be1e27082177d43"><code>8efd0cd</code></a> Bump version to 0.1.4</li> <li><a href="https://github.com/faye/websocket-extensions-node/commit/3dad4ad44a8c5f74d4f8f4efd3f9d6e0b5df3051"><code>3dad4ad</code></a> Remove ReDoS vulnerability in the Sec-WebSocket-Extensions header parser</li> <li><a href="https://github.com/faye/websocket-extensions-node/commit/4a76c75efb1c5d6a2f60550e9501757458d19533"><code>4a76c75</code></a> Add Node versions 13 and 14 on Travis</li> <li><a href="https://github.com/faye/websocket-extensions-node/commit/44a677a9c0631daed0b0f4a4b68c095b624183b8"><code>44a677a</code></a> Formatting change: {...} should have spaces inside the braces</li> <li><a href="https://github.com/faye/websocket-extensions-node/commit/f6c50aba0c20ff45b0f87cea33babec1217ec3f5"><code>f6c50ab</code></a> Let npm reformat package.json</li> <li><a href="https://github.com/faye/websocket-extensions-node/commit/2d211f3705d52d9efb4f01daf5a253adf828592e"><code>2d211f3</code></a> Change markdown formatting of docs.</li> <li><a href="https://github.com/faye/websocket-extensions-node/commit/0b620834cc1e1f2eace1d55ab17f71d90d88271d"><code>0b62083</code></a> Update Travis target versions.</li> <li><a href="https://github.com/faye/websocket-extensions-node/commit/729a4653073fa8dd020561113513bfa2e2119415"><code>729a465</code></a> Switch license to Apache 2.0.</li> <li>See full diff in <a href="https://github.com/faye/websocket-extensions-node/compare/0.1.3...0.1.4">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+3 -3

0 comment

1 changed file

dependabot-preview[bot]

pr closed time in 2 months

PR closed Strimoid/Strimoid

Bump expose-loader from 0.7.5 to 1.0.0 dependencies javascript

Bumps expose-loader from 0.7.5 to 1.0.0. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/expose-loader/releases">expose-loader's releases</a>.</em></p> <blockquote> <h2>v1.0.0</h2> <h2><a href="https://github.com/webpack-contrib/expose-loader/compare/v0.7.5...v1.0.0">1.0.0</a> (2020-06-23)</h2> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported Node.js version is <code>10.13</code></li> <li>minimum supported <code>webpack</code> version is <code>4</code></li> <li><code>inline</code> syntax was changed, please <a href="https://github.com/webpack-contrib/expose-loader#inline">read</a></li> <li>list of exposed values moved to the <code>exposes</code> option, please <a href="https://github.com/webpack-contrib/expose-loader#exposes">read</a></li> <li>migrate away from <code>pitch</code> phase</li> <li>do not override existing exposed values in the global object by default, because it is unsafe, please <a href="https://github.com/webpack-contrib/expose-loader#override">read</a></li> </ul> <h3>Features</h3> <ul> <li>validate options</li> <li>support webpack 5</li> <li>support multiple exposed values</li> <li>interpolate exposed values</li> <li>allow to expose part of a module</li> <li>allow to expose values with <code>.</code> (dot) in the name</li> </ul> <h3>Fixes</h3> <ul> <li>do not break source maps</li> <li>do not generate different hashed on different os</li> <li>compatibility with ES module syntax</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/expose-loader/blob/master/CHANGELOG.md">expose-loader's changelog</a>.</em></p> <blockquote> <h2><a href="https://github.com/webpack-contrib/expose-loader/compare/v0.7.5...v1.0.0">1.0.0</a> (2020-06-23)</h2> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported Node.js version is <code>10.13</code></li> <li>minimum supported <code>webpack</code> version is <code>4</code></li> <li><code>inline</code> syntax was changed, please <a href="https://github.com/webpack-contrib/expose-loader#inline">read</a></li> <li>list of exposed values moved to the <code>exposes</code> option, please <a href="https://github.com/webpack-contrib/expose-loader#exposes">read</a></li> <li>migrate away from <code>pitch</code> phase</li> <li>do not override existing exposed values in the global object by default, because it is unsafe, please <a href="https://github.com/webpack-contrib/expose-loader#override">read</a></li> </ul> <h3>Features</h3> <ul> <li>validate options</li> <li>support webpack 5</li> <li>support multiple exposed values</li> <li>interpolate exposed values</li> <li>allow to expose part of a module</li> <li>allow to expose values with <code>.</code> (dot) in the name</li> </ul> <h3>Fixes</h3> <ul> <li>do not break source maps</li> <li>do not generate different hashed on different os</li> <li>compatibility with ES module syntax</li> </ul> <p><!-- raw HTML omitted --><!-- raw HTML omitted --></p> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/367c0e134bad01e17bdef2d7bdd11fa7a750c298"><code>367c0e1</code></a> chore(release): 1.0.0 (<a href="https://github-redirect.dependabot.com/webpack-contrib/expose-loader/issues/111">#111</a>)</li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/46bd532aae400f78d87738f3b03a9380d27115ea"><code>46bd532</code></a> refactor: <code>override</code></li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/748798bcce0dc7e1730f868c77f12e2c01818b96"><code>748798b</code></a> test: side effects (<a href="https://github-redirect.dependabot.com/webpack-contrib/expose-loader/issues/109">#109</a>)</li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/04c1fa7eb5b88ff46585267506b1a34705f48dbf"><code>04c1fa7</code></a> refactor: code</li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/eb5dd2236618b336be92b4590b2cedc7a623655d"><code>eb5dd22</code></a> refactor: remove sourcemap generation (<a href="https://github-redirect.dependabot.com/webpack-contrib/expose-loader/issues/106">#106</a>)</li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/c7557f627d6f1a06d2b632ed2520a062de1841ec"><code>c7557f6</code></a> refactor: code</li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/fe0e0e8c5d191426937eff24691f7e256f0a3f0e"><code>fe0e0e8</code></a> feat: es modules</li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/3738ee9545c4253136e61b75957e5c1f579d93db"><code>3738ee9</code></a> refactor: code and docs</li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/d7a40c866c5faf12b4cdbd4a5d03f405b47a824b"><code>d7a40c8</code></a> refactor: code</li> <li><a href="https://github.com/webpack-contrib/expose-loader/commit/9ef60542bc7f3e856cb318b5982317cec4711d31"><code>9ef6054</code></a> feat: interpolate of names (<a href="https://github-redirect.dependabot.com/webpack-contrib/expose-loader/issues/101">#101</a>)</li> <li>Additional commits viewable in <a href="https://github.com/webpack-contrib/expose-loader/compare/v0.7.5...v1.0.0">compare view</a></li> </ul> </details> <details> <summary>Maintainer changes</summary> <p>This version was pushed to npm by <a href="https://www.npmjs.com/~evilebottnawi">evilebottnawi</a>, a new releaser for expose-loader since your current version.</p> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+2404 -1290

0 comment

4 changed files

dependabot-preview[bot]

pr closed time in 2 months

PR closed Strimoid/Strimoid

Bump imports-loader from 0.8.0 to 1.1.0 dependencies javascript

Bumps imports-loader from 0.8.0 to 1.1.0. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/imports-loader/releases">imports-loader's releases</a>.</em></p> <blockquote> <h2>v1.1.0</h2> <h2><a href="https://github.com/webpack-contrib/imports-loader/compare/v1.0.0...v1.1.0">1.1.0</a> (2020-06-24)</h2> <h3>Features</h3> <ul> <li>"|" character can be used as delimiter for inline string syntax (<a href="https://github.com/webpack-contrib/imports-loader/commit/00697dee3d0108bf632b3f82bd3adc62bd7aa907">00697de</a>)</li> </ul> <h2>v1.0.0</h2> <h2><a href="https://github.com/webpack-contrib/imports-loader/compare/v0.8.0...v1.0.0">1.0.0</a> (2020-06-17)</h2> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported Node.js version is <code>10.13</code></li> <li>minimum supported <code>webpack</code> version is <code>4</code></li> <li><code>inline</code> syntax was changed, please <a href="https://github.com/webpack-contrib/imports-loader#inline">read</a></li> <li>list of imported modules moved to the <code>imports</code> option, please <a href="https://github.com/webpack-contrib/imports-loader#imports">read</a></li> <li>wrapper moved to the <code>wrapper</code> option, please <a href="https://github.com/webpack-contrib/imports-loader#wrapper">read</a></li> <li>custom variables moved to the <code>additionalCode</code> option, please <a href="https://github.com/webpack-contrib/imports-loader#additionalcode">read</a></li> <li>generates ES module default import by default (<code>import Foo from 'foo';</code>)</li> </ul> <h3>Features</h3> <ul> <li>validate options</li> <li>support webpack 5</li> <li>implemented the <code>type</code> option (imports can be CommonsJS or ES module format)</li> <li>implemented the ability to generate multiple import in CommonJS or ES module format</li> <li>improved support of <code>inline</code> usage</li> <li>allowed to adding arguments for wrapper</li> <li>allowed to inject any custom code</li> </ul> <h3>Bug Fixes</h3> <ul> <li>do not crash on invalid inline syntax</li> <li>respect <code>'use strict';</code></li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/imports-loader/blob/master/CHANGELOG.md">imports-loader's changelog</a>.</em></p> <blockquote> <h2><a href="https://github.com/webpack-contrib/imports-loader/compare/v1.0.0...v1.1.0">1.1.0</a> (2020-06-24)</h2> <h3>Features</h3> <ul> <li>"|" character can be used as delimiter for inline string syntax (<a href="https://github.com/webpack-contrib/imports-loader/commit/00697dee3d0108bf632b3f82bd3adc62bd7aa907">00697de</a>)</li> </ul> <h2><a href="https://github.com/webpack-contrib/imports-loader/compare/v0.8.0...v1.0.0">1.0.0</a> (2020-06-17)</h2> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported Node.js version is <code>10.13</code></li> <li>minimum supported <code>webpack</code> version is <code>4</code></li> <li><code>inline</code> syntax was changed, please <a href="https://github.com/webpack-contrib/imports-loader#inline">read</a></li> <li>list of imported modules moved to the <code>imports</code> option, please <a href="https://github.com/webpack-contrib/imports-loader#imports">read</a></li> <li>wrapper moved to the <code>wrapper</code> option, please <a href="https://github.com/webpack-contrib/imports-loader#wrapper">read</a></li> <li>custom variables moved to the <code>additionalCode</code> option, please <a href="https://github.com/webpack-contrib/imports-loader#additionalcode">read</a></li> <li>generates ES module default import by default (<code>import Foo from 'foo';</code>)</li> </ul> <h3>Features</h3> <ul> <li>validate options</li> <li>support webpack 5</li> <li>implemented the <code>type</code> option (imports can be CommonsJS or ES module format)</li> <li>implemented the ability to generate multiple import in CommonJS or ES module format</li> <li>improved support of <code>inline</code> usage</li> <li>allowed to adding arguments for wrapper</li> <li>allowed to inject any custom code</li> </ul> <h3>Bug Fixes</h3> <ul> <li>do not crash on invalid inline syntax</li> <li>respect <code>'use strict';</code></li> </ul> <p><!-- raw HTML omitted --><!-- raw HTML omitted --></p> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/afc19989f3a68216e2efb30ac5eefe3832082ac0"><code>afc1998</code></a> chore(release): 1.1.0</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/00697dee3d0108bf632b3f82bd3adc62bd7aa907"><code>00697de</code></a> feat: "|" character can be used as delimiter for inline string syntax</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/13b06dbb3a64bcc38cb0555c72353889b8f2b845"><code>13b06db</code></a> docs: remove redundant "to example.js" (<a href="https://github-redirect.dependabot.com/webpack-contrib/imports-loader/issues/80">#80</a>)</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/ebfc6ad3a14ad0d7688ed28ad8eb5988e9a71053"><code>ebfc6ad</code></a> chore(release): 1.0.0</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/574b5f64ed0c8c608759fd334bb4a068f342d82d"><code>574b5f6</code></a> refactor: <code>wrapper</code> option (<a href="https://github-redirect.dependabot.com/webpack-contrib/imports-loader/issues/78">#78</a>)</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/c7f879918a95574c0ca0412f123265f802b64ea4"><code>c7f8799</code></a> fix: respect 'use strict' (<a href="https://github-redirect.dependabot.com/webpack-contrib/imports-loader/issues/77">#77</a>)</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/9e2cec4183e0a782bd2911c779dfe457d82ef141"><code>9e2cec4</code></a> refactor: code</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/7265bc8d26b88f23ce09577b07a17e28cc20eb4c"><code>7265bc8</code></a> refactor: options for commonjs</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/bef708f699ad4ed4bf977caebbc9436eae1976b5"><code>bef708f</code></a> refactor: code</li> <li><a href="https://github.com/webpack-contrib/imports-loader/commit/754baa81181c52ca67529e0747f6adae92df845c"><code>754baa8</code></a> chore: defaults update (<a href="https://github-redirect.dependabot.com/webpack-contrib/imports-loader/issues/73">#73</a>)</li> <li>Additional commits viewable in <a href="https://github.com/webpack-contrib/imports-loader/compare/v0.8.0...v1.1.0">compare view</a></li> </ul> </details> <details> <summary>Maintainer changes</summary> <p>This version was pushed to npm by <a href="https://www.npmjs.com/~evilebottnawi">evilebottnawi</a>, a new releaser for imports-loader since your current version.</p> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+2404 -1290

0 comment

4 changed files

dependabot-preview[bot]

pr closed time in 2 months

PR closed Strimoid/Strimoid

Bump sass-loader from 8.0.2 to 9.0.2 dependencies javascript

Bumps sass-loader from 8.0.2 to 9.0.2. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/sass-loader/releases">sass-loader's releases</a>.</em></p> <blockquote> <h2>v9.0.2</h2> <h3><a href="https://github.com/webpack-contrib/sass-loader/compare/v9.0.1...v9.0.2">9.0.2</a> (2020-07-07)</h3> <h3>Bug Fixes</h3> <ul> <li>resolution algorithm for <code>node-sass</code> (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/866">#866</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/4584c9054befbc56661e2781a55df96fb9f94673">4584c90</a>)</li> </ul> <h2>v9.0.1</h2> <h3><a href="https://github.com/webpack-contrib/sass-loader/compare/v9.0.0...v9.0.1">9.0.1</a> (2020-07-03)</h3> <h3>Bug Fixes</h3> <ul> <li>do not crash on errors (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/860">#860</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/e8549330f8d9373ff8baccffbfd3e0c3b6f3ef61">e854933</a>)</li> </ul> <h2>v9.0.0</h2> <h2><a href="https://github.com/webpack-contrib/sass-loader/compare/v8.0.2...v9.0.0">9.0.0</a> (2020-07-02)</h2> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported Nodejs version is <code>10.13</code></li> <li>prefer <code>sass</code> (<code>dart-sass</code>) by default, it is strongly recommended to migrate on <code>sass</code> (<code>dart-sass</code>)</li> <li>the <code>prependData</code> option was removed in favor the <code>additionalData</code> option, see <a href="https://github.com/webpack-contrib/sass-loader#additionaldata">docs</a></li> <li>when the <code>sourceMap</code> is <code>true</code>, <code>sassOptions.sourceMap</code>, <code>sassOptions.sourceMapContents</code>, <code>sassOptions.sourceMapEmbed</code>, <code>sassOptions.sourceMapRoot</code> and <code>sassOptions.omitSourceMapUrl</code> will be ignored.</li> </ul> <h3>Features</h3> <ul> <li>pass the loader context to custom importers under the <code>this.webpackLoaderContext</code> property (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/853">#853</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/d487683221fcd1e5a173e083b4b40644751c8cb1">d487683</a>)</li> <li>supports for <code>process.cwd()</code> resolution logic by default (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/837">#837</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/0c8d3b3fb1cf371779b4a886cfc4e60facf68759">0c8d3b3</a>)</li> <li>supports for <code>SASS-PATH</code> env variable resolution logic by default (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/836">#836</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/83761798380dcccc5a2badde3b3affe2bac385e8">8376179</a>)</li> <li>supports for the <code>sass</code> property for the <code>exports</code> field from <code>package.json</code> (conditional exports, for more information read <a href="https://nodejs.org/api/esm.html">docs</a>)</li> </ul> <h3>Bug Fixes</h3> <ul> <li>avoid different content on different os (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/832">#832</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/68dd27883ce0536adc5bc170816242c67fb118ff">68dd278</a>)</li> <li>resolution logic when the <code>includePaths</code> option used was improved (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/827">#827</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/cbe5ad407582a617be097d3eadd3ad8619e52507">cbe5ad4</a>)</li> <li>resolution logic for <code>file://</code> scheme was improved (<a href="https://github.com/webpack-contrib/sass-loader/commit/17832fdb11f91593f4e2995003d67aebefb3be90">17832fd</a>)</li> <li>resolution logic for absolute paths and server relative URLs was improved</li> <li>source maps generation was improved</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/sass-loader/blob/master/CHANGELOG.md">sass-loader's changelog</a>.</em></p> <blockquote> <h3><a href="https://github.com/webpack-contrib/sass-loader/compare/v9.0.1...v9.0.2">9.0.2</a> (2020-07-07)</h3> <h3>Bug Fixes</h3> <ul> <li>resolution algorithm for <code>node-sass</code> (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/866">#866</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/4584c9054befbc56661e2781a55df96fb9f94673">4584c90</a>)</li> </ul> <h3><a href="https://github.com/webpack-contrib/sass-loader/compare/v9.0.0...v9.0.1">9.0.1</a> (2020-07-03)</h3> <h3>Bug Fixes</h3> <ul> <li>do not crash on errors (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/860">#860</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/e8549330f8d9373ff8baccffbfd3e0c3b6f3ef61">e854933</a>)</li> </ul> <h2><a href="https://github.com/webpack-contrib/sass-loader/compare/v8.0.2...v9.0.0">9.0.0</a> (2020-07-02)</h2> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported Nodejs version is <code>10.13</code></li> <li>prefer <code>sass</code> (<code>dart-sass</code>) by default, it is strongly recommended to migrate on <code>sass</code> (<code>dart-sass</code>)</li> <li>the <code>prependData</code> option was removed in favor the <code>additionalData</code> option, see <a href="https://github.com/webpack-contrib/sass-loader#additionaldata">docs</a></li> <li>when the <code>sourceMap</code> is <code>true</code>, <code>sassOptions.sourceMap</code>, <code>sassOptions.sourceMapContents</code>, <code>sassOptions.sourceMapEmbed</code>, <code>sassOptions.sourceMapRoot</code> and <code>sassOptions.omitSourceMapUrl</code> will be ignored.</li> </ul> <h3>Features</h3> <ul> <li>pass the loader context to custom importers under the <code>this.webpackLoaderContext</code> property (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/853">#853</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/d487683221fcd1e5a173e083b4b40644751c8cb1">d487683</a>)</li> <li>supports for <code>process.cwd()</code> resolution logic by default (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/837">#837</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/0c8d3b3fb1cf371779b4a886cfc4e60facf68759">0c8d3b3</a>)</li> <li>supports for <code>SASS-PATH</code> env variable resolution logic by default (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/836">#836</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/83761798380dcccc5a2badde3b3affe2bac385e8">8376179</a>)</li> <li>supports for the <code>sass</code> property for the <code>exports</code> field from <code>package.json</code> (conditional exports, for more information read <a href="https://nodejs.org/api/esm.html">docs</a>)</li> </ul> <h3>Bug Fixes</h3> <ul> <li>avoid different content on different os (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/832">#832</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/68dd27883ce0536adc5bc170816242c67fb118ff">68dd278</a>)</li> <li>resolution logic when the <code>includePaths</code> option used was improved (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/827">#827</a>) (<a href="https://github.com/webpack-contrib/sass-loader/commit/cbe5ad407582a617be097d3eadd3ad8619e52507">cbe5ad4</a>)</li> <li>resolution logic for <code>file://</code> scheme was improved (<a href="https://github.com/webpack-contrib/sass-loader/commit/17832fdb11f91593f4e2995003d67aebefb3be90">17832fd</a>)</li> <li>resolution logic for absolute paths and server relative URLs was improved</li> <li>source maps generation was improved</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/2cdcd6f76a0a7e63fe61dbd0b5755d14fe1c0439"><code>2cdcd6f</code></a> chore(release): 9.0.2</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/4584c9054befbc56661e2781a55df96fb9f94673"><code>4584c90</code></a> fix: resolution algorithm for <code>node-sass</code> (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/866">#866</a>)</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/eabf5006909335407059daeff071ce8c933a971e"><code>eabf500</code></a> docs: update readme.md (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/864">#864</a>)</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/30628b51a95bc6d13ba45a1a4f3bf1d883aa7d39"><code>30628b5</code></a> chore(release): 9.0.1</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/e8549330f8d9373ff8baccffbfd3e0c3b6f3ef61"><code>e854933</code></a> fix: do not crash on errors (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/860">#860</a>)</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/9a164329bb7fc8fd04b63aa278e351fec4d2480f"><code>9a16432</code></a> refactor: replace clone-deep with smaller klona (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/857">#857</a>)</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/45bd8655864adbfe7e1c71a277c8e9cbb22b86ab"><code>45bd865</code></a> chore(release): 9.0.0</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/062991588769f20bd9887a2913e8fdd22ac7eedb"><code>0629915</code></a> refactor: code before release</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/c11478da281ce06812f9d8444d713cce501b7c72"><code>c11478d</code></a> test: ambiguous imports (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/855">#855</a>)</li> <li><a href="https://github.com/webpack-contrib/sass-loader/commit/73009fda97881f6675649d7c6e9bd94f7afe4372"><code>73009fd</code></a> docs: yarn pnp + using <code>dart-sass</code> by default (<a href="https://github-redirect.dependabot.com/webpack-contrib/sass-loader/issues/854">#854</a>)</li> <li>Additional commits viewable in <a href="https://github.com/webpack-contrib/sass-loader/compare/v8.0.2...v9.0.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+2404 -1290

0 comment

4 changed files

dependabot-preview[bot]

pr closed time in 2 months

PR closed Strimoid/Strimoid

Bump webpack-merge from 4.2.2 to 5.0.9 dependencies javascript

Bumps webpack-merge from 4.2.2 to 5.0.9. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/survivejs/webpack-merge/blob/master/CHANGELOG.md">webpack-merge's changelog</a>.</em></p> <blockquote> <h2>5.0.9 / 2020-07-09</h2> <ul> <li>Fix - Don't crash on <code>merge()</code> and <code>merge([])</code>. Now <code>{}</code> is returned in these corner cases.</li> </ul> <h2>5.0.8 / 2020-07-07</h2> <ul> <li>Fix - Support Node 10 <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/138">#138</a></li> </ul> <h2>5.0.7 / 2020-07-06</h2> <ul> <li>Fix - Drop tslib dependency by setting <code>"importHelpers": false,</code></li> </ul> <h2>5.0.6 / 2020-07-06</h2> <ul> <li>Fix - Add tslib to dependencies</li> </ul> <h2>5.0.5 / 2020-07-06</h2> <ul> <li>Tech - Optimize build size (UMD isn't needed)</li> </ul> <h2>5.0.4 / 2020-07-06</h2> <ul> <li>Documentation - Use CommonJS imports at the examples. <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/137">#137</a></li> </ul> <h2>5.0.3 / 2020-07-06</h2> <ul> <li>Feature - Support TypeScript out of the box. <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/84">#84</a> <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/86">#86</a> <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/95">#95</a> <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/110">#110</a> <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/112">#112</a></li> <li>Deprecation - <code>merge.smart</code> has been dropped as it's tricky to support all the corner cases. Instead, it's better to use the provided utilities to put together a <code>merge</code> that fits your case.</li> <li>Deprecation - <code>mergeStrategy</code> has been dropped in favor of using <code>mergeWithCustomize</code> with <code>customizeArray</code> and <code>customizeObject</code>.</li> <li>Deprecation - <code>merge.multiple</code> has been dropped as the functionality was too specific and it's better to implement in the user space if needed.</li> <li>Breaking - <code>merge</code> has been moved as a regular import (i.e. <code>import { merge } from 'webpack-merge'</code>).</li> <li>Breaking - Merge customization has been moved behind <code>mergeWithCustomize</code>.</li> <li>Breaking - Bump supported Node version to 12</li> <li>Feature - <code>customizeArray</code> supports wildcards now. Example: <code>'entry.*': 'prepend'</code>. <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/45">#45</a> <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/99">#99</a></li> <li>Feature - Throw an error in case a <code>Promise</code> is being merged. It's better to wrap configuration within a <code>Promise</code> and merge inside it. <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/81">#81</a></li> <li>Fix - Drop lodash in favor of simpler dependencies. <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/134">#134</a></li> <li>Fix - Make <code>unique</code> merge from right to left to match behavior elsewhere. <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/119">#119</a></li> <li>Fix - Make sure <code>unique</code> doesn't lose non-unique items to merge. <a href="https://github-redirect.dependabot.com/survivejs/webpack-merge/issues/125">#125</a></li> </ul> <p>Special thanks to Google and Addy Osmani for supporting the work financially as it allowed me to complete the work required by the new major release.</p> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/survivejs/webpack-merge/commit/8bf5d21663416091a54f115c4174e8212737a017"><code>8bf5d21</code></a> 5.0.9</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/9e7f6ddfb2edc918618312ced096c4c65ed2dd78"><code>9e7f6dd</code></a> fix: Don't crash on merge() or merge([])</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/968b6df76297d2f1c33d8bb7b733fabae5ec7753"><code>968b6df</code></a> 5.0.8</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/d523f4ad50cd912f24fb58efa9b5fca6ee60bde0"><code>d523f4a</code></a> fix: Fix changelog versioning</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/aae2c4c83ac5a2b874ce6018d848e173d4c9f978"><code>aae2c4c</code></a> fix: Add Jest setup</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/7bdd0362173e46afd048b8e7caec22e324997e29"><code>7bdd036</code></a> fix: Add support for Node 10</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/9bc18f76eeac54131ea2cfdfc9a87d85ab549e6a"><code>9bc18f7</code></a> 5.0.7</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/176076a94195bdf339a7fbcdf0a0ec72afdef135"><code>176076a</code></a> fix: Drop tslib dependency</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/9e5a774bbc99d28a0cd99765a60de15bab79096c"><code>9e5a774</code></a> 5.0.6</li> <li><a href="https://github.com/survivejs/webpack-merge/commit/e601b5590a97178013b51fa278c1fecfd502c8a2"><code>e601b55</code></a> fix: Add tslib to dependencies</li> <li>Additional commits viewable in <a href="https://github.com/survivejs/webpack-merge/compare/v4.2.2...v5.0.9">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+2404 -1290

0 comment

4 changed files

dependabot-preview[bot]

pr closed time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 5212fb5a21af61445161d5e392cad39c34c2f562

Update dependencies

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha ed1985c4c0a9524d872524a36028cbc9b2ea444e

Update dependencies

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha d53e0255f7185f9e3f770a35e4a25752ad35ba9d

Update dependencies

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha a4d04c42e5f43a76f9ec8b555bda39806e52a2fd

Upgrade to Laravel 7

view details

duxet

commit sha b305fa2e8ab76368a07d7559841dcfa7a1991221

Use broadcasting

view details

duxet

commit sha 23e4d97be8236df5d3859113e5566dc84d2dcb62

Update client side template

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 23e4d97be8236df5d3859113e5566dc84d2dcb62

Update client side template

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha d98edf174859e8a0ed20b62c539716ac9661850c

Update client side template

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 6374f6d77c9c0812acfe9a9e931425489497a76a

Add MockSeeder

view details

duxet

commit sha a4d04c42e5f43a76f9ec8b555bda39806e52a2fd

Upgrade to Laravel 7

view details

duxet

commit sha b305fa2e8ab76368a07d7559841dcfa7a1991221

Use broadcasting

view details

duxet

commit sha 21abd61f9a0dadfc466d34608d32190b9c3cfafc

Update client side template

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 0e478ec294c83e16bbfb74e2b8f11260ca9de90d

Add MockSeeder

view details

duxet

commit sha 714ea921532e8e92289c40604cb08722e257b58d

Update client side template

view details

push time in 2 months

startedpcardune/handlebars-loader

started time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 6374f6d77c9c0812acfe9a9e931425489497a76a

Add MockSeeder

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha b988413fc8971bae8d942c1adb724565c0db520f

Fix preview on content comments page

view details

duxet

commit sha 53ba31b13e571c964bfb9a5d5cf713785db2566e

Fix settings view

view details

duxet

commit sha 68c17f129e916b8ca4ad3f10770c978202f30db5

Add language setting

view details

duxet

commit sha 8b5859606611af7dadad641ae3149dae645ec4b9

Update dependencies

view details

duxet

commit sha c441afaffc36bbd572321bf7689f9ad045481959

Fix issue with broken notifications

view details

duxet

commit sha 852fa25564635969b35996c654d347338239ecb9

Fix migration oauth issue

view details

duxet

commit sha 4589f7e75ce86628c67cb577697d216c6157ffd3

Fix registration form

view details

duxet

commit sha e69eba8d3cf33e9824dafebe05b3797693313b9e

Upgrade to Laravel 7

view details

duxet

commit sha df73b2c3c15c455f7696f1840c9cd26ee293e480

Use broadcasting

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 4589f7e75ce86628c67cb577697d216c6157ffd3

Fix registration form

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 852fa25564635969b35996c654d347338239ecb9

Fix migration oauth issue

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha c441afaffc36bbd572321bf7689f9ad045481959

Fix issue with broken notifications

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 659b6eac3d3f5bda12784f4948a206035067a660

Fix issue with broken notifications

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 6a0805bc4910ace9cfdc8d4787877804957bbc97

Fix issue with broken notifications

view details

push time in 2 months

push eventStrimoid/Strimoid

duxet

commit sha 8b5859606611af7dadad641ae3149dae645ec4b9

Update dependencies

view details

push time in 2 months

startedbeyondcode/laravel-server-timing

started time in 2 months

startedrequery/requery

started time in 3 months

startedebean-orm/ebean

started time in 3 months

startedkotlin-orm/ktorm

started time in 3 months

startedaholstenson/miio

started time in 3 months

more