profile
viewpoint
David Michael Gregg davegregg Indianapolis, IN JavaScript, Ruby, Elixir, PHP, HTML5, CSS, VB, C++, Java, devops

fork davegregg/grimoire

Functional 5e spell list by class and level

https://thebombzen.com/grimoire/

fork in 15 days

startedjxnblk/mdx-deck

started time in 20 days

issue openedmps-youtube/mps-youtube

`pylast not installed` when trying to set lastfm_password

Issue

Upon trying to configure MPSYT's LastFM support, when setting lastfm_password, I get the error pylast not installed. The password remains unset and of course LastFM support remains disabled.

Suggestion

pylast should either be installed automatically, or the user should be provided instructions for how to install it manually.

Manual Fix

I fixed this problem for myself by finding the pip3 binary buried in mps-youtube's installation directory and ran the pylast install using it – like so:

/usr/local/opt/mps-youtube/libexec/bin/pip3 install pylast

My Environment

OS: MacOS Mojave 10.14.5 Beta Package Manager: Homebrew (brew install mps-youtube) Shell/Terminal: BASH/Kitty Music Player: mpv 0.29.1 mpsyt --version results:

   notes           : released 17 February 2018
pafy version       : 0.5.4 (youtube-dl backend)
youtube-dl version : 2019.04.24
Python version     : 3.7.3 (default, Mar 27 2019, 09:23:15) 
[Clang 10.0.1 (clang-1001.0.46.3)]
Processor          : i386
Machine type       : x86_64
Architecture       : 64bit, 
Platform           : Darwin-18.6.0-x86_64-i386-64bit
sys.stdout.enc     : UTF-8
default enc        : utf-8
Config dir         : /Users/dmg/.config/mps-youtube
env:TERM           : xterm-256color
env:SHELL          : /bin/bash
env:LANG           : en_US.UTF-8```

created time in a month

issue commentkovidgoyal/kitty

BrokenPipeError when enabling completion in bash

For the record, I'm experiencing the exact same set of scenarios as @WillEccles.

  1. The same BrokenPipeError exception.
  2. The same unterminating behavior from executing kitty +complete bash > kitty-completions. Here is the traceback I get after I force termination with Ctrl-C:
  File "Python/runpy.py", line 280, in run_path
  File "Python/runpy.py", line 85, in _run_code
  File "kitty/__main__.py", line 117, in <module>
  File "kitty/__main__.py", line 108, in main
  File "kitty/__main__.py", line 68, in namespaced
  File "kitty/__main__.py", line 39, in complete
  File "kitty/complete.py", line 376, in main
WillEccles

comment created time in 2 months

push eventdavegregg/homebrew-core

David Michael Gregg

commit sha fd70184564d9524a6b854bdcac7b7961507fc608

Correct spelling error in Tesseract formula's Caveats Remove the `e` in `containes`.

view details

push time in 2 months

fork davegregg/homebrew-core

🍻 Default formulae for the missing package manager for macOS

https://brew.sh

fork in 2 months

push eventdavegregg/homebrew-core

David Michael Gregg

commit sha 9a74e0a0f7eedf4e9b06b01399433f331fd62ae3

Correct minor spelling error in 'Caveats' Remove the `e` in `containes`.

view details

push time in 2 months

fork davegregg/homebrew-core

🍻 Default formulae for the missing package manager for macOS

https://brew.sh

fork in 2 months

startedsyumai/dinatra

started time in 2 months

startedlquixada/cross-fetch

started time in 3 months

PR opened standard/eslint-config-standard

Update globals config to use 'readonly' instead of deprecated 'false'…

This PR updates eslintrc.json in keeping with the following change to ESLint:

The merged https://github.com/eslint/eslint/pull/11384 deprecates the use of true and false for globals, replacing them with writable and readonly, respectively.

Users are told: "For historical reasons, the boolean value false and the string value "readable" are equivalent to "readonly". Similarly, the boolean value true and the string value "writeable" are equivalent to "writable". However, the use of older values is deprecated."

+3 -3

0 comment

1 changed file

pr created time in 3 months

push eventdavegregg/eslint-config-standard

davegregg

commit sha a8f47590a386597a3b4b6041cb7868ac5e6161e3

Update globals config to use 'readonly' instead of deprecated 'false', following github/eslint/eslint#11384.

view details

push time in 3 months

more