profile
viewpoint
Mendel Greenberg chabad360 Washington, USA chabad360.me

chabad360/hugo-gh-pages 28

🚀 Build and Publish Your Hugo Site to GitHub Pages 🚀

chabad360/covey 8

A lightweight Linux cluster orchestration system written in Go (Under active development, just working on plugins https://github.com/chabad360/plugins)

chabad360/htmlproofer 6

🚀 Test your rendered HTML files to make sure they're accurate. 🚀

chabad360/gomcu 3

An implementation and documentation of the the Mackie Control Protocol in Go

chabad360/hugo-actions 3

🚀 Use Hugo with GitHub Actions 🚀

chabad360/argos-installer 2

Argos URI handler for bitbar://

chabad360/frappe_docker 2

Docker image for frappe-bench

chabad360/openrazer 2

An entirely open source driver and user-space daemon that allows you to manage your Razer peripherals on GNU/Linux

chabad360/plugins 1

Go plugins based on Yaegi

chabad360/-English 0

(Not quite) English as a programming language.

issue commentopenrazer/openrazer

Support for BlackShark V2 Pro

@Benzer1406 I'll check tonight with another AUX-based headset.

EDIT: Just saw the response in the other issue. Please let me know if it worked for you. I'm not too interested in the fancy sound controls, rather being able to use the headset and mic wirelessly.

I will also test out those suggested tweaks tonight. I'll let you know how it goes.

mohammed-n-shamsi

comment created time in 7 minutes

issue commentopenrazer/openrazer

Support for Razer BlackShark V2 Headset

@HarshitJoshi Sounds good, I'll try this tonight. Thank you for the quick and thorough response!

cyferc

comment created time in 10 minutes

issue commentopenrazer/openrazer

Support for Razer BlackShark V2 Headset

@ceiphr I have the Blackshark V2, to start off, you would want to pull down cyerc's repo (https://github.com/cyferc/openrazer) and build. Regarding the PulseAudio setup, the "Razer USB Sound Card" (at least for me) with Analog Stereo Duplex under the Configuration tab in Pulseaudio worked for me. Let me know if you need any further help. Bear in mind, all I've been able to do is minimal audio control and mic usage. No fancy sound/mixer controls.

cyferc

comment created time in 14 hours

issue commentopenrazer/openrazer

Support for [Tartarus Pro] 1532:0244

Has there been any update on support for this?

Voraga

comment created time in 14 hours

issue commentopenrazer/openrazer

Support for BlackShark V2 Pro

@ceiphr oh wow, that scares me. I just ordered my v2 Pro today. I read in 2 articles though that it works with Linux. What is weird is that with a normal audio jack cable the mic doesn't work. I suppose you used the one with three rings?!

I use Kubuntu with Ubuntu 20.04. I hope it'll work at least with the cable. Do you have a chance to check if it's your audio jack port or really the headset? (Maybe with a different headset or a different computer.

Not sure what else could be done...so sad as it's the premium model and quite expensive.

mohammed-n-shamsi

comment created time in 14 hours

issue commentopenrazer/openrazer

Support for BlackShark V2 Pro

@Benzer1406 Thanks for that.

@ceiphr #1254 (comment)

Here somebody got it to work by changing some pulse audio settings. Could be helpful to look into that...

I made a comment in that issue just now to see what pulseaudio settings were used.

The mic works fine when you connect the cable, right?

I just tried with the cable, still doesn't work. But, it's important to note that my AUX port is a bit janky, the output audio sounds a bit low/muffled too.

mohammed-n-shamsi

comment created time in 14 hours

issue commentopenrazer/openrazer

Support for Razer BlackShark V2 Headset

@HarshitJoshi Glad to hear you got it working. Could you elaborate on what pulseaudio settings you changed?

cyferc

comment created time in 14 hours

issue commentopenrazer/openrazer

Support for BlackShark V2 Pro

@ceiphr https://github.com/openrazer/openrazer/issues/1254#issuecomment-746855753

Here somebody got it to work by changing some pulse audio settings. Could be helpful to look into that...

The mic works fine when you connect the cable, right?

mohammed-n-shamsi

comment created time in 14 hours

issue commentopenrazer/openrazer

Support for BlackShark V2 Pro

@Benzer1406 Standard Ubuntu 20.10 with GNOME on Wayland. OpenRazer and Polychromatic installed.

mohammed-n-shamsi

comment created time in 15 hours

issue commentopenrazer/openrazer

Support for BlackShark V2 Pro

@ceiphr Thanks for the info. What distribution do you use? Have you OpenRazer installed and tried with that? @mohammed-n-shamsi do you think there might be an update soon?

mohammed-n-shamsi

comment created time in 15 hours

issue commentopenrazer/openrazer

Support for Huntsman Mini (60%)

@elliott-maguire same here! The lighting on my 2020 Blade 15 works like a charm! Would be a huge win to sync it with my Huntsman Mini! Currently it just cycles colors ;) I'll try to do some pcap, but I've never done this before. If I find out anything useful, I'll let you know. Cheers!

Cipulot

comment created time in 15 hours

issue commentopenrazer/openrazer

Support for BlackShark V2 Pro

@Benzer1406 Just got mine. Everything works except the microphone on Ubuntu 20.10. I'm currently using my system's internal microphone as a substitute.

Hopefully, we can see progress on this issue, so the microphone can work in the future.

mohammed-n-shamsi

comment created time in 16 hours

issue commentopenrazer/openrazer

Audio buttons - Razer Ornata Chroma V2

I also have been having the same issue but with the razer cynosa v2

FIvanO

comment created time in a day

issue commentopenrazer/openrazer

Support for Razer Naga Pro

@binarypie the pcap files and synapse screenshots are required to get a device supported. To get a pcap file that is useful, follow the instructions that are given here: https://github.com/openrazer/openrazer/wiki/Reverse-Engineering-USB-Protocol Make sure you save the data as a .pcapng file as requested in said documentation.

teeehhias

comment created time in a day

issue commentopenrazer/openrazer

Support for BlackShark V2 Pro

Any updates? I'm considering buying the V2 Pro but am not sure if it is compatible with Linux. Anybody can give me a hint? (I use Kubuntu with Ubuntu 20.04)

mohammed-n-shamsi

comment created time in a day

pull request commentopenrazer/openrazer

Add support for Razer Basilisk V2

@kerberizer @mahmoudhossam Thanks a lot. I'll hold off then until it's reviewed. :bow:

mahmoudhossam

comment created time in 2 days

pull request commentopenrazer/openrazer

Feature: fan control

I've squashed the commits and fixed up a few things now.

Question: do you think this functionality is available on all these devices? RAZER_BLADE_2018_BASE RAZER_BLADE_STEALTH_2019 RAZER_BLADE_STEALTH_LATE_2019 RAZER_BLADE_STEALTH_EARLY_2020 RAZER_BLADE_STEALTH_LATE_2020 RAZER_BLADE_2019_BASE RAZER_BLADE_EARLY_2020_BASE

If yes we should also add the fan methods to the daemon for these devices. If not, then we need to adjust razerkbd_driver.c I assume it is since the other features are identical but I have not way of knowing or testing

vvvrrooomm

comment created time in 2 days

pull request commentopenrazer/openrazer

Add support for Razer Basilisk V2

@jgrim I've been using @mahmoudhossam 's branch without problems for a few weeks now, with two caveats however:

  • I'm on Arch, so I used openrazer-git from AUR (i.e. haven't build it “manually”);
  • I used it only to set the LED colors for the in-memory profiles—which works—but not for much else.
mahmoudhossam

comment created time in 2 days

pull request commentopenrazer/openrazer

Add support for Razer Basilisk V2

@jgrim you can test it yourself, I haven't received any reviews on this PR yet so I can't really tell as this is my first interaction with the code.

mahmoudhossam

comment created time in 2 days

issue commentopenrazer/openrazer

Audio buttons - Razer Ornata Chroma V2

By the way, fn + F11/F12 (backlight intensity), fn + F10 (game mode) doesn't work either

FIvanO

comment created time in 2 days

issue commentopenrazer/openrazer

Audio buttons - Razer Ornata Chroma V2

No. And I feel the problem is far worse on the Ornata V2. Here are the key when I debug:

  • media buttons (play/pause, next, previous, volume up/down, mute): 2,
  • fn button alone: 4 (enters the code block),
  • fn + F11/F12: 5.

I may be wrong but this is totally new, right?

FIvanO

comment created time in 2 days

issue commentopenrazer/openrazer

Support for Huntsman Mini (60%)

Also looking for Huntsman Mini support - if there's anything I could do to help, let me know.

Cipulot

comment created time in 2 days

pull request commentopenrazer/openrazer

Add support for Razer Basilisk V2

Could I build this by running the make file on this branch and be able to install it before it's public release? Is there anything special I should know before I attempt that?

mahmoudhossam

comment created time in 3 days

issue commentopenrazer/openrazer

naga trinity does not save static color

At least the effect restores. That would also be nice for Razer Nari Ultimate since that one also resets the effect (static green). Too bad they don't have support for anything. I was working on it but couldn't get the driver working with those...

flyer48

comment created time in 3 days

issue commentopenrazer/openrazer

naga trinity does not save static color

Ok, well that kills half that theory. :smile: Looks like the effect works without the need for the special report it's using now. But the effect isn't stored for whatever reason and the persistence added in the newer openrazer version is restoring it each time.

flyer48

comment created time in 3 days

issue commentopenrazer/openrazer

naga trinity does not save static color

No, it does not. It switches back to spectrum effect. Tested on a different laptop running Pop!_OS 20.10 who never saw openrazer.

flyer48

comment created time in 3 days

issue commentopenrazer/openrazer

naga trinity does not save static color

@TermoZour Nice! Does the color persist if you plug the mouse into a system not running openrazer (or Synapse)?

flyer48

comment created time in 3 days

issue commentopenrazer/openrazer

naga trinity does not save static color

I have cloned the repo with your specified branch and ran the install script to generate the debs.

I have installed said debs, rebooted the PC, and the mouse indeed restores the old color (at least from RazerGenie). It doesn't default to spectrum anymore.

flyer48

comment created time in 3 days

issue commentopenrazer/openrazer

naga trinity does not save static color

@TermoZour That would be great! :smile: Yeah, I've got a branch here: https://github.com/nightsky30/openrazer/tree/fix_naga_trinity_static_effect Clone, checkout, build per usual.

If that works, I'd be interested in possibly getting the other effects working on it. Looks like it should support breathing, reactive, and spectrum as well.

flyer48

comment created time in 3 days

issue commentopenrazer/openrazer

naga trinity does not save static color

I can test the branch right now. How do I do it exactly? Clone your repo and install it as usual?

flyer48

comment created time in 3 days

more