profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/bsneha90/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.

Bahmni/openmrs-module-bahmniapps 98

Angular.JS based UI application that is used by Clinicians and Patient care providers.

AppiumTestDistribution/ATD-Remote 13

Simple Webserver to manage devices and start/stop appium server

Bahmni/openmrs-module-appointments-frontend 7

UI for Bahmni Appointment Scheduling written in both React and Angular

Bahmni/implementer-interface 5

A repository for implementer interfaces like form builder, reporting, dashboard config etc.

akhil-ghatiki/foreCastAlexSkillBackend 3

This is a custom backend logic for Alexa skill that forecasts the retail demand

bsneha90/RecursiveSwaggerSchemaParser 3

Parse the Swagger response to resolve all dependencies.

Bahmni/form-controls 2

Repository for form controls

Bahmni/openmrs-module-appointments 2

Bahmni appointment scheduling module.

Pull request review commentBahmni/openmrs-module-appointments-frontend

Venkatesh, Supriya | MOBN_1629 | Add missing translations for appointments Frontend

   "APPOINTMENT_ACCEPT_CONFIRM_MESSAGE": "Are you sure, you want to accept the appointment invite?",   "JOIN_TELE_CONSULTATION":"Join Teleconsultation",   "COPY_LINK": "Copy TeleConsultation Link"

, missing

binduak

comment created time in 11 hours

Pull request review commentBahmni/openmrs-module-bahmniapps

Bindu, Supriya, Tarun | BAH-1222 | Address Translation gaps in the Clinical, IPD, OT and Document Upload modules

 angular.module('bahmni.ipd')                 spinner.forPromise(bedService.assignBed(bed.bedId, patientUuid, encounterUuid).then(function () {                     bed.status = "OCCUPIED";                     $scope.$emit("event:patientAssignedToBed", $rootScope.selectedBedInfo.bed);-                    messagingService.showMessage('info', "Bed " + bed.bedNumber + " is assigned successfully");+                    messagingService.showMessage("info", $translate.instant("BED") + " " + bed.bedNumber + " " + $translate.instant("IS_SUCCESSFULLY_ASSIGNED_MESSAGE"));

Hardcoding "OCCUPIED" can be moved to a config file.

binduak

comment created time in 11 hours

issue commentAppiumTestDistribution/AppiumTestDistribution

How to add the child element in the pagefactory

https://github.com/AppiumTestDistribution/PageObjectPatternAppium/blob/master/src/test/java/com/appium/page/objects/WelcomePageObjects.java#L58-L59

@SandeepAppium Check this

SandeepAppium

comment created time in 2 days

PR opened Bahmni/form-controls

Bindu| MOBN-1653 | Fix the invalid FormFieldPath Issue

Product JIRA link -> https://bahmni.atlassian.net/browse/BAH-1221

+13 -1

0 comment

1 changed file

pr created time in 2 days

create barnchbahmni-msf/form-controls

branch : BAH-1221

created branch time in 2 days

push eventbahmni-msf/form-controls

Himabindu Thungathurty

commit sha 9fb90e6465f46fa57d5109c080991b1eb4489e94

Bindu, Tarun | MOBN-1551 | Save event not working in Preview Tab (#7) * Bindu, Tarun | MOBN-1551 | added callback method to get the container data object * Bindu, Tarun | MOBN-1551 | Refactor code and fix unit tests * Bindu, Tarun | MOBN-1551 | Bump up form-controls version to 0.93.3 Co-authored-by: tarunkumar-tw <tarunkumar.s@thoughtworks.com>

view details

Himabindu Thungathurty

commit sha ed2e26520f3ce13b68cf51ae35deb1689166d628

Supriya, Vinisha | MOBN-1559 | Add step attribute to numeric input field (#5) * Supriya, Vinisha | MOBN-1559 | Add step attribute to numeric input field * Supriya, Vinisha | MOBN-1559 | Bump up version to 0.93.1

view details

tarunkumar-tw

commit sha fdd631f2bbf629efa2ed3feb406949d6b53e0e81

Supriya, Tarun | MOBN-1188 | Fix issues with complex concepts when addMore is enabled (#6) * Tarun,Supriya | MOBN-1188 | Fix issues with complex concepts when addMore is enabled * Supriya, Tarun | MOBN-1188 | Fix unit tests * Supriya, Tarun | MOBN-1188 | Fix issues for complex concepts with addMore enabled * Supriya, Tarun | MOBN-1188 | Fix issues for complex concepts with addMore enabled * Supriya, Tarun | MOBN-1188 | Add unit tests for canAddNextFormFieldPath Co-authored-by: Supriya Muppiri <supriya.muppiri@thoughtworks.com>

view details

buvaneswari-arun

commit sha 42239df91cee0ad6bfc9f23fc99c5788957aa76a

Merge pull request #37 from bahmni-msf/BAH-1017 Bindu, Tarun | BAH-1017 | MOBN-1551 | Save event not working in Preview Tab

view details

buvaneswari-arun

commit sha 624f1d2b6667bc4d24de30398f9a285cd246630b

Merge pull request #38 from bahmni-msf/BAH-1131 Supriya, Vinisha | BAH-1131 | MOBN-1559 | Add step attribute to numeric input field

view details

buvaneswari-arun

commit sha c40740c7b9f1ebc76105254d6e58796b9bd6e643

Merge pull request #39 from bahmni-msf/BAH-1132 Supriya, Tarun | BAH-1132 | MOBN-1188 | Fix issues with complex concepts when addMore is enabled

view details

tarunkumar-tw

commit sha aa5356442e1e316f799a7c750b84018e6095a658

Tarun, Supriya | BAH-1132 | Fix indentation errors

view details

buvaneswari-arun

commit sha 9e4aa46e0cf650df0390a90752e4da11f9c8c18a

Merge pull request #40 from bahmni-msf/BAH-1132 Tarun, Supriya | BAH-1132 | Fix indentation errors

view details

binduak

commit sha 2560620a5366e5764784c338f08245cfcdb3753c

Bindu | Bump up version to 0.93.6

view details

push time in 2 days

PR opened Bahmni/openmrs-module-bahmniapps

Bindu | MOBN-446 | Change bacteriology save call from specimen to bahmniEncounter api
  • Bindu | MOBN-446 | Change bacteriology save call from specimen to bahmniEncounter api

  • Bindu | MOBN-446 | Add browser close dialog message

+50 -14

0 comment

2 changed files

pr created time in 2 days

push eventBahmni/openmrs-module-bahmniapps

tarunkumar-tw

commit sha bd0f40c88ae632784070a72dad044374b4927c88

Tarun, Gopi | MOBN-1628 | Add support to create surgical blocks across days (#51) (#354) * Tarun | MOBN-1628 | Add confirmation popup for creating surgical block across multiple days * Tarun | MOBN-1628 | Fix day view to show surgical blocks created across days * Gopi ,Tarun | MOBN-1628 | Removed Syntax Error Which Is Causing Error PopUp on OT Page Load * Tarun, Gopi | MOBN-1628 | Fix week view to show surgical blocks created across days * Tarun, Gopi | MOBN-1628 | Fix list view to show surgical appointments created across days * Gopi,Tarun | MOBN-1628 | Fixed Existing UI Tests * Tarun, Gopi | MOBN-1628 | Show both startdate and enddate in surgical block dialog if both dates are different * Gopi,Tarun | MOBN-1628 | Fixed Remaining UI Tests * Tarun, Gopi | MOBN-1628 | Add date input field in actual time dialog * Tarun, Gopi | MOBN-1628 | Add date in est & actual time fields in appointment details dialog * Tarun, Gopi | MOBN-1628 | Show surgical block end date if block end on a different date * Tarun, Gopi | MOBN-1628 | Correct typo issue * Tarun, Gopi | MOBN-1628 | Handle code review changes * Tarun, Gopi | MOBN-1628 | Handle code review changes Co-authored-by: gopikrishna-yaramothu <65332533+gopikrishna-yaramothu@users.noreply.github.com> Co-authored-by: gopikrishna-yaramothu <gopikrishna.y@thoughtworks.com> Co-authored-by: gopikrishna-yaramothu <65332533+gopikrishna-yaramothu@users.noreply.github.com> Co-authored-by: gopikrishna-yaramothu <gopikrishna.y@thoughtworks.com>

view details

push time in 3 days

push eventBahmni/openmrs-module-bahmniapps

tarunkumar-tw

commit sha e997d726541b26ecc9f826bc69e1f8162b3f2377

Tarun, Venky | MOBN-1430 | Fix issues related to multiple clicks while admitting, transferring and discharging (#48) (#350) * Tarun, Venky | MOBN-1430 | Fix issues related to multiple clicks while admitting, transferring and discharging * Tarun,Venky | MOBN-1430 | Fix unit cases Co-authored-by: venky <58026249+venkybavisetti@users.noreply.github.com> Co-authored-by: venky <58026249+venkybavisetti@users.noreply.github.com>

view details

push time in 3 days

delete branch AppiumTestDistribution/AppiumTestDistribution

delete branch : dependabot/maven/org.mockito-mockito-core-3.11.1

delete time in 3 days

PR closed AppiumTestDistribution/AppiumTestDistribution

Bump mockito-core from 3.7.0 to 3.11.1 dependencies

Bumps mockito-core from 3.7.0 to 3.11.1. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/mockito/mockito/releases">mockito-core's releases</a>.</em></p> <blockquote> <h2>v3.11.1</h2> <p><!-- raw HTML omitted --><!-- raw HTML omitted --><em>Changelog generated by <a href="https://github.com/shipkit/shipkit-changelog">Shipkit Changelog Gradle Plugin</a></em><!-- raw HTML omitted --><!-- raw HTML omitted --></p> <h4>3.11.1</h4> <ul> <li>2021-06-11 - <a href="https://github.com/mockito/mockito/compare/v3.11.0...v3.11.1">3 commit(s)</a> by Charles Munger, dependabot[bot]</li> <li>Bump versions.bytebuddy from 1.11.1 to 1.11.2 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2322">#2322</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2322">mockito/mockito#2322</a>)</li> <li>Check package-privacy of method params [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2318">#2318</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2318">mockito/mockito#2318</a>)</li> <li>Bump shipkit-auto-version from 1.1.16 to 1.1.17 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2317">#2317</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2317">mockito/mockito#2317</a>)</li> </ul> <h2>v3.11.0</h2> <p><!-- raw HTML omitted --><!-- raw HTML omitted --><em>Changelog generated by <a href="https://github.com/shipkit/shipkit-changelog">Shipkit Changelog Gradle Plugin</a></em><!-- raw HTML omitted --><!-- raw HTML omitted --></p> <h4>3.11.0</h4> <ul> <li>2021-06-03 - <a href="https://github.com/mockito/mockito/compare/v3.10.0...v3.11.0">18 commit(s)</a> by Charles Munger, Szczepan Faber, dependabot[bot]</li> <li>Bump versions.bytebuddy from 1.11.0 to 1.11.1 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2313">#2313</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2313">mockito/mockito#2313</a>)</li> <li>Undo parent for MultipleParentsClassLoader [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2312">#2312</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2312">mockito/mockito#2312</a>)</li> <li>Bump shipkit-auto-version from 1.1.14 to 1.1.16 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2310">#2310</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2310">mockito/mockito#2310</a>)</li> <li>Bump gradle/wrapper-validation-action from 1.0.3 to 1.0.4 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2309">#2309</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2309">mockito/mockito#2309</a>)</li> <li>Bump com.github.ben-manes.versions from 0.38.0 to 0.39.0 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2308">#2308</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2308">mockito/mockito#2308</a>)</li> <li>Bump shipkit-auto-version from 1.1.11 to 1.1.14 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2307">#2307</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2307">mockito/mockito#2307</a>)</li> <li>Use the parent classloader if the context classloader is a child of it. [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2306">#2306</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2306">mockito/mockito#2306</a>)</li> <li>Bump kotlin-stdlib from 1.5.0 to 1.5.10 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2305">#2305</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2305">mockito/mockito#2305</a>)</li> <li>"The type is not public and its mock class is loaded by a different class loader" with a context classloader that delegates [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2303">#2303</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2303">mockito/mockito#2303</a>)</li> <li>Enabled automated changelog [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2301">#2301</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2301">mockito/mockito#2301</a>)</li> <li>Bump kotlinx-coroutines-core from 1.4.3-native-mt to 1.5.0-native-mt [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2299">#2299</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2299">mockito/mockito#2299</a>)</li> <li>Bump versions.errorprone from 2.6.0 to 2.7.1 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2298">#2298</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2298">mockito/mockito#2298</a>)</li> <li>Bump junit-platform-launcher from 1.7.1 to 1.7.2 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2297">#2297</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2297">mockito/mockito#2297</a>)</li> <li>Bump versions.junitJupiter from 5.7.1 to 5.7.2 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2296">#2296</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2296">mockito/mockito#2296</a>)</li> <li>Renamed main dev branch [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2295">#2295</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2295">mockito/mockito#2295</a>)</li> <li>Bump gradle/wrapper-validation-action from 1 to 1.0.3 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2294">#2294</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2294">mockito/mockito#2294</a>)</li> <li>Bump actions/checkout from 2 to 2.3.4 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2293">#2293</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2293">mockito/mockito#2293</a>)</li> <li>'this' is not available - when enabling mock-maker-inline [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2082">#2082</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2082">mockito/mockito#2082</a>)</li> </ul> <h2>v3.10.0</h2> <p><!-- raw HTML omitted --><!-- raw HTML omitted --><em>Changelog generated by <a href="https://github.com/shipkit/shipkit-changelog">Shipkit Changelog Gradle Plugin</a></em><!-- raw HTML omitted --><!-- raw HTML omitted --></p> <h4>3.10.0</h4> <ul> <li>2021-05-12 - <a href="https://github.com/mockito/mockito/compare/HEAD...v3.10.0">0 commit(s)</a> by</li> <li>No notable improvements. No pull requests (issues) were referenced from commits.</li> </ul> <h2>v3.9.10</h2> <p><!-- raw HTML omitted --><!-- raw HTML omitted --><em>Changelog generated by <a href="https://github.com/shipkit/shipkit-changelog">Shipkit Changelog Gradle Plugin</a></em><!-- raw HTML omitted --><!-- raw HTML omitted --></p> <h4>3.9.10</h4> <ul> <li>2021-04-29 - <a href="https://github.com/mockito/mockito/compare/v3.9.7...v3.9.10">3 commit(s)</a> by Ismaël Mejía, Tim van der Lippe, dependabot[bot]</li> <li>Remove ASM dependency [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2279">#2279</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2279">mockito/mockito#2279</a>)</li> <li>Apply automated ErrorProne fixes [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2277">#2277</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2277">mockito/mockito#2277</a>)</li> <li>Bump kotlinx-coroutines-core from 1.4.2-native-mt to 1.4.3-native-mt [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2276">#2276</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2276">mockito/mockito#2276</a>)</li> </ul> <h2>v3.9.9</h2> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/mockito/mockito/commit/ef34307383da5a27fff23f7310787d262fbb4cfd"><code>ef34307</code></a> Bump versions.bytebuddy from 1.11.1 to 1.11.2 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2322">#2322</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/41e445c1f7029a8635283428f1f02846ba95f241"><code>41e445c</code></a> Check for non-public type references in methods (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2318">#2318</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/07951e90c82d194f65821ff809247ea819264ea2"><code>07951e9</code></a> Bump shipkit-auto-version from 1.1.16 to 1.1.17 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2317">#2317</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/92cbac227d930f9b306527e8292a89bdb0cde348"><code>92cbac2</code></a> Undo parent for MultipleParentsClassLoader (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2312">#2312</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/67c56326daac74ac9f2a147f760f84635c2b8044"><code>67c5632</code></a> Bump versions.bytebuddy from 1.11.0 to 1.11.1 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2313">#2313</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/d4753548bc3e9be3f95395c52ce856b5cf518b13"><code>d475354</code></a> Bump gradle/wrapper-validation-action from 1.0.3 to 1.0.4 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2309">#2309</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/7ceabaf529aeb227f20b1eecbd4e7be95924290c"><code>7ceabaf</code></a> Bump shipkit-auto-version from 1.1.14 to 1.1.16 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2310">#2310</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/5c775ee9a8bc65b3c9118d02788f65e803b24e69"><code>5c775ee</code></a> Bump com.github.ben-manes.versions from 0.38.0 to 0.39.0 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2308">#2308</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/66998ea7f81c6adf49983cea081586e19760b7a0"><code>66998ea</code></a> Use the parent classloader if the context classloader is a child of it (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2306">#2306</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/ae6dd4efbd0aa4a58558fb689bbed8be474cfe68"><code>ae6dd4e</code></a> Bump shipkit-auto-version from 1.1.11 to 1.1.14 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2307">#2307</a>)</li> <li>Additional commits viewable in <a href="https://github.com/mockito/mockito/compare/v3.7.0...v3.11.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

1 comment

1 changed file

dependabot[bot]

pr closed time in 3 days

pull request commentAppiumTestDistribution/AppiumTestDistribution

Bump mockito-core from 3.7.0 to 3.11.1

Superseded by #865.

dependabot[bot]

comment created time in 3 days

PR opened AppiumTestDistribution/AppiumTestDistribution

Bump mockito-core from 3.7.0 to 3.11.2

Bumps mockito-core from 3.7.0 to 3.11.2. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/mockito/mockito/releases">mockito-core's releases</a>.</em></p> <blockquote> <h2>v3.11.2</h2> <p><!-- raw HTML omitted --><!-- raw HTML omitted --><em>Changelog generated by <a href="https://github.com/shipkit/shipkit-changelog">Shipkit Changelog Gradle Plugin</a></em><!-- raw HTML omitted --><!-- raw HTML omitted --></p> <h4>3.11.2</h4> <ul> <li>2021-06-21 - <a href="https://github.com/mockito/mockito/compare/v3.11.1...v3.11.2">5 commit(s)</a> by dependabot[bot]</li> <li>Bump versions.bytebuddy from 1.11.2 to 1.11.3 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2333">#2333</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2333">mockito/mockito#2333</a>)</li> <li>Bump assertj-core from 3.20.0 to 3.20.1 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2332">#2332</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2332">mockito/mockito#2332</a>)</li> <li>Bump org.eclipse.osgi from 3.16.200 to 3.16.300 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2330">#2330</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2330">mockito/mockito#2330</a>)</li> <li>Bump assertj-core from 3.19.0 to 3.20.0 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2329">#2329</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2329">mockito/mockito#2329</a>)</li> <li>Bump shipkit-auto-version from 1.1.17 to 1.1.19 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2328">#2328</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2328">mockito/mockito#2328</a>)</li> </ul> <h2>v3.11.1</h2> <p><!-- raw HTML omitted --><!-- raw HTML omitted --><em>Changelog generated by <a href="https://github.com/shipkit/shipkit-changelog">Shipkit Changelog Gradle Plugin</a></em><!-- raw HTML omitted --><!-- raw HTML omitted --></p> <h4>3.11.1</h4> <ul> <li>2021-06-11 - <a href="https://github.com/mockito/mockito/compare/v3.11.0...v3.11.1">3 commit(s)</a> by Charles Munger, dependabot[bot]</li> <li>Bump versions.bytebuddy from 1.11.1 to 1.11.2 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2322">#2322</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2322">mockito/mockito#2322</a>)</li> <li>Check package-privacy of method params [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2318">#2318</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2318">mockito/mockito#2318</a>)</li> <li>Bump shipkit-auto-version from 1.1.16 to 1.1.17 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2317">#2317</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2317">mockito/mockito#2317</a>)</li> </ul> <h2>v3.11.0</h2> <p><!-- raw HTML omitted --><!-- raw HTML omitted --><em>Changelog generated by <a href="https://github.com/shipkit/shipkit-changelog">Shipkit Changelog Gradle Plugin</a></em><!-- raw HTML omitted --><!-- raw HTML omitted --></p> <h4>3.11.0</h4> <ul> <li>2021-06-03 - <a href="https://github.com/mockito/mockito/compare/v3.10.0...v3.11.0">18 commit(s)</a> by Charles Munger, Szczepan Faber, dependabot[bot]</li> <li>Bump versions.bytebuddy from 1.11.0 to 1.11.1 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2313">#2313</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2313">mockito/mockito#2313</a>)</li> <li>Undo parent for MultipleParentsClassLoader [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2312">#2312</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2312">mockito/mockito#2312</a>)</li> <li>Bump shipkit-auto-version from 1.1.14 to 1.1.16 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2310">#2310</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2310">mockito/mockito#2310</a>)</li> <li>Bump gradle/wrapper-validation-action from 1.0.3 to 1.0.4 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2309">#2309</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2309">mockito/mockito#2309</a>)</li> <li>Bump com.github.ben-manes.versions from 0.38.0 to 0.39.0 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2308">#2308</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2308">mockito/mockito#2308</a>)</li> <li>Bump shipkit-auto-version from 1.1.11 to 1.1.14 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2307">#2307</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2307">mockito/mockito#2307</a>)</li> <li>Use the parent classloader if the context classloader is a child of it. [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2306">#2306</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2306">mockito/mockito#2306</a>)</li> <li>Bump kotlin-stdlib from 1.5.0 to 1.5.10 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2305">#2305</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2305">mockito/mockito#2305</a>)</li> <li>"The type is not public and its mock class is loaded by a different class loader" with a context classloader that delegates [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2303">#2303</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2303">mockito/mockito#2303</a>)</li> <li>Enabled automated changelog [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2301">#2301</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2301">mockito/mockito#2301</a>)</li> <li>Bump kotlinx-coroutines-core from 1.4.3-native-mt to 1.5.0-native-mt [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2299">#2299</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2299">mockito/mockito#2299</a>)</li> <li>Bump versions.errorprone from 2.6.0 to 2.7.1 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2298">#2298</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2298">mockito/mockito#2298</a>)</li> <li>Bump junit-platform-launcher from 1.7.1 to 1.7.2 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2297">#2297</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2297">mockito/mockito#2297</a>)</li> <li>Bump versions.junitJupiter from 5.7.1 to 5.7.2 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2296">#2296</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2296">mockito/mockito#2296</a>)</li> <li>Renamed main dev branch [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2295">#2295</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2295">mockito/mockito#2295</a>)</li> <li>Bump gradle/wrapper-validation-action from 1 to 1.0.3 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2294">#2294</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2294">mockito/mockito#2294</a>)</li> <li>Bump actions/checkout from 2 to 2.3.4 [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2293">#2293</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/pull/2293">mockito/mockito#2293</a>)</li> <li>'this' is not available - when enabling mock-maker-inline [(<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2082">#2082</a>)](<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2082">mockito/mockito#2082</a>)</li> </ul> <h2>v3.10.0</h2> <p><!-- raw HTML omitted --><!-- raw HTML omitted --><em>Changelog generated by <a href="https://github.com/shipkit/shipkit-changelog">Shipkit Changelog Gradle Plugin</a></em><!-- raw HTML omitted --><!-- raw HTML omitted --></p> <h4>3.10.0</h4> <ul> <li>2021-05-12 - <a href="https://github.com/mockito/mockito/compare/HEAD...v3.10.0">0 commit(s)</a> by</li> <li>No notable improvements. No pull requests (issues) were referenced from commits.</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/mockito/mockito/commit/2be3fcfa306d9e130d87213ff6698c859d01aef0"><code>2be3fcf</code></a> Bump versions.bytebuddy from 1.11.2 to 1.11.3 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2333">#2333</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/566cfa5e95b2f22f23321868f272f773017db2d8"><code>566cfa5</code></a> Bump assertj-core from 3.20.0 to 3.20.1 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2332">#2332</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/a8164eacb870013b5a21027f28ef5eec171965df"><code>a8164ea</code></a> Bump shipkit-auto-version from 1.1.17 to 1.1.19 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2328">#2328</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/163629c5cb5af73f8efd0fabd234963483f09440"><code>163629c</code></a> Bump assertj-core from 3.19.0 to 3.20.0 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2329">#2329</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/441e5569dc58c8c6cc1b060f1071b5c8975953a0"><code>441e556</code></a> Bump org.eclipse.osgi from 3.16.200 to 3.16.300 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2330">#2330</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/ef34307383da5a27fff23f7310787d262fbb4cfd"><code>ef34307</code></a> Bump versions.bytebuddy from 1.11.1 to 1.11.2 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2322">#2322</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/41e445c1f7029a8635283428f1f02846ba95f241"><code>41e445c</code></a> Check for non-public type references in methods (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2318">#2318</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/07951e90c82d194f65821ff809247ea819264ea2"><code>07951e9</code></a> Bump shipkit-auto-version from 1.1.16 to 1.1.17 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2317">#2317</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/92cbac227d930f9b306527e8292a89bdb0cde348"><code>92cbac2</code></a> Undo parent for MultipleParentsClassLoader (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2312">#2312</a>)</li> <li><a href="https://github.com/mockito/mockito/commit/67c56326daac74ac9f2a147f760f84635c2b8044"><code>67c5632</code></a> Bump versions.bytebuddy from 1.11.0 to 1.11.1 (<a href="https://github-redirect.dependabot.com/mockito/mockito/issues/2313">#2313</a>)</li> <li>Additional commits viewable in <a href="https://github.com/mockito/mockito/compare/v3.7.0...v3.11.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

pr created time in 3 days

issue openedAppiumTestDistribution/AppiumTestDistribution

How to add the child element in the pagefactory

i have a scenario where the elements are present in grid, and multiple grids are present. SessionList is the Grid under the grid there are multiple sessions present and id are different in android & ios

Current im doing, like this @AndroidFindBy(id ="sessionList") @iOSXCUITFindBy(id = "session-cell") public List<MobileElement> sessionList;

from screenflows, im returning the element based on the device, like

for android -return sessionList.findelementById("android"); for ios -return sessionList.findelementById("iOS");

im not sure how to add child element in the pagefactory.

is this the correct approach or anyother alternate or suggestions! @saikrishna321

created time in 7 days

Pull request review commentBahmni/openmrs-module-appointments

AP-77: Changed characters escaping in Liquibase SQL files.

 INSERT INTO global_property (property, property_value, description, uuid)- VALUES ('bahmni.sqlGet.pastAppointments',-"SELECT+VALUES ('bahmni.sqlGet.pastAppointments','SELECT      app_service.name                                                                                AS `DASHBOARD_APPOINTMENTS_SERVICE_KEY`,      app_service_type.name                                                                           AS `DASHBOARD_APPOINTMENTS_SERVICE_TYPE_KEY`,-     DATE_FORMAT(start_date_time, \"%d/%m/%Y\")                                                        AS `DASHBOARD_APPOINTMENTS_DATE_KEY`,-     CONCAT(DATE_FORMAT(start_date_time, \"%l:%i %p\"), \" - \", DATE_FORMAT(end_date_time, \"%l:%i %p\")) AS `DASHBOARD_APPOINTMENTS_SLOT_KEY`,+     DATE_FORMAT(start_date_time, "%d/%m/%Y")                                                        AS `DASHBOARD_APPOINTMENTS_DATE_KEY`,+     CONCAT(DATE_FORMAT(start_date_time, "%l:%i %p"), " - ", DATE_FORMAT(end_date_time, "%l:%i %p")) AS `DASHBOARD_APPOINTMENTS_SLOT_KEY`,      CONCAT(pn.given_name, ' ', pn.family_name)                                                      AS `DASHBOARD_APPOINTMENTS_PROVIDER_KEY`,      pa.status                                                                                       AS `DASHBOARD_APPOINTMENTS_STATUS_KEY` FROM    patient_appointment pa    JOIN person p ON p.person_id = pa.patient_id AND pa.voided IS FALSE    JOIN appointment_service app_service      ON app_service.appointment_service_id = pa.appointment_service_id AND app_service.voided IS FALSE+   LEFT JOIN patient_appointment_provider pap on pa.patient_appointment_id = pap.patient_appointment_id AND (pap.voided=0 OR pap.voided IS NULL)

@binduak

Side note, I installed the module using the OpenMrs SDK with MySQL 5.7 and everything seems to work after the fix mentioned above. However if you find any issue pls let me know

icrc-toliveira

comment created time in 8 days

Pull request review commentBahmni/openmrs-module-appointments

AP-77: Changed characters escaping in Liquibase SQL files.

 INSERT INTO global_property (property, property_value, description, uuid)- VALUES ('bahmni.sqlGet.pastAppointments',-"SELECT+VALUES ('bahmni.sqlGet.pastAppointments','SELECT      app_service.name                                                                                AS `DASHBOARD_APPOINTMENTS_SERVICE_KEY`,      app_service_type.name                                                                           AS `DASHBOARD_APPOINTMENTS_SERVICE_TYPE_KEY`,-     DATE_FORMAT(start_date_time, \"%d/%m/%Y\")                                                        AS `DASHBOARD_APPOINTMENTS_DATE_KEY`,-     CONCAT(DATE_FORMAT(start_date_time, \"%l:%i %p\"), \" - \", DATE_FORMAT(end_date_time, \"%l:%i %p\")) AS `DASHBOARD_APPOINTMENTS_SLOT_KEY`,+     DATE_FORMAT(start_date_time, "%d/%m/%Y")                                                        AS `DASHBOARD_APPOINTMENTS_DATE_KEY`,+     CONCAT(DATE_FORMAT(start_date_time, "%l:%i %p"), " - ", DATE_FORMAT(end_date_time, "%l:%i %p")) AS `DASHBOARD_APPOINTMENTS_SLOT_KEY`,      CONCAT(pn.given_name, ' ', pn.family_name)                                                      AS `DASHBOARD_APPOINTMENTS_PROVIDER_KEY`,      pa.status                                                                                       AS `DASHBOARD_APPOINTMENTS_STATUS_KEY` FROM    patient_appointment pa    JOIN person p ON p.person_id = pa.patient_id AND pa.voided IS FALSE    JOIN appointment_service app_service      ON app_service.appointment_service_id = pa.appointment_service_id AND app_service.voided IS FALSE+   LEFT JOIN patient_appointment_provider pap on pa.patient_appointment_id = pap.patient_appointment_id AND (pap.voided=0 OR pap.voided IS NULL)

Hi @binduak

After taking a look, it seems that the use of "pap" instead of "pa", is intended. The problem was that the files "patientPastAppointments.sql" and "patientUpcomingAppointments.sql" were both missing a join. Keep in mind that this join used to be present in past versions, however was removed a couple PR's ago.

Also another reason that lead me to believe the use of "pap" was intended, was its presence on "patientPastAppointments_v2.sql" and "patientUpcomingAppointments_v2". Files us purpose is to update the queries present in "patientPastAppointments.sql" and "patientUpcomingAppointments.sql"

icrc-toliveira

comment created time in 8 days

PR opened Bahmni/openmrs-module-appointments

AP-77: Changed characters escaping in Liquibase SQL files.

Note: Some files contained an error in the SQL (patientPastAppointments.sql / patientUpcomingAppointments.sql).

Issue: https://bahmni.atlassian.net/browse/AP-77

A MYSQL error was found when using openMRS 2.4.0. The cause seems to be related with the functions inside the files:

patientPastAppointments.sql patientPastAppointments_v2.sql patientUpcomingAppointments.sql patientUpcomingAppointments_v2.sql After a closer look, root of the error seems to be the way some characters are escaped.

Solution: The solution seems too be using different forms of "" and '' instead of relying on \ to do the character escaping

+39 -38

0 comment

5 changed files

pr created time in 8 days

delete branch AppiumTestDistribution/AppiumTestDistribution

delete branch : dependabot/maven/com.github.everit-org.json-schema-org.everit.json.schema-1.12.2

delete time in 8 days

PR closed AppiumTestDistribution/AppiumTestDistribution

Bump org.everit.json.schema from 1.12.1 to 1.12.2 dependencies

Bumps org.everit.json.schema from 1.12.1 to 1.12.2. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/everit-org/json-schema/releases">org.everit.json.schema's releases</a>.</em></p> <blockquote> <h2>Maintenance release</h2> <h2>Bugfixes:</h2> <ul> <li>fixing the behavior or <code>"defeault"</code> keyword in <code>"oneOf"</code> schemas - contributed by <a href="https://github.com/dab-libs"><code>@dab-libs</code></a></li> <li>fixing error message for <code>"type": "integer"</code> violations - contributed by <a href="https://github.com/zgyorffi"><code>@zgyorffi</code></a></li> <li>fixing NPE while validating <code>"additionalItem"</code> when <code>"items"</code> is not specified - contributed by <a href="https://github.com/zgyorffi"><code>@zgyorffi</code></a></li> <li>keep precision in case of big numbers - contributed by <a href="https://github.com/zgyorffi"><code>@zgyorffi</code></a></li> </ul> <h2>Enhancements:</h2> <ul> <li>migrating to JUnit 5 - contributed by <a href="https://github.com/gstoupis"><code>@gstoupis</code></a></li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/everit-org/json-schema/commit/0f25663d38dff231d7b9a12d652876d890cb7f4d"><code>0f25663</code></a> bumping version number to 1.12.2</li> <li><a href="https://github.com/everit-org/json-schema/commit/390a45a24dc3b507417dae244a9603f33e6f7fc2"><code>390a45a</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/401">#401</a> from zgyorffi/master</li> <li><a href="https://github.com/everit-org/json-schema/commit/0779550c551b32a6f034db8c582b504bd36a65d9"><code>0779550</code></a> Address review comments <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/401">#401</a></li> <li><a href="https://github.com/everit-org/json-schema/commit/11e6f47e8ca98f4055d0819e737e5a48562339c0"><code>11e6f47</code></a> Fix <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/400">#400</a>, keep precision in case of big numbers</li> <li><a href="https://github.com/everit-org/json-schema/commit/76adcc44ee6585254d05e18ececbba0639f25870"><code>76adcc4</code></a> Merge remote-tracking branch 'upstream/master'</li> <li><a href="https://github.com/everit-org/json-schema/commit/e91863289e17a3cc04771d60195a00bbb8f51155"><code>e918632</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/398">#398</a> from dab-libs/master</li> <li><a href="https://github.com/everit-org/json-schema/commit/564259293ed758876aa7093c37a95c3d36472b6b"><code>5642592</code></a> Changes a signature of the methods: ValidationFailureReporter.getState and Va...</li> <li><a href="https://github.com/everit-org/json-schema/commit/acb54852c63d579f04c49874f1a0b0234d13a664"><code>acb5485</code></a> Tests existing a default value</li> <li><a href="https://github.com/everit-org/json-schema/commit/671a6eca883823d7fe1275a7139d5caf346d52a0"><code>671a6ec</code></a> reproducing missing validation from issue <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/400">#400</a></li> <li><a href="https://github.com/everit-org/json-schema/commit/060a8e0577e23dc3c8cbee02963c0d3d1735b17a"><code>060a8e0</code></a> adding example of programmatically generated schema with $ref</li> <li>Additional commits viewable in <a href="https://github.com/everit-org/json-schema/compare/1.12.1...1.12.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

1 comment

1 changed file

dependabot[bot]

pr closed time in 8 days

PR opened AppiumTestDistribution/AppiumTestDistribution

Bump org.everit.json.schema from 1.12.1 to 1.12.3

Bumps org.everit.json.schema from 1.12.1 to 1.12.3. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/everit-org/json-schema/releases">org.everit.json.schema's releases</a>.</em></p> <blockquote> <h2>Maintenance release</h2> <h2>Bugfixes:</h2> <ul> <li>fixing the behavior or <code>"defeault"</code> keyword in <code>"oneOf"</code> schemas - contributed by <a href="https://github.com/dab-libs"><code>@​dab-libs</code></a></li> <li>fixing error message for <code>"type": "integer"</code> violations - contributed by <a href="https://github.com/zgyorffi"><code>@​zgyorffi</code></a></li> <li>fixing NPE while validating <code>"additionalItem"</code> when <code>"items"</code> is not specified - contributed by <a href="https://github.com/zgyorffi"><code>@​zgyorffi</code></a></li> <li>keep precision in case of big numbers - contributed by <a href="https://github.com/zgyorffi"><code>@​zgyorffi</code></a></li> </ul> <h2>Enhancements:</h2> <ul> <li>migrating to JUnit 5 - contributed by <a href="https://github.com/gstoupis"><code>@​gstoupis</code></a></li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/everit-org/json-schema/commit/d58f877ae3986a99b83dd5b2d8da9eb0b3c242d8"><code>d58f877</code></a> bumping version number to 1.12.3</li> <li><a href="https://github.com/everit-org/json-schema/commit/5fcc2cf0809cd984beca68864646d1f9c84c0ddb"><code>5fcc2cf</code></a> Slim mode support (<a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/420">#420</a>)</li> <li><a href="https://github.com/everit-org/json-schema/commit/2903f54985c5d3d74fffaf694bf687010e4d8907"><code>2903f54</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/411">#411</a> from everit-org/dependabot/maven/core/com.google.guav...</li> <li><a href="https://github.com/everit-org/json-schema/commit/8e3387edfb926b3a8eb430377a4f8e5515774cd6"><code>8e3387e</code></a> Bump guava from 28.0-jre to 29.0-jre in /core</li> <li><a href="https://github.com/everit-org/json-schema/commit/811995893386f05f86615e615d80d548c2189298"><code>8119958</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/408">#408</a> from erosb/issue407</li> <li><a href="https://github.com/everit-org/json-schema/commit/4840a51f48b21f27aea86db3f212e2424aa3656a"><code>4840a51</code></a> addressing PR comment</li> <li><a href="https://github.com/everit-org/json-schema/commit/824fc54a7aabff8f7836625cd4d829ccbd6378a2"><code>824fc54</code></a> fixing <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/407">#407</a> (incorrect SchemaException#schemaLocation when a remote shema fai...</li> <li><a href="https://github.com/everit-org/json-schema/commit/eae88edc87067d8a3872ec25984d9099a368400c"><code>eae88ed</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/everit-org/json-schema/issues/405">#405</a> from paulfrmbstn/issue/404</li> <li><a href="https://github.com/everit-org/json-schema/commit/0f32f90bcf6882464e4f40bb731a6fc69cf7a535"><code>0f32f90</code></a> Issue 404: Non-deterministic validation result when useDefaults are used with...</li> <li><a href="https://github.com/everit-org/json-schema/commit/23cad68cdf9dc09ced424a714db9ea8bd7b03fb2"><code>23cad68</code></a> javadoc links to recent versions</li> <li>Additional commits viewable in <a href="https://github.com/everit-org/json-schema/compare/1.12.1...1.12.3">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

pr created time in 8 days

pull request commentBahmni/openmrs-module-appointments-frontend

Bump postcss from 7.0.18 to 7.0.36

CLA assistant check <br/>Thank you for your submission! We really appreciate it. Like many open source projects, we ask that you sign our Contributor License Agreement before we can accept your contribution.<br/><sub>You have signed the CLA already but the status is still pending? Let us recheck it.</sub>

dependabot[bot]

comment created time in 9 days

PR opened Bahmni/openmrs-module-appointments-frontend

Bump postcss from 7.0.18 to 7.0.36

Bumps postcss from 7.0.18 to 7.0.36. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/postcss/postcss/releases">postcss's releases</a>.</em></p> <blockquote> <h2>7.0.36</h2> <ul> <li>Backport ReDoS vulnerabilities from PostCSS 8.</li> </ul> <h2>7.0.35</h2> <ul> <li>Add <a href="https://github.com/postcss/postcss/wiki/PostCSS-8-for-end-users">migration guide link</a> to PostCSS 8 error text.</li> </ul> <h2>7.0.34</h2> <ul> <li>Fix compatibility with <code>postcss-scss</code> 2.</li> </ul> <h2>7.0.33</h2> <ul> <li>Add error message for PostCSS 8 plugins.</li> </ul> <h2>7.0.32</h2> <ul> <li>Fix error message (by <a href="https://github.com/admosity"><code>@​admosity</code></a>).</li> </ul> <h2>7.0.31</h2> <ul> <li>Use only the latest source map annotation (by <a href="https://github.com/emzoumpo"><code>@​emzoumpo</code></a>).</li> </ul> <h2>7.0.30</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/nex3"><code>@​nex3</code></a>)</li> </ul> <h2>7.0.29</h2> <ul> <li>Update <code>Processor#version</code>.</li> </ul> <h2>7.0.28</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/nex3"><code>@​nex3</code></a>).</li> </ul> <h2>7.0.27</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/nex3"><code>@​nex3</code></a>).</li> </ul> <h2>7.0.26</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/nex3"><code>@​nex3</code></a>)</li> </ul> <h2>7.0.25</h2> <ul> <li>Fix absolute path support for Windows (by <a href="https://github.com/tomrav"><code>@​tomrav</code></a>)</li> </ul> <h2>7.0.24</h2> <ul> <li>Fix TypeScript definition (by <a href="https://github.com/keithamus"><code>@​keithamus</code></a>).</li> </ul> <h2>7.0.23</h2> <ul> <li>Update <code>Processor#version</code>.</li> </ul> <h2>7.0.22</h2> <ul> <li>Add funding link for <code>npm fund</code>.</li> </ul> <h2>7.0.21</h2> <ul> <li>Revert passing <code>nodes</code> property to node constructor.</li> </ul> <h2>7.0.20</h2> <ul> <li>Allow to pass PostCSS’s nodes in <code>nodes</code> property to node constructor.</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/postcss/postcss/blob/main/CHANGELOG.md">postcss's changelog</a>.</em></p> <blockquote> <h2>7.0.36</h2> <ul> <li>Backport ReDoS vulnerabilities from PostCSS 8.</li> </ul> <h2>7.0.35</h2> <ul> <li>Add migration guide link to PostCSS 8 error text.</li> </ul> <h2>7.0.34</h2> <ul> <li>Fix compatibility with <code>postcss-scss</code> 2.</li> </ul> <h2>7.0.33</h2> <ul> <li>Add error message for PostCSS 8 plugins.</li> </ul> <h2>7.0.36</h2> <ul> <li>Backport ReDoS vulnerabilities from PostCSS 8.</li> </ul> <h2>7.0.35</h2> <ul> <li>Add migration guide link to PostCSS 8 error text.</li> </ul> <h2>7.0.34</h2> <ul> <li>Fix compatibility with <code>postcss-scss</code> 2.</li> </ul> <h2>7.0.33</h2> <ul> <li>Add error message for PostCSS 8 plugins.</li> </ul> <h2>7.0.32</h2> <ul> <li>Fix error message (by <a href="https://github.com/admosity"><code>@​admosity</code></a>).</li> </ul> <h2>7.0.31</h2> <ul> <li>Use only the latest source map annotation (by Emmanouil Zoumpoulakis).</li> </ul> <h2>7.0.30</h2> <ul> <li>Fix TypeScript definition (by Natalie Weizenbaum).</li> </ul> <h2>7.0.29</h2> <ul> <li>Update <code>Processor#version</code>.</li> </ul> <h2>7.0.28</h2> <ul> <li>Fix TypeScript definition (by Natalie Weizenbaum).</li> </ul> <h2>7.0.27</h2> <ul> <li>Fix TypeScript definition (by Natalie Weizenbaum).</li> </ul> <h2>7.0.26</h2> <ul> <li>Fix TypeScript definition (by Natalie Weizenbaum).</li> </ul> <h2>7.0.25</h2> <ul> <li>Fix absolute path support for Windows (by Tom Raviv).</li> </ul> <h2>7.0.24</h2> <ul> <li>Fix TypeScript definition (by Keith Cirkel).</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/postcss/postcss/commit/67e3d7b3402c5d3d036ab7c1e781f86910d6ca72"><code>67e3d7b</code></a> Release 7.0.36 version</li> <li><a href="https://github.com/postcss/postcss/commit/54cbf3c4847eb0fb1501b9d2337465439e849734"><code>54cbf3c</code></a> Backport ReDoS vulnerabilities from PostCSS 8</li> <li><a href="https://github.com/postcss/postcss/commit/12832f3d203474bd273bd06bd3b2407567bfe09e"><code>12832f3</code></a> Release 7.0.35 version</li> <li><a href="https://github.com/postcss/postcss/commit/4455ef6baf84ceea87cb662131f95d798063896c"><code>4455ef6</code></a> Use OpenCollective in funding</li> <li><a href="https://github.com/postcss/postcss/commit/e867c794b5d646839350dd4b76f3cc81423413e6"><code>e867c79</code></a> Add migration guide to PostCSS 8 error</li> <li><a href="https://github.com/postcss/postcss/commit/32a22a98bc4de9c7a2489041ceae24eedc62144f"><code>32a22a9</code></a> Release 7.0.34 version</li> <li><a href="https://github.com/postcss/postcss/commit/22939829688574b9acdbd29106ca2ec9470b2b17"><code>2293982</code></a> Lock build targets</li> <li><a href="https://github.com/postcss/postcss/commit/2c3a111a940b373a60fae196e63931b3b6e9d8ca"><code>2c3a111</code></a> Release 7.0.33 version</li> <li><a href="https://github.com/postcss/postcss/commit/4105f21b48d75847e822e89746633792c478922b"><code>4105f21</code></a> Use yaspeller instead of yaspeller-ci</li> <li><a href="https://github.com/postcss/postcss/commit/c8d02a0da503f9fa5d96a854a2c9244710c18c72"><code>c8d02a0</code></a> Revert yaspeller-ci removal</li> <li>Additional commits viewable in <a href="https://github.com/postcss/postcss/compare/7.0.18...7.0.36">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+4 -4

0 comment

1 changed file

pr created time in 9 days