profile
viewpoint
Webdesign29 benfavre Webdesign29 Brest, Finistère, France http://www.webdesign29.net/

benfavre/archlinux-packages 0

Source of my ArchLinux packages

benfavre/bitcoin 0

Bencoin Core

benfavre/bootstrap-sass 0

Official Sass port of Bootstrap 2 and 3.

benfavre/catalog-dockerfiles 0

Dockerfiles for Rancher Catalog containers

benfavre/chartist-js 0

Simple responsive charts

benfavre/crm-php 0

Scripts to connect MS Dynamics CRM with PHP

benfavre/css-loader 0

css loader module for webpack

startedsmall-tech/site.js

started time in 4 hours

startedethereum-optimism/optimism-monorepo

started time in 4 hours

startedzmitton/merkle-mountain-range

started time in 5 hours

push eventBlackShabat/rewooc

blackshabat

commit sha cfd3e240aca489ca694b7c813cb754f29bd16054

change connectPage HOC to hooks

view details

blackshabat

commit sha b8f3019cc1ddc00882c846a4f659ef058444e84c

change containers to hook

view details

blackshabat

commit sha ccc47f2c9146be3f0b5edb9869607af052f3a399

use redux hooks to SignIn

view details

blackshabat

commit sha 4b5da2fe92cbf983425e80e4108eea617532c434

use redux hooks to SignOut

view details

blackshabat

commit sha 86c6587cf2bbbb67d1b4e484079e48431d1347c7

remove destruction from useSelector

view details

blackshabat

commit sha 108d0625fefbb59378b6e8d543d2931597be8b4f

create data layer folder and move searchProducts there

view details

blackshabat

commit sha aab87e4fa66a7b7905ae4382ef15f56beeb68b5f

separate fetch page to data layer

view details

blackshabat

commit sha 3807d045b51b87a82ccf4c53a72566f9b482b7df

move fetch current user to data layer

view details

blackshabat

commit sha 8c40227ab9ccfb2a2c8bd4065220c8754f85b786

move fetch general data to data layer

view details

blackshabat

commit sha f5263ea7aea14eb3d990e2c905b86e6e8c301e3d

move fetch catalog pages to data layer

view details

blackshabat

commit sha 4bdf48f5a0ef30256970112abb47824ba45b917f

move cart to data layer

view details

blackshabat

commit sha 4c07b6883d95d0e0710e8bb04c74c0a88c715efb

change data layer export

view details

Andriy Shabat

commit sha 050179cac2ca83aeeeb91d6812338c2b05b63742

Merge pull request #19 from BlackShabat/redux-hooks/RWC-29 Redux hooks/rwc 29

view details

push time in a day

PR merged BlackShabat/rewooc

Redux hooks/rwc 29
+269 -317

0 comment

26 changed files

BlackShabat

pr closed time in a day

PR opened BlackShabat/rewooc

Redux hooks/rwc 29
+269 -317

0 comment

26 changed files

pr created time in a day

create barnchBlackShabat/rewooc

branch : redux-hooks/RWC-29

created branch time in a day

issue commentdanielgatis/rembg

Blurred

I pushed a fix to this: https://github.com/danielgatis/rembg/commit/24711986b73043f20a9b15549c3bcb6e628ecf35

Tks!

helmutkaufmann

comment created time in 2 days

push eventdanielgatis/rembg

Daniel Gatis

commit sha 24711986b73043f20a9b15549c3bcb6e628ecf35

add base_size arg

view details

push time in 2 days

issue commentdanielgatis/rembg

Error ModuleNotFoundError: No module named 'pymatting_aot.aot'

Please let me know How to fix this in windows?

arnold408

comment created time in 2 days

issue commentdanielgatis/rembg

Blurred

Actually solved it after carefully going through the code. There was a hardcoded initialisation of size to (1000,1000) which was significantly reducing the quality. (1600,1600) does a good job of preserving the quality without much impact on processing time.

helmutkaufmann

comment created time in 2 days

issue closeddanielgatis/rembg

Unable to install on MacOS Big Sur

Hi , I am trying to install this on MacOS 11.0 (Big sur) it always fails , I have tried different things but it doesn't work Python version : 3.8.2 , also tried earlier 3.9.0 doesn't work either

Here are my logs:

  Using cached https://files.pythonhosted.org/packages/74/5a/46cbdb14769ed50b1fa16d57e7a34c04d7251afbacdd3589cdfa8ad3503e/rembg-1.0.16.tar.gz
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... done
Collecting scikit-image==0.17.2 (from rembg)
  Using cached https://files.pythonhosted.org/packages/54/fd/c1b0bb8f6f12ef9b4ee8d7674dac82cd482886f8b5cd165631efa533e237/scikit-image-0.17.2.tar.gz
    ERROR: Command errored out with exit status 1:
     command: /Applications/Xcode.app/Contents/Developer/usr/bin/python3 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/setup.py'"'"'; __file__='"'"'/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base pip-egg-info
         cwd: /private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/
    Complete output (7 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/setup.py", line 234, in <module>
        'build_ext': openmp_build_ext(),
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/setup.py", line 58, in openmp_build_ext
        from numpy.distutils.command.build_ext import build_ext
    ModuleNotFoundError: No module named 'numpy'
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
WARNING: You are using pip version 19.2.3, however version 20.2.4 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
➜  rembg-master git:(master) ✗ curl -s http://input.png | rembg > output.png
zsh: command not found: rembg
➜  rembg-master git:(master) ✗ pip install --upgrade pip
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Defaulting to user installation because normal site-packages is not writeable
Requirement already up-to-date: pip in /Library/Python/2.7/site-packages (20.2.4)
➜  rembg-master git:(master) ✗ which python
/usr/bin/python
➜  rembg-master git:(master) ✗ brew uninstall python
Error: No installed keg or cask with the name "python"
➜  rembg-master git:(master) ✗ python --version
Python 2.7.16
➜  rembg-master git:(master) ✗ python3 --version
Python 3.8.2
➜  rembg-master git:(master) ✗ brew reinstall python
Warning: You are using macOS 11.0.
We do not provide support for this released but not yet supported version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew's GitHub,
Twitter or any other official channels. You are responsible for resolving
any issues you experience while you are running this
released but not yet supported version.

==> Downloading https://homebrew.bintray.com/bottles/python%403.9-3.9.0_1.big_
Already downloaded: /Users/nikhilsingh/Library/Caches/Homebrew/downloads/07eae7a7d7ed36eb2ce66e5a1a771df7d9483f58872e38036325d56194554bf8--python@3.9-3.9.0_1.big_sur.bottle.tar.gz
==> Reinstalling python@3.9
==> Pouring python@3.9-3.9.0_1.big_sur.bottle.tar.gz
^C
➜  rembg-master git:(master) ✗ brew reinstall python@3.8
Warning: You are using macOS 11.0.
We do not provide support for this released but not yet supported version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew's GitHub,
Twitter or any other official channels. You are responsible for resolving
any issues you experience while you are running this
released but not yet supported version.

==> Downloading https://homebrew.bintray.com/bottles/python%403.8-3.8.6_1.big_
Already downloaded: /Users/nikhilsingh/Library/Caches/Homebrew/downloads/bc25badd58f2a016a9cf5f45f7ec5b4beb87cba2f01324fbad4a351696738a24--python@3.8-3.8.6_1.big_sur.bottle.tar.gz
==> Reinstalling python@3.8
==> Pouring python@3.8-3.8.6_1.big_sur.bottle.tar.gz
==> /usr/local/Cellar/python@3.8/3.8.6_1/bin/python3 -s setup.py --no-user-cfg
==> /usr/local/Cellar/python@3.8/3.8.6_1/bin/python3 -s setup.py --no-user-cfg
==> /usr/local/Cellar/python@3.8/3.8.6_1/bin/python3 -s setup.py --no-user-cfg
==> Caveats
Python has been installed as
  /usr/local/opt/python@3.8/bin/python3

Unversioned symlinks `python`, `python-config`, `pip` etc. pointing to
`python3`, `python3-config`, `pip3` etc., respectively, have been installed into
  /usr/local/opt/python@3.8/libexec/bin

You can install Python packages with
  /usr/local/opt/python@3.8/bin/pip3 install <package>
They will install into the site-package directory
  /usr/local/lib/python3.8/site-packages

See: https://docs.brew.sh/Homebrew-and-Python

python@3.8 is keg-only, which means it was not symlinked into /usr/local,
because this is an alternate version of another formula.

If you need to have python@3.8 first in your PATH run:
  echo 'export PATH="/usr/local/opt/python@3.8/bin:$PATH"' >> ~/.zshrc

For compilers to find python@3.8 you may need to set:
  export LDFLAGS="-L/usr/local/opt/python@3.8/lib"

For pkg-config to find python@3.8 you may need to set:
  export PKG_CONFIG_PATH="/usr/local/opt/python@3.8/lib/pkgconfig"

==> Summary
🍺  /usr/local/Cellar/python@3.8/3.8.6_1: 4,329 files, 69.4MB
➜  rembg-master git:(master) ✗ python --version
Python 2.7.16
➜  rembg-master git:(master) ✗ python3.8
zsh: command not found: python3.8
➜  rembg-master git:(master) ✗ pip3 install --upgrade pip
Collecting pip
  Using cached https://files.pythonhosted.org/packages/cb/28/91f26bd088ce8e22169032100d4260614fc3da435025ff389ef1d396a433/pip-20.2.4-py2.py3-none-any.whl
Installing collected packages: pip
  Found existing installation: pip 19.2.3
    Uninstalling pip-19.2.3:
      Successfully uninstalled pip-19.2.3
  Rolling back uninstall of pip
  Moving to /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/pip-19.2.3.dist-info/
   from /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/~ip-19.2.3.dist-info
  Moving to /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/pip/
   from /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/~ip
  Moving to /Users/nikhilsingh/Library/Caches/com.apple.python/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/pip/
   from /Users/nikhilsingh/Library/Caches/com.apple.python/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/~ip
ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/Library/Python/3.8'
Consider using the `--user` option or check the permissions.

WARNING: You are using pip version 19.2.3, however version 20.2.4 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
➜  rembg-master git:(master) ✗ pip3 install --upgrade pip --user
Collecting pip
  Using cached https://files.pythonhosted.org/packages/cb/28/91f26bd088ce8e22169032100d4260614fc3da435025ff389ef1d396a433/pip-20.2.4-py2.py3-none-any.whl
Installing collected packages: pip
Successfully installed pip-20.2.4
WARNING: You are using pip version 19.2.3, however version 20.2.4 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
➜  rembg-master git:(master) ✗ pip3 install --upgrade pip3 --user
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
ERROR: Could not find a version that satisfies the requirement pip3 (from versions: none)
ERROR: No matching distribution found for pip3
➜  rembg-master git:(master) ✗ pip3 install rembg

WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
Defaulting to user installation because normal site-packages is not writeable
Collecting rembg
  Using cached rembg-1.0.16.tar.gz (13 kB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... done
Collecting numpy==1.19.4
  Downloading numpy-1.19.4.zip (7.3 MB)
     |████████████████████████████████| 7.3 MB 2.6 MB/s
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... error
    ERROR: Command errored out with exit status 1:
     command: /Applications/Xcode.app/Contents/Developer/usr/bin/python3 /Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py prepare_metadata_for_build_wheel /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp2c2qcd32
         cwd: /private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy
    Complete output (225 lines):
    Processing numpy/random/_bounded_integers.pxd.in
    Processing numpy/random/_philox.pyx
    Processing numpy/random/_bounded_integers.pyx.in
    Processing numpy/random/_sfc64.pyx
    Processing numpy/random/_mt19937.pyx
    Processing numpy/random/bit_generator.pyx
    Processing numpy/random/mtrand.pyx
    Processing numpy/random/_generator.pyx
    Processing numpy/random/_pcg64.pyx
    Processing numpy/random/_common.pyx
    Cythonizing sources
    blas_opt_info:
    blas_mkl_info:
    customize UnixCCompiler
    C compiler: xcrun -sdk macosx clang -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -iwithsysroot/System/Library/Frameworks/System.framework/PrivateHeaders -iwithsysroot/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/Headers -arch arm64 -arch x86_64

    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders/bm
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k
    compile options: '-MMD -MF /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/file.c.d -c'
    xcrun: /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/file.c
      libraries mkl_rt not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    blis_info:
      libraries blis not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    openblas_info:
      libraries openblas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_3_10_blas_threads_info:
    Setting PTATLAS=ATLAS
      libraries tatlas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_3_10_blas_info:
      libraries satlas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_blas_threads_info:
    Setting PTATLAS=ATLAS
      libraries ptf77blas,ptcblas,atlas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_blas_info:
      libraries f77blas,cblas,atlas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    accelerate_info:
      libraries accelerate not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
    Library accelerate was not found. Ignoring
      libraries veclib not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
    Library veclib was not found. Ignoring
      FOUND:
        extra_compile_args = ['-msse3', '-I/System/Library/Frameworks/vecLib.framework/Headers']
        extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
        define_macros = [('NO_ATLAS_INFO', 3), ('HAVE_CBLAS', None)]

      FOUND:
        extra_compile_args = ['-msse3', '-I/System/Library/Frameworks/vecLib.framework/Headers']
        extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
        define_macros = [('NO_ATLAS_INFO', 3), ('HAVE_CBLAS', None)]

    non-existing path in 'numpy/distutils': 'site.cfg'
    lapack_opt_info:
    lapack_mkl_info:
      libraries mkl_rt not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    openblas_lapack_info:
      libraries openblas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    openblas_clapack_info:
      libraries openblas,lapack not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    flame_info:
      libraries flame not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_3_10_threads_info:
    Setting PTATLAS=ATLAS
      libraries lapack_atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries tatlas,tatlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries tatlas,tatlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/lib
      libraries tatlas,tatlas not found in /usr/lib
    <class 'numpy.distutils.system_info.atlas_3_10_threads_info'>
      NOT AVAILABLE

    atlas_3_10_info:
      libraries lapack_atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries satlas,satlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries satlas,satlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/lib
      libraries satlas,satlas not found in /usr/lib
    <class 'numpy.distutils.system_info.atlas_3_10_info'>
      NOT AVAILABLE

    atlas_threads_info:
    Setting PTATLAS=ATLAS
      libraries lapack_atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries ptf77blas,ptcblas,atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/lib
      libraries ptf77blas,ptcblas,atlas not found in /usr/lib
    <class 'numpy.distutils.system_info.atlas_threads_info'>
      NOT AVAILABLE

    atlas_info:
      libraries lapack_atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries f77blas,cblas,atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries f77blas,cblas,atlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/lib
      libraries f77blas,cblas,atlas not found in /usr/lib
    <class 'numpy.distutils.system_info.atlas_info'>
      NOT AVAILABLE

      FOUND:
        extra_compile_args = ['-msse3', '-I/System/Library/Frameworks/vecLib.framework/Headers']
        extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
        define_macros = [('NO_ATLAS_INFO', 3), ('HAVE_CBLAS', None)]

    running dist_info
    running build_src
    build_src
    building py_modules sources
    creating build
    creating build/src.macosx-10.14.6-x86_64-3.8
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/distutils
    building library "npymath" sources
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath/npy_math_internal.h
      adding 'build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath' to include_dirs.
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath/ieee754.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath/npy_math_complex.c
    None - nothing done with h_files = ['build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath/npy_math_internal.h']
    building library "npysort" sources
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_sort.h
      adding 'build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common' to include_dirs.
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/quicksort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/mergesort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/timsort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/heapsort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/radixsort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_partition.h
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/selection.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_binsearch.h
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/binsearch.c
    None - nothing done with h_files = ['build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_sort.h', 'build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_partition.h', 'build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_binsearch.h']
    building library "npyrandom" sources
    building extension "numpy.core._multiarray_tests" sources
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/multiarray
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/multiarray/_multiarray_tests.c
    building extension "numpy.core._multiarray_umath" sources
    Running from numpy source directory.
    setup.py:480: UserWarning: Unrecognized setuptools command, proceeding with generating Cython sources and expanding templates
      run_build = parse_setuppy_commands()
    /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/dist.py:274: UserWarning: Unknown distribution option: 'define_macros'
      warnings.warn(msg)
    Traceback (most recent call last):
      File "/Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py", line 280, in <module>
        main()
      File "/Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py", line 263, in main
        json_out['return_val'] = hook(**hook_input['kwargs'])
      File "/Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py", line 133, in prepare_metadata_for_build_wheel
        return hook(metadata_directory, config_settings)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/build_meta.py", line 156, in prepare_metadata_for_build_wheel
        self.run_setup()
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/build_meta.py", line 236, in run_setup
        super(_BuildMetaLegacyBackend,
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/build_meta.py", line 142, in run_setup
        exec(compile(code, __file__, 'exec'), locals())
      File "setup.py", line 508, in <module>
        setup_package()
      File "setup.py", line 500, in setup_package
        setup(**metadata)
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/core.py", line 169, in setup
        return old_setup(**new_attr)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/__init__.py", line 145, in setup
        return distutils.core.setup(**attrs)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/core.py", line 148, in setup
        dist.run_commands()
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/dist.py", line 966, in run_commands
        self.run_command(cmd)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/dist.py", line 985, in run_command
        cmd_obj.run()
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/command/dist_info.py", line 31, in run
        egg_info.run()
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/egg_info.py", line 24, in run
        self.run_command("build_src")
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/cmd.py", line 313, in run_command
        self.distribution.run_command(command)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/dist.py", line 985, in run_command
        cmd_obj.run()
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/build_src.py", line 144, in run
        self.build_sources()
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/build_src.py", line 161, in build_sources
        self.build_extension_sources(ext)
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/build_src.py", line 318, in build_extension_sources
        sources = self.generate_sources(sources, ext)
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/build_src.py", line 378, in generate_sources
        source = func(extension, build_dir)
      File "numpy/core/setup.py", line 436, in generate_config_h
        moredefs, ignored = cocache.check_types(config_cmd, ext, build_dir)
      File "numpy/core/setup.py", line 47, in check_types
        out = check_types(*a, **kw)
      File "numpy/core/setup.py", line 292, in check_types
        raise SystemError(
    SystemError: Cannot compile 'Python.h'. Perhaps you need to install python-dev|python-devel.
    ----------------------------------------
ERROR: Command errored out with exit status 1: /Applications/Xcode.app/Contents/Developer/usr/bin/python3 /Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py prepare_metadata_for_build_wheel /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp2c2qcd32 Check the logs for full command output.```

Help appreciated, thanks!

closed time in 2 days

nikhilmufc7
IssuesEvent

issue closeddanielgatis/rembg

Unable to install on MacOS Big Sur

Hi , I am trying to install this on MacOS 11.0 (Big sur) it always fails , I have tried different things but it doesn't work Python version : 3.8.2 , also tried earlier 3.9.0 doesn't work either

Here are my logs:

  Using cached https://files.pythonhosted.org/packages/74/5a/46cbdb14769ed50b1fa16d57e7a34c04d7251afbacdd3589cdfa8ad3503e/rembg-1.0.16.tar.gz
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... done
Collecting scikit-image==0.17.2 (from rembg)
  Using cached https://files.pythonhosted.org/packages/54/fd/c1b0bb8f6f12ef9b4ee8d7674dac82cd482886f8b5cd165631efa533e237/scikit-image-0.17.2.tar.gz
    ERROR: Command errored out with exit status 1:
     command: /Applications/Xcode.app/Contents/Developer/usr/bin/python3 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/setup.py'"'"'; __file__='"'"'/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base pip-egg-info
         cwd: /private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/
    Complete output (7 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/setup.py", line 234, in <module>
        'build_ext': openmp_build_ext(),
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-v7cbgt59/scikit-image/setup.py", line 58, in openmp_build_ext
        from numpy.distutils.command.build_ext import build_ext
    ModuleNotFoundError: No module named 'numpy'
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
WARNING: You are using pip version 19.2.3, however version 20.2.4 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
➜  rembg-master git:(master) ✗ curl -s http://input.png | rembg > output.png
zsh: command not found: rembg
➜  rembg-master git:(master) ✗ pip install --upgrade pip
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Defaulting to user installation because normal site-packages is not writeable
Requirement already up-to-date: pip in /Library/Python/2.7/site-packages (20.2.4)
➜  rembg-master git:(master) ✗ which python
/usr/bin/python
➜  rembg-master git:(master) ✗ brew uninstall python
Error: No installed keg or cask with the name "python"
➜  rembg-master git:(master) ✗ python --version
Python 2.7.16
➜  rembg-master git:(master) ✗ python3 --version
Python 3.8.2
➜  rembg-master git:(master) ✗ brew reinstall python
Warning: You are using macOS 11.0.
We do not provide support for this released but not yet supported version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew's GitHub,
Twitter or any other official channels. You are responsible for resolving
any issues you experience while you are running this
released but not yet supported version.

==> Downloading https://homebrew.bintray.com/bottles/python%403.9-3.9.0_1.big_
Already downloaded: /Users/nikhilsingh/Library/Caches/Homebrew/downloads/07eae7a7d7ed36eb2ce66e5a1a771df7d9483f58872e38036325d56194554bf8--python@3.9-3.9.0_1.big_sur.bottle.tar.gz
==> Reinstalling python@3.9
==> Pouring python@3.9-3.9.0_1.big_sur.bottle.tar.gz
^C
➜  rembg-master git:(master) ✗ brew reinstall python@3.8
Warning: You are using macOS 11.0.
We do not provide support for this released but not yet supported version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew's GitHub,
Twitter or any other official channels. You are responsible for resolving
any issues you experience while you are running this
released but not yet supported version.

==> Downloading https://homebrew.bintray.com/bottles/python%403.8-3.8.6_1.big_
Already downloaded: /Users/nikhilsingh/Library/Caches/Homebrew/downloads/bc25badd58f2a016a9cf5f45f7ec5b4beb87cba2f01324fbad4a351696738a24--python@3.8-3.8.6_1.big_sur.bottle.tar.gz
==> Reinstalling python@3.8
==> Pouring python@3.8-3.8.6_1.big_sur.bottle.tar.gz
==> /usr/local/Cellar/python@3.8/3.8.6_1/bin/python3 -s setup.py --no-user-cfg
==> /usr/local/Cellar/python@3.8/3.8.6_1/bin/python3 -s setup.py --no-user-cfg
==> /usr/local/Cellar/python@3.8/3.8.6_1/bin/python3 -s setup.py --no-user-cfg
==> Caveats
Python has been installed as
  /usr/local/opt/python@3.8/bin/python3

Unversioned symlinks `python`, `python-config`, `pip` etc. pointing to
`python3`, `python3-config`, `pip3` etc., respectively, have been installed into
  /usr/local/opt/python@3.8/libexec/bin

You can install Python packages with
  /usr/local/opt/python@3.8/bin/pip3 install <package>
They will install into the site-package directory
  /usr/local/lib/python3.8/site-packages

See: https://docs.brew.sh/Homebrew-and-Python

python@3.8 is keg-only, which means it was not symlinked into /usr/local,
because this is an alternate version of another formula.

If you need to have python@3.8 first in your PATH run:
  echo 'export PATH="/usr/local/opt/python@3.8/bin:$PATH"' >> ~/.zshrc

For compilers to find python@3.8 you may need to set:
  export LDFLAGS="-L/usr/local/opt/python@3.8/lib"

For pkg-config to find python@3.8 you may need to set:
  export PKG_CONFIG_PATH="/usr/local/opt/python@3.8/lib/pkgconfig"

==> Summary
🍺  /usr/local/Cellar/python@3.8/3.8.6_1: 4,329 files, 69.4MB
➜  rembg-master git:(master) ✗ python --version
Python 2.7.16
➜  rembg-master git:(master) ✗ python3.8
zsh: command not found: python3.8
➜  rembg-master git:(master) ✗ pip3 install --upgrade pip
Collecting pip
  Using cached https://files.pythonhosted.org/packages/cb/28/91f26bd088ce8e22169032100d4260614fc3da435025ff389ef1d396a433/pip-20.2.4-py2.py3-none-any.whl
Installing collected packages: pip
  Found existing installation: pip 19.2.3
    Uninstalling pip-19.2.3:
      Successfully uninstalled pip-19.2.3
  Rolling back uninstall of pip
  Moving to /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/pip-19.2.3.dist-info/
   from /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/~ip-19.2.3.dist-info
  Moving to /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/pip/
   from /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/~ip
  Moving to /Users/nikhilsingh/Library/Caches/com.apple.python/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/pip/
   from /Users/nikhilsingh/Library/Caches/com.apple.python/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/~ip
ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/Library/Python/3.8'
Consider using the `--user` option or check the permissions.

WARNING: You are using pip version 19.2.3, however version 20.2.4 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
➜  rembg-master git:(master) ✗ pip3 install --upgrade pip --user
Collecting pip
  Using cached https://files.pythonhosted.org/packages/cb/28/91f26bd088ce8e22169032100d4260614fc3da435025ff389ef1d396a433/pip-20.2.4-py2.py3-none-any.whl
Installing collected packages: pip
Successfully installed pip-20.2.4
WARNING: You are using pip version 19.2.3, however version 20.2.4 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
➜  rembg-master git:(master) ✗ pip3 install --upgrade pip3 --user
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
ERROR: Could not find a version that satisfies the requirement pip3 (from versions: none)
ERROR: No matching distribution found for pip3
➜  rembg-master git:(master) ✗ pip3 install rembg

WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
Defaulting to user installation because normal site-packages is not writeable
Collecting rembg
  Using cached rembg-1.0.16.tar.gz (13 kB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... done
Collecting numpy==1.19.4
  Downloading numpy-1.19.4.zip (7.3 MB)
     |████████████████████████████████| 7.3 MB 2.6 MB/s
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... error
    ERROR: Command errored out with exit status 1:
     command: /Applications/Xcode.app/Contents/Developer/usr/bin/python3 /Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py prepare_metadata_for_build_wheel /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp2c2qcd32
         cwd: /private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy
    Complete output (225 lines):
    Processing numpy/random/_bounded_integers.pxd.in
    Processing numpy/random/_philox.pyx
    Processing numpy/random/_bounded_integers.pyx.in
    Processing numpy/random/_sfc64.pyx
    Processing numpy/random/_mt19937.pyx
    Processing numpy/random/bit_generator.pyx
    Processing numpy/random/mtrand.pyx
    Processing numpy/random/_generator.pyx
    Processing numpy/random/_pcg64.pyx
    Processing numpy/random/_common.pyx
    Cythonizing sources
    blas_opt_info:
    blas_mkl_info:
    customize UnixCCompiler
    C compiler: xcrun -sdk macosx clang -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -iwithsysroot/System/Library/Frameworks/System.framework/PrivateHeaders -iwithsysroot/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/Headers -arch arm64 -arch x86_64

    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders/bm
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T
    creating /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k
    compile options: '-MMD -MF /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/file.c.d -c'
    xcrun: /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp96fh0k1k/file.c
      libraries mkl_rt not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    blis_info:
      libraries blis not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    openblas_info:
      libraries openblas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_3_10_blas_threads_info:
    Setting PTATLAS=ATLAS
      libraries tatlas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_3_10_blas_info:
      libraries satlas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_blas_threads_info:
    Setting PTATLAS=ATLAS
      libraries ptf77blas,ptcblas,atlas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_blas_info:
      libraries f77blas,cblas,atlas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    accelerate_info:
      libraries accelerate not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
    Library accelerate was not found. Ignoring
      libraries veclib not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
    Library veclib was not found. Ignoring
      FOUND:
        extra_compile_args = ['-msse3', '-I/System/Library/Frameworks/vecLib.framework/Headers']
        extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
        define_macros = [('NO_ATLAS_INFO', 3), ('HAVE_CBLAS', None)]

      FOUND:
        extra_compile_args = ['-msse3', '-I/System/Library/Frameworks/vecLib.framework/Headers']
        extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
        define_macros = [('NO_ATLAS_INFO', 3), ('HAVE_CBLAS', None)]

    non-existing path in 'numpy/distutils': 'site.cfg'
    lapack_opt_info:
    lapack_mkl_info:
      libraries mkl_rt not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    openblas_lapack_info:
      libraries openblas not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    openblas_clapack_info:
      libraries openblas,lapack not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    flame_info:
      libraries flame not found in ['/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib', '/usr/local/lib', '/usr/lib']
      NOT AVAILABLE

    atlas_3_10_threads_info:
    Setting PTATLAS=ATLAS
      libraries lapack_atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries tatlas,tatlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries tatlas,tatlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/lib
      libraries tatlas,tatlas not found in /usr/lib
    <class 'numpy.distutils.system_info.atlas_3_10_threads_info'>
      NOT AVAILABLE

    atlas_3_10_info:
      libraries lapack_atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries satlas,satlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries satlas,satlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/lib
      libraries satlas,satlas not found in /usr/lib
    <class 'numpy.distutils.system_info.atlas_3_10_info'>
      NOT AVAILABLE

    atlas_threads_info:
    Setting PTATLAS=ATLAS
      libraries lapack_atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries ptf77blas,ptcblas,atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries ptf77blas,ptcblas,atlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/lib
      libraries ptf77blas,ptcblas,atlas not found in /usr/lib
    <class 'numpy.distutils.system_info.atlas_threads_info'>
      NOT AVAILABLE

    atlas_info:
      libraries lapack_atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries f77blas,cblas,atlas not found in /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib
      libraries lapack_atlas not found in /usr/local/lib
      libraries f77blas,cblas,atlas not found in /usr/local/lib
      libraries lapack_atlas not found in /usr/lib
      libraries f77blas,cblas,atlas not found in /usr/lib
    <class 'numpy.distutils.system_info.atlas_info'>
      NOT AVAILABLE

      FOUND:
        extra_compile_args = ['-msse3', '-I/System/Library/Frameworks/vecLib.framework/Headers']
        extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
        define_macros = [('NO_ATLAS_INFO', 3), ('HAVE_CBLAS', None)]

    running dist_info
    running build_src
    build_src
    building py_modules sources
    creating build
    creating build/src.macosx-10.14.6-x86_64-3.8
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/distutils
    building library "npymath" sources
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath/npy_math_internal.h
      adding 'build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath' to include_dirs.
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath/ieee754.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath/npy_math_complex.c
    None - nothing done with h_files = ['build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npymath/npy_math_internal.h']
    building library "npysort" sources
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_sort.h
      adding 'build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common' to include_dirs.
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/quicksort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/mergesort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/timsort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/heapsort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/radixsort.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_partition.h
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/selection.c
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_binsearch.h
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/npysort/binsearch.c
    None - nothing done with h_files = ['build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_sort.h', 'build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_partition.h', 'build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/common/npy_binsearch.h']
    building library "npyrandom" sources
    building extension "numpy.core._multiarray_tests" sources
    creating build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/multiarray
    conv_template:> build/src.macosx-10.14.6-x86_64-3.8/numpy/core/src/multiarray/_multiarray_tests.c
    building extension "numpy.core._multiarray_umath" sources
    Running from numpy source directory.
    setup.py:480: UserWarning: Unrecognized setuptools command, proceeding with generating Cython sources and expanding templates
      run_build = parse_setuppy_commands()
    /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/dist.py:274: UserWarning: Unknown distribution option: 'define_macros'
      warnings.warn(msg)
    Traceback (most recent call last):
      File "/Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py", line 280, in <module>
        main()
      File "/Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py", line 263, in main
        json_out['return_val'] = hook(**hook_input['kwargs'])
      File "/Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py", line 133, in prepare_metadata_for_build_wheel
        return hook(metadata_directory, config_settings)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/build_meta.py", line 156, in prepare_metadata_for_build_wheel
        self.run_setup()
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/build_meta.py", line 236, in run_setup
        super(_BuildMetaLegacyBackend,
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/build_meta.py", line 142, in run_setup
        exec(compile(code, __file__, 'exec'), locals())
      File "setup.py", line 508, in <module>
        setup_package()
      File "setup.py", line 500, in setup_package
        setup(**metadata)
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/core.py", line 169, in setup
        return old_setup(**new_attr)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/__init__.py", line 145, in setup
        return distutils.core.setup(**attrs)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/core.py", line 148, in setup
        dist.run_commands()
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/dist.py", line 966, in run_commands
        self.run_command(cmd)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/dist.py", line 985, in run_command
        cmd_obj.run()
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/site-packages/setuptools/command/dist_info.py", line 31, in run
        egg_info.run()
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/egg_info.py", line 24, in run
        self.run_command("build_src")
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/cmd.py", line 313, in run_command
        self.distribution.run_command(command)
      File "/Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/distutils/dist.py", line 985, in run_command
        cmd_obj.run()
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/build_src.py", line 144, in run
        self.build_sources()
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/build_src.py", line 161, in build_sources
        self.build_extension_sources(ext)
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/build_src.py", line 318, in build_extension_sources
        sources = self.generate_sources(sources, ext)
      File "/private/var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/pip-install-wsstgq1n/numpy/numpy/distutils/command/build_src.py", line 378, in generate_sources
        source = func(extension, build_dir)
      File "numpy/core/setup.py", line 436, in generate_config_h
        moredefs, ignored = cocache.check_types(config_cmd, ext, build_dir)
      File "numpy/core/setup.py", line 47, in check_types
        out = check_types(*a, **kw)
      File "numpy/core/setup.py", line 292, in check_types
        raise SystemError(
    SystemError: Cannot compile 'Python.h'. Perhaps you need to install python-dev|python-devel.
    ----------------------------------------
ERROR: Command errored out with exit status 1: /Applications/Xcode.app/Contents/Developer/usr/bin/python3 /Users/nikhilsingh/Library/Python/3.8/lib/python/site-packages/pip/_vendor/pep517/_in_process.py prepare_metadata_for_build_wheel /var/folders/bm/8v69908x5q11f27w9ydcn5kh0000gn/T/tmp2c2qcd32 Check the logs for full command output.```

Help appreciated, thanks!

closed time in 2 days

nikhilmufc7

issue commentdanielgatis/rembg

Unable to install on MacOS Big Sur

You need to install the python headers file. Try this:

xcode-select --install
nikhilmufc7

comment created time in 2 days

issue closeddanielgatis/rembg

rembg can not work with torch 1.7.1?

I installed pytorch 1.7.1 with anaconda. When I run pip install rembg it said

ERROR: Could not find a version that satisfies the requirement torch==1.7.0 (from rembg) (from versions: 0.1.2, 0.1.2.post1, 0.1.2.post2, 1.7.1)
ERROR: No matching distribution found for torch==1.7.0 (from rembg)

Does rembg need torch exact version 1.7.0?

closed time in 2 days

qinglangee

issue closeddanielgatis/rembg

Upgrade torchvision version

I got an error for installing rembg

ERROR: Could not find a version that satisfies the requirement torchvision==0.8.1 (from rembg) (from versions: 0.1.6, 0.1.7, 0.1.8, 0.1.9, 0.2.0, 0.2.1, 0.2.2, 0.2.2.post2, 0.2.2.post3, 0.5.0) ERROR: No matching distribution found for torchvision==0.8.1 (from rembg)

closed time in 2 days

ibrahimnsu15

issue closeddanielgatis/rembg

How install it on windows?

  1. Does it support win?
  2. how run it without cuda?

closed time in 2 days

ahvahsky2008

issue closeddanielgatis/rembg

pip install rembg: ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

 pip install rembg
Collecting rembg
  Using cached rembg-1.0.16.tar.gz (13 kB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... done
Collecting waitress==1.4.4
  Using cached waitress-1.4.4-py2.py3-none-any.whl (58 kB)
Collecting numpy==1.19.4
  Using cached numpy-1.19.4-cp39-cp39-win_amd64.whl (13.0 MB)
Collecting scikit-image==0.17.2
  Downloading scikit-image-0.17.2.tar.gz (29.8 MB)
     |████████████████████████████████| 29.8 MB 6.8 MB/s
    ERROR: Command errored out with exit status 1:
     command: 'd:\lab\rembg\rembg-env\scripts\python.exe' -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'C:\\Users\\karbo\\AppData\\Local\\Temp\\pip-install-x23l74te\\scikit-image\\setup.py'"'"'; __file__='"'"'C:\\Users\\karbo\\AppData\\Local\\Temp\\pip-install-x23l74te\\scikit-image\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base 'C:\Users\karbo\AppData\Local\Temp\pip-pip-egg-info-ic2ueh8m'
         cwd: C:\Users\karbo\AppData\Local\Temp\pip-install-x23l74te\scikit-image\
    Complete output (7 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:\Users\karbo\AppData\Local\Temp\pip-install-x23l74te\scikit-image\setup.py", line 234, in <module>
        'build_ext': openmp_build_ext(),
      File "C:\Users\karbo\AppData\Local\Temp\pip-install-x23l74te\scikit-image\setup.py", line 58, in openmp_build_ext
        from numpy.distutils.command.build_ext import build_ext
    ModuleNotFoundError: No module named 'numpy'
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
WARNING: You are using pip version 20.2.3; however, version 20.3.1 is available.
You should consider upgrading via the 'd:\lab\rembg\rembg-env\scripts\python.exe -m pip install --upgrade pip' command.
(rembg-env) PS D:\Lab\rembg\rembg-env> python --version
Python 3.9.0

image

closed time in 2 days

karborator

issue commentdanielgatis/rembg

pip install rembg: ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

ModuleNotFoundError: No module named 'numpy'

You need to install the numpy module.

karborator

comment created time in 2 days

issue closeddanielgatis/rembg

ERROR: Command errored out with exit status 1:

Please, it is failing. I dont know what is causing the error.

ERROR: Command errored out with exit status 1: command: 'c:\users\a\appdata\local\programs\python\python38\python.exe' 'c:\users\a\appdata\local\programs\python\python38\lib\site-packages\pip' install --ignore-installed --no-user --prefix 'C:\Users\a\AppData\Local\Temp\pip-build-env-j66cn8f3\overlay' --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'setuptools>=40.8.0' wheel cwd: None Complete output (14 lines): Traceback (most recent call last): File "c:\users\a\appdata\local\programs\python\python38\lib\runpy.py", line 194, in _run_module_as_main return _run_code(code, main_globals, None, File "c:\users\a\appdata\local\programs\python\python38\lib\runpy.py", line 87, in run_code exec(code, run_globals) File "c:\users\a\appdata\local\programs\python\python38\lib\site-packages\pip_main.py", line 23, in <module> from pip._internal.cli.main import main as _main # isort:skip # noqa File "c:\users\a\appdata\local\programs\python\python38\lib\site-packages\pip_internal\cli\main.py", line 5, in <module> import locale File "c:\users\a\appdata\local\programs\python\python38\lib\locale.py", line 16, in <module> import re File "c:\users\a\appdata\local\programs\python\python38\lib\re.py", line 145, in <module> class RegexFlag(enum.IntFlag): AttributeError: module 'enum' has no attribute 'IntFlag'

ERROR: Command errored out with exit status 1: 'c:\users\a\appdata\local\programs\python\python38\python.exe' 'c:\users\a\appdata\local\programs\python\python38\lib\site-packages\pip' install --ignore-installed --no-user --prefix 'C:\Users\a\AppData\Local\Temp\pip-build-env-j66cn8f3\overlay' --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'setuptools>=40.8.0' wheel Check the logs for full command output.

closed time in 2 days

AzazelHD

issue commentdanielgatis/rembg

ERROR: Command errored out with exit status 1:

It is related to your python installation. Look at this link:

https://stackoverflow.com/questions/43124775/why-python-3-6-1-throws-attributeerror-module-enum-has-no-attribute-intflag

AzazelHD

comment created time in 2 days

issue closeddanielgatis/rembg

Older versions (for <= python 3.7) not working

My initial codebase is written for python 3.7 so I was using version 1.0.13 of the rembg package for a long time. Two days ago I started receiving that error: _pickle.UnpicklingError: invalid load key, '<'.

image

I now can't even use older versions. Does anybody have a solution in mind?

closed time in 2 days

zemahran

issue commentdanielgatis/rembg

Older versions (for <= python 3.7) not working

The older versions have a bug when downloading the models. So, you can try download the models manually and try run.

https://github.com/danielgatis/rembg/issues/52#issuecomment-765503415

zemahran

comment created time in 2 days

issue closeddanielgatis/rembg

Blurred

I have 3000x5000px images and the background removal works more or less nicely. However, the resulting image is blurred (the dimensions are the same as the original). Is there a parameter to address this? additionally, would it be possible to just output the alpha channel?

closed time in 2 days

helmutkaufmann

issue commentdanielgatis/rembg

Blurred

To achieve this you need to train your own models.

https://github.com/danielgatis/rembg/issues/58

helmutkaufmann

comment created time in 2 days

issue closeddanielgatis/rembg

requests.exceptions.ConnectionError: HTTPSConnectionPool(host='docs.google.com', port=443)

Traceback (most recent call last): File "/Users/apple/.pyenv/versions/3.8.6/bin/rembg", line 8, in <module> sys.exit(main()) File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/rembg/cmd/cli.py", line 122, in main remove( File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/rembg/bg.py", line 87, in remove model = get_model(model_name) File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/rembg/bg.py", line 76, in get_model return detect.load_model(model_name="u2net") File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/rembg/u2net/detect.py", line 83, in load_model download_file_from_google_drive( File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/rembg/u2net/detect.py", line 28, in download_file_from_google_drive response = session.get(URL, params={"id": id}, stream=True) File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/requests/sessions.py", line 543, in get return self.request('GET', url, **kwargs) File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/requests/sessions.py", line 530, in request resp = self.send(prep, **send_kwargs) File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/requests/sessions.py", line 643, in send r = adapter.send(request, **kwargs) File "/Users/apple/.pyenv/versions/3.8.6/lib/python3.8/site-packages/requests/adapters.py", line 516, in send raise ConnectionError(e, request=request) requests.exceptions.ConnectionError: HTTPSConnectionPool(host='docs.google.com', port=443): Max retries exceeded with url: /uc?export=download&id=1ao1ovG1Qtx4b7EoskHXmi2E9rp5CHLcZ (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at 0x136a4b460>: Failed to establish a new connection: [Errno 60] Operation timed out'))

closed time in 2 days

hallywang

issue commentdanielgatis/rembg

requests.exceptions.ConnectionError: HTTPSConnectionPool(host='docs.google.com', port=443)

Download the models:

https://drive.google.com/file/d/1ao1ovG1Qtx4b7EoskHXmi2E9rp5CHLcZ/view?usp=sharing (u2net.pth) https://drive.google.com/file/d/1rbSTGKAE-MTxBYHd-51l2hMOQPT_7EPy/view?usp=sharing (u2netp.pth)

and copy to folder ~/.u2net

~/.u2net
     |-- u2net.pth
     |-- u2netp.pth
hallywang

comment created time in 2 days

issue closeddanielgatis/rembg

How can I make a c++ version of this model to bundle in mobile apps?

Hello Thanks for the awesome model + tools.

How can I make c++ version of this app ?

closed time in 2 days

Tonku
more