profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/amartya-dev/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
Amartya Gaur amartya-dev Ohuru Tech https://ohuru.tech/ I can code

amartya-dev/flutter-bloc 42

A compilation of flutter block state management tutorials

amartya-dev/covid-19-crisis-communication 4

A ChatBot for essential communication and relief during the Covid-19 Crisis

amartya-dev/chat_ui_fluid 3

Simple Chat UI in flutter with chat, call, screen using liquid swipe animation for changing screens

amartya-dev/blog_drf 1

Creating a minimal blog applicatino with DRF and Vuew.JS

amartya-dev/chat_ui_circular_navigation 1

Chat UI with screens for chatting, list of chats, list of calls, search and bottom circular navigation

amartya-dev/Database-system-B-plus-Trees 1

Implementation of B+ trees in C++, this repository aims to index records inserted by B+ trees

amartya-dev/authenticate 0

Django OAuth2.0 signup and login APIs

PR merged amartya-dev/authenticate

Bump urllib3 from 1.25.9 to 1.26.5 dependencies

Bumps urllib3 from 1.25.9 to 1.26.5. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/releases">urllib3's releases</a>.</em></p> <blockquote> <h2>1.26.5</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed deprecation warnings emitted in Python 3.10.</li> <li>Updated vendored <code>six</code> library to 1.16.0.</li> <li>Improved performance of URL parser when splitting the authority component.</li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.4</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Changed behavior of the default <code>SSLContext</code> when connecting to HTTPS proxy during HTTPS requests. The default <code>SSLContext</code> now sets <code>check_hostname=True</code>.</li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.3</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li> <p>Fixed bytes and string comparison issue with headers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2141">#2141</a>)</p> </li> <li> <p>Changed <code>ProxySchemeUnknown</code> error message to be more actionable if the user supplies a proxy URL without a scheme (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2107">#2107</a>)</p> </li> </ul> <p><strong>If you or your organization rely on urllib3 consider supporting us via <a href="https://github.com/sponsors/urllib3">GitHub Sponsors</a></strong></p> <h2>1.26.2</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed an issue where <code>wrap_socket</code> and <code>CERT_REQUIRED</code> wouldn't be imported properly on Python 2.7.8 and earlier (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2052">#2052</a>)</li> </ul> <h2>1.26.1</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li>Fixed an issue where two <code>User-Agent</code> headers would be sent if a <code>User-Agent</code> header key is passed as <code>bytes</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2047">#2047</a>)</li> </ul> <h2>1.26.0</h2> <p>:warning: <strong>IMPORTANT: urllib3 v2.0 will drop support for Python 2</strong>: <a href="https://urllib3.readthedocs.io/en/latest/v2-roadmap.html">Read more in the v2.0 Roadmap</a></p> <ul> <li> <p>Added support for HTTPS proxies contacting HTTPS servers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1923">#1923</a>, Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1806">#1806</a>)</p> </li> <li> <p>Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning should opt-in explicitly by setting <code>ssl_version=ssl.PROTOCOL_TLSv1_1</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2002">#2002</a>) <strong>Starting in urllib3 v2.0: Connections that receive a <code>DeprecationWarning</code> will fail</strong></p> </li> <li> <p>Deprecated <code>Retry</code> options <code>Retry.DEFAULT_METHOD_WHITELIST</code>, <code>Retry.DEFAULT_REDIRECT_HEADERS_BLACKLIST</code> and <code>Retry(method_whitelist=...)</code> in favor of <code>Retry.DEFAULT_ALLOWED_METHODS</code>, <code>Retry.DEFAULT_REMOVE_HEADERS_ON_REDIRECT</code>, and <code>Retry(allowed_methods=...)</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2000">#2000</a>) <strong>Starting in urllib3 v2.0: Deprecated options will be removed</strong></p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/blob/main/CHANGES.rst">urllib3's changelog</a>.</em></p> <blockquote> <h2>1.26.5 (2021-05-26)</h2> <ul> <li>Fixed deprecation warnings emitted in Python 3.10.</li> <li>Updated vendored <code>six</code> library to 1.16.0.</li> <li>Improved performance of URL parser when splitting the authority component.</li> </ul> <h2>1.26.4 (2021-03-15)</h2> <ul> <li>Changed behavior of the default <code>SSLContext</code> when connecting to HTTPS proxy during HTTPS requests. The default <code>SSLContext</code> now sets <code>check_hostname=True</code>.</li> </ul> <h2>1.26.3 (2021-01-26)</h2> <ul> <li> <p>Fixed bytes and string comparison issue with headers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2141">#2141</a>)</p> </li> <li> <p>Changed <code>ProxySchemeUnknown</code> error message to be more actionable if the user supplies a proxy URL without a scheme. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2107">#2107</a>)</p> </li> </ul> <h2>1.26.2 (2020-11-12)</h2> <ul> <li>Fixed an issue where <code>wrap_socket</code> and <code>CERT_REQUIRED</code> wouldn't be imported properly on Python 2.7.8 and earlier (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2052">#2052</a>)</li> </ul> <h2>1.26.1 (2020-11-11)</h2> <ul> <li>Fixed an issue where two <code>User-Agent</code> headers would be sent if a <code>User-Agent</code> header key is passed as <code>bytes</code> (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/2047">#2047</a>)</li> </ul> <h2>1.26.0 (2020-11-10)</h2> <ul> <li> <p><strong>NOTE: urllib3 v2.0 will drop support for Python 2</strong>. <code>Read more in the v2.0 Roadmap <https://urllib3.readthedocs.io/en/latest/v2-roadmap.html></code>_.</p> </li> <li> <p>Added support for HTTPS proxies contacting HTTPS servers (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1923">#1923</a>, Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1806">#1806</a>)</p> </li> <li> <p>Deprecated negotiating TLSv1 and TLSv1.1 by default. Users that still wish to use TLS earlier than 1.2 without a deprecation warning</p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/urllib3/urllib3/commit/d1616473df94b94f0f5ad19d2a6608cfe93b7cdf"><code>d161647</code></a> Release 1.26.5</li> <li><a href="https://github.com/urllib3/urllib3/commit/2d4a3fee6de2fa45eb82169361918f759269b4ec"><code>2d4a3fe</code></a> Improve performance of sub-authority splitting in URL</li> <li><a href="https://github.com/urllib3/urllib3/commit/2698537d52f8ff1f0bbb1d45cf018b118e91f637"><code>2698537</code></a> Update vendored six to 1.16.0</li> <li><a href="https://github.com/urllib3/urllib3/commit/07bed791e9c391d8bf12950f76537dc3c6f90550"><code>07bed79</code></a> Fix deprecation warnings for Python 3.10 ssl module</li> <li><a href="https://github.com/urllib3/urllib3/commit/d725a9b56bb8baf87c9e6eee0e9edf010034b63b"><code>d725a9b</code></a> Add Python 3.10 to GitHub Actions</li> <li><a href="https://github.com/urllib3/urllib3/commit/339ad34c677c98fd9ad008de1d8bbeb9dbf34381"><code>339ad34</code></a> Use pytest==6.2.4 on Python 3.10+</li> <li><a href="https://github.com/urllib3/urllib3/commit/f271c9c3149e20d7feffb6429b135bbb6c09ddf4"><code>f271c9c</code></a> Apply latest Black formatting</li> <li><a href="https://github.com/urllib3/urllib3/commit/1884878aac87ef0494b282e940c32c24ee917d52"><code>1884878</code></a> [1.26] Properly proxy EOF on the SSLTransport test suite</li> <li><a href="https://github.com/urllib3/urllib3/commit/a8913042b676c510e94fc2b097f6b514ae11a537"><code>a891304</code></a> Release 1.26.4</li> <li><a href="https://github.com/urllib3/urllib3/commit/8d65ea1ecf6e2cdc27d42124e587c1b83a3118b0"><code>8d65ea1</code></a> Merge pull request from GHSA-5phf-pp7p-vc2r</li> <li>Additional commits viewable in <a href="https://github.com/urllib3/urllib3/compare/1.25.9...1.26.5">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 7 days

push eventamartya-dev/authenticate

dependabot[bot]

commit sha 3d6428395654a678329740c7ea3bf50f7291a825

Bump urllib3 from 1.25.9 to 1.26.5 Bumps [urllib3](https://github.com/urllib3/urllib3) from 1.25.9 to 1.26.5. - [Release notes](https://github.com/urllib3/urllib3/releases) - [Changelog](https://github.com/urllib3/urllib3/blob/main/CHANGES.rst) - [Commits](https://github.com/urllib3/urllib3/compare/1.25.9...1.26.5) --- updated-dependencies: - dependency-name: urllib3 dependency-type: direct:production ... Signed-off-by: dependabot[bot] <support@github.com>

view details

Amartya Gaur

commit sha c18b99825208f7d4b8cb272d6c3e77601ee3aeba

Merge pull request #7 from amartya-dev/dependabot/pip/urllib3-1.26.5 Bump urllib3 from 1.25.9 to 1.26.5

view details

push time in 7 days

push eventamartya-dev/authenticate

dependabot[bot]

commit sha 323e081f93f2b1bc632371ab3c6d34f11efafeec

Bump django from 3.0.14 to 3.1.12 Bumps [django](https://github.com/django/django) from 3.0.14 to 3.1.12. - [Release notes](https://github.com/django/django/releases) - [Commits](https://github.com/django/django/compare/3.0.14...3.1.12) --- updated-dependencies: - dependency-name: django dependency-type: direct:production ... Signed-off-by: dependabot[bot] <support@github.com>

view details

Amartya Gaur

commit sha 8a4c99ea36a63fcb1defe17e723c7f8316dd85ae

Merge pull request #9 from amartya-dev/dependabot/pip/django-3.1.12 Bump django from 3.0.14 to 3.1.12

view details

push time in 7 days

PR merged amartya-dev/authenticate

Bump django from 3.0.14 to 3.1.12 dependencies

Bumps django from 3.0.14 to 3.1.12. <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/django/django/commit/625d3c1c643b0eb5c84339415ca0ba9f1728efa2"><code>625d3c1</code></a> [3.1.x] Bumped version for 3.1.12 release.</li> <li><a href="https://github.com/django/django/commit/203d4ab9ebcd72fc4d6eb7398e66ed9e474e118e"><code>203d4ab</code></a> [3.1.x] Fixed CVE-2021-33571 -- Prevented leading zeros in IPv4 addresses.</li> <li><a href="https://github.com/django/django/commit/20c67a0693c4ede2b09af02574823485e82e4c8f"><code>20c67a0</code></a> [3.1.x] Fixed CVE-2021-33203 -- Fixed potential path-traversal via admindocs'...</li> <li><a href="https://github.com/django/django/commit/aa8781c0a671610d5327d0a14d45df3b1f29640d"><code>aa8781c</code></a> [3.1.x] Confirmed release date for Django 3.1.12, and 2.2.24.</li> <li><a href="https://github.com/django/django/commit/a4eb07ac06fa629f13fe757cda730f77dbf46074"><code>a4eb07a</code></a> [3.1.x] Fixed typo in MiddlewareMixin deprecation note.</li> <li><a href="https://github.com/django/django/commit/c7fdc790cfebe52371e04c03164ac5ab93ac3e67"><code>c7fdc79</code></a> [3.1.x] Added stub release notes and date for Django 3.1.12 and 2.2.24.</li> <li><a href="https://github.com/django/django/commit/024e969062d1b7772c48c5fe45b65fcde50dea67"><code>024e969</code></a> [3.1.x] Changed IRC references to Libera.Chat.</li> <li><a href="https://github.com/django/django/commit/c53a76bdbf9b88fac0820cac50ae42e43f9b803f"><code>c53a76b</code></a> [3.1.x] Post-release version bump.</li> <li><a href="https://github.com/django/django/commit/6efdf1b7e9425c186f5ae1c5dd9a11629131fcbe"><code>6efdf1b</code></a> [3.1.x] Bumped version for 3.1.11 release.</li> <li><a href="https://github.com/django/django/commit/b7d4a6fa650f97982cf9ca246ddfa623d685487b"><code>b7d4a6f</code></a> [3.1.x] Fixed <a href="https://github-redirect.dependabot.com/django/django/issues/32718">#32718</a> -- Relaxed file name validation in FileField.</li> <li>Additional commits viewable in <a href="https://github.com/django/django/compare/3.0.14...3.1.12">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 7 days

issue commentunlayer/react-email-editor

Fonts aren't displayed

@talovicnedim nope, I am thinking of moving away from this

amartya-dev

comment created time in a month

create barnchamartya-dev/parking_dashboard

branch : main

created branch time in 2 months

created repositoryamartya-dev/parking_dashboard

created time in 2 months

startedm-Ryan/easy-email

started time in 2 months

issue openedunlayer/react-email-editor

Fonts aren't displayed

I am trying to embed the EmailEditor via React, everything seems to work fine except the fonts section, the dropdown which is supposed to contain the list of fonts, shows nothing and even the font size selection is a bit off:

the_editor_font_problem_1 the_editor_font_problem_2

Is it a bug with the editor itself? or am I doing something wrong:

Code:

import {
  Button,
  Box,
  Container,
  Grid,
  Hidden,
  Typography,
  AppBar,
} from "@material-ui/core";
import clsx from "clsx";
import React, { useRef } from "react";
import EmailEditor from "react-email-editor";
import { useSelector } from "react-redux";
import { useStyles } from "./emailBuilder.css";

import { selectOpen } from "../../redux/utils";
import { TemplatesNav } from "./TemplatesNav";
import Component from "react-email-editor";

export function EmailBuilder() {
  const emailEditorRef = useRef<Component>(null);

  const onLoad = () => {
    // you can load your template here;
    // const templateJson = {};
    // emailEditorRef.current.editor.loadDesign(templateJson);
  };

  const classes = useStyles();

  const drawerOpen = useSelector(selectOpen);

  const [templatesNavOpen, setTemplatesNavOpen] =
    React.useState<boolean>(false);
  const openTemplatesNav =
    () => (event: React.KeyboardEvent | React.MouseEvent) => {
      console.log(templatesNavOpen);
      setTemplatesNavOpen(true);
    };

  const exportHtml = async () => {
    emailEditorRef.current!.exportHtml(
      (data: { design: Object; html: String }) => {
        const { design, html } = data;
        console.log("exportHtml", html);
        console.log("Design JSON", design);
      }
    );
  };

  return (
    <Container maxWidth="xl">
      <Hidden mdDown>
        <AppBar
          position="fixed"
          className={clsx(classes.appBarStyle, {
            [classes.shiftedAppBarStyle]: drawerOpen,
          })}
          elevation={0}
        >
          <Box display="flex" m={1} p={1}>
            <Box p={1} flexGrow={1}>
              <Button
                onClick={openTemplatesNav()}
                color="primary"
                variant="contained"
              >
                Templates
              </Button>
            </Box>
            <Box p={1}>
              <Button color="primary" variant="contained">
                Preview
              </Button>
            </Box>
            <Box p={1}>
              <Button color="primary" variant="contained" onClick={exportHtml}>
                Save
              </Button>
            </Box>
          </Box>
        </AppBar>
        <TemplatesNav
          drawerOpen={templatesNavOpen}
          setDrawerOpen={setTemplatesNavOpen}
        />
        <Grid container className={classes.container}>
          <EmailEditor ref={emailEditorRef} onLoad={onLoad} />
        </Grid>
      </Hidden>
      <Hidden mdUp>
        <Typography variant="h5">
          Shoot !! We do not support designing on mobiles yet
        </Typography>
      </Hidden>
    </Container>
  );
}

created time in 2 months