profile
viewpoint
Moulik Aggarwal aggmoulik DeepSource Jaipur https://www.aggmoulik.me/ Software Enginner @deepsourcelabs | GSoC'19 @oclif

aggmoulik/25DaysOfServerless 0

Each day between now and December 25 will bring a new problem to solve using serverless technology. #25DaysOfServerless

aggmoulik/Alphynite 0

Alphynite

aggmoulik/aura 0

GDG Chapter website template

aggmoulik/awesome-ctf 0

A curated list of CTF frameworks, libraries, resources and softwares

aggmoulik/Awesome-Profile-README-templates 0

A collection of awesome readme templates to display on your profile

aggmoulik/command 0

oclif base command

aggmoulik/dailycodebase 0

2 month data structures and algorithmic scripting challenge starting from 20th December 2018 - Coding is Fun! 💯💯 Do it everyday

aggmoulik/deno_lint 0

Blazing fast linter for JavaScript and TypeScript written in Rust

created repositorycodereport/CTfP-2021

created time in 3 hours

created repositoryPraneet460/TextGen_API

Text generation API built using Django-Rest-Framework and Tensorflow

created time in 9 hours

fork heyAyushh/storybook

📓 The UI component explorer. Develop, document, & test for React, Vue, Angular, Ember, Web Components, & more!

https://storybook.js.org

fork in 12 hours

fork fyhertz/pgloader

Migrate to PostgreSQL in a single command!

http://pgloader.io

fork in 12 hours

created repositoryheyAyushh/aquilla

created time in 12 hours

startedjmespath/jmespath.terminal

started time in 13 hours

startedkanzitelli/rabbit-app

started time in 16 hours

startedtootsuite/mastodon

started time in 17 hours

startedmxrch/GHunt

started time in 17 hours

startedsignalapp/Signal-Server

started time in 17 hours

startedsvenstaro/miniserve

started time in 17 hours

startedowncloud/ocis

started time in 18 hours

startedemacs-ng/emacs-ng

started time in 19 hours

MemberEvent

issue openedoclif/oclif

Compilation error on newly generated "multi" cli: TS6306

Do you want to request a feature or report a bug?

Bug

What is the current behavior?

Brand new "multi" cli gives compilation error: " Error:(7, 5) TS6306: Referenced project '/Users/path/to/project' must have setting "composite": true."

If the current behavior is a bug, please provide the steps to reproduce.

  1. Using the "multi" command generate a new cli.
  2. Following the prompt I selected the following config options:

npm package name: delete ? command bin name the CLI will export: delete ? description: delete ? author: Jonathan Lassiter @LassiterJ ? version: 0.0.0 ? license: MIT ? Who is the GitHub owner of repository: (https://github.com/OWNER/repo) LassiterJ ? What is the GitHub name of repository: (https://github.com/owner/REPO) delete ? Select a package manager: yarn ? TypeScript: Yes ? Use eslint (linter for JavaScript and Typescript): Yes ? Use mocha (testing framework): Yes ------------> This option generates the test folder with the tsconfig where the error occurs. ? Add CI service config: circleci

3. after new cli is generated, run the compiler and you should get the TS6306 error.

What is the expected behavior?

No compile errors on new cli.

Please mention your oclif and OS version. MacOs 11.1 BigSur oclif/1.16.1 darwin-x64 node-v15.4.0 IDE: Webstorm 2020.3.1

Potentially related to #172

created time in a day

startedlmatteis/torrent-net

started time in a day

issue commentoclif/oclif

oclif-dev manifest command is executing source code.

Good to point out! Though I'll skip calling it a bug for now, unless you want to document an adverse effect.

Please document this! I have spent hours trying to figure out the "root index" command, which could also use an example in the docs, and was confused when a console.log was firing from a command with only the bin name keyword.

rockmandash

comment created time in a day

startedveeral-patel/how-to-secure-anything

started time in a day

startedDefinitelyTyped/DefinitelyTyped

started time in a day

startedcriteo/kerberos-docker

started time in 2 days

starteddalenguyen/serverless-rest-api

started time in 2 days

created repositorynerdeveloper/argocd

created time in 2 days

startedk4yt3x/video2x

started time in 2 days

MemberEvent

fork codereport/shields

Concise, consistent, and legible badges in SVG and raster format

https://shields.io

fork in 2 days

startedJamesCooteUK/SharpSphere

started time in 2 days

startedblendin/3snake

started time in 2 days

startedbeizhedenglong/react-hooks-lib

started time in 2 days

startedmirage/irmin

started time in 3 days

issue closedoclif/oclif

Bug - Error: EEXIT: 0 when running --help and -h

What is the current behavior?

Good morning, I'm trying to use the --help and -h option to see the help information from my command but I'm receiving the following error plus the help information:

➜  booster git:(master) ✗ boost new:command -h    
generate new resource, write 'boost new' to see options

USAGE
  $ boost new:command [COMMANDNAME]

OPTIONS
  -f, --fields=fields  field that this command will contain
  -h, --help           show CLI help

ExitError: EEXIT: 0
    at Object.exit (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/node_modules/@oclif/errors/lib/index.js:19:11)
    at Command.exit (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/node_modules/@oclif/command/lib/command.js:54:23)
    at Command._help (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/node_modules/@oclif/command/lib/command.js:127:21)
    at Object.parse (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/node_modules/@oclif/command/lib/flags.js:37:17)
    at Parser._flags (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/node_modules/@oclif/parser/lib/parse.js:149:42)
    at Parser.parse (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/node_modules/@oclif/parser/lib/parse.js:117:28)
    at Object.parse (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/node_modules/@oclif/parser/lib/index.js:27:27)
    at Command.parse (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/node_modules/@oclif/command/lib/command.js:86:41)
    at Command.runWithErrors (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/dist/commands/new/command.js:16:38)
    at Command.run (/Users/.../.nvm/versions/node/v14.2.0/lib/node_modules/@boostercloud/cli/dist/commands/new/command.js:13:21) {
  oclif: { exit: 0 },
  code: 'EEXIT'

Here's the branch with the changes:

  1. Command: https://github.com/boostercloud/booster/blob/cli_help_error/packages/cli/src/commands/new/command.ts
  2. Test: https://github.com/boostercloud/booster/blob/cli_help_error/packages/cli/test/commands/new.test.ts

The thing is that "unchained commands" (like boost start -h) are working, but not the chained ones, like boost new:event -h

What is the expected behavior?

I would like to avoid printing that Error: EEXIT: 0, and only print the --help information

Does anyone know what is going on?

closed time in 3 days

juanjoman
more