profile
viewpoint
Hardy YehezkielSaputra Singapore https://hardysaputra.herokuapp.com/ Java, ASP.Net, Angular, ReactJS, NodeJS Fullstack Programmer

YehezkielSaputra/azure-chat-bot 1

Create Chat Bot Sample Using Azure Bot Builder v4 in Node JS

YehezkielSaputra/angular 0

Angular Questions and Answers

YehezkielSaputra/asp.net 0

ASP.Net Questions and Answers

YehezkielSaputra/nodejs 0

NodeJS Questions and Answers

YehezkielSaputra/reactjs 0

ReactJS Questions and Answers

YehezkielSaputra/typeorm 0

ORM for TypeScript and JavaScript (ES7, ES6, ES5). Supports MySQL, PostgreSQL, MariaDB, SQLite, MS SQL Server, Oracle, WebSQL databases. Works in NodeJS, Browser, Ionic, Cordova and Electron platforms.

fork YehezkielSaputra/GMap-PHP

Use Google Map with PHP (and MySQL) arrays

fork in 2 months

fork YehezkielSaputra/restapidocs

Templates for documenting REST APIs

fork in 3 months

push eventYehezkielSaputra/azure-chat-bot

dependabot[bot]

commit sha 8c19d182ddc104afdb0b801b406ac8f0cab73904

Bump mixin-deep from 1.3.1 to 1.3.2 Bumps [mixin-deep](https://github.com/jonschlinkert/mixin-deep) from 1.3.1 to 1.3.2. - [Release notes](https://github.com/jonschlinkert/mixin-deep/releases) - [Commits](https://github.com/jonschlinkert/mixin-deep/compare/1.3.1...1.3.2) Signed-off-by: dependabot[bot] <support@github.com>

view details

Hardy

commit sha 9bd1ac1eb425c7a97073c0531a765e5da425b291

Merge pull request #5 from YehezkielSaputra/dependabot/npm_and_yarn/mixin-deep-1.3.2 Bump mixin-deep from 1.3.1 to 1.3.2

view details

push time in 3 months

PR merged YehezkielSaputra/azure-chat-bot

Bump mixin-deep from 1.3.1 to 1.3.2 dependencies

Bumps mixin-deep from 1.3.1 to 1.3.2. <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/jonschlinkert/mixin-deep/commit/754f0c20e1bc13ea5a21a64fbc7d6ba5f7b359b9"><code>754f0c2</code></a> 1.3.2</li> <li><a href="https://github.com/jonschlinkert/mixin-deep/commit/90ee1fab375fccfd9b926df718243339b4976d50"><code>90ee1fa</code></a> ensure keys are valid when mixing in values</li> <li>See full diff in <a href="https://github.com/jonschlinkert/mixin-deep/compare/1.3.1...1.3.2">compare view</a></li> </ul> </details> <details> <summary>Maintainer changes</summary> <p>This version was pushed to npm by <a href="https://www.npmjs.com/~doowb">doowb</a>, a new releaser for mixin-deep since your current version.</p> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+3 -3

0 comment

1 changed file

dependabot[bot]

pr closed time in 3 months

push eventYehezkielSaputra/azure-chat-bot

dependabot[bot]

commit sha 7923ca8eed4bfc5362d1f83a770bbabd4bc4d42a

Bump eslint-utils from 1.3.1 to 1.4.3 Bumps [eslint-utils](https://github.com/mysticatea/eslint-utils) from 1.3.1 to 1.4.3. - [Release notes](https://github.com/mysticatea/eslint-utils/releases) - [Commits](https://github.com/mysticatea/eslint-utils/compare/v1.3.1...v1.4.3) Signed-off-by: dependabot[bot] <support@github.com>

view details

Hardy

commit sha a2e20765540cbfa7260e03d976ddc8ddb623e7a2

Merge pull request #4 from YehezkielSaputra/dependabot/npm_and_yarn/eslint-utils-1.4.3 Bump eslint-utils from 1.3.1 to 1.4.3

view details

push time in 3 months

PR merged YehezkielSaputra/azure-chat-bot

Bump eslint-utils from 1.3.1 to 1.4.3 dependencies

Bumps eslint-utils from 1.3.1 to 1.4.3. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/mysticatea/eslint-utils/releases">eslint-utils's releases</a>.</em></p> <blockquote> <h2>v1.4.3</h2> <h2>🐛 Bug fixes</h2> <ul> <li>8f9e481ecc1204c7a1331b697f97903f90c75154 fixed false positive of <code>ReferenceTracker</code>.</li> </ul> <h2>v1.4.2</h2> <h2>🐛 Bug fixes</h2> <ul> <li>e4cb01498df6096b66edb0c78965ee6f47d3ac77 fixed a regression of the previous release.</li> </ul> <h2>v1.4.1</h2> <h2>🐛 Bug fixes</h2> <ul> <li>c119e832952c8c653bd4f21e39eb9f7ce48e5947 fixed <code>getStaticValue()</code> function to handle <code>null</code> literal correctly even if runtimes don't support BigInt natively.</li> <li>587cca2f82c245f5fc4a8b9fb2cf6b35c0d02552 fixed <code>getStringIfConstant()</code> function to handle regular expression literals and BigInt literals even if runtimes don't support those.</li> <li>08158db1c98fd71cf0f32ddefbc147e2620e724c fixed GHSA-3gx7-xhv7-5mx3.</li> </ul> <h2>v1.4.0</h2> <h2>✨ Enhancements</h2> <ul> <li>66456c5356310fc4309b4fe2756995f27b907747 (and ebf5a8378d3f0a20a74adb158a7112cb616bce44, aac472e815551688d23cc8fd88f9044dbf276804) added <code>isParenthesized()</code> function that checks if a given node is parenthesized or not.</li> <li>4f8407dd6cd52274ba115b3a8558153ec6d799a7 (and cb518c70ee037722f802d808bbbe93da83f07fb3) added <code>hasSideEffect()</code> function that checks if a given node may have side-effects or not.</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/mysticatea/eslint-utils/commit/23f4ddc58eda5e6aec3d6a43c6266acbe19345cd"><code>23f4ddc</code></a> 🔖 1.4.3</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/8f9e481ecc1204c7a1331b697f97903f90c75154"><code>8f9e481</code></a> 🐛 fix reference tracker false positive</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/663327835abfb1f62fc6fc5d69028457e11b5f80"><code>6633278</code></a> ⚒ fix test scripts</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/7c8e67c22f7222685a6a9154ba5eec2ac4896a3e"><code>7c8e67c</code></a> ⚒ fix build scripts</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/41ff95e728db2c52122ae3dad42997dccd223388"><code>41ff95e</code></a> ⚒ update dependencies</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/49420121ff4d2b4758d4016848055c1631389faa"><code>4942012</code></a> ⚒ fix build scripts</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/f1c8d02b3fd190a97e39603929c0aabe36c9904f"><code>f1c8d02</code></a> ⚒ update build scripts</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/a88598a74f0d71376447c4ecb6b56b27272f3992"><code>a88598a</code></a> Create FUNDING.yml</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/4e1bc077c2a6bb00538d66b69a63c24de3463bed"><code>4e1bc07</code></a> 1.4.2</li> <li><a href="https://github.com/mysticatea/eslint-utils/commit/e4cb01498df6096b66edb0c78965ee6f47d3ac77"><code>e4cb014</code></a> 🐛 add null test</li> <li>Additional commits viewable in <a href="https://github.com/mysticatea/eslint-utils/compare/v1.3.1...v1.4.3">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+15 -4

0 comment

1 changed file

dependabot[bot]

pr closed time in 3 months

push eventYehezkielSaputra/azure-chat-bot

dependabot[bot]

commit sha 0842d9f9ce171286e8d71b9694c8b49a8d0003fe

Bump js-yaml from 3.12.1 to 3.14.0 Bumps [js-yaml](https://github.com/nodeca/js-yaml) from 3.12.1 to 3.14.0. - [Release notes](https://github.com/nodeca/js-yaml/releases) - [Changelog](https://github.com/nodeca/js-yaml/blob/master/CHANGELOG.md) - [Commits](https://github.com/nodeca/js-yaml/compare/3.12.1...3.14.0) Signed-off-by: dependabot[bot] <support@github.com>

view details

Hardy

commit sha 735a96707313741f852dfe6d5b63b39a7b561198

Merge pull request #3 from YehezkielSaputra/dependabot/npm_and_yarn/js-yaml-3.14.0 Bump js-yaml from 3.12.1 to 3.14.0

view details

push time in 3 months

PR merged YehezkielSaputra/azure-chat-bot

Bump js-yaml from 3.12.1 to 3.14.0 dependencies

Bumps js-yaml from 3.12.1 to 3.14.0. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/nodeca/js-yaml/blob/master/CHANGELOG.md">js-yaml's changelog</a>.</em></p> <blockquote> <h2>[3.14.0] - 2020-05-22</h2> <h3>Changed</h3> <ul> <li>Support <code>safe/loadAll(input, options)</code> variant of call.</li> <li>CI: drop outdated nodejs versions.</li> <li>Dev deps bump.</li> </ul> <h3>Fixed</h3> <ul> <li>Quote <code>=</code> in plain scalars <a href="https://github-redirect.dependabot.com/nodeca/js-yaml/issues/519">#519</a>.</li> <li>Check the node type for <code>!<?></code> tag in case user manually specifies it.</li> <li>Verify that there are no null-bytes in input.</li> <li>Fix wrong quote position when writing condensed flow, <a href="https://github-redirect.dependabot.com/nodeca/js-yaml/issues/526">#526</a>.</li> </ul> <h2>[3.13.1] - 2019-04-05</h2> <h3>Security</h3> <ul> <li>Fix possible code execution in (already unsafe) <code>.load()</code>, <a href="https://github-redirect.dependabot.com/nodeca/js-yaml/issues/480">#480</a>.</li> </ul> <h2>[3.13.0] - 2019-03-20</h2> <h3>Security</h3> <ul> <li>Security fix: <code>safeLoad()</code> can hang when arrays with nested refs used as key. Now throws exception for nested arrays. <a href="https://github-redirect.dependabot.com/nodeca/js-yaml/issues/475">#475</a>.</li> </ul> <h2>[3.12.2] - 2019-02-26</h2> <h3>Fixed</h3> <ul> <li>Fix <code>noArrayIndent</code> option for root level, <a href="https://github-redirect.dependabot.com/nodeca/js-yaml/issues/468">#468</a>.</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/nodeca/js-yaml/commit/34e5072f43fd36b08aaaad433da73c10d47c41e5"><code>34e5072</code></a> 3.14.0 released</li> <li><a href="https://github.com/nodeca/js-yaml/commit/7b25c83a6dc77097c2bf14bf714e168f60ee199b"><code>7b25c83</code></a> Browser files rebuild</li> <li><a href="https://github.com/nodeca/js-yaml/commit/6f7347396867b8dcfc042722c2aae810dfe4caae"><code>6f73473</code></a> Dev deps bump</li> <li><a href="https://github.com/nodeca/js-yaml/commit/0c293491d903cddcd41b41c165bc45eeb9a8d720"><code>0c29349</code></a> Travis-CI: drop old nodejs versions</li> <li><a href="https://github.com/nodeca/js-yaml/commit/10be97ebbd588e68907e6c67e0b3843a4caab475"><code>10be97e</code></a> fix(loader): Add support for <code>safe/loadAll(input, options)</code></li> <li><a href="https://github.com/nodeca/js-yaml/commit/d6983dd4291849b2854e8d26e1beb302edfd4c76"><code>d6983dd</code></a> Fix issue <a href="https://github-redirect.dependabot.com/nodeca/js-yaml/issues/526">#526</a>: wrong quote position writing condensed flow (<a href="https://github-redirect.dependabot.com/nodeca/js-yaml/issues/527">#527</a>)</li> <li><a href="https://github.com/nodeca/js-yaml/commit/93fbf7d4ddecea60709c8379397247af28f11e10"><code>93fbf7d</code></a> fix issue 526 (wrong quote position writing condensed flow)</li> <li><a href="https://github.com/nodeca/js-yaml/commit/e569cc70ec9b41760d0d37b805a1d9b3ada519ca"><code>e569cc7</code></a> readme: update titelift info</li> <li><a href="https://github.com/nodeca/js-yaml/commit/8fb29059223b5f700dec4ea09b3d5550cd3a8e32"><code>8fb2905</code></a> changelog format update</li> <li><a href="https://github.com/nodeca/js-yaml/commit/33c2236d702fee430cac27ab41d75069b6647765"><code>33c2236</code></a> Verify that there are no null-bytes in input</li> <li>Additional commits viewable in <a href="https://github.com/nodeca/js-yaml/compare/3.12.1...3.14.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+3 -3

0 comment

1 changed file

dependabot[bot]

pr closed time in 3 months

push eventYehezkielSaputra/azure-chat-bot

dependabot[bot]

commit sha a3e38bac3f2d7a2b532b87cf04e5565bedf1a29d

Bump axios from 0.18.0 to 0.18.1 Bumps [axios](https://github.com/axios/axios) from 0.18.0 to 0.18.1. - [Release notes](https://github.com/axios/axios/releases) - [Changelog](https://github.com/axios/axios/blob/v0.18.1/CHANGELOG.md) - [Commits](https://github.com/axios/axios/compare/v0.18.0...v0.18.1) Signed-off-by: dependabot[bot] <support@github.com>

view details

Hardy

commit sha 157858e74340b88d65966d039eaa37ee1efb8caa

Merge pull request #6 from YehezkielSaputra/dependabot/npm_and_yarn/axios-0.18.1 Bump axios from 0.18.0 to 0.18.1

view details

push time in 3 months

PR merged YehezkielSaputra/azure-chat-bot

Bump axios from 0.18.0 to 0.18.1 dependencies

Bumps axios from 0.18.0 to 0.18.1. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/axios/axios/releases">axios's releases</a>.</em></p> <blockquote> <h2>v0.18.1</h2> <p>Security Fix:</p> <ul> <li>Destroy stream on exceeding maxContentLength (fixes <a href="https://github-redirect.dependabot.com/axios/axios/issues/1098">#1098</a>) (<a href="https://github-redirect.dependabot.com/axios/axios/issues/1485">#1485</a>) - Gadzhi Gadzhiev</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/axios/axios/blob/v0.18.1/CHANGELOG.md">axios's changelog</a>.</em></p> <blockquote> <h3>0.18.1 (May 31, 2019)</h3> <p>Security Fix:</p> <ul> <li>Destroy stream on exceeding maxContentLength (fixes <a href="https://github-redirect.dependabot.com/axios/axios/issues/1098">#1098</a>) (<a href="https://github-redirect.dependabot.com/axios/axios/pull/1485">#1485</a>) - Gadzhi Gadzhiev</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/axios/axios/commit/face0165de613696d10b1fd2a0e2f7b3852fa018"><code>face016</code></a> Releasing 0.18.1</li> <li><a href="https://github.com/axios/axios/commit/062876378b2e46aa12cb084dce56dddde1f8172c"><code>0628763</code></a> Update Changelog for release (0.18.1)</li> <li><a href="https://github.com/axios/axios/commit/dc9b29c3411f160009570d369013585693deb154"><code>dc9b29c</code></a> adjust README to match IE support</li> <li><a href="https://github.com/axios/axios/commit/16326d5fe93bb2bf9d793fe04786e3198f298429"><code>16326d5</code></a> Remove usages of isOldIE in tests</li> <li><a href="https://github.com/axios/axios/commit/5a4228b9f82ef9dfb695e10c95d237f4b7afdc14"><code>5a4228b</code></a> Remove IE10 launcher from karma config</li> <li><a href="https://github.com/axios/axios/commit/695b5f7241d7a3b339a768e3d04cfa5d1efd758e"><code>695b5f7</code></a> Remove isOldIE check in tests</li> <li><a href="https://github.com/axios/axios/commit/e314ab00b48be01283f4c48fc2ecaef73fac7c85"><code>e314ab0</code></a> Remove HTTP 1223 handling</li> <li><a href="https://github.com/axios/axios/commit/7efa822b2e8ac47c54f3eafc7fb0c6b52ffaa0c6"><code>7efa822</code></a> Remove btoa polyfill tests</li> <li><a href="https://github.com/axios/axios/commit/f3cdcc7f0125a069998bb3c74337fea99dd98f7b"><code>f3cdcc7</code></a> Delete btoa polyfill</li> <li><a href="https://github.com/axios/axios/commit/efc0b581c828fe0e5e6d39a40d65d1c73181e05c"><code>efc0b58</code></a> Remove ie8/9 special CORS treatment and btoa polyfill</li> <li>Additional commits viewable in <a href="https://github.com/axios/axios/compare/v0.18.0...v0.18.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+36 -14

0 comment

1 changed file

dependabot[bot]

pr closed time in 3 months

more