profile
viewpoint
최민호 Vnthf NHN Entertainment Pankyo https://showerbugs.github.io http://vnthf.logdown.com/

amazingguni/pomodoro-androidapp 0

The android aplplication client of pomoDOro service.

Vnthf/angular-bootstrap-checkbox 0

A checkbox for AngularJS styled to fit the Twitter Bootstrap standard design

Vnthf/angular-dragdrop 0

Angular HTML5 Drag and Drop directive written in pure js with no dependency on JQuery.

Vnthf/angular-froala 0

Angular.js bindings for Froala WYSIWYG HTML Rich Text Editor.

Vnthf/angular-svg-base 0

Auto directives to automatically rewrite absolute hash URLs for fragment references in SVG elements, to work around <base> side effects in Gecko and Blink.

Vnthf/At.js 0

Add Github like mentions autocomplete to your application.

created repositoryzachleat/herald-of-the-dog

An announcement bar banner component.

created time in 7 days

startedmongodb-js/boxednode

started time in a month

PR opened grass-party/api

Bump requests from 2.18.4 to 2.20.0

Bumps requests from 2.18.4 to 2.20.0. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/psf/requests/blob/master/HISTORY.md">requests's changelog</a>.</em></p> <blockquote> <h2>2.20.0 (2018-10-18)</h2> <p><strong>Bugfixes</strong></p> <ul> <li>Content-Type header parsing is now case-insensitive (e.g. charset=utf8 v Charset=utf8).</li> <li>Fixed exception leak where certain redirect urls would raise uncaught urllib3 exceptions.</li> <li>Requests removes Authorization header from requests redirected from https to http on the same hostname. (CVE-2018-18074)</li> <li><code>should_bypass_proxies</code> now handles URIs without hostnames (e.g. files).</li> </ul> <p><strong>Dependencies</strong></p> <ul> <li>Requests now supports urllib3 v1.24.</li> </ul> <p><strong>Deprecations</strong></p> <ul> <li>Requests has officially stopped support for Python 2.6.</li> </ul> <h2>2.19.1 (2018-06-14)</h2> <p><strong>Bugfixes</strong></p> <ul> <li>Fixed issue where status_codes.py's <code>init</code> function failed trying to append to a <code>doc</code> value of <code>None</code>.</li> </ul> <h2>2.19.0 (2018-06-12)</h2> <p><strong>Improvements</strong></p> <ul> <li>Warn user about possible slowdown when using cryptography version < 1.3.4</li> <li>Check for invalid host in proxy URL, before forwarding request to adapter.</li> <li>Fragments are now properly maintained across redirects. (RFC7231 7.1.2)</li> <li>Removed use of cgi module to expedite library load time.</li> <li>Added support for SHA-256 and SHA-512 digest auth algorithms.</li> <li>Minor performance improvement to <code>Request.content</code>.</li> <li>Migrate to using collections.abc for 3.7 compatibility.</li> </ul> <p><strong>Bugfixes</strong></p> <ul> <li>Parsing empty <code>Link</code> headers with <code>parse_header_links()</code> no longer return one bogus entry.</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/psf/requests/commit/bd840450c0d1e9db3bf62382c15d96378cc3a056"><code>bd84045</code></a> v2.20.0</li> <li><a href="https://github.com/psf/requests/commit/7fd9267b3bab1d45f5e4ac0953629c5531ecbc55"><code>7fd9267</code></a> remove final remnants from 2.6</li> <li><a href="https://github.com/psf/requests/commit/6ae8a2189235b62d7c5b2a6b95528750f046097c"><code>6ae8a21</code></a> Add myself to AUTHORS</li> <li><a href="https://github.com/psf/requests/commit/89ab030cdb83a728a30e172bc65d27ba214d2eda"><code>89ab030</code></a> Use comprehensions whenever possible</li> <li><a href="https://github.com/psf/requests/commit/2c6a8426aebd853966747f2c851f551c583cb21a"><code>2c6a842</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/psf/requests/issues/4827">#4827</a> from webmaven/patch-1</li> <li><a href="https://github.com/psf/requests/commit/30be889651e7034eaa56edaf5794d68ffbfde9ed"><code>30be889</code></a> CVE URLs update: www sub-subdomain no longer valid</li> <li><a href="https://github.com/psf/requests/commit/a6cd380c640087218695bc7c62311a4843777e43"><code>a6cd380</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/psf/requests/issues/4765">#4765</a> from requests/encapsulate_urllib3_exc</li> <li><a href="https://github.com/psf/requests/commit/bbdbcc8f0553f112ff68b0950b4128bd8af000fc"><code>bbdbcc8</code></a> wrap url parsing exceptions from urllib3's PoolManager</li> <li><a href="https://github.com/psf/requests/commit/ff0c325014f817095de35013d385e137b111d6e8"><code>ff0c325</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/psf/requests/issues/4805">#4805</a> from jdufresne/https</li> <li><a href="https://github.com/psf/requests/commit/b0ad2499c8641d29affc90f565e6628d333d2a96"><code>b0ad249</code></a> Prefer https:// for URLs throughout project</li> <li>Additional commits viewable in <a href="https://github.com/psf/requests/compare/v2.18.4...v2.20.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

pr created time in a month

create barnchgrass-party/api

branch : dependabot/pip/requests-2.20.0

created branch time in a month

create barnchgrass-party/api

branch : dependabot/pip/djangorestframework-3.9.1

created branch time in a month

PR opened grass-party/api

Bump djangorestframework from 3.7.7 to 3.9.1

Bumps djangorestframework from 3.7.7 to 3.9.1. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/encode/django-rest-framework/releases">djangorestframework's releases</a>.</em></p> <blockquote> <h2>Version 3.9.1</h2> <p>Change Notes: <a href="https://www.django-rest-framework.org/community/release-notes/#39x-series">https://www.django-rest-framework.org/community/release-notes/#39x-series</a></p> <h2>Verision 3.9.0</h2> <p>Release announcement: <a href="https://www.django-rest-framework.org/community/3.9-announcement/">https://www.django-rest-framework.org/community/3.9-announcement/</a></p> <p>Change Notes: <a href="https://www.django-rest-framework.org/community/release-notes/#39x-series">https://www.django-rest-framework.org/community/release-notes/#39x-series</a></p> <h2>Version 3.8.2</h2> <p>Point release for 3.8.x series</p> <ul> <li>Fix <code>read_only</code> + <code>default</code> <code>unique_together</code> validation. <a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/5922">#5922</a></li> <li>authtoken.views import coreapi from rest_framework.compat, not directly. <a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/5921">#5921</a></li> <li>Docs: Add missing argument 'detail' to Route <a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/5920">#5920</a></li> </ul> <h2>Version 3.8.1</h2> <ul> <li> <p>Use old <code>url_name</code> behavior in route decorators <a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/5915">#5915</a></p> <p>For <code>list_route</code> and <code>detail_route</code> maintain the old behavior of <code>url_name</code>, basing it on the <code>url_path</code> instead of the function name.</p> </li> </ul> <h2>Version 3.8</h2> <ul> <li> <p><a href="http://www.django-rest-framework.org/topics/3.8-announcement/">Release Announcement</a></p> </li> <li> <p><a href="https://github.com/encode/django-rest-framework/milestone/61?closed=1">3.8.0 Milestone</a></p> </li> <li> <p><strong>Breaking Change</strong>: Alter <code>read_only</code> plus <code>default</code> behaviour. <a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/5886">#5886</a></p> <p><code>read_only</code> fields will now <strong>always</strong> be excluded from writable fields.</p> <p>Previously <code>read_only</code> fields with a <code>default</code> value would use the <code>default</code> for create and update operations.</p> <p>In order to maintain the old behaviour you may need to pass the value of <code>read_only</code> fields when calling <code>save()</code> in the view:</p> <pre><code> def perform_create(self, serializer): serializer.save(owner=self.request.user) </code></pre> <p>Alternatively you may override <code>save()</code> or <code>create()</code> or <code>update()</code> on the serialiser as appropriate.</p> </li> <li> <p>Correct allow_null behaviour when required=False <a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/5888">#5888</a></p> <p>Without an explicit <code>default</code>, <code>allow_null</code> implies a default of <code>null</code> for outgoing serialisation. Previously such fields were being skipped when read-only or otherwise not required.</p> <p><strong>Possible backwards compatibility break</strong> if you were relying on such fields being excluded from the outgoing representation. In order to restore the old behaviour you can override <code>data</code> to exclude the field when <code>None</code>.</p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/encode/django-rest-framework/commit/453196e9c3a581bac3bf68eb8c9cdd7d28d2dcd6"><code>453196e</code></a> Version 3.9.1 (<a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/6405">#6405</a>)</li> <li><a href="https://github.com/encode/django-rest-framework/commit/4bb9a3c48427867ef1e46f7dee945a4c25a4f9b8"><code>4bb9a3c</code></a> Fix XSS caused by disabled autoescaping in the default DRF Browsable API view...</li> <li><a href="https://github.com/encode/django-rest-framework/commit/e3bd4b90488bab756694ce271a9615460783f987"><code>e3bd4b9</code></a> Fix <a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/1811">#1811</a>: take limit_choices_to into account with FK (<a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/6371">#6371</a>)</li> <li><a href="https://github.com/encode/django-rest-framework/commit/9c408b296b65ea14173de69139218afc97e158b3"><code>9c408b2</code></a> Remove reference to deprecated drf-openapi package (<a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/6398">#6398</a>)</li> <li><a href="https://github.com/encode/django-rest-framework/commit/e0ae975e5c543c16f0330cc4acda9387d25fee74"><code>e0ae975</code></a> Fix a badly formatted title in docs (<a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/6089">#6089</a>)</li> <li><a href="https://github.com/encode/django-rest-framework/commit/c052a86c7b8ebc8159582dafaea3f6cf4a8c40f5"><code>c052a86</code></a> compat: (py2) urlparse = urllib.parse (py3) (<a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/6262">#6262</a>)</li> <li><a href="https://github.com/encode/django-rest-framework/commit/a49d744d5ee84ae2e89abde30ceddd2463e1f676"><code>a49d744</code></a> Fix OpenAPI links (<a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/6382">#6382</a>)</li> <li><a href="https://github.com/encode/django-rest-framework/commit/0860ef9eeebf77e1780b0d86b3fdf01f5aaa5cc3"><code>0860ef9</code></a> Update quickstart to Django 2.0 routing syntax (<a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/6385">#6385</a>)</li> <li><a href="https://github.com/encode/django-rest-framework/commit/587058e3c25aac4d871828a3ef19637eb9e8ddbd"><code>587058e</code></a> Allow run_validators() to handle non-dict types. (<a href="https://github-redirect.dependabot.com/encode/django-rest-framework/issues/6365">#6365</a>)</li> <li><a href="https://github.com/encode/django-rest-framework/commit/0cf18c41631a1e2ee6013a58c7b9bbdb9d8bd8e4"><code>0cf18c4</code></a> Use Default Version in URLPathVersioning if 'version' Didn't Specified by Cli...</li> <li>Additional commits viewable in <a href="https://github.com/encode/django-rest-framework/compare/3.7.7...3.9.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

pr created time in a month

PR opened grass-party/api

Bump urllib3 from 1.22 to 1.24.2

Bumps urllib3 from 1.22 to 1.24.2. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/urllib3/urllib3/blob/master/CHANGES.rst">urllib3's changelog</a>.</em></p> <blockquote> <h2>1.24.2 (2019-04-17)</h2> <ul> <li> <p>Don't load system certificates by default when any other <code>ca_certs</code>, <code>ca_certs_dir</code> or <code>ssl_context</code> parameters are specified.</p> </li> <li> <p>Remove Authorization header regardless of case when redirecting to cross-site. (Issue <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1510">#1510</a>)</p> </li> <li> <p>Add support for IPv6 addresses in subjectAltName section of certificates. (Issue <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1269">#1269</a>)</p> </li> </ul> <h2>1.24.1 (2018-11-02)</h2> <ul> <li> <p>Remove quadratic behavior within <code>GzipDecoder.decompress()</code> (Issue <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1467">#1467</a>)</p> </li> <li> <p>Restored functionality of <code>ciphers</code> parameter for <code>create_urllib3_context()</code>. (Issue <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1462">#1462</a>)</p> </li> </ul> <h2>1.24 (2018-10-16)</h2> <ul> <li> <p>Allow key_server_hostname to be specified when initializing a PoolManager to allow custom SNI to be overridden. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1449">#1449</a>)</p> </li> <li> <p>Test against Python 3.7 on AppVeyor. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1453">#1453</a>)</p> </li> <li> <p>Early-out ipv6 checks when running on App Engine. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1450">#1450</a>)</p> </li> <li> <p>Change ambiguous description of backoff_factor (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1436">#1436</a>)</p> </li> <li> <p>Add ability to handle multiple Content-Encodings (Issue <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1441">#1441</a> and Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1442">#1442</a>)</p> </li> <li> <p>Skip DNS names that can't be idna-decoded when using pyOpenSSL (Issue <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1405">#1405</a>).</p> </li> <li> <p>Add a server_hostname parameter to HTTPSConnection which allows for overriding the SNI hostname sent in the handshake. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1397">#1397</a>)</p> </li> <li> <p>Drop support for EOL Python 2.6 (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1429">#1429</a> and Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1430">#1430</a>)</p> </li> <li> <p>Fixed bug where responses with header Content-Type: message/* erroneously raised HeaderParsingError, resulting in a warning being logged. (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1439">#1439</a>)</p> </li> <li> <p>Move urllib3 to src/urllib3 (Pull <a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1409">#1409</a>)</p> </li> </ul> <h2>1.23 (2018-06-04)</h2> <ul> <li>Allow providing a list of headers to strip from requests when redirecting to a different host. Defaults to the <code>Authorization</code> header. Different</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/urllib3/urllib3/commit/1efadf43dc63317cd9eaa3e0fdb9e05ab07254b1"><code>1efadf4</code></a> Release 1.24.2 (<a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1564">#1564</a>)</li> <li><a href="https://github.com/urllib3/urllib3/commit/a6ec68a5c5c5743c59fe5c62c635c929586c429b"><code>a6ec68a</code></a> Merging new release version: 1.24.1</li> <li><a href="https://github.com/urllib3/urllib3/commit/0cedb3b0f1e5d79c89c6db767c534b064b794cf2"><code>0cedb3b</code></a> Restore context.set_ciphers() to create_urllib3_context() (<a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1463">#1463</a>)</li> <li><a href="https://github.com/urllib3/urllib3/commit/0aeba3be0224a930f6ffef254ed12b41303a86d7"><code>0aeba3b</code></a> Use bytearray to accumulate bytes from gzip (<a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1468">#1468</a>)</li> <li><a href="https://github.com/urllib3/urllib3/commit/f8d1c787d9b02a70d66ddbde9c99061d9073d54a"><code>f8d1c78</code></a> Uninstall oclint to ensure gcc can be brew upgraded (<a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1464">#1464</a>)</li> <li><a href="https://github.com/urllib3/urllib3/commit/cd7cfa613b2678e700597d098ce9bbdc934863e6"><code>cd7cfa6</code></a> Resolve pytest pluggy version conflict (<a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1457">#1457</a>)</li> <li><a href="https://github.com/urllib3/urllib3/commit/b548abc9812a628d3290d0cab83e44f3c31ac6fe"><code>b548abc</code></a> Update changelog for 1.24 release</li> <li><a href="https://github.com/urllib3/urllib3/commit/ef0c74542abe69421a86c4d3c6a86fe43cb809a4"><code>ef0c745</code></a> Merging new release version: 1.24</li> <li><a href="https://github.com/urllib3/urllib3/commit/a0964d9947c07d2b8495726ac23ad251b5d236af"><code>a0964d9</code></a> Add missing key_server_hostname variable (<a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1449">#1449</a>)</li> <li><a href="https://github.com/urllib3/urllib3/commit/34d8298ecf93c84f9916457d89701d6d5c807780"><code>34d8298</code></a> Test against Python 3.7 on AppVeyor (<a href="https://github-redirect.dependabot.com/urllib3/urllib3/issues/1453">#1453</a>)</li> <li>Additional commits viewable in <a href="https://github.com/urllib3/urllib3/compare/1.22...1.24.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

pr created time in a month

create barnchgrass-party/api

branch : dependabot/pip/urllib3-1.24.2

created branch time in a month

PR opened grass-party/api

Bump pyyaml from 3.12 to 5.1

Bumps pyyaml from 3.12 to 5.1. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/yaml/pyyaml/blob/master/CHANGES">pyyaml's changelog</a>.</em></p> <blockquote> <h2>5.1 (2019-03-13)</h2> <ul> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/35">yaml/pyyaml#35</a> -- Some modernization of the test running</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/42">yaml/pyyaml#42</a> -- Install tox in a virtualenv</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/45">yaml/pyyaml#45</a> -- Allow colon in a plain scalar in a flow context</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/48">yaml/pyyaml#48</a> -- Fix typos</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/55">yaml/pyyaml#55</a> -- Improve RepresenterError creation</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/59">yaml/pyyaml#59</a> -- Resolves <a href="https://github-redirect.dependabot.com/yaml/pyyaml/issues/57">#57</a>, update readme issues link</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/60">yaml/pyyaml#60</a> -- Document and test Python 3.6 support</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/61">yaml/pyyaml#61</a> -- Use Travis CI built in pip cache support</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/62">yaml/pyyaml#62</a> -- Remove tox workaround for Travis CI</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/63">yaml/pyyaml#63</a> -- Adding support to Unicode characters over codepoint 0xffff</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/75">yaml/pyyaml#75</a> -- add 3.12 changelog</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/76">yaml/pyyaml#76</a> -- Fallback to Pure Python if Compilation fails</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/84">yaml/pyyaml#84</a> -- Drop unsupported Python 3.3</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/102">yaml/pyyaml#102</a> -- Include license file in the generated wheel package</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/105">yaml/pyyaml#105</a> -- Removed Python 2.6 & 3.3 support</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/111">yaml/pyyaml#111</a> -- Remove commented out Psyco code</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/129">yaml/pyyaml#129</a> -- Remove call to <code>ord</code> in lib3 emitter code</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/149">yaml/pyyaml#149</a> -- Test on Python 3.7-dev</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/158">yaml/pyyaml#158</a> -- Support escaped slash in double quotes "/"</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/175">yaml/pyyaml#175</a> -- Updated link to pypi in release announcement</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/181">yaml/pyyaml#181</a> -- Import Hashable from collections.abc</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/194">yaml/pyyaml#194</a> -- Reverting <a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/74">yaml/pyyaml#74</a></li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/195">yaml/pyyaml#195</a> -- Build libyaml on travis</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/196">yaml/pyyaml#196</a> -- Force cython when building sdist</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/254">yaml/pyyaml#254</a> -- Allow to turn off sorting keys in Dumper (2)</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/256">yaml/pyyaml#256</a> -- Make default_flow_style=False</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/257">yaml/pyyaml#257</a> -- Deprecate yaml.load and add FullLoader and UnsafeLoader classes</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/261">yaml/pyyaml#261</a> -- Skip certain unicode tests when maxunicode not > 0xffff</li> <li><a href="https://github-redirect.dependabot.com/yaml/pyyaml/pull/263">yaml/pyyaml#263</a> -- Windows Appveyor build</li> </ul> <h2>3.13 (2018-07-05)</h2> <ul> <li>Resolved issues around PyYAML working in Python 3.7.</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/yaml/pyyaml/commit/e471e86bf6dabdad45a1438c20a4a5c033eb9034"><code>e471e86</code></a> Updates for 5.1 release</li> <li><a href="https://github.com/yaml/pyyaml/commit/9141e900d10d280173335b20207e87d4a15e62c6"><code>9141e90</code></a> Windows Appveyor build</li> <li><a href="https://github.com/yaml/pyyaml/commit/d6cbff662084dd94bde5421ece495482d1b14454"><code>d6cbff6</code></a> Skip certain unicode tests when maxunicode not > 0xffff</li> <li><a href="https://github.com/yaml/pyyaml/commit/69103ba255dd807ecb576654e84bd5efba3bad6e"><code>69103ba</code></a> Update .travis.yml to use libyaml 0.2.2</li> <li><a href="https://github.com/yaml/pyyaml/commit/91c9435bb667dc318c845f5b3e8af36bb84c66eb"><code>91c9435</code></a> Squash/merge pull request <a href="https://github-redirect.dependabot.com/yaml/pyyaml/issues/105">#105</a> from nnadeau/patch-1</li> <li><a href="https://github.com/yaml/pyyaml/commit/507a464ce62c933bf667b2296a96ad45f0147873"><code>507a464</code></a> Make default_flow_style=False</li> <li><a href="https://github.com/yaml/pyyaml/commit/07c88c6c1bee51439a00bc07827980fbb161a1ad"><code>07c88c6</code></a> Allow to turn off sorting keys in Dumper</li> <li><a href="https://github.com/yaml/pyyaml/commit/611ba395079026fda2ea67c4ad23eb6351c5aa18"><code>611ba39</code></a> Include license file in the generated wheel package</li> <li><a href="https://github.com/yaml/pyyaml/commit/857dff153d2c9f238d3a68821262b7764aeb44ea"><code>857dff1</code></a> Apply FullLoader/UnsafeLoader changes to lib3</li> <li><a href="https://github.com/yaml/pyyaml/commit/0cedb2a0697b2bc49e4f3841b8d4590b6b15657e"><code>0cedb2a</code></a> Deprecate/warn usage of yaml.load(input)</li> <li>Additional commits viewable in <a href="https://github.com/yaml/pyyaml/compare/3.12...5.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

pr created time in a month

create barnchgrass-party/api

branch : dependabot/pip/pyyaml-5.1

created branch time in a month

delete branch grass-party/api

delete branch : dependabot/pip/django-2.2.13

delete time in a month

push eventgrass-party/api

dependabot[bot]

commit sha 74a1b43d32f7b378689be08f02429e08e58f9a7a

Bump django from 2.0 to 2.2.13 Bumps [django](https://github.com/django/django) from 2.0 to 2.2.13. - [Release notes](https://github.com/django/django/releases) - [Commits](https://github.com/django/django/compare/2.0...2.2.13) Signed-off-by: dependabot[bot] <support@github.com>

view details

Noh Byung Kuk

commit sha 0d15d323f594f359575120c3ed5e2efb1c6a826a

Merge pull request #18 from grass-party/dependabot/pip/django-2.2.13 Bump django from 2.0 to 2.2.13

view details

push time in a month

PR merged grass-party/api

Bump django from 2.0 to 2.2.13 dependencies

Bumps django from 2.0 to 2.2.13. <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/django/django/commit/8093aaa8ff9dd7386a069c6eb49fcc1c5980c033"><code>8093aaa</code></a> [2.2.x] Bumped version for 2.2.13 release.</li> <li><a href="https://github.com/django/django/commit/07e59caa02831c4569bbebb9eb773bdd9cb4b206"><code>07e59ca</code></a> [2.2.x] Fixed CVE-2020-13254 -- Enforced cache key validation in memcached ba...</li> <li><a href="https://github.com/django/django/commit/6d61860b22875f358fac83d903dc629897934815"><code>6d61860</code></a> [2.0.x] Fixed CVE-2020-13596 -- Fixed potential XSS in admin ForeignKeyRawIdW...</li> <li><a href="https://github.com/django/django/commit/7e1084ead07b10e36d391f5366f411c58fbcc4c2"><code>7e1084e</code></a> [2.2.x] Added release date for 2.2.13.</li> <li><a href="https://github.com/django/django/commit/2b69680264aabb94661b4f67a8e70d522070dc2a"><code>2b69680</code></a> [2.2.x] Refs <a href="https://github-redirect.dependabot.com/django/django/issues/31485">#31485</a> -- Backported jQuery upgrade to 3.5.1.</li> <li><a href="https://github.com/django/django/commit/8301bc9cfad588074375edadfe0f19024dc217f8"><code>8301bc9</code></a> [2.2.x] Fixed E128, E741 flake8 warnings.</li> <li><a href="https://github.com/django/django/commit/c7bab8d2b7160a635a6f55e4d89e0a2e66d1679c"><code>c7bab8d</code></a> [2.2.x] Fixed term warning on Sphinx 3.0.1+.</li> <li><a href="https://github.com/django/django/commit/79baf338aef2ac21d3d29ee56e85f69678eef1a1"><code>79baf33</code></a> [2.2.x] Fixed highlightlang deprecation warning on Sphinx 1.8+.</li> <li><a href="https://github.com/django/django/commit/151a83e92c1a457baf028160ed9191405b869df6"><code>151a83e</code></a> [2.2.x] Fixed CodeBlock deprecation warning on Sphinx 2.1+.</li> <li><a href="https://github.com/django/django/commit/b0d810a77bbed01d45f92df93195f7bdc8d4da62"><code>b0d810a</code></a> [2.2.x] Fixed Sphinx warnings on duplicate object descriptions.</li> <li>Additional commits viewable in <a href="https://github.com/django/django/compare/2.0...2.2.13">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in a month

delete branch grass-party/api

delete branch : dependabot/pip/werkzeug-0.15.3

delete time in a month

push eventgrass-party/api

dependabot[bot]

commit sha 72691c477b716002f28047ab3c7525c555d31811

Bump werkzeug from 0.12 to 0.15.3 Bumps [werkzeug](https://github.com/pallets/werkzeug) from 0.12 to 0.15.3. - [Release notes](https://github.com/pallets/werkzeug/releases) - [Changelog](https://github.com/pallets/werkzeug/blob/master/CHANGES.rst) - [Commits](https://github.com/pallets/werkzeug/compare/0.12...0.15.3) Signed-off-by: dependabot[bot] <support@github.com>

view details

Noh Byung Kuk

commit sha 53e2aa6534cc5a9c035aa2ddcab65095df564523

Merge pull request #16 from grass-party/dependabot/pip/werkzeug-0.15.3 Bump werkzeug from 0.12 to 0.15.3

view details

push time in a month

PR merged grass-party/api

Bump werkzeug from 0.12 to 0.15.3 dependencies

Bumps werkzeug from 0.12 to 0.15.3. <details> <summary>Release notes</summary>

Sourced from werkzeug's releases.

0.15.3

  • Blog: https://palletsprojects.com/blog/werkzeug-0-15-3-released/
  • Changes: https://werkzeug.palletsprojects.com/en/0.15.x/changes/#version-0-15-3

0.15.2

  • Blog: https://palletsprojects.com/blog/werkzeug-0-15-2-released/
  • Changes: https://werkzeug.palletsprojects.com/en/0.15.x/changes/#version-0-15-2

0.15.1

  • Blog: https://palletsprojects.com/blog/werkzeug-0-15-1-released/
  • Changes: https://werkzeug.palletsprojects.com/en/0.15.x/changes/

0.15.0

  • Blog: https://palletsprojects.com/blog/werkzeug-0-15-0-released/
  • Changes: https://werkzeug.palletsprojects.com/en/0.15.x/changes/

0.13

Read the announcement here.

Read the full changelog.

Install from PyPI with pip:

pip install -U Werkzeug

</details> <details> <summary>Changelog</summary>

Sourced from werkzeug's changelog.

Version 0.15.3

Released 2019-05-14

  • Properly handle multi-line header folding in development server in Python 2.7. (:issue:1080)
  • Restore the response argument to :exc:~exceptions.Unauthorized. (:pr:1527)
  • :exc:~exceptions.Unauthorized doesn't add the WWW-Authenticate header if www_authenticate is not given. (:issue:1516)
  • The default URL converter correctly encodes bytes to string rather than representing them with b''. (:issue:1502)
  • Fix the filename format string in :class:~middleware.profiler.ProfilerMiddleware to correctly handle float values. (:issue:1511)
  • Update :class:~middleware.lint.LintMiddleware to work on Python 3. (:issue:1510)
  • The debugger detects cycles in chained exceptions and does not time out in that case. (:issue:1536)
  • When running the development server in Docker, the debugger security pin is now unique per container.

Version 0.15.2

Released 2019-04-02

  • Rule code generation uses a filename that coverage will ignore. The previous value, "generated", was causing coverage to fail. (:issue:1487)
  • The test client removes the cookie header if there are no persisted cookies. This fixes an issue introduced in 0.15.0 where the cookies from the original request were used for redirects, causing functions such as logout to fail. (:issue:1491)
  • The test client copies the environ before passing it to the app, to prevent in-place modifications from affecting redirect requests. (:issue:1498)
  • The "werkzeug" logger only adds a handler if there is no handler configured for its level in the logging chain. This avoids double logging if other code configures logging first. (:issue:1492)

Version 0.15.1

Released 2019-03-21

  • :exc:~exceptions.Unauthorized takes description as the first </tr></table> ... (truncated) </details> <details> <summary>Commits</summary>
  • 9b1123a release version 0.15.3
  • 00bc43b unique debugger pin in Docker containers
  • 2cbdf2b Merge pull request #1542 from asottile/exceptions_arent_always_hashable
  • 0e669f6 Fix unhashable exception types
  • bdc17e4 Merge pull request #1540 from pallets/break-tb-cycle
  • 44e38c2 break cycle in chained exceptions
  • 777500b Merge pull request #1518 from NiklasMM/fix/1510_lint-middleware-python3-compa...
  • e00c7c2 Make LintMiddleware Python 3 compatible and add tests
  • d590cc7 Merge pull request #1539 from pallets/profiler-format
  • 0388fc9 update filename_format for ProfilerMiddleware.
  • Additional commits viewable in compare view </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot ignore this [patch|minor|major] version will close this PR and stop Dependabot creating any more for this minor/major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in a month

startedpdehaan/11ty-dynamic-permalink-test

started time in 2 months

PublicEvent

created repositoryzachleat/a-single-html-file

I am a single HTML file.

created time in 3 months

more