profile
viewpoint
Jonas Snellinckx Superjo149 Belgium Full stack developer, Web and blockchain enthusiast

Superjo149/auryo 589

Auryo - Unofficial Soundcloud Desktop App

Superjo149/awesome-electron 2

Useful resources for creating apps with Electron

artus/DeGist 1

Decentralized Gists.

Superjo149/aws-ses-lambda-forwarder 0

Forward Inbound AWS Simple Email Service (SES) Emails with Lambda Function

Superjo149/bondingCurvesUX 0

Frontend application for Bonding Curves UX

Superjo149/caster 0

A Chromecast client based on the new (CASTV2) protocol

Superjo149/COINGECKO 0

CoinGecko Real Time Spreadsheet Feed: Prices, Volumes, Market Cap

Superjo149/conf 0

Simple config handling for your app or module

Superjo149/craft 0

nystudio107 Craft 3 CMS scaffolding project

Superjo149/electron-apps 0

A collection of apps built on Electron

startedSuperjo149/auryo

started time in 19 hours

startedSuperjo149/auryo

started time in 2 days

PR opened wearetheledger/hyperledger-typescript-boilerplate

Bump socket.io from 2.2.0 to 2.4.1

Bumps socket.io from 2.2.0 to 2.4.1. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/socketio/socket.io/releases">socket.io's releases</a>.</em></p> <blockquote> <h2>2.4.1</h2> <p>This release reverts the breaking change introduced in <code>2.4.0</code> (<a href="https://github.com/socketio/socket.io/commit/f78a575f66ab693c3ea96ea88429ddb1a44c86c7">https://github.com/socketio/socket.io/commit/f78a575f66ab693c3ea96ea88429ddb1a44c86c7</a>).</p> <p>If you are using Socket.IO v2, you should explicitly allow/disallow cross-origin requests:</p> <ul> <li>without CORS (server and client are served from the same domain):</li> </ul> <pre lang="js"><code>io.origins((req, callback) => { callback(null, req.headers.origin === undefined); // cross-origin requests will not be allowed }); </code></pre> <ul> <li>with CORS (server and client are served from distinct domains):</li> </ul> <pre lang="js"><code>io.origins(["http://localhost:3000"]); // for local development io.origins(["https://example.com"]); </code></pre> <p>In any case, please consider upgrading to Socket.IO v3, where this security issue is now fixed (CORS is disabled by default).</p> <h3>Reverts</h3> <ul> <li>fix(security): do not allow all origins by default (<a href="https://github.com/socketio/socket.io/commit/a1690509470e9dd5559cec4e60908ca6c23e9ba0">a169050</a>)</li> </ul> <h4>Links:</h4> <ul> <li>Diff: <a href="https://github.com/socketio/socket.io/compare/2.4.0...2.4.1">https://github.com/socketio/socket.io/compare/2.4.0...2.4.1</a></li> <li>Client release: -</li> <li>engine.io version: <code>~3.5.0</code></li> <li>ws version: <code>~7.4.2</code></li> </ul> <h2>2.4.0</h2> <p>Related blog post: <a href="https://socket.io/blog/socket-io-2-4-0/">https://socket.io/blog/socket-io-2-4-0/</a></p> <h3>Features (from Engine.IO)</h3> <ul> <li>add support for all cookie options (<a href="https://github.com/socketio/engine.io/commit/19cc58264a06dca47ed401fbaca32dcdb80a903b">19cc582</a>)</li> <li>disable perMessageDeflate by default (<a href="https://github.com/socketio/engine.io/commit/5ad273601eb66c7b318542f87026837bf9dddd21">5ad2736</a>)</li> </ul> <h3>Bug Fixes</h3> <ul> <li><strong>security:</strong> do not allow all origins by default (<a href="https://github.com/socketio/socket.io/commit/f78a575f66ab693c3ea96ea88429ddb1a44c86c7">f78a575</a>)</li> <li>properly overwrite the query sent in the handshake (<a href="https://github.com/socketio/socket.io/commit/d33a619905a4905c153d4fec337c74da5b533a9e">d33a619</a>)</li> </ul> <p>:warning: <strong>BREAKING CHANGE</strong> :warning:</p> <p>Previously, CORS was enabled by default, which meant that a Socket.IO server sent the necessary CORS headers (<code>Access-Control-Allow-xxx</code>) to <strong>any</strong> domain. This will not be the case anymore, and you now have to explicitly enable it.</p> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/socketio/socket.io/blob/2.4.1/CHANGELOG.md">socket.io's changelog</a>.</em></p> <blockquote> <h2><a href="https://github.com/socketio/socket.io/compare/2.4.0...2.4.1">2.4.1</a> (2021-01-07)</h2> <h3>Reverts</h3> <ul> <li>fix(security): do not allow all origins by default (<a href="https://github.com/socketio/socket.io/commit/a1690509470e9dd5559cec4e60908ca6c23e9ba0">a169050</a>)</li> </ul> <h1><a href="https://github.com/socketio/socket.io/compare/2.3.0...2.4.0">2.4.0</a> (2021-01-04)</h1> <h3>Bug Fixes</h3> <ul> <li><strong>security:</strong> do not allow all origins by default (<a href="https://github.com/socketio/socket.io/commit/f78a575f66ab693c3ea96ea88429ddb1a44c86c7">f78a575</a>)</li> <li>properly overwrite the query sent in the handshake (<a href="https://github.com/socketio/socket.io/commit/d33a619905a4905c153d4fec337c74da5b533a9e">d33a619</a>)</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/socketio/socket.io/commit/e6b869738c73fa0ce9928974d823e50cc92f7a1a"><code>e6b8697</code></a> chore(release): 2.4.1</li> <li><a href="https://github.com/socketio/socket.io/commit/a1690509470e9dd5559cec4e60908ca6c23e9ba0"><code>a169050</code></a> revert: fix(security): do not allow all origins by default</li> <li><a href="https://github.com/socketio/socket.io/commit/873fdc55eddd672960fdbc1325ccb7c4bf466f05"><code>873fdc5</code></a> chore(release): 2.4.0</li> <li><a href="https://github.com/socketio/socket.io/commit/f78a575f66ab693c3ea96ea88429ddb1a44c86c7"><code>f78a575</code></a> fix(security): do not allow all origins by default</li> <li><a href="https://github.com/socketio/socket.io/commit/d33a619905a4905c153d4fec337c74da5b533a9e"><code>d33a619</code></a> fix: properly overwrite the query sent in the handshake</li> <li><a href="https://github.com/socketio/socket.io/commit/3951a79359c19f9497de664d96a8f9f80196a405"><code>3951a79</code></a> chore: bump engine.io version</li> <li><a href="https://github.com/socketio/socket.io/commit/6fa026fc94fb3a1e6674b8a2c1211b24ee38934a"><code>6fa026f</code></a> ci: migrate to GitHub Actions</li> <li><a href="https://github.com/socketio/socket.io/commit/47161a65d40c2587535de750ac4c7d448e5842ba"><code>47161a6</code></a> [chore] Release 2.3.0</li> <li><a href="https://github.com/socketio/socket.io/commit/cf39362014f5ff13a17168b74772c43920d6e4fd"><code>cf39362</code></a> [chore] Bump socket.io-parser to version 3.4.0</li> <li><a href="https://github.com/socketio/socket.io/commit/4d01b2c84cc8dcd6968e422d44cb5e78851058b9"><code>4d01b2c</code></a> test: remove deprecated Buffer usage (<a href="https://github-redirect.dependabot.com/socketio/socket.io/issues/3481">#3481</a>)</li> <li>Additional commits viewable in <a href="https://github.com/socketio/socket.io/compare/2.2.0...2.4.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+164 -191

0 comment

1 changed file

pr created time in 2 days

issue commentSuperjo149/auryo

Request failed with status code 403

It seems to have started working now. I had the same issue a few days ago, updated nothing and now it loads.

Superjo149

comment created time in 6 days

startedSuperjo149/auryo

started time in 8 days

startedKong/insomnia

started time in 9 days

issue commentSuperjo149/auryo

Request failed with status code 403

I get either Error 401 or 403, seems to be be interchangeable between Not Authorized and Forbidden.

Superjo149

comment created time in 9 days

startedSuperjo149/auryo

started time in 10 days

issue commentSuperjo149/auryo

Request failed with status code 405

Auryo fails to start up with Error code 403:

image

and from running within Terminal it only shows this;

$ auryo
(electron) The default value of app.allowRendererProcessReuse is deprecated, it is currently "false".  It will change to be "true" in Electron 9.  For more information please check https://github.com/electron/electron/issues/18397
[1610363070819] INFO : App started

KebabLord

comment created time in 12 days

startedSuperjo149/auryo

started time in 13 days

fork notmeta/auryo

Auryo - Unofficial Soundcloud Desktop App

http://auryo.com

fork in 13 days

startedSuperjo149/auryo

started time in 14 days

startedSuperjo149/auryo

started time in 15 days

startedSuperjo149/auryo

started time in 15 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/lodash-4.17.19

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/electron-8.5.2

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/elliptic-6.5.3

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/decompress-4.2.1

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/highlight.js-9.18.5

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/websocket-extensions-0.1.4

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/axios-0.21.1

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/ini-1.3.7

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/http-proxy-1.18.1

delete time in 17 days

delete branch Superjo149/auryo

delete branch : dependabot/npm_and_yarn/jquery-3.5.0

delete time in 17 days

pull request commentSuperjo149/auryo

build(deps): bump axios from 0.19.2 to 0.21.1

OK, I won't notify you again about this release, but will get in touch when a new version is available. If you'd rather skip all updates until the next major or minor version, let me know by commenting @dependabot ignore this major version or @dependabot ignore this minor version.

If you change your mind, just re-open this PR and I'll resolve any conflicts on it.

dependabot[bot]

comment created time in 17 days

pull request commentSuperjo149/auryo

build(deps): bump ini from 1.3.5 to 1.3.7

OK, I won't notify you again about this release, but will get in touch when a new version is available. If you'd rather skip all updates until the next major or minor version, let me know by commenting @dependabot ignore this major version or @dependabot ignore this minor version.

If you change your mind, just re-open this PR and I'll resolve any conflicts on it.

dependabot[bot]

comment created time in 17 days

pull request commentSuperjo149/auryo

build(deps): bump highlight.js from 9.18.1 to 9.18.5

OK, I won't notify you again about this release, but will get in touch when a new version is available. If you'd rather skip all updates until the next major or minor version, let me know by commenting @dependabot ignore this major version or @dependabot ignore this minor version.

If you change your mind, just re-open this PR and I'll resolve any conflicts on it.

dependabot[bot]

comment created time in 17 days

pull request commentSuperjo149/auryo

build(deps-dev): bump electron from 8.0.3 to 8.5.2

OK, I won't notify you again about this release, but will get in touch when a new version is available. If you'd rather skip all updates until the next major or minor version, let me know by commenting @dependabot ignore this major version or @dependabot ignore this minor version.

If you change your mind, just re-open this PR and I'll resolve any conflicts on it.

dependabot[bot]

comment created time in 17 days

pull request commentSuperjo149/auryo

build(deps): bump decompress from 4.2.0 to 4.2.1

OK, I won't notify you again about this release, but will get in touch when a new version is available. If you'd rather skip all updates until the next major or minor version, let me know by commenting @dependabot ignore this major version or @dependabot ignore this minor version.

If you change your mind, just re-open this PR and I'll resolve any conflicts on it.

dependabot[bot]

comment created time in 17 days

more